source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 1820

Revision 1820, 18.7 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 0.13.1
10Release: 1%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source: http://download.gnome.org/sources/rhythmbox/0.13/%{name}-%{version}.tar.bz2
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: libgpod-devel
18BuildRequires: libgnomeui-devel >= 2.18.0
19BuildRequires: brasero-devel
20BuildRequires: gstreamer-plugins-base-devel >= 0.10
21BuildRequires: gettext, rarian-compat
22BuildRequires: totem-pl-parser-devel
23BuildRequires: sqlite3-devel
24BuildRequires: libffi-devel
25BuildRequires: gnome-vfs2-devel >= 2.18.0
26BuildRequires: avahi-glib-devel >= 0.6
27BuildRequires: libmusicbrainz-devel >= 2.1.0
28BuildRequires: libnotify-devel
29BuildRequires: libsexy-devel
30BuildRequires: libgudev1-devel
31BuildRequires: libsoup-devel
32BuildRequires: dbus-devel >= 1.0
33BuildRequires: dbus-glib-devel
34BuildRequires: gnome-doc-utils >= 0.3.2
35BuildRequires: python-devel, pygtk2-devel
36BuildRequires: check >= 0.8.2
37BuildRequires: intltool >= 0.35.0
38BuildRequires: gstreamer-python
39BuildRequires: popt-devel
40BuildRequires: lirc
41BuildRequires: libmtp-devel
42BuildRequires: libgnome-keyring-devel >= 2.30.0
43BuildRequires: gnome-media-devel
44BuildRequires: libSM-devel
45Requires: libgpod
46Requires: libnotify
47Requires: libsexy
48Requires: lirc
49Requires: libmtp
50Requires: libgnomeui
51Requires: brasero
52Requires: gnome-python gnome-vfs2
53Requires: gnome-themes
54Requires: libgnome-keyring
55Requires: gstreamer-python
56%if %{enable_DLNA_UPnP}
57Requires: python-Coherence
58%endif
59Requires: desktop-file-utils >= %{desktop_file_utils_version}
60Requires: scrollkeeper GConf2
61
62# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
63# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
64# # respectively.
65# Requires: self-build-gstreamer-plugins-ffmpeg
66# Requires: self-build-gstreamer-plugins-ugly
67
68
69%description
70Rhythmbox is an integrated music management application based on the powerful
71GStreamer media framework. It has a number of features, including an easy to
72use music browser, searching and sorting, comprehensive audio format support
73through GStreamer, Internet Radio support, playlists and more.
74
75Rhythmbox is extensible through a plugin system.
76
77%description -l ja
78Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
79統合音楽管理アプリケーションです。
80見やすいユーザインターフェースを備え、検索や整列ができ、
81GStreamer により数多くの音声フォーマットをサポート、
82インターネットラジオをサポート、プレイリスト管理などの
83数多くの特徴を持ちます。
84
85%package devel
86Summary: Development tools for rhythmbox applications.
87Summary(ja): rhythmbox アプリケーションの開発用ファイル
88Group: Development/Libraries
89Requires: %{name} = %{version}-%{release}
90Requires: pkgconfig
91Requires: glib2-devel
92Requires: gtk2-devel
93Requires: libsoup-devel
94Requires: gnome-media-devel
95Requires: totem-pl-parser-devel
96Requires: gstreamer-devel
97
98%description devel
99Header files and libraries for building a extension library for the rhythmbox.
100
101%description devel -l ja
102
103%prep
104%setup -q
105# autoreconf -i
106
107# Use the installed louie, not the one in Coherence
108find plugins/coherence/upnp_coherence/ -type f \
109    -exec %__sed -i 's/coherence.extern.louie as louie/louie/' '{}' ';'
110
111%build
112# work around a gstreamer bug
113/usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
114
115%configure --with-ipod \
116    --with-mtp \
117    --with-dbus \
118    --with-mdns=avahi \
119    --with-libnautilus-burn \
120    --with-cd-burning \
121    --with-metadata-helper \
122    --enable-lirc \
123    --enable-python \
124    --disable-vala \
125    --disable-browser-plugin \
126    --disable-static \
127    --disable-scrollkeeper \
128    --disable-schemas-install \
129    --without-hal
130%__make %{?_smp_mflags}
131
132%install
133%__rm -rf $RPM_BUILD_ROOT
134export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
135%__make install DESTDIR=$RPM_BUILD_ROOT
136unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
137
138%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
139%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
140%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
141%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
142%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
143%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
144%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
145
146## Don't package DLNA/UPnP plugin
147%if !%{enable_DLNA_UPnP}
148%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
149%endif
150
151%find_lang %{name}
152
153
154# Don't package api docs
155%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
156
157# Don't package scrollkeeper catalogs
158%__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
159
160# And don't package vala
161%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
162        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
163
164# save space by linking identical images in translated docs
165helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
166for f in $helpdir/C/figures/*.png; do
167  b="$(basename $f)"
168  for d in $helpdir/*; do
169    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
170      g="$d/figures/$b"
171      if [ -f "$g" ]; then
172        if cmp -s $f $g; then
173          %__rm "$g"; ln -s "../../C/figures/$b" "$g"
174        fi
175      fi
176    fi
177  done
178done
179
180
181%clean
182%__rm -rf $RPM_BUILD_ROOT
183
184%post
185/sbin/ldconfig
186export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
187gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/rhythmbox.schemas >/dev/null
188update-desktop-database -q
189scrollkeeper-update -q
190touch --no-create %{_datadir}/icons/hicolor
191if [ -x /usr/bin/gtk-update-icon-cache ]; then
192  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
193fi
194
195%preun
196if [ "$1" -eq 0 ]; then
197    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
198    gconftool-2 --makefile-uninstall-rule \
199      %{_sysconfdir}/gconf/schemas/rhythmbox.schemas > /dev/null || :
200fi
201
202%postun
203/sbin/ldconfig
204update-desktop-database -q
205scrollkeeper-update -q
206touch --no-create %{_datadir}/icons/hicolor
207if [ -x /usr/bin/gtk-update-icon-cache ]; then
208  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
209fi
210
211
212%files -f %{name}.lang
213%defattr(-, root, root)
214%doc AUTHORS COPYING ChangeLog README NEWS
215%{_sysconfdir}/gconf/schemas/rhythmbox.schemas
216%{_bindir}/*
217%{_libdir}/lib*.so.*
218%{_libdir}/rhythmbox/plugins
219%{_datadir}/applications/rhythmbox.desktop
220%{_datadir}/applications/rhythmbox-device.desktop
221%{_datadir}/dbus-1/services/org.gnome.Rhythmbox.service
222%{_datadir}/gnome/help/rhythmbox
223%{_datadir}/icons/*
224%{_datadir}/omf/rhythmbox
225%{_datadir}/rhythmbox
226%{_mandir}/man1/*
227%{_libexecdir}/rhythmbox-metadata
228
229%files devel
230%defattr(-, root, root)
231%{_includedir}/%{name}/*
232%{_libdir}/*.so
233%{_libdir}/pkgconfig/*.pc
234
235
236%changelog
237* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
238- new upstream release
239- fix %files (add rhythmbox-device.desktop)
240
241* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
242- new upstream release
243- change BuildRequires: gnome-media-devel instead of gnome-media
244- add devel package
245- drop Patch0
246
247* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
248- new upstream release
249- drop Patch1, Patch2, Patch3
250- change BuildRequires: nautilus-cd-burner -> brasero-devel
251- change Requires: nautilus-cd-burner -> brasero
252- change BuildRequires: hal-devel -> libgudev1-devel
253- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
254- change Requires: gnome-keyring -> libgnome-keyring
255- add configure option (--without-hal)
256
257* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
258- rebuilt with new environment
259
260* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
261- new upstream release
262  - dropped upstreamed/obsolete patches
263  - added patches applied Fedora development
264
265* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
266- new upstream release
267- added configure options:
268  --disable-vala
269  --disable-browser-plugin
270
271* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
272- added Japanese description
273
274* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
275- new upstream release
276  - dropped rb-disable-power-plugin-by-default.patch
277- added BuildRequires:
278  - libSM-devel
279  - gnome-media
280
281* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
282- rebuild with libgpod-0.7.2
283
284* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
285- new upstream release
286- corrected License tag
287- dropped rhythmbox-0.11.6-libmtp.patch
288- added BuildRequires:
289  - sqlite3-devel
290  - libffi-devel
291
292* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
293- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
294- applied rhythmbox-0.11.6-libmtp.patch
295- added Requires:
296  - libgpod
297  - libnotify
298  - libsexy
299  - lirc
300  - libmtp
301  - libgnomeui
302  - nautilus-cd-burner
303  - gstreamer-python
304  - gnome-vfs2
305  - gnome-themes
306  - gnome-keyring
307  - python-Coherence, if enable_DLNA_UPnP = 1
308- added BuildRequires:
309  - libnotify-devel
310  - libsexy-devel
311  - lirc
312  - libmtp-devel
313  - gnome-vfs2-devel, instead of gnome-vfs2
314  - gnome-keyring-devel
315- dropped --with-internal-libsexy in configure options
316- added in configure options:
317  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
318- added %%preun to remove the schema
319
320* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
321- new upstream release
322- changed to --with-metadata-helper in configure options
323- added BuildRequires:
324  - gstreamer-python
325  - intltool >= 0.35.0
326  - popt-devel
327
328* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
329- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
330- rebuilt with python-2.5.2
331- applied new versioning policy
332- spec in utf-8
333
334* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
335- rebuilt with libgpod-0.6.0
336
337* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
338- new upstream release
339
340* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
341- new upstream release
342
343* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
344- rebuilt with new toolchain and libgpod-0.4.2
345- add BuildRequires: dbus-glib-devel
346
347* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
348- new upstream release
349
350* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
351- rebuilt for VineSeed
352
353* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
354- new upstream release
355- added --enable-python option to %%configure
356- added Requires: gnome-python
357
358* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
359- new upstream release
360- built with libsoup 2.2.99
361
362* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
363- added --with-cd-burner to configure
364- added BuildRequires: libsexy-devel hal-devel libsoup-devel
365
366* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
367- add BuildRequires:
368  - gnome-doc-utils >= 0.3.2
369  - python-devel
370  - pygtk2-devel
371  - check >= 0.8.2
372
373* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
374- rebuild with gnutls-1.4.1
375
376* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
377- new upstream release
378
379* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
380- new upstream release
381- run scrollkeeper-update at %post and %postun
382- added BuildRequires: libnotify-devel
383
384* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
385- new upstream release (dropped patch0)
386- added --without-metadata-helper at configure
387
388* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
389- Initial build for Vine Linux based on FC pacakge
390
391* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
392- add patch from James "Doc" Livingston to stop a hang
393  for new users (bug 183883)
394
395* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
396- bump again for double-long bug on ppc(64)
397
398* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
399- rebuilt for new gcc4.1 snapshot and glibc changes
400
401* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
402- Update to 0.9.3.1
403- Use gstreamer (0.10)
404
405* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
406- Remove hack for 173869, as its no longer needed.
407
408* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
409- 0.9.3
410
411* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
412- Newer CVS snapshot
413
414* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
415- Update to latest CVS
416- Add hack to workaround bug #173869
417
418* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
419- Rebuild, now that gstreamer08-plugins has been fixed
420
421* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
422- bonobo multilib issue (bug 156982)
423
424* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
425- rebuild with ipod support
426
427* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
428- rebuilt again
429
430* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
431- rebuilt
432
433* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
434- rebuild
435
436* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
437- rebuild for new dbus
438
439* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
440- Update to 0.9.2
441
442* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
443- Update to 0.9.1
444
445* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
446- Add configure flags --with-bonobo --with-dbus
447- BR nautilus-cd-burner-devel
448- New upstream CVS snapshot for testing
449- Drop IDL file and ui .xml
450- Add dbus service file
451- Drop upstreamed rhythmbox-bluecurve.tar.gz
452- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
453
454* Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
455- Add Bluecurve-ized icons from Jeff Schroeder (157716)
456- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
457  cell renderer for playback icon (no longer necessary) and
458  changes the rating renderer to work with non-b&w icons
459
460* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
461- Rebuild for GCC4
462
463* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
464- New upstream version
465- Remove librb-nautilus-context-menu.so, killed upstream
466
467* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
468- PreReq desktop-file-utils >= 0.9
469
470* Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
471- New upstream version
472
473* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
474- Fix postun to use correct syntax, thanks Nils Philippsen
475
476* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
477- New upstream version
478- Call update-desktop-database in post and postun
479
480* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
481- New upstream version
482
483* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
484- rebuilt
485
486* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
487- New upstream version
488- Remove backported patches
489- Gratuitiously bump various BuildRequires versions
490
491* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
492- Remove code to unregister GConf schema for now (Closes: #122532)
493
494* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
495- Apply tiny patch from 0.8 arch to fix GConf key used
496  for initial sorting
497
498* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
499- Apply patch from 0.8 arch tree to fix a number of memleaks
500
501* Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
502- Update to 0.8.3: fixes showstopper bug with internet radio
503
504* Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
505- Update to 0.8.2
506- Fix Source url
507- Add smp_mflags
508- Bump BuildRequires on gstreamer to 0.8.1
509
510* Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
511- Uninstall GConf schemas on removal
512
513* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
514- Update to 0.8.1
515
516* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
517- Update to 0.8.0
518
519* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
520- Update to 0.7.2
521
522* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
523- Remove BuildRequires on autoconf and libvorbis-devel
524
525* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
526- New major version - I know we are past major version slush, but
527  this should have been done two weeks ago along with the GNOME 2.6
528  upload.  As upstream author as well, I believe this version is
529  good enough for FC2.
530- Remove --disable-mp3
531- Remove id3, flac variables
532- Remove GStreamer major version patch
533- Fix typo in description
534
535* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
536- rebuild for new gstreamer
537
538* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
539- update to 0.6.8
540
541* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
542- rebuilt
543
544* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
545- update to 0.6.7
546
547* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
548- rebuilt
549
550* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
551- New upstream version
552- Don't re-run the autotools; upstream incorporates newer versions.
553* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
554- new version
555- remove smp_flags
556
557* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
558- remove the initial iradio channels as they all are mp3 based.
559
560* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
561- Fix category from Development/Libraries to Applications/Multimedia.
562- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
563- Fix SCHEMES vs. SCHEMAS in the post scriplet.
564- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
565- Removed unnecessary date expansion define.
566- Updated description, including mp3 reference removal.
567- Added libid3tag and flac optional support for convenient rebuild.
568- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
569
570* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
571- new version
572- use %{_sysconfdir} instead of /etc
573
574* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
575- rebuilt
576
577* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
578- gave up on other archs for the Beta
579- new version
580- remove werror and add missing files
581
582* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
583- update to newer cvs snap
584
585* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
586- update to cvs snap
587
588* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
589- use %%(lang)
590
591* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
592- fix post to actually install the schema
593
594* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
595- Added gconf file
596- Added i18n directory
597
598* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
599- Updated for new rewrite of rhythmbox, thanks to Jeroen
600
601* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
602- removed bonobo dependency
603* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
604- created new spec file
Note: See TracBrowser for help on using the repository browser.