source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 1708

Revision 1708, 18.5 KB checked in by Takemikaduchi, 14 years ago (diff)

rhythmbox: new upstream release, gnome-media: add devel package

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 0.13.0
10Release: 1%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source: http://download.gnome.org/sources/rhythmbox/0.13/%{name}-%{version}.tar.bz2
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: libgpod-devel
18BuildRequires: libgnomeui-devel >= 2.18.0
19BuildRequires: brasero-devel
20BuildRequires: gstreamer-plugins-base-devel >= 0.10
21BuildRequires: gettext, rarian-compat
22BuildRequires: totem-pl-parser-devel
23BuildRequires: sqlite3-devel
24BuildRequires: libffi-devel
25BuildRequires: gnome-vfs2-devel >= 2.18.0
26BuildRequires: avahi-glib-devel >= 0.6
27BuildRequires: libmusicbrainz-devel >= 2.1.0
28BuildRequires: libnotify-devel
29BuildRequires: libsexy-devel
30BuildRequires: libgudev1-devel
31BuildRequires: libsoup-devel
32BuildRequires: dbus-devel >= 1.0
33BuildRequires: dbus-glib-devel
34BuildRequires: gnome-doc-utils >= 0.3.2
35BuildRequires: python-devel, pygtk2-devel
36BuildRequires: check >= 0.8.2
37BuildRequires: intltool >= 0.35.0
38BuildRequires: gstreamer-python
39BuildRequires: popt-devel
40BuildRequires: lirc
41BuildRequires: libmtp-devel
42BuildRequires: libgnome-keyring-devel >= 2.30.0
43BuildRequires: gnome-media-devel
44BuildRequires: libSM-devel
45Requires: libgpod
46Requires: libnotify
47Requires: libsexy
48Requires: lirc
49Requires: libmtp
50Requires: libgnomeui
51Requires: brasero
52Requires: gnome-python gnome-vfs2
53Requires: gnome-themes
54Requires: libgnome-keyring
55Requires: gstreamer-python
56%if %{enable_DLNA_UPnP}
57Requires: python-Coherence
58%endif
59Requires: desktop-file-utils >= %{desktop_file_utils_version}
60Requires: scrollkeeper GConf2
61
62# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
63# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
64# # respectively.
65# Requires: self-build-gstreamer-plugins-ffmpeg
66# Requires: self-build-gstreamer-plugins-ugly
67
68
69%description
70Rhythmbox is an integrated music management application based on the powerful
71GStreamer media framework. It has a number of features, including an easy to
72use music browser, searching and sorting, comprehensive audio format support
73through GStreamer, Internet Radio support, playlists and more.
74
75Rhythmbox is extensible through a plugin system.
76
77%description -l ja
78Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
79統合音楽管理アプリケーションです。
80見やすいユーザインターフェースを備え、検索や整列ができ、
81GStreamer により数多くの音声フォーマットをサポート、
82インターネットラジオをサポート、プレイリスト管理などの
83数多くの特徴を持ちます。
84
85%package devel
86Summary: Development tools for rhythmbox applications.
87Summary(ja): rhythmbox アプリケーションの開発用ファイル
88Group: Development/Libraries
89Requires: %{name} = %{version}-%{release}
90Requires: pkgconfig
91Requires: glib2-devel
92Requires: gtk2-devel
93Requires: libsoup-devel
94Requires: gnome-media-devel
95Requires: totem-pl-parser-devel
96Requires: gstreamer-devel
97
98%description devel
99Header files and libraries for building a extension library for the rhythmbox.
100
101%description devel -l ja
102
103%prep
104%setup -q
105# autoreconf -i
106
107# Use the installed louie, not the one in Coherence
108find plugins/coherence/upnp_coherence/ -type f \
109    -exec %__sed -i 's/coherence.extern.louie as louie/louie/' '{}' ';'
110
111%build
112# work around a gstreamer bug
113/usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
114
115%configure --with-ipod \
116    --with-mtp \
117    --with-dbus \
118    --with-mdns=avahi \
119    --with-libnautilus-burn \
120    --with-cd-burning \
121    --with-metadata-helper \
122    --enable-lirc \
123    --enable-python \
124    --disable-vala \
125    --disable-browser-plugin \
126    --disable-static \
127    --disable-scrollkeeper \
128    --disable-schemas-install \
129    --without-hal
130%__make %{?_smp_mflags}
131
132%install
133%__rm -rf $RPM_BUILD_ROOT
134export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
135%__make install DESTDIR=$RPM_BUILD_ROOT
136unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
137
138%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
139%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
140%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
141%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
142%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
143%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
144%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
145
146## Don't package DLNA/UPnP plugin
147%if !%{enable_DLNA_UPnP}
148%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
149%endif
150
151%find_lang %{name}
152
153
154# Don't package api docs
155%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
156
157# Don't package scrollkeeper catalogs
158%__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
159
160# And don't package vala
161%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
162        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
163
164# save space by linking identical images in translated docs
165helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
166for f in $helpdir/C/figures/*.png; do
167  b="$(basename $f)"
168  for d in $helpdir/*; do
169    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
170      g="$d/figures/$b"
171      if [ -f "$g" ]; then
172        if cmp -s $f $g; then
173          %__rm "$g"; ln -s "../../C/figures/$b" "$g"
174        fi
175      fi
176    fi
177  done
178done
179
180
181%clean
182%__rm -rf $RPM_BUILD_ROOT
183
184%post
185/sbin/ldconfig
186export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
187gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/rhythmbox.schemas >/dev/null
188update-desktop-database -q
189scrollkeeper-update -q
190touch --no-create %{_datadir}/icons/hicolor
191if [ -x /usr/bin/gtk-update-icon-cache ]; then
192  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
193fi
194
195%preun
196if [ "$1" -eq 0 ]; then
197    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
198    gconftool-2 --makefile-uninstall-rule \
199      %{_sysconfdir}/gconf/schemas/rhythmbox.schemas > /dev/null || :
200fi
201
202%postun
203/sbin/ldconfig
204update-desktop-database -q
205scrollkeeper-update -q
206touch --no-create %{_datadir}/icons/hicolor
207if [ -x /usr/bin/gtk-update-icon-cache ]; then
208  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
209fi
210
211
212%files -f %{name}.lang
213%defattr(-, root, root)
214%doc AUTHORS COPYING ChangeLog README NEWS
215%{_sysconfdir}/gconf/schemas/rhythmbox.schemas
216%{_bindir}/*
217%{_libdir}/lib*.so.*
218%{_libdir}/rhythmbox/plugins
219%{_datadir}/applications/rhythmbox.desktop
220%{_datadir}/dbus-1/services/org.gnome.Rhythmbox.service
221%{_datadir}/gnome/help/rhythmbox
222%{_datadir}/icons/*
223%{_datadir}/omf/rhythmbox
224%{_datadir}/rhythmbox
225%{_mandir}/man1/*
226%{_libexecdir}/rhythmbox-metadata
227
228%files devel
229%defattr(-, root, root)
230%{_includedir}/%{name}/*
231%{_libdir}/*.so
232%{_libdir}/pkgconfig/*.pc
233
234
235%changelog
236* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
237- new upstream release
238- change BuildRequires: gnome-media-devel instead of gnome-media
239- add devel package
240- drop Patch0
241
242* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
243- new upstream release
244- drop Patch1, Patch2, Patch3
245- change BuildRequires: nautilus-cd-burner -> brasero-devel
246- change Requires: nautilus-cd-burner -> brasero
247- change BuildRequires: hal-devel -> libgudev1-devel
248- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
249- change Requires: gnome-keyring -> libgnome-keyring
250- add configure option (--without-hal)
251
252* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
253- rebuilt with new environment
254
255* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
256- new upstream release
257  - dropped upstreamed/obsolete patches
258  - added patches applied Fedora development
259
260* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
261- new upstream release
262- added configure options:
263  --disable-vala
264  --disable-browser-plugin
265
266* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
267- added Japanese description
268
269* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
270- new upstream release
271  - dropped rb-disable-power-plugin-by-default.patch
272- added BuildRequires:
273  - libSM-devel
274  - gnome-media
275
276* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
277- rebuild with libgpod-0.7.2
278
279* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
280- new upstream release
281- corrected License tag
282- dropped rhythmbox-0.11.6-libmtp.patch
283- added BuildRequires:
284  - sqlite3-devel
285  - libffi-devel
286
287* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
288- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
289- applied rhythmbox-0.11.6-libmtp.patch
290- added Requires:
291  - libgpod
292  - libnotify
293  - libsexy
294  - lirc
295  - libmtp
296  - libgnomeui
297  - nautilus-cd-burner
298  - gstreamer-python
299  - gnome-vfs2
300  - gnome-themes
301  - gnome-keyring
302  - python-Coherence, if enable_DLNA_UPnP = 1
303- added BuildRequires:
304  - libnotify-devel
305  - libsexy-devel
306  - lirc
307  - libmtp-devel
308  - gnome-vfs2-devel, instead of gnome-vfs2
309  - gnome-keyring-devel
310- dropped --with-internal-libsexy in configure options
311- added in configure options:
312  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
313- added %%preun to remove the schema
314
315* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
316- new upstream release
317- changed to --with-metadata-helper in configure options
318- added BuildRequires:
319  - gstreamer-python
320  - intltool >= 0.35.0
321  - popt-devel
322
323* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
324- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
325- rebuilt with python-2.5.2
326- applied new versioning policy
327- spec in utf-8
328
329* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
330- rebuilt with libgpod-0.6.0
331
332* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
333- new upstream release
334
335* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
336- new upstream release
337
338* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
339- rebuilt with new toolchain and libgpod-0.4.2
340- add BuildRequires: dbus-glib-devel
341
342* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
343- new upstream release
344
345* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
346- rebuilt for VineSeed
347
348* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
349- new upstream release
350- added --enable-python option to %%configure
351- added Requires: gnome-python
352
353* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
354- new upstream release
355- built with libsoup 2.2.99
356
357* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
358- added --with-cd-burner to configure
359- added BuildRequires: libsexy-devel hal-devel libsoup-devel
360
361* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
362- add BuildRequires:
363  - gnome-doc-utils >= 0.3.2
364  - python-devel
365  - pygtk2-devel
366  - check >= 0.8.2
367
368* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
369- rebuild with gnutls-1.4.1
370
371* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
372- new upstream release
373
374* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
375- new upstream release
376- run scrollkeeper-update at %post and %postun
377- added BuildRequires: libnotify-devel
378
379* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
380- new upstream release (dropped patch0)
381- added --without-metadata-helper at configure
382
383* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
384- Initial build for Vine Linux based on FC pacakge
385
386* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
387- add patch from James "Doc" Livingston to stop a hang
388  for new users (bug 183883)
389
390* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
391- bump again for double-long bug on ppc(64)
392
393* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
394- rebuilt for new gcc4.1 snapshot and glibc changes
395
396* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
397- Update to 0.9.3.1
398- Use gstreamer (0.10)
399
400* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
401- Remove hack for 173869, as its no longer needed.
402
403* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
404- 0.9.3
405
406* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
407- Newer CVS snapshot
408
409* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
410- Update to latest CVS
411- Add hack to workaround bug #173869
412
413* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
414- Rebuild, now that gstreamer08-plugins has been fixed
415
416* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
417- bonobo multilib issue (bug 156982)
418
419* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
420- rebuild with ipod support
421
422* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
423- rebuilt again
424
425* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
426- rebuilt
427
428* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
429- rebuild
430
431* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
432- rebuild for new dbus
433
434* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
435- Update to 0.9.2
436
437* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
438- Update to 0.9.1
439
440* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
441- Add configure flags --with-bonobo --with-dbus
442- BR nautilus-cd-burner-devel
443- New upstream CVS snapshot for testing
444- Drop IDL file and ui .xml
445- Add dbus service file
446- Drop upstreamed rhythmbox-bluecurve.tar.gz
447- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
448
449* Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
450- Add Bluecurve-ized icons from Jeff Schroeder (157716)
451- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
452  cell renderer for playback icon (no longer necessary) and
453  changes the rating renderer to work with non-b&w icons
454
455* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
456- Rebuild for GCC4
457
458* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
459- New upstream version
460- Remove librb-nautilus-context-menu.so, killed upstream
461
462* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
463- PreReq desktop-file-utils >= 0.9
464
465* Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
466- New upstream version
467
468* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
469- Fix postun to use correct syntax, thanks Nils Philippsen
470
471* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
472- New upstream version
473- Call update-desktop-database in post and postun
474
475* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
476- New upstream version
477
478* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
479- rebuilt
480
481* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
482- New upstream version
483- Remove backported patches
484- Gratuitiously bump various BuildRequires versions
485
486* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
487- Remove code to unregister GConf schema for now (Closes: #122532)
488
489* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
490- Apply tiny patch from 0.8 arch to fix GConf key used
491  for initial sorting
492
493* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
494- Apply patch from 0.8 arch tree to fix a number of memleaks
495
496* Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
497- Update to 0.8.3: fixes showstopper bug with internet radio
498
499* Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
500- Update to 0.8.2
501- Fix Source url
502- Add smp_mflags
503- Bump BuildRequires on gstreamer to 0.8.1
504
505* Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
506- Uninstall GConf schemas on removal
507
508* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
509- Update to 0.8.1
510
511* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
512- Update to 0.8.0
513
514* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
515- Update to 0.7.2
516
517* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
518- Remove BuildRequires on autoconf and libvorbis-devel
519
520* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
521- New major version - I know we are past major version slush, but
522  this should have been done two weeks ago along with the GNOME 2.6
523  upload.  As upstream author as well, I believe this version is
524  good enough for FC2.
525- Remove --disable-mp3
526- Remove id3, flac variables
527- Remove GStreamer major version patch
528- Fix typo in description
529
530* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
531- rebuild for new gstreamer
532
533* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
534- update to 0.6.8
535
536* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
537- rebuilt
538
539* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
540- update to 0.6.7
541
542* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
543- rebuilt
544
545* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
546- New upstream version
547- Don't re-run the autotools; upstream incorporates newer versions.
548* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
549- new version
550- remove smp_flags
551
552* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
553- remove the initial iradio channels as they all are mp3 based.
554
555* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
556- Fix category from Development/Libraries to Applications/Multimedia.
557- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
558- Fix SCHEMES vs. SCHEMAS in the post scriplet.
559- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
560- Removed unnecessary date expansion define.
561- Updated description, including mp3 reference removal.
562- Added libid3tag and flac optional support for convenient rebuild.
563- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
564
565* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
566- new version
567- use %{_sysconfdir} instead of /etc
568
569* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
570- rebuilt
571
572* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
573- gave up on other archs for the Beta
574- new version
575- remove werror and add missing files
576
577* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
578- update to newer cvs snap
579
580* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
581- update to cvs snap
582
583* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
584- use %%(lang)
585
586* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
587- fix post to actually install the schema
588
589* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
590- Added gconf file
591- Added i18n directory
592
593* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
594- Updated for new rewrite of rhythmbox, thanks to Jeroen
595
596* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
597- removed bonobo dependency
598* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
599- created new spec file
Note: See TracBrowser for help on using the repository browser.