source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 10716

Revision 10716, 20.7 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME-3.20

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 3.3.1
10Release: 1%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source0: http://download.gnome.org/sources/${name}/3.3/%{name}-%{version}.tar.xz
15
16Source101:      rhythmbox-png.tar.bz2
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: gtk3-devel
20BuildRequires: avahi-glib-devel >= 0.6
21BuildRequires: brasero-devel >= 2.32.0
22BuildRequires: dbus-glib-devel
23BuildRequires: gstreamer1-plugins-base-devel
24BuildRequires: json-glib-devel
25BuildRequires: libSM-devel
26BuildRequires: libgnome-keyring-devel >= 2.30.0
27BuildRequires: libgpod-devel
28BuildRequires: eudev-libgudev1-devel
29BuildRequires: libmusicbrainz3-devel >= 3.0.2
30BuildRequires: libnotify-devel
31BuildRequires: libsoup-devel
32BuildRequires: pygobject3-devel
33BuildRequires: totem-pl-parser-devel
34BuildRequires: WebKit3-gtk-devel
35BuildRequires: libpeas-devel
36BuildRequires: libsecret-devel
37BuildRequires: clutter-gtk-devel
38BuildRequires: clutter-gst-devel
39BuildRequires: libmx-devel
40BuildRequires: check-devel
41BuildRequires: libmtp-devel
42BuildRequires: libtdb-devel
43BuildRequires: grilo-devel
44BuildRequires: libdmapsharing-devel
45BuildRequires: lirc-devel
46BuildRequires: gnome-doc-utils >= 0.3.2
47BuildRequires: yelp-tools
48
49Requires: brasero
50Requires: libgnome-keyring
51%if %{enable_DLNA_UPnP}
52Requires: python-Coherence
53%endif
54Requires: desktop-file-utils >= %{desktop_file_utils_version}
55
56# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
57# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
58# # respectively.
59# Requires: self-build-gstreamer-plugins-ffmpeg
60# Requires: self-build-gstreamer-plugins-ugly
61
62Vendor: Project Vine
63Distribution: Vine Linux
64
65
66%description
67Rhythmbox is an integrated music management application based on the powerful
68GStreamer media framework. It has a number of features, including an easy to
69use music browser, searching and sorting, comprehensive audio format support
70through GStreamer, Internet Radio support, playlists and more.
71
72Rhythmbox is extensible through a plugin system.
73
74%description -l ja
75Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
76統合音楽管理アプリケーションです。
77見やすいユーザインターフェースを備え、検索や整列ができ、
78GStreamer により数多くの音声フォーマットをサポート、
79インターネットラジオをサポート、プレイリスト管理などの
80数多くの特徴を持ちます。
81
82%package devel
83Summary: Development tools for rhythmbox applications.
84Summary(ja): rhythmbox アプリケーションの開発用ファイル
85Group: Development/Libraries
86Requires: %{name} = %{version}-%{release}
87Requires: pkgconfig
88Requires: libxml2-devel
89Requires: glib2-devel
90Requires: gtk3-devel
91Requires: libsoup-devel
92Requires: totem-pl-parser-devel
93Requires: gstreamer1-devel
94
95%description devel
96Header files and libraries for building a extension library for the rhythmbox.
97
98%description devel -l ja
99
100%prep
101%setup -q
102tar xjf %{SOURCE101}
103
104%build
105autoreconf -if
106intltoolize --force --copy
107%configure --with-ipod \
108    --with-mtp \
109    --enable-lirc \
110    --disable-python \
111    --disable-vala \
112    --disable-browser-plugin \
113    --disable-static \
114    --enable-browser-plugin \
115    --without-hal
116%__make %{?_smp_mflags}
117
118%install
119%__rm -rf $RPM_BUILD_ROOT
120%__make install DESTDIR=$RPM_BUILD_ROOT
121
122%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
123%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
124%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
125%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
126%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
127%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
128%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
129
130## Don't package DLNA/UPnP plugin
131%if !%{enable_DLNA_UPnP}
132%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
133%endif
134
135%find_lang %{name} --all-name --with-gnome
136
137
138# Don't package api docs
139%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
140
141# And don't package vala
142%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
143        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
144
145# remove sample plugins
146rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
147
148%clean
149%__rm -rf $RPM_BUILD_ROOT
150
151%post
152/sbin/ldconfig
153update-desktop-database -q
154touch --no-create %{_datadir}/icons/hicolor
155if [ -x /usr/bin/gtk-update-icon-cache ]; then
156  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
157fi
158
159%postun
160/sbin/ldconfig
161update-desktop-database -q
162touch --no-create %{_datadir}/icons/hicolor
163if [ -x /usr/bin/gtk-update-icon-cache ]; then
164  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
165fi
166glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
167
168%posttrans
169glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
170
171
172%files -f %{name}.lang
173%defattr(-, root, root)
174%doc AUTHORS COPYING ChangeLog README NEWS
175%{_bindir}/*
176%{_libdir}/girepository-1.0/*.typelib
177%{_libdir}/lib*.so.*
178%{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
179%{_libdir}/rhythmbox/plugins
180%{_datadir}/appdata/rhythmbox.appdata.xml
181%{_datadir}/applications/rhythmbox.desktop
182%{_datadir}/applications/rhythmbox-device.desktop
183%{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
184%{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
185%{_datadir}/icons/*
186%{_datadir}/rhythmbox
187%{_mandir}/man1/*
188%{_libexecdir}/rhythmbox-metadata
189
190%files devel
191%defattr(-, root, root)
192%{_includedir}/%{name}/*
193%{_libdir}/*.so
194%{_libdir}/pkgconfig/*.pc
195%{_datadir}/gir-1.0/*.gir
196
197
198%changelog
199* Mon Jul 18 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.1-1
200- new upstream release
201- add BuildRequires: libsecret-devel, lirc-devel
202- remove Patch0 (rhythmbox-3.0-disable-python3.patch)
203
204* Thu May 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.2.1-2
205- rebuilt with libimobiledevice 1.2.0 and libplist 1.12
206
207* Sun May 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
208- new upstream release
209
210* Sat Apr 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2-1
211- new upstream release
212
213* Wed Jul 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.3-2
214- rebuild with new libimobiledevice
215
216* Sat Jun 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
217- new upstream release
218
219* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
220- new upstream release
221
222* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-2
223- rebuild with VineSeed environment
224
225* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
226- new upstream release
227
228* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
229- new upstream release
230- add Patch0 (rhythmbox-3.0-disable-python3.patch)
231
232* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.1-1
233- new upstream release
234- add BuildRequies: yelp-tools
235- change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
236
237* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-2
238- rebuild with libimobiledevice-1.1.5
239
240* Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
241- new upstream release
242- add BuildRequires: grilo-devel, libdmapsharing-devel
243
244* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
245- new upstream release
246
247* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
248- new upstream release
249
250* Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
251- new upstream release
252- add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
253- remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
254
255* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
256- rebuild with cogl-0.8.0
257
258* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
259- rebuild with libnotify-0.7
260- change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
261- change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
262- add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
263- add Patch0 (rhythmbox-0.13.3-git20110809.patch)
264- add Source101 (rhythmbox-png.tar.bz2)
265
266* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
267- add BuildRequires: json-glib-devel
268- remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
269
270* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
271- new upstream release
272- change BuildRequires: gstreamer-python-devel instead of gstreamer-python
273
274* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
275- new upstream release
276
277* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
278- rebuild with brasero-2.32.0
279
280* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
281- rebuild with rpm-4.8.1 for pkg-config file
282
283* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
284- new upstream release
285- fix %files (add rhythmbox-device.desktop)
286
287* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
288- new upstream release
289- change BuildRequires: gnome-media-devel instead of gnome-media
290- add devel package
291- drop Patch0
292
293* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
294- new upstream release
295- drop Patch1, Patch2, Patch3
296- change BuildRequires: nautilus-cd-burner -> brasero-devel
297- change Requires: nautilus-cd-burner -> brasero
298- change BuildRequires: hal-devel -> libgudev1-devel
299- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
300- change Requires: gnome-keyring -> libgnome-keyring
301- add configure option (--without-hal)
302
303* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
304- rebuilt with new environment
305
306* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
307- new upstream release
308  - dropped upstreamed/obsolete patches
309  - added patches applied Fedora development
310
311* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
312- new upstream release
313- added configure options:
314  --disable-vala
315  --disable-browser-plugin
316
317* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
318- added Japanese description
319
320* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
321- new upstream release
322  - dropped rb-disable-power-plugin-by-default.patch
323- added BuildRequires:
324  - libSM-devel
325  - gnome-media
326
327* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
328- rebuild with libgpod-0.7.2
329
330* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
331- new upstream release
332- corrected License tag
333- dropped rhythmbox-0.11.6-libmtp.patch
334- added BuildRequires:
335  - sqlite3-devel
336  - libffi-devel
337
338* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
339- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
340- applied rhythmbox-0.11.6-libmtp.patch
341- added Requires:
342  - libgpod
343  - libnotify
344  - libsexy
345  - lirc
346  - libmtp
347  - libgnomeui
348  - nautilus-cd-burner
349  - gstreamer-python
350  - gnome-vfs2
351  - gnome-themes
352  - gnome-keyring
353  - python-Coherence, if enable_DLNA_UPnP = 1
354- added BuildRequires:
355  - libnotify-devel
356  - libsexy-devel
357  - lirc
358  - libmtp-devel
359  - gnome-vfs2-devel, instead of gnome-vfs2
360  - gnome-keyring-devel
361- dropped --with-internal-libsexy in configure options
362- added in configure options:
363  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
364- added %%preun to remove the schema
365
366* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
367- new upstream release
368- changed to --with-metadata-helper in configure options
369- added BuildRequires:
370  - gstreamer-python
371  - intltool >= 0.35.0
372  - popt-devel
373
374* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
375- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
376- rebuilt with python-2.5.2
377- applied new versioning policy
378- spec in utf-8
379
380* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
381- rebuilt with libgpod-0.6.0
382
383* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
384- new upstream release
385
386* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
387- new upstream release
388
389* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
390- rebuilt with new toolchain and libgpod-0.4.2
391- add BuildRequires: dbus-glib-devel
392
393* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
394- new upstream release
395
396* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
397- rebuilt for VineSeed
398
399* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
400- new upstream release
401- added --enable-python option to %%configure
402- added Requires: gnome-python
403
404* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
405- new upstream release
406- built with libsoup 2.2.99
407
408* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
409- added --with-cd-burner to configure
410- added BuildRequires: libsexy-devel hal-devel libsoup-devel
411
412* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
413- add BuildRequires:
414  - gnome-doc-utils >= 0.3.2
415  - python-devel
416  - pygtk2-devel
417  - check >= 0.8.2
418
419* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
420- rebuild with gnutls-1.4.1
421
422* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
423- new upstream release
424
425* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
426- new upstream release
427- run scrollkeeper-update at %post and %postun
428- added BuildRequires: libnotify-devel
429
430* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
431- new upstream release (dropped patch0)
432- added --without-metadata-helper at configure
433
434* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
435- Initial build for Vine Linux based on FC pacakge
436
437* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
438- add patch from James "Doc" Livingston to stop a hang
439  for new users (bug 183883)
440
441* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
442- bump again for double-long bug on ppc(64)
443
444* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
445- rebuilt for new gcc4.1 snapshot and glibc changes
446
447* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
448- Update to 0.9.3.1
449- Use gstreamer (0.10)
450
451* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
452- Remove hack for 173869, as its no longer needed.
453
454* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
455- 0.9.3
456
457* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
458- Newer CVS snapshot
459
460* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
461- Update to latest CVS
462- Add hack to workaround bug #173869
463
464* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
465- Rebuild, now that gstreamer08-plugins has been fixed
466
467* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
468- bonobo multilib issue (bug 156982)
469
470* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
471- rebuild with ipod support
472
473* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
474- rebuilt again
475
476* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
477- rebuilt
478
479* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
480- rebuild
481
482* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
483- rebuild for new dbus
484
485* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
486- Update to 0.9.2
487
488* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
489- Update to 0.9.1
490
491* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
492- Add configure flags --with-bonobo --with-dbus
493- BR nautilus-cd-burner-devel
494- New upstream CVS snapshot for testing
495- Drop IDL file and ui .xml
496- Add dbus service file
497- Drop upstreamed rhythmbox-bluecurve.tar.gz
498- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
499
500* Mon Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
501- Add Bluecurve-ized icons from Jeff Schroeder (157716)
502- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
503  cell renderer for playback icon (no longer necessary) and
504  changes the rating renderer to work with non-b&w icons
505
506* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
507- Rebuild for GCC4
508
509* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
510- New upstream version
511- Remove librb-nautilus-context-menu.so, killed upstream
512
513* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
514- PreReq desktop-file-utils >= 0.9
515
516* Wed Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
517- New upstream version
518
519* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
520- Fix postun to use correct syntax, thanks Nils Philippsen
521
522* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
523- New upstream version
524- Call update-desktop-database in post and postun
525
526* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
527- New upstream version
528
529* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
530- rebuilt
531
532* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
533- New upstream version
534- Remove backported patches
535- Gratuitiously bump various BuildRequires versions
536
537* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
538- Remove code to unregister GConf schema for now (Closes: #122532)
539
540* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
541- Apply tiny patch from 0.8 arch to fix GConf key used
542  for initial sorting
543
544* Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
545- Apply patch from 0.8 arch tree to fix a number of memleaks
546
547* Sun May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
548- Update to 0.8.3: fixes showstopper bug with internet radio
549
550* Fri Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
551- Update to 0.8.2
552- Fix Source url
553- Add smp_mflags
554- Bump BuildRequires on gstreamer to 0.8.1
555
556* Fri Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
557- Uninstall GConf schemas on removal
558
559* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
560- Update to 0.8.1
561
562* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
563- Update to 0.8.0
564
565* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
566- Update to 0.7.2
567
568* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
569- Remove BuildRequires on autoconf and libvorbis-devel
570
571* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
572- New major version - I know we are past major version slush, but
573  this should have been done two weeks ago along with the GNOME 2.6
574  upload.  As upstream author as well, I believe this version is
575  good enough for FC2.
576- Remove --disable-mp3
577- Remove id3, flac variables
578- Remove GStreamer major version patch
579- Fix typo in description
580
581* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
582- rebuild for new gstreamer
583
584* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
585- update to 0.6.8
586
587* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
588- rebuilt
589
590* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
591- update to 0.6.7
592
593* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
594- rebuilt
595
596* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
597- New upstream version
598- Don't re-run the autotools; upstream incorporates newer versions.
599* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
600- new version
601- remove smp_flags
602
603* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
604- remove the initial iradio channels as they all are mp3 based.
605
606* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
607- Fix category from Development/Libraries to Applications/Multimedia.
608- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
609- Fix SCHEMES vs. SCHEMAS in the post scriplet.
610- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
611- Removed unnecessary date expansion define.
612- Updated description, including mp3 reference removal.
613- Added libid3tag and flac optional support for convenient rebuild.
614- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
615
616* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
617- new version
618- use %{_sysconfdir} instead of /etc
619
620* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
621- rebuilt
622
623* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
624- gave up on other archs for the Beta
625- new version
626- remove werror and add missing files
627
628* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
629- update to newer cvs snap
630
631* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
632- update to cvs snap
633
634* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
635- use %%(lang)
636
637* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
638- fix post to actually install the schema
639
640* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
641- Added gconf file
642- Added i18n directory
643
644* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
645- Updated for new rewrite of rhythmbox, thanks to Jeroen
646
647* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
648- removed bonobo dependency
649* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
650- created new spec file
Note: See TracBrowser for help on using the repository browser.