source: projects/specs/trunk/r/rhythmbox/rhythmbox-vl.spec @ 1917

Revision 1917, 18.8 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1# -*- coding: utf-8-unix -*-
2%define desktop_file_utils_version 0.9
3
4%define enable_DLNA_UPnP 0
5
6Summary: Music Management Application
7Summary(ja): 音楽管理アプリケーション
8Name: rhythmbox
9Version: 0.13.1
10Release: 2%{?_dist_release}
11License: GPL2+ with exceptions and GFDL
12Group: Applications/Multimedia
13URL: http://projects.gnome.org/rhythmbox/
14Source: http://download.gnome.org/sources/rhythmbox/0.13/%{name}-%{version}.tar.bz2
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: libgpod-devel
18BuildRequires: libgnomeui-devel >= 2.18.0
19BuildRequires: brasero-devel
20BuildRequires: gstreamer-plugins-base-devel >= 0.10
21BuildRequires: gettext, rarian-compat
22BuildRequires: totem-pl-parser-devel
23BuildRequires: sqlite3-devel
24BuildRequires: libffi-devel
25BuildRequires: gnome-vfs2-devel >= 2.18.0
26BuildRequires: avahi-glib-devel >= 0.6
27BuildRequires: libmusicbrainz-devel >= 2.1.0
28BuildRequires: libnotify-devel
29BuildRequires: libsexy-devel
30BuildRequires: libgudev1-devel
31BuildRequires: libsoup-devel
32BuildRequires: dbus-devel >= 1.0
33BuildRequires: dbus-glib-devel
34BuildRequires: gnome-doc-utils >= 0.3.2
35BuildRequires: python-devel, pygtk2-devel
36BuildRequires: check >= 0.8.2
37BuildRequires: intltool >= 0.35.0
38BuildRequires: gstreamer-python
39BuildRequires: popt-devel
40BuildRequires: lirc
41BuildRequires: libmtp-devel
42BuildRequires: libgnome-keyring-devel >= 2.30.0
43BuildRequires: gnome-media-devel
44BuildRequires: libSM-devel
45Requires: libgpod
46Requires: libnotify
47Requires: libsexy
48Requires: lirc
49Requires: libmtp
50Requires: libgnomeui
51Requires: brasero
52Requires: gnome-python gnome-vfs2
53Requires: gnome-themes
54Requires: libgnome-keyring
55Requires: gstreamer-python
56%if %{enable_DLNA_UPnP}
57Requires: python-Coherence
58%endif
59Requires: desktop-file-utils >= %{desktop_file_utils_version}
60Requires: scrollkeeper GConf2
61
62# # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
63# # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
64# # respectively.
65# Requires: self-build-gstreamer-plugins-ffmpeg
66# Requires: self-build-gstreamer-plugins-ugly
67
68
69%description
70Rhythmbox is an integrated music management application based on the powerful
71GStreamer media framework. It has a number of features, including an easy to
72use music browser, searching and sorting, comprehensive audio format support
73through GStreamer, Internet Radio support, playlists and more.
74
75Rhythmbox is extensible through a plugin system.
76
77%description -l ja
78Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
79統合音楽管理アプリケーションです。
80見やすいユーザインターフェースを備え、検索や整列ができ、
81GStreamer により数多くの音声フォーマットをサポート、
82インターネットラジオをサポート、プレイリスト管理などの
83数多くの特徴を持ちます。
84
85%package devel
86Summary: Development tools for rhythmbox applications.
87Summary(ja): rhythmbox アプリケーションの開発用ファイル
88Group: Development/Libraries
89Requires: %{name} = %{version}-%{release}
90Requires: pkgconfig
91Requires: glib2-devel
92Requires: gtk2-devel
93Requires: libsoup-devel
94Requires: gnome-media-devel
95Requires: totem-pl-parser-devel
96Requires: gstreamer-devel
97
98%description devel
99Header files and libraries for building a extension library for the rhythmbox.
100
101%description devel -l ja
102
103%prep
104%setup -q
105# autoreconf -i
106
107# Use the installed louie, not the one in Coherence
108find plugins/coherence/upnp_coherence/ -type f \
109    -exec %__sed -i 's/coherence.extern.louie as louie/louie/' '{}' ';'
110
111%build
112# work around a gstreamer bug
113/usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
114
115%configure --with-ipod \
116    --with-mtp \
117    --with-dbus \
118    --with-mdns=avahi \
119    --with-libnautilus-burn \
120    --with-cd-burning \
121    --with-metadata-helper \
122    --enable-lirc \
123    --enable-python \
124    --disable-vala \
125    --disable-browser-plugin \
126    --disable-static \
127    --disable-scrollkeeper \
128    --disable-schemas-install \
129    --without-hal
130%__make %{?_smp_mflags}
131
132%install
133%__rm -rf $RPM_BUILD_ROOT
134export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
135%__make install DESTDIR=$RPM_BUILD_ROOT
136unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
137
138%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
139%__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
140%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
141%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
142%__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
143%__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
144%__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
145
146## Don't package DLNA/UPnP plugin
147%if !%{enable_DLNA_UPnP}
148%__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
149%endif
150
151%find_lang %{name}
152
153
154# Don't package api docs
155%__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
156
157# Don't package scrollkeeper catalogs
158%__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
159
160# And don't package vala
161%__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
162        %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
163
164# save space by linking identical images in translated docs
165helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
166for f in $helpdir/C/figures/*.png; do
167  b="$(basename $f)"
168  for d in $helpdir/*; do
169    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
170      g="$d/figures/$b"
171      if [ -f "$g" ]; then
172        if cmp -s $f $g; then
173          %__rm "$g"; ln -s "../../C/figures/$b" "$g"
174        fi
175      fi
176    fi
177  done
178done
179
180
181%clean
182%__rm -rf $RPM_BUILD_ROOT
183
184%post
185/sbin/ldconfig
186export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
187gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/rhythmbox.schemas >/dev/null
188update-desktop-database -q
189scrollkeeper-update -q
190touch --no-create %{_datadir}/icons/hicolor
191if [ -x /usr/bin/gtk-update-icon-cache ]; then
192  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
193fi
194
195%preun
196if [ "$1" -eq 0 ]; then
197    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
198    gconftool-2 --makefile-uninstall-rule \
199      %{_sysconfdir}/gconf/schemas/rhythmbox.schemas > /dev/null || :
200fi
201
202%postun
203/sbin/ldconfig
204update-desktop-database -q
205scrollkeeper-update -q
206touch --no-create %{_datadir}/icons/hicolor
207if [ -x /usr/bin/gtk-update-icon-cache ]; then
208  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
209fi
210
211
212%files -f %{name}.lang
213%defattr(-, root, root)
214%doc AUTHORS COPYING ChangeLog README NEWS
215%{_sysconfdir}/gconf/schemas/rhythmbox.schemas
216%{_bindir}/*
217%{_libdir}/lib*.so.*
218%{_libdir}/rhythmbox/plugins
219%{_datadir}/applications/rhythmbox.desktop
220%{_datadir}/applications/rhythmbox-device.desktop
221%{_datadir}/dbus-1/services/org.gnome.Rhythmbox.service
222%{_datadir}/gnome/help/rhythmbox
223%{_datadir}/icons/*
224%{_datadir}/omf/rhythmbox
225%{_datadir}/rhythmbox
226%{_mandir}/man1/*
227%{_libexecdir}/rhythmbox-metadata
228
229%files devel
230%defattr(-, root, root)
231%{_includedir}/%{name}/*
232%{_libdir}/*.so
233%{_libdir}/pkgconfig/*.pc
234
235
236%changelog
237* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
238- rebuild with rpm-4.8.1 for pkg-config file
239
240* Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
241- new upstream release
242- fix %files (add rhythmbox-device.desktop)
243
244* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
245- new upstream release
246- change BuildRequires: gnome-media-devel instead of gnome-media
247- add devel package
248- drop Patch0
249
250* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
251- new upstream release
252- drop Patch1, Patch2, Patch3
253- change BuildRequires: nautilus-cd-burner -> brasero-devel
254- change Requires: nautilus-cd-burner -> brasero
255- change BuildRequires: hal-devel -> libgudev1-devel
256- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
257- change Requires: gnome-keyring -> libgnome-keyring
258- add configure option (--without-hal)
259
260* Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
261- rebuilt with new environment
262
263* Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
264- new upstream release
265  - dropped upstreamed/obsolete patches
266  - added patches applied Fedora development
267
268* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
269- new upstream release
270- added configure options:
271  --disable-vala
272  --disable-browser-plugin
273
274* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
275- added Japanese description
276
277* Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
278- new upstream release
279  - dropped rb-disable-power-plugin-by-default.patch
280- added BuildRequires:
281  - libSM-devel
282  - gnome-media
283
284* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
285- rebuild with libgpod-0.7.2
286
287* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
288- new upstream release
289- corrected License tag
290- dropped rhythmbox-0.11.6-libmtp.patch
291- added BuildRequires:
292  - sqlite3-devel
293  - libffi-devel
294
295* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
296- defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
297- applied rhythmbox-0.11.6-libmtp.patch
298- added Requires:
299  - libgpod
300  - libnotify
301  - libsexy
302  - lirc
303  - libmtp
304  - libgnomeui
305  - nautilus-cd-burner
306  - gstreamer-python
307  - gnome-vfs2
308  - gnome-themes
309  - gnome-keyring
310  - python-Coherence, if enable_DLNA_UPnP = 1
311- added BuildRequires:
312  - libnotify-devel
313  - libsexy-devel
314  - lirc
315  - libmtp-devel
316  - gnome-vfs2-devel, instead of gnome-vfs2
317  - gnome-keyring-devel
318- dropped --with-internal-libsexy in configure options
319- added in configure options:
320  --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
321- added %%preun to remove the schema
322
323* Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
324- new upstream release
325- changed to --with-metadata-helper in configure options
326- added BuildRequires:
327  - gstreamer-python
328  - intltool >= 0.35.0
329  - popt-devel
330
331* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
332- added BuildRequires: totem-pl-parser-devel, instead of totem-devel
333- rebuilt with python-2.5.2
334- applied new versioning policy
335- spec in utf-8
336
337* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
338- rebuilt with libgpod-0.6.0
339
340* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
341- new upstream release
342
343* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
344- new upstream release
345
346* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
347- rebuilt with new toolchain and libgpod-0.4.2
348- add BuildRequires: dbus-glib-devel
349
350* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
351- new upstream release
352
353* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
354- rebuilt for VineSeed
355
356* Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
357- new upstream release
358- added --enable-python option to %%configure
359- added Requires: gnome-python
360
361* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
362- new upstream release
363- built with libsoup 2.2.99
364
365* Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
366- added --with-cd-burner to configure
367- added BuildRequires: libsexy-devel hal-devel libsoup-devel
368
369* Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
370- add BuildRequires:
371  - gnome-doc-utils >= 0.3.2
372  - python-devel
373  - pygtk2-devel
374  - check >= 0.8.2
375
376* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
377- rebuild with gnutls-1.4.1
378
379* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
380- new upstream release
381
382* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
383- new upstream release
384- run scrollkeeper-update at %post and %postun
385- added BuildRequires: libnotify-devel
386
387* Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
388- new upstream release (dropped patch0)
389- added --without-metadata-helper at configure
390
391* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
392- Initial build for Vine Linux based on FC pacakge
393
394* Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
395- add patch from James "Doc" Livingston to stop a hang
396  for new users (bug 183883)
397
398* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
399- bump again for double-long bug on ppc(64)
400
401* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
402- rebuilt for new gcc4.1 snapshot and glibc changes
403
404* Sat Feb  4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
405- Update to 0.9.3.1
406- Use gstreamer (0.10)
407
408* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
409- Remove hack for 173869, as its no longer needed.
410
411* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
412- 0.9.3
413
414* Wed Feb  1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
415- Newer CVS snapshot
416
417* Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
418- Update to latest CVS
419- Add hack to workaround bug #173869
420
421* Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
422- Rebuild, now that gstreamer08-plugins has been fixed
423
424* Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
425- bonobo multilib issue (bug 156982)
426
427* Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
428- rebuild with ipod support
429
430* Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
431- rebuilt again
432
433* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
434- rebuilt
435
436* Mon Dec  5 2005 Matthias Clasen <mclasen@redhat.com>
437- rebuild
438
439* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
440- rebuild for new dbus
441
442* Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
443- Update to 0.9.2
444
445* Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
446- Update to 0.9.1
447
448* Fri Sep 02 2005 Colin Walters <walters@redhat.com>
449- Add configure flags --with-bonobo --with-dbus
450- BR nautilus-cd-burner-devel
451- New upstream CVS snapshot for testing
452- Drop IDL file and ui .xml
453- Add dbus service file
454- Drop upstreamed rhythmbox-bluecurve.tar.gz
455- Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
456
457* Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
458- Add Bluecurve-ized icons from Jeff Schroeder (157716)
459- Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
460  cell renderer for playback icon (no longer necessary) and
461  changes the rating renderer to work with non-b&w icons
462
463* Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
464- Rebuild for GCC4
465
466* Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
467- New upstream version
468- Remove librb-nautilus-context-menu.so, killed upstream
469
470* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
471- PreReq desktop-file-utils >= 0.9
472
473* Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
474- New upstream version
475
476* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
477- Fix postun to use correct syntax, thanks Nils Philippsen
478
479* Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
480- New upstream version
481- Call update-desktop-database in post and postun
482
483* Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
484- New upstream version
485
486* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
487- rebuilt
488
489* Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
490- New upstream version
491- Remove backported patches
492- Gratuitiously bump various BuildRequires versions
493
494* Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
495- Remove code to unregister GConf schema for now (Closes: #122532)
496
497* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
498- Apply tiny patch from 0.8 arch to fix GConf key used
499  for initial sorting
500
501* Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
502- Apply patch from 0.8 arch tree to fix a number of memleaks
503
504* Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
505- Update to 0.8.3: fixes showstopper bug with internet radio
506
507* Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
508- Update to 0.8.2
509- Fix Source url
510- Add smp_mflags
511- Bump BuildRequires on gstreamer to 0.8.1
512
513* Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
514- Uninstall GConf schemas on removal
515
516* Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
517- Update to 0.8.1
518
519* Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
520- Update to 0.8.0
521
522* Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
523- Update to 0.7.2
524
525* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
526- Remove BuildRequires on autoconf and libvorbis-devel
527
528* Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
529- New major version - I know we are past major version slush, but
530  this should have been done two weeks ago along with the GNOME 2.6
531  upload.  As upstream author as well, I believe this version is
532  good enough for FC2.
533- Remove --disable-mp3
534- Remove id3, flac variables
535- Remove GStreamer major version patch
536- Fix typo in description
537
538* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
539- rebuild for new gstreamer
540
541* Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
542- update to 0.6.8
543
544* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
545- rebuilt
546
547* Mon Mar  1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
548- update to 0.6.7
549
550* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
551- rebuilt
552
553* Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
554- New upstream version
555- Don't re-run the autotools; upstream incorporates newer versions.
556* Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
557- new version
558- remove smp_flags
559
560* Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
561- remove the initial iradio channels as they all are mp3 based.
562
563* Wed Oct  8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
564- Fix category from Development/Libraries to Applications/Multimedia.
565- Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
566- Fix SCHEMES vs. SCHEMAS in the post scriplet.
567- Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
568- Removed unnecessary date expansion define.
569- Updated description, including mp3 reference removal.
570- Added libid3tag and flac optional support for convenient rebuild.
571- Removed obsolete omf.make and xmldocs.make (included ones are the same now).
572
573* Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
574- new version
575- use %{_sysconfdir} instead of /etc
576
577* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
578- rebuilt
579
580* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
581- gave up on other archs for the Beta
582- new version
583- remove werror and add missing files
584
585* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
586- update to newer cvs snap
587
588* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
589- update to cvs snap
590
591* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
592- use %%(lang)
593
594* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
595- fix post to actually install the schema
596
597* Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
598- Added gconf file
599- Added i18n directory
600
601* Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
602- Updated for new rewrite of rhythmbox, thanks to Jeroen
603
604* Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
605- removed bonobo dependency
606* Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
607- created new spec file
Note: See TracBrowser for help on using the repository browser.