source: projects/specs/trunk/p/perl-Tk/perl-Tk-vl.spec @ 821

Revision 821, 2.7 KB checked in by inagaki, 14 years ago (diff)

updated: perl-Tk, perl-HTML-Parser

Line 
1%define pkgname Tk
2
3Summary:        A perl module for Tk.
4Name:           perl-%{pkgname}
5Version:        804.028
6Release:        3%{_dist_release}
7Group:          Development/Libraries
8License:        GPL or Artistic
9URL:            http://perltk.org/
10Source0:        %{pkgname}-%{version}.tar.gz
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12BuildRequires:  libX11-devel libpng-devel
13
14## bug fix
15# fixed: http://rt.cpan.org/Public/Bug/Display.html?id=38746
16Patch11:        perl-Tk-fix38746.patch
17
18## security fix
19Patch100:       Tk-804.027-suse-CVE-2006-4484.patch
20
21Provides: perl(Tk::LabRadio) = 4.004
22Provides: perl(Tk::TextReindex) = 4.004
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27%description
28Perl bindings to the Tk Graphical User Interface ToolKit.
29
30%prep
31%setup -q -n %{pkgname}-%{version}
32%{__mkdir} pTk.docs
33%{__cp} pTk/Tix.license pTk/license.terms pTk/license.html_lib pTk.docs
34
35## bug fix
36%patch11 -p0 -b .bug38746
37
38## security fix
39%patch100 -p0 -b .CVE-2006-4484
40
41%build
42find . -type f -exec %{__perl} -pi -e 's|^#!/.*bin/perl\S*|#!%{__perl}|i;' {} \;
43CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL PREFIX=$RPM_BUILD_ROOT%{_prefix} INSTALLDIRS=vendor
44make %{?_smp_mflags}
45# make test
46
47%install
48rm -rf $RPM_BUILD_ROOT
49make install
50
51[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
52
53find $RPM_BUILD_ROOT%{_prefix} -type f -print | \
54        sed "s@^$RPM_BUILD_ROOT@@g" | \
55        grep -v perllocal.pod | \
56        grep -v "\.packlist" > %{pkgname}-%{version}-filelist
57if [ "$(cat %{pkgname}-%{version}-filelist)X" = "X" ] ; then
58    echo "ERROR: EMPTY FILE LIST"
59    exit -1
60fi
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%files -f %{pkgname}-%{version}-filelist
66%defattr(-,root,root)
67%doc README MANIFEST COPYING Change.log Changes README.linux pTk.docs
68
69%changelog
70* Sat Jan  9 2010 IWAI, Masaharu <iwai@alib.jp> 804.028-3
71- add BuildRequires: libX11-devel libpng-devel : <BTS:VineLinux:866>
72- drop X11LIBS argument for Makefile.PL on x86_64 architecture
73- add documents
74
75* Mon Jan  4 2010 IWAI, Masaharu <iwai@alib.jp> 804.028-2
76- add patch11 for fix CPAN bug #38746: <BTS:VineLinux:866>
77  - see http://rt.cpan.org/Public/Bug/Display.html?id=38746
78
79* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 804.028-1
80- new upstream release
81- build with perl-8.10.0
82
83* Fri Mar 28 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 804.027-3
84- add patch100 for fix CVE-2006-4484
85- with new versioning policy
86- add Vendor/Distribution tag
87
88* Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 804.027-0vl2
89- added X11LIB to build (for x86_64)
90
91* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 804.027-0vl1
92- updated to 804.027
93- build with perl-5.8.6
94- no noarch now (arch-dependent files/binaries are actually included)
95
96* Sun Oct 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 804.026-0vl1
97- initial build for Vine Linux
98
Note: See TracBrowser for help on using the repository browser.