source: projects/specs/trunk/p/perl-Tk/perl-Tk-vl.spec @ 521

Revision 521, 2.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pkgname Tk
2
3Summary:        A perl module for Tk.
4Name:           perl-%{pkgname}
5Version:        804.028
6Release:        1%{_dist_release}
7Group:          Development/Libraries
8License:        GPL or Artistic
9URL:            http://perltk.org/
10Source0:        %{pkgname}-%{version}.tar.gz
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
13# security fix
14Patch100:       Tk-804.027-suse-CVE-2006-4484.patch
15
16Provides: perl(Tk::LabRadio) = 4.004
17Provides: perl(Tk::TextReindex) = 4.004
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23Perl bindings to the Tk Graphical User Interface ToolKit.
24
25%prep
26%setup -q -n %{pkgname}-%{version}
27
28# security fix
29%patch100 -p0 -b .CVE-2006-4484
30
31%build
32find . -type f -exec %{__perl} -pi -e 's|^#!/.*bin/perl\S*|#!%{__perl}|i;' {} \;
33%ifarch x86_64
34CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL PREFIX=$RPM_BUILD_ROOT%{_prefix} \
35        INSTALLDIRS=vendor X11LIB=/usr/X11R6/%{_lib}
36%else
37CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL PREFIX=$RPM_BUILD_ROOT%{_prefix} INSTALLDIRS=vendor
38%endif
39make %{?_smp_mflags}
40# make test
41
42%install
43rm -rf $RPM_BUILD_ROOT
44make install
45
46[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
47
48find $RPM_BUILD_ROOT%{_prefix} -type f -print | \
49        sed "s@^$RPM_BUILD_ROOT@@g" | \
50        grep -v perllocal.pod | \
51        grep -v "\.packlist" > %{pkgname}-%{version}-filelist
52if [ "$(cat %{pkgname}-%{version}-filelist)X" = "X" ] ; then
53    echo "ERROR: EMPTY FILE LIST"
54    exit -1
55fi
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%files -f %{pkgname}-%{version}-filelist
61%defattr(-,root,root)
62%doc README MANIFEST
63
64%changelog
65* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 804.028-1
66- new upstream release
67- build with perl-8.10.0
68
69* Fri Mar 28 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 804.027-3
70- add patch100 for fix CVE-2006-4484
71- with new versioning policy
72- add Vendor/Distribution tag
73
74* Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 804.027-0vl2
75- added X11LIB to build (for x86_64)
76
77* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 804.027-0vl1
78- updated to 804.027
79- build with perl-5.8.6
80- no noarch now (arch-dependent files/binaries are actually included)
81
82* Sun Oct 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 804.026-0vl1
83- initial build for Vine Linux
84
Note: See TracBrowser for help on using the repository browser.