source: projects/specs/trunk/p/perl-Tk/perl-Tk-vl.spec @ 3934

Revision 3934, 3.6 KB checked in by owa, 13 years ago (diff)

rebuild: perl-Tk

Line 
1# if you wanna test, add " --define '_run_test 1' " option to rpmbuild command
2%define run_test %{?_run_test:1}%{!?_run_test:0}
3%define pkgname Tk
4
5Summary:        A perl module for Tk.
6Name:           perl-%{pkgname}
7Version:        804.028
8Release:        4%{_dist_release}
9Group:          Development/Libraries
10License:        GPL or Artistic
11URL:            http://perltk.org/
12Source0:        %{pkgname}-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  libX11-devel libpng-devel
15
16## bug fix
17# fixed: http://rt.cpan.org/Public/Bug/Display.html?id=38746
18Patch11:        perl-Tk-fix38746.patch
19
20## security fix
21Patch100:       Tk-804.027-suse-CVE-2006-4484.patch
22
23## for VineLinux6
24Patch200: perl-Tk-804.028.Xlib.patch
25Patch201: perl-Tk-804.028.pTkCallback.patch
26Patch202: perl-Tk-804.028.encGlue.patch
27Patch203: perl-Tk-804.028.tkGlue.patch
28
29
30Provides: perl(Tk::LabRadio) = 4.004
31Provides: perl(Tk::TextReindex) = 4.004
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37Perl bindings to the Tk Graphical User Interface ToolKit.
38
39%prep
40%setup -q -n %{pkgname}-%{version}
41%{__mkdir} pTk.docs
42%{__cp} pTk/Tix.license pTk/license.terms pTk/license.html_lib pTk.docs
43
44## bug fix
45%patch11 -p0 -b .bug38746
46
47## security fix
48%patch100 -p0 -b .CVE-2006-4484
49
50## for VineLinux6
51%patch200 -p1 -b .Xlib
52%patch201 -p1 -b .pTkCallback
53%patch202 -p1 -b .encGlue
54%patch203 -p1 -b .tkGlue
55
56%build
57find . -type f -exec %{__perl} -pi -e 's|^#!/.*bin/perl\S*|#!%{__perl}|i;' {} \;
58CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL PREFIX=$RPM_BUILD_ROOT%{_prefix} INSTALLDIRS=vendor
59make %{?_smp_mflags}
60
61%if %{run_test}
62make test
63#-------------------------------#
64# Sun May 22 2011 ..last tested #
65# Result: PASS
66#-------------------------------#
67%endif
68
69
70%install
71rm -rf $RPM_BUILD_ROOT
72make install
73
74[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
75
76find $RPM_BUILD_ROOT%{_prefix} -type f -print | \
77        sed "s@^$RPM_BUILD_ROOT@@g" | \
78        grep -v perllocal.pod | \
79        grep -v "\.packlist" > %{pkgname}-%{version}-filelist
80if [ "$(cat %{pkgname}-%{version}-filelist)X" = "X" ] ; then
81    echo "ERROR: EMPTY FILE LIST"
82    exit -1
83fi
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%files -f %{pkgname}-%{version}-filelist
89%defattr(-,root,root)
90%doc README MANIFEST COPYING Change.log Changes README.linux pTk.docs
91%exclude %{perl_archlib}/perllocal.pod
92%exclude %{perl_vendorarch}/auto/Tk/.packlist
93
94
95%changelog
96* Sun May 22 2011 Shu KONNO <owa@bg.wakwak.com> 804.028-4
97- added Patch200: perl-Tk-804.028.Xlib.patch
98- added Patch201: perl-Tk-804.028.pTkCallback.patch
99- added Patch202: perl-Tk-804.028.encGlue.patch
100- added Patch203: perl-Tk-804.028.tkGlue.patch
101- added _run_test option
102
103* Sat Jan  9 2010 IWAI, Masaharu <iwai@alib.jp> 804.028-3
104- add BuildRequires: libX11-devel libpng-devel : <BTS:VineLinux:866>
105- drop X11LIBS argument for Makefile.PL on x86_64 architecture
106- add documents
107
108* Mon Jan  4 2010 IWAI, Masaharu <iwai@alib.jp> 804.028-2
109- add patch11 for fix CPAN bug #38746: <BTS:VineLinux:866>
110  - see http://rt.cpan.org/Public/Bug/Display.html?id=38746
111
112* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 804.028-1
113- new upstream release
114- build with perl-8.10.0
115
116* Fri Mar 28 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 804.027-3
117- add patch100 for fix CVE-2006-4484
118- with new versioning policy
119- add Vendor/Distribution tag
120
121* Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 804.027-0vl2
122- added X11LIB to build (for x86_64)
123
124* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 804.027-0vl1
125- updated to 804.027
126- build with perl-5.8.6
127- no noarch now (arch-dependent files/binaries are actually included)
128
129* Sun Oct 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 804.026-0vl1
130- initial build for Vine Linux
131
Note: See TracBrowser for help on using the repository browser.