source: projects/specs/trunk/p/perl-Tk/perl-Tk-vl.spec @ 12120

Revision 12120, 4.3 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1# if you wanna test, add " --define '_run_test 1' " option to rpmbuild command
2%define run_test %{?_run_test:1}%{!?_run_test:0}
3%define pkgname Tk
4
5Summary:        A perl module for Tk.
6Name:           perl-%{pkgname}
7Version:        804.034
8Release:        1%{_dist_release}
9Group:          Development/Libraries
10License:        GPL or Artistic
11URL:            http://perltk.org/
12Source0:        %{pkgname}-%{version}.tar.gz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  libX11-devel
16BuildRequires:  libpng-devel
17BuildRequires:  libjpeg-turbo-devel
18BuildRequires:  libxcrypt-devel
19BuildRequires:  libnsl2-devel
20Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
21
22Patch0:         perl-Tk-widget.patch
23# modified version of http://ftp.de.debian.org/debian/pool/main/p/perl-tk/perl-tk_804.027-8.diff.gz
24Patch1:         perl-Tk-debian.patch.gz
25# fix segfaults as in #235666 because of broken cashing code
26Patch2:         perl-Tk-seg.patch
27# Fix freetype detection with 2.5
28Patch4:         perl-Tk-freetype25.patch
29
30Provides:       perl(Tk::LabRadio) = 4.004
31Provides:       perl(Tk::TextReindex) = 4.004
32
33Vendor:         Project Vine
34Distribution:   Vine Linux
35
36%description
37Perl bindings to the Tk Graphical User Interface ToolKit.
38
39%prep
40%setup -q -n %{pkgname}-%{version}
41%{__mkdir} pTk.docs
42%{__cp} pTk/Tix.license pTk/license.terms pTk/license.html_lib pTk.docs
43
44# fix for widget as docs
45%patch0
46%{__perl} -pi -e \
47's,\@demopath\@,%{?_pkgdocdir}%{!?_pkgdocdir:%{_docdir}/%{name}-%{version}}/demo
48s,g' demos/widget
49# debian patch
50%patch1 -p1
51# patch to fix #235666 ... seems like caching code is broken
52%patch2 -p1 -b .seg
53# freetype-2.5 detection
54%patch4 -p1
55
56
57%build
58find . -type f -exec %{__perl} -pi -e 's|^#!/.*bin/perl\S*|#!%{__perl}|i;' {} \;
59CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL PREFIX=$RPM_BUILD_ROOT%{_prefix} INSTALLDIRS=vendor
60#make %{?_smp_mflags}
61make
62
63%if %{run_test}
64make test
65#-------------------------------#
66# Sun May 22 2011 ..last tested #
67# Result: PASS
68#-------------------------------#
69%endif
70
71
72%install
73rm -rf $RPM_BUILD_ROOT
74make install
75
76[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
77
78find $RPM_BUILD_ROOT%{_prefix} -type f -print | \
79        sed "s@^$RPM_BUILD_ROOT@@g" | \
80        grep -v perllocal.pod | \
81        grep -v "\.packlist" > %{pkgname}-%{version}-filelist
82if [ "$(cat %{pkgname}-%{version}-filelist)X" = "X" ] ; then
83    echo "ERROR: EMPTY FILE LIST"
84    exit -1
85fi
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%files -f %{pkgname}-%{version}-filelist
91%defattr(-,root,root)
92%license COPYING
93%doc README MANIFEST Change.log Changes README.linux pTk.docs
94%exclude %{perl_archlib}/perllocal.pod
95%exclude %{perl_vendorarch}/auto/Tk/.packlist
96
97
98%changelog
99* Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 804-034-1
100- new upstream release.
101- rebuilt with perl-5.26.
102- added BR:libxcrypt-devel,libnsl2-devel.
103
104* Wed Apr 15 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 804.033-1
105- new upstream release
106
107* Thu Jul 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 804.032-1
108- new upstream release.
109- replaced patches.
110
111* Sun May 22 2011 Shu KONNO <owa@bg.wakwak.com> 804.028-5
112- added BR: libjpeg-turbo-devel
113
114* Sun May 22 2011 Shu KONNO <owa@bg.wakwak.com> 804.028-4
115- added Patch200: perl-Tk-804.028.Xlib.patch
116- added Patch201: perl-Tk-804.028.pTkCallback.patch
117- added Patch202: perl-Tk-804.028.encGlue.patch
118- added Patch203: perl-Tk-804.028.tkGlue.patch
119- added _run_test option
120
121* Sat Jan  9 2010 IWAI, Masaharu <iwai@alib.jp> 804.028-3
122- add BuildRequires: libX11-devel libpng-devel : <BTS:VineLinux:866>
123- drop X11LIBS argument for Makefile.PL on x86_64 architecture
124- add documents
125
126* Mon Jan  4 2010 IWAI, Masaharu <iwai@alib.jp> 804.028-2
127- add patch11 for fix CPAN bug #38746: <BTS:VineLinux:866>
128  - see http://rt.cpan.org/Public/Bug/Display.html?id=38746
129
130* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 804.028-1
131- new upstream release
132- build with perl-8.10.0
133
134* Fri Mar 28 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 804.027-3
135- add patch100 for fix CVE-2006-4484
136- with new versioning policy
137- add Vendor/Distribution tag
138
139* Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 804.027-0vl2
140- added X11LIB to build (for x86_64)
141
142* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 804.027-0vl1
143- updated to 804.027
144- build with perl-5.8.6
145- no noarch now (arch-dependent files/binaries are actually included)
146
147* Sun Oct 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 804.026-0vl1
148- initial build for Vine Linux
149
Note: See TracBrowser for help on using the repository browser.