source: projects/specs/trunk/lib/libc/libcap-ng/libcap-ng-vl.spec @ 8119

Revision 8119, 5.7 KB checked in by Takemikaduchi, 10 years ago (diff)

rebuild or new upstream release

Line 
1%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Summary: An alternate posix capabilities library
4Name: libcap-ng
5Version: 0.7.3
6Release: 2%{?_dist_release}
7License: LGPLv2+
8Group: System Environment/Libraries
9URL: http://people.redhat.com/sgrubb/libcap-ng
10Source0: http://people.redhat.com/sgrubb/libcap-ng/%{name}-%{version}.tar.gz
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12BuildRequires: kernel-headers >= 2.6.11
13BuildRequires: libattr-devel
14
15Vendor: Project Vine
16Distribution: Vine Linux
17Packager: Takemikaduchi
18
19%description
20Libcap-ng is a library that makes using posix capabilities easier
21
22%package devel
23Summary: Header files for libcap-ng library
24License: LGPLv2+
25Group: Development/Libraries
26Requires: kernel-headers >= 2.6.11
27Requires: %{name} = %{version}-%{release}
28Requires: pkgconfig
29
30%description devel
31The libcap-ng-devel package contains the files needed for developing
32applications that need to use the libcap-ng library.
33
34%package python
35Summary: Python bindings for libcap-ng library
36License: LGPLv2+
37Group: Development/Libraries
38BuildRequires: python-devel swig
39Requires: %{name} = %{version}-%{release}
40
41%description python
42The libcap-ng-python package contains the bindings so that libcap-ng
43and can be used by python applications.
44
45%package utils
46Summary: Utilities for analysing and setting file capabilities
47License: GPLv2+
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50
51%description utils
52The libcap-ng-utils package contains applications to analyse the
53posix capabilities of all the program running on a system. It also
54lets you set the file system based capabilities.
55
56%prep
57%setup -q
58
59%build
60%configure --libdir=/%{_lib}
61make %{?_smp_mflags}
62
63%install
64rm -rf $RPM_BUILD_ROOT
65make DESTDIR="${RPM_BUILD_ROOT}" install
66
67# Move the symlink
68rm -f $RPM_BUILD_ROOT/%{_lib}/%{name}.so
69mkdir -p $RPM_BUILD_ROOT%{_libdir}
70VLIBNAME=$(ls $RPM_BUILD_ROOT/%{_lib}/%{name}.so.*.*.*)
71LIBNAME=$(basename $VLIBNAME)
72ln -s ../../%{_lib}/$LIBNAME $RPM_BUILD_ROOT%{_libdir}/%{name}.so
73
74# Move the pkgconfig file
75mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
76
77# Remove a couple things so they don't get picked up
78rm -f $RPM_BUILD_ROOT/%{_lib}/libcap-ng.la
79rm -f $RPM_BUILD_ROOT/%{_lib}/libcap-ng.a
80rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_capng.a
81rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_capng.la
82
83%check
84make check
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%post -p /sbin/ldconfig
90
91%postun -p /sbin/ldconfig
92
93
94%files
95%defattr(-,root,root,-)
96%doc COPYING.LIB
97%attr(0755,root,root) /%{_lib}/libcap-ng.so.*
98
99%files devel
100%defattr(-,root,root,-)
101%attr(0644,root,root) %{_mandir}/man3/*
102%attr(0644,root,root) %{_includedir}/cap-ng.h
103%attr(0755,root,root) %{_libdir}/libcap-ng.so
104%attr(0644,root,root) %{_datadir}/aclocal/cap-ng.m4
105%{_libdir}/pkgconfig/libcap-ng.pc
106
107%files python
108%defattr(-,root,root,-)
109%attr(755,root,root) /%{_libdir}/python?.?/site-packages/_capng.so
110%{python_sitearch}/capng.py*
111
112%files utils
113%defattr(-,root,root,-)
114%doc COPYING
115%attr(0755,root,root) %{_bindir}/*
116%attr(0644,root,root) %{_mandir}/man8/*
117
118%changelog
119* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
120- rebuild with VineSeed environment
121
122* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-1
123- new upstream release
124
125* Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.1-1
126- new upstream release
127
128* Mon Feb 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.6-2
129- rebuild with python-2.7.2
130
131* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.6-1
132- initial build for Vine Linux
133
134
135* Fri Jun 24 2011 Steve Grubb <sgrubb@redhat.com> 0.6.6-1
136- New upstream release
137
138* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.5-2
139- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
140
141* Wed Nov 03 2010 Steve Grubb <sgrubb@redhat.com> 0.6.5-1
142- New upstream release fixing 2.6.36 kernel header issue
143
144* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.6.4-4
145- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
146
147* Thu Jun 17 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-3
148- Only open regular files in filecap
149
150* Mon May 24 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-2
151- In utils subpackage added a requires statement.
152
153* Thu May 06 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-1
154- New upstream release fixing multi-threading issue
155
156* Wed Apr 28 2010 Steve Grubb <sgrubb@redhat.com> 0.6.3-2
157- filecap shows full capabilities if a file has any
158
159* Thu Mar 11 2010 Steve Grubb <sgrubb@redhat.com> 0.6.3-1
160- New upstream release
161
162* Tue Feb 16 2010 Steve Grubb <sgrubb@redhat.com> 0.6.2-4
163- Use global macro and require pkgconfig for devel subpackage
164
165* Fri Oct 09 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-3
166- Apply patch to retain setpcap only if clearing bounding set
167
168* Sat Oct 03 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-2
169- Apply patch correcting pscap and netcap acct detection
170
171* Mon Sep 28 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-1
172- New upstream release
173
174* Sun Jul 26 2009 Steve Grubb <sgrubb@redhat.com> 0.6.1-1
175- New upstream release
176
177* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-2
178- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
179
180* Mon Jun 29 2009 Steve Grubb <sgrubb@redhat.com> 0.6-1
181- New upstream release
182
183* Sun Jun 21 2009 Steve Grubb <sgrubb@redhat.com> 0.5.1-1
184- New upstream release
185
186* Fri Jun 19 2009 Steve Grubb <sgrubb@redhat.com> 0.5-1
187- New upstream release
188
189* Fri Jun 12 2009 Steve Grubb <sgrubb@redhat.com> 0.4.2-1
190- New upstream release
191
192* Fri Jun 12 2009 Steve Grubb <sgrubb@redhat.com> 0.4.1-1
193- Initial build.
194
Note: See TracBrowser for help on using the repository browser.