source: projects/specs/trunk/lib/libc/libcap-ng/libcap-ng-vl.spec @ 7302

Revision 7302, 5.5 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Summary: An alternate posix capabilities library
4Name: libcap-ng
5Version: 0.7.3
6Release: 1%{?_dist_release}
7License: LGPLv2+
8Group: System Environment/Libraries
9URL: http://people.redhat.com/sgrubb/libcap-ng
10Source0: http://people.redhat.com/sgrubb/libcap-ng/%{name}-%{version}.tar.gz
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12BuildRequires: kernel-headers >= 2.6.11
13BuildRequires: libattr-devel
14
15Vendor: Project Vine
16Distribution: Vine Linux
17
18%description
19Libcap-ng is a library that makes using posix capabilities easier
20
21%package devel
22Summary: Header files for libcap-ng library
23License: LGPLv2+
24Group: Development/Libraries
25Requires: kernel-headers >= 2.6.11
26Requires: %{name} = %{version}-%{release}
27Requires: pkgconfig
28
29%description devel
30The libcap-ng-devel package contains the files needed for developing
31applications that need to use the libcap-ng library.
32
33%package python
34Summary: Python bindings for libcap-ng library
35License: LGPLv2+
36Group: Development/Libraries
37BuildRequires: python-devel swig
38Requires: %{name} = %{version}-%{release}
39
40%description python
41The libcap-ng-python package contains the bindings so that libcap-ng
42and can be used by python applications.
43
44%package utils
45Summary: Utilities for analysing and setting file capabilities
46License: GPLv2+
47Group: Development/Libraries
48Requires: %{name} = %{version}-%{release}
49
50%description utils
51The libcap-ng-utils package contains applications to analyse the
52posix capabilities of all the program running on a system. It also
53lets you set the file system based capabilities.
54
55%prep
56%setup -q
57
58%build
59%configure --libdir=/%{_lib}
60make %{?_smp_mflags}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64make DESTDIR="${RPM_BUILD_ROOT}" install
65
66# Move the symlink
67rm -f $RPM_BUILD_ROOT/%{_lib}/%{name}.so
68mkdir -p $RPM_BUILD_ROOT%{_libdir}
69VLIBNAME=$(ls $RPM_BUILD_ROOT/%{_lib}/%{name}.so.*.*.*)
70LIBNAME=$(basename $VLIBNAME)
71ln -s ../../%{_lib}/$LIBNAME $RPM_BUILD_ROOT%{_libdir}/%{name}.so
72
73# Move the pkgconfig file
74mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
75
76# Remove a couple things so they don't get picked up
77rm -f $RPM_BUILD_ROOT/%{_lib}/libcap-ng.la
78rm -f $RPM_BUILD_ROOT/%{_lib}/libcap-ng.a
79rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_capng.a
80rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_capng.la
81
82%check
83make check
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%post -p /sbin/ldconfig
89
90%postun -p /sbin/ldconfig
91
92
93%files
94%defattr(-,root,root,-)
95%doc COPYING.LIB
96%attr(0755,root,root) /%{_lib}/libcap-ng.so.*
97
98%files devel
99%defattr(-,root,root,-)
100%attr(0644,root,root) %{_mandir}/man3/*
101%attr(0644,root,root) %{_includedir}/cap-ng.h
102%attr(0755,root,root) %{_libdir}/libcap-ng.so
103%attr(0644,root,root) %{_datadir}/aclocal/cap-ng.m4
104%{_libdir}/pkgconfig/libcap-ng.pc
105
106%files python
107%defattr(-,root,root,-)
108%attr(755,root,root) /%{_libdir}/python?.?/site-packages/_capng.so
109%{python_sitearch}/capng.py*
110
111%files utils
112%defattr(-,root,root,-)
113%doc COPYING
114%attr(0755,root,root) %{_bindir}/*
115%attr(0644,root,root) %{_mandir}/man8/*
116
117%changelog
118* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-1
119- new upstream release
120
121* Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.1-1
122- new upstream release
123
124* Mon Feb 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.6-2
125- rebuild with python-2.7.2
126
127* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.6-1
128- initial build for Vine Linux
129
130
131* Fri Jun 24 2011 Steve Grubb <sgrubb@redhat.com> 0.6.6-1
132- New upstream release
133
134* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.5-2
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
136
137* Wed Nov 03 2010 Steve Grubb <sgrubb@redhat.com> 0.6.5-1
138- New upstream release fixing 2.6.36 kernel header issue
139
140* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.6.4-4
141- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
142
143* Thu Jun 17 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-3
144- Only open regular files in filecap
145
146* Mon May 24 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-2
147- In utils subpackage added a requires statement.
148
149* Thu May 06 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-1
150- New upstream release fixing multi-threading issue
151
152* Wed Apr 28 2010 Steve Grubb <sgrubb@redhat.com> 0.6.3-2
153- filecap shows full capabilities if a file has any
154
155* Thu Mar 11 2010 Steve Grubb <sgrubb@redhat.com> 0.6.3-1
156- New upstream release
157
158* Tue Feb 16 2010 Steve Grubb <sgrubb@redhat.com> 0.6.2-4
159- Use global macro and require pkgconfig for devel subpackage
160
161* Fri Oct 09 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-3
162- Apply patch to retain setpcap only if clearing bounding set
163
164* Sat Oct 03 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-2
165- Apply patch correcting pscap and netcap acct detection
166
167* Mon Sep 28 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-1
168- New upstream release
169
170* Sun Jul 26 2009 Steve Grubb <sgrubb@redhat.com> 0.6.1-1
171- New upstream release
172
173* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-2
174- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
175
176* Mon Jun 29 2009 Steve Grubb <sgrubb@redhat.com> 0.6-1
177- New upstream release
178
179* Sun Jun 21 2009 Steve Grubb <sgrubb@redhat.com> 0.5.1-1
180- New upstream release
181
182* Fri Jun 19 2009 Steve Grubb <sgrubb@redhat.com> 0.5-1
183- New upstream release
184
185* Fri Jun 12 2009 Steve Grubb <sgrubb@redhat.com> 0.4.2-1
186- New upstream release
187
188* Fri Jun 12 2009 Steve Grubb <sgrubb@redhat.com> 0.4.1-1
189- Initial build.
190
Note: See TracBrowser for help on using the repository browser.