source: projects/specs/trunk/lib/libc/libcap-ng/libcap-ng-vl.spec @ 11550

Revision 11550, 7.2 KB checked in by tomop, 6 years ago (diff)

libcap-ng-0.7.9-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4Summary: An alternate posix capabilities library
5Name: libcap-ng
6Version: 0.7.9
7Release: 1%{?_dist_release}
8License: LGPLv2+
9Group: System Environment/Libraries
10URL: http://people.redhat.com/sgrubb/libcap-ng/
11Source0: http://people.redhat.com/sgrubb/libcap-ng/%{name}-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13BuildRequires: kernel-headers >= 2.6.11
14BuildRequires: libattr-devel
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19%description
20Libcap-ng is a library that makes using posix capabilities easier
21
22%package devel
23Summary: Header files for libcap-ng library
24License: LGPLv2+
25Group: Development/Libraries
26Requires: kernel-headers >= 2.6.11
27Requires: %{name} = %{version}-%{release}
28Requires: pkgconfig
29
30%description devel
31The libcap-ng-devel package contains the files needed for developing
32applications that need to use the libcap-ng library.
33
34%package python
35Summary: Python bindings for libcap-ng library
36License: LGPLv2+
37Group: Development/Libraries
38BuildRequires: python-devel swig
39BuildRequires: python-rpm-macros
40Requires: %{name} = %{version}-%{release}
41
42%description python
43The libcap-ng-python package contains the bindings so that libcap-ng
44and can be used by python applications.
45
46%package python3
47Summary: Python3 bindings for libcap-ng library
48License: LGPLv2+
49Group: Development/Libraries
50BuildRequires: python3-devel swig
51BuildRequires: python3-rpm-macros
52Requires: %{name} = %{version}-%{release}
53
54%description python3
55The libcap-ng-python3 package contains the bindings so that libcap-ng
56and can be used by python3 applications.
57
58%package utils
59Summary: Utilities for analysing and setting file capabilities
60License: GPLv2+
61Group: Development/Libraries
62Requires: %{name} = %{version}-%{release}
63
64%description utils
65The libcap-ng-utils package contains applications to analyse the
66posix capabilities of all the program running on a system. It also
67lets you set the file system based capabilities.
68
69%package -n compat32-%{name}
70Summary: An alternate posix capabilities library
71Requires: %{name} = %{version}-%{release}
72
73%description -n compat32-%{name}
74Libcap-ng is a library that makes using posix capabilities easier
75
76%package -n compat32-%{name}-devel
77Summary: Header files for libcap-ng library
78License: LGPLv2+
79Group: Development/Libraries
80Requires: %{name}-devel = %{version}-%{release}
81
82%description -n compat32-%{name}-devel
83The libcap-ng-devel package contains the files needed for developing
84applications that need to use the libcap-ng library.
85
86
87%prep
88%setup -q
89
90%build
91%configure --libdir=/%{_lib} --with-python --with-python3
92make %{?_smp_mflags}
93
94%install
95rm -rf $RPM_BUILD_ROOT
96make DESTDIR="${RPM_BUILD_ROOT}" install
97
98# Move the symlink
99rm -f $RPM_BUILD_ROOT/%{_lib}/%{name}.so
100mkdir -p $RPM_BUILD_ROOT%{_libdir}
101VLIBNAME=$(ls $RPM_BUILD_ROOT/%{_lib}/%{name}.so.*.*.*)
102LIBNAME=$(basename $VLIBNAME)
103ln -s ../../%{_lib}/$LIBNAME $RPM_BUILD_ROOT%{_libdir}/%{name}.so
104
105# Move the pkgconfig file
106mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
107
108# Remove a couple things so they don't get picked up
109rm -f $RPM_BUILD_ROOT/%{_lib}/libcap-ng.la
110rm -f $RPM_BUILD_ROOT/%{_lib}/libcap-ng.a
111rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_capng.a
112rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_capng.la
113
114%check
115make check
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%post -p /sbin/ldconfig
121%postun -p /sbin/ldconfig
122
123%post -n compat32-%{name} -p /sbin/ldconfig
124%postun -n compat32-%{name} -p /sbin/ldconfig
125
126%files
127%defattr(-,root,root,-)
128%doc COPYING.LIB
129%attr(0755,root,root) /%{_lib}/libcap-ng.so.*
130
131%files devel
132%defattr(-,root,root,-)
133%attr(0644,root,root) %{_mandir}/man3/*
134%attr(0644,root,root) %{_includedir}/cap-ng.h
135%attr(0755,root,root) %{_libdir}/libcap-ng.so
136%attr(0644,root,root) %{_datadir}/aclocal/cap-ng.m4
137%{_libdir}/pkgconfig/libcap-ng.pc
138
139%files python
140%defattr(-,root,root,-)
141%attr(755,root,root) /%{_libdir}/python?.?/site-packages/_capng.so
142%{python_sitearch}/capng.py*
143
144%files python3
145%defattr(-,root,root,-)
146%attr(755,root,root) %{python3_sitearch}/*
147%{python3_sitearch}/capng.py*
148
149%files utils
150%defattr(-,root,root,-)
151%doc COPYING
152%attr(0755,root,root) %{_bindir}/*
153%attr(0644,root,root) %{_mandir}/man8/*
154
155%if %{build_compat32}
156%files -n compat32-%{name}
157%defattr(-,root,root,-)
158%attr(0755,root,root) /%{_lib}/libcap-ng.so.*
159
160%files -n compat32-%{name}-devel
161%defattr(-,root,root,-)
162%attr(0755,root,root) %{_libdir}/libcap-ng.so
163%{_libdir}/pkgconfig/libcap-ng.pc
164%endif
165
166%changelog
167* Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.7.9-1
168- new upstream release.
169- added compat32-* packages.
170- enabled python3 modules.
171
172* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
173- rebuild with VineSeed environment
174
175* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-1
176- new upstream release
177
178* Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.1-1
179- new upstream release
180
181* Mon Feb 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.6-2
182- rebuild with python-2.7.2
183
184* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.6-1
185- initial build for Vine Linux
186
187
188* Fri Jun 24 2011 Steve Grubb <sgrubb@redhat.com> 0.6.6-1
189- New upstream release
190
191* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.5-2
192- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
193
194* Wed Nov 03 2010 Steve Grubb <sgrubb@redhat.com> 0.6.5-1
195- New upstream release fixing 2.6.36 kernel header issue
196
197* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.6.4-4
198- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
199
200* Thu Jun 17 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-3
201- Only open regular files in filecap
202
203* Mon May 24 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-2
204- In utils subpackage added a requires statement.
205
206* Thu May 06 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-1
207- New upstream release fixing multi-threading issue
208
209* Wed Apr 28 2010 Steve Grubb <sgrubb@redhat.com> 0.6.3-2
210- filecap shows full capabilities if a file has any
211
212* Thu Mar 11 2010 Steve Grubb <sgrubb@redhat.com> 0.6.3-1
213- New upstream release
214
215* Tue Feb 16 2010 Steve Grubb <sgrubb@redhat.com> 0.6.2-4
216- Use global macro and require pkgconfig for devel subpackage
217
218* Fri Oct 09 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-3
219- Apply patch to retain setpcap only if clearing bounding set
220
221* Sat Oct 03 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-2
222- Apply patch correcting pscap and netcap acct detection
223
224* Mon Sep 28 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-1
225- New upstream release
226
227* Sun Jul 26 2009 Steve Grubb <sgrubb@redhat.com> 0.6.1-1
228- New upstream release
229
230* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-2
231- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
232
233* Mon Jun 29 2009 Steve Grubb <sgrubb@redhat.com> 0.6-1
234- New upstream release
235
236* Sun Jun 21 2009 Steve Grubb <sgrubb@redhat.com> 0.5.1-1
237- New upstream release
238
239* Fri Jun 19 2009 Steve Grubb <sgrubb@redhat.com> 0.5-1
240- New upstream release
241
242* Fri Jun 12 2009 Steve Grubb <sgrubb@redhat.com> 0.4.2-1
243- New upstream release
244
245* Fri Jun 12 2009 Steve Grubb <sgrubb@redhat.com> 0.4.1-1
246- Initial build.
247
Note: See TracBrowser for help on using the repository browser.