source: projects/specs/trunk/lib/libc/libcap-ng/libcap-ng-vl.spec @ 12531

Revision 12531, 7.9 KB checked in by tomop, 3 years ago (diff)

updated 10 packages

file-5.39-1

jansson-2.13.1-1

lz4-1.9.3-1

libarchive-3.5.1-1

libcap-ng-0.8.2-1

libevent-2.1.12-1

libnet-1.2-1

nss-3.61-1

openssl-1.1.1j-1

zstd-1.4.8-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4Summary:        An alternate posix capabilities library
5Name:           libcap-ng
6Version:        0.8.2
7Release:        1%{?_dist_release}
8Group:          system
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        LGPLv2+
13URL:            http://people.redhat.com/sgrubb/libcap-ng/
14Source0:        http://people.redhat.com/sgrubb/libcap-ng/%{name}-%{version}.tar.gz
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17BuildRequires:  kernel-headers >= 2.6.11
18BuildRequires:  libattr-devel
19
20%description
21Libcap-ng is a library that makes using posix capabilities easier
22
23
24%package        devel
25Summary:        Header files for libcap-ng library
26License:        LGPLv2+
27Group:          programming
28Requires:       kernel-headers >= 2.6.11
29Requires:       %{name} = %{version}-%{release}
30Requires:       pkgconfig
31
32%description    devel
33The libcap-ng-devel package contains the files needed for developing
34applications that need to use the libcap-ng library.
35
36
37%package        python
38Summary:        Python bindings for libcap-ng library
39License:        LGPLv2+
40Group:          programming
41BuildRequires:  python-devel swig
42BuildRequires:  python-rpm-macros
43Requires:       %{name} = %{version}-%{release}
44
45%description    python
46The libcap-ng-python package contains the bindings so that libcap-ng
47and can be used by python applications.
48
49
50%package        python3
51Summary:        Python3 bindings for libcap-ng library
52License:        LGPLv2+
53Group:          programming
54BuildRequires:  python3-devel swig
55BuildRequires:  python3-rpm-macros
56Requires:       %{name} = %{version}-%{release}
57
58%description    python3
59The libcap-ng-python3 package contains the bindings so that libcap-ng
60and can be used by python3 applications.
61
62
63%package        utils
64Summary:        Utilities for analysing and setting file capabilities
65License:        GPLv2+
66Group:          admin-tools
67Requires:       %{name} = %{version}-%{release}
68
69%description    utils
70The libcap-ng-utils package contains applications to analyse the
71posix capabilities of all the program running on a system. It also
72lets you set the file system based capabilities.
73
74
75%package -n     compat32-%{name}
76Summary:        An alternate posix capabilities library
77Group:          system
78Requires:       %{name} = %{version}-%{release}
79
80%description -n compat32-%{name}
81Libcap-ng is a library that makes using posix capabilities easier
82
83
84%package -n     compat32-%{name}-devel
85Summary:        Header files for libcap-ng library
86Group:          programming
87License:        LGPLv2+
88Requires:       %{name}-devel = %{version}-%{release}
89
90%description -n compat32-%{name}-devel
91The libcap-ng-devel package contains the files needed for developing
92applications that need to use the libcap-ng library.
93
94
95%debug_package
96
97
98%prep
99%setup -q
100
101
102%build
103%configure --libdir=/%{_lib} --with-python --with-python3
104make %{?_smp_mflags}
105
106
107%install
108rm -rf $RPM_BUILD_ROOT
109make DESTDIR="${RPM_BUILD_ROOT}" install
110
111# Move the symlink
112rm -f $RPM_BUILD_ROOT/%{_lib}/%{name}.so
113mkdir -p $RPM_BUILD_ROOT%{_libdir}
114VLIBNAME=$(ls $RPM_BUILD_ROOT/%{_lib}/%{name}.so.*.*.*)
115LIBNAME=$(basename $VLIBNAME)
116ln -s ../../%{_lib}/$LIBNAME $RPM_BUILD_ROOT%{_libdir}/%{name}.so
117
118# Move the pkgconfig file
119mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
120
121# Remove a couple things so they don't get picked up
122rm -f $RPM_BUILD_ROOT/%{_lib}/libcap-ng.la
123rm -f $RPM_BUILD_ROOT/%{_lib}/libcap-ng.a
124rm -f $RPM_BUILD_ROOT/%{_lib}/libdrop_ambient.la
125rm -f $RPM_BUILD_ROOT/%{_lib}/libdrop_ambient.a
126rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_capng.a
127rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_capng.la
128
129
130%check
131make check
132
133
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137
138%post -p /sbin/ldconfig
139%postun -p /sbin/ldconfig
140
141%post -n compat32-%{name} -p /sbin/ldconfig
142%postun -n compat32-%{name} -p /sbin/ldconfig
143
144
145%files
146%defattr(-,root,root,-)
147%license COPYING.LIB
148%attr(0755,root,root) /%{_lib}/libcap-ng.so.*
149%attr(0755,root,root) /%{_lib}/libdrop_ambient.so.*
150
151%files devel
152%defattr(-,root,root,-)
153%attr(0644,root,root) %{_mandir}/man3/*
154%attr(0644,root,root) %{_mandir}/man7/*
155%attr(0644,root,root) %{_includedir}/cap-ng.h
156%attr(0755,root,root) %{_libdir}/libcap-ng.so
157%attr(0755,root,root) /%{_lib}/libdrop_ambient.so
158%attr(0644,root,root) %{_datadir}/aclocal/cap-ng.m4
159%{_libdir}/pkgconfig/libcap-ng.pc
160
161%files python
162%defattr(-,root,root,-)
163%attr(755,root,root) /%{_libdir}/python?.?/site-packages/_capng.so
164%{python_sitearch}/capng.py*
165
166%files python3
167%defattr(-,root,root,-)
168%attr(755,root,root) %{python3_sitearch}/*
169%{python3_sitearch}/capng.py*
170
171%files utils
172%defattr(-,root,root,-)
173%doc COPYING
174%attr(0755,root,root) %{_bindir}/*
175%attr(0644,root,root) %{_mandir}/man8/*
176
177%if %{build_compat32}
178%files -n compat32-%{name}
179%defattr(-,root,root,-)
180%attr(0755,root,root) /%{_lib}/libcap-ng.so.*
181
182%files -n compat32-%{name}-devel
183%defattr(-,root,root,-)
184%attr(0755,root,root) %{_libdir}/libcap-ng.so
185%{_libdir}/pkgconfig/libcap-ng.pc
186%endif
187
188
189%changelog
190* Wed Feb 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.8.2-1
191- new upstream release.
192
193* Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.7.10-1
194- new upstream release.
195
196* Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.7.9-1
197- new upstream release.
198- added compat32-* packages.
199- enabled python3 modules.
200
201* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
202- rebuild with VineSeed environment
203
204* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-1
205- new upstream release
206
207* Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.1-1
208- new upstream release
209
210* Mon Feb 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.6-2
211- rebuild with python-2.7.2
212
213* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.6-1
214- initial build for Vine Linux
215
216
217* Fri Jun 24 2011 Steve Grubb <sgrubb@redhat.com> 0.6.6-1
218- New upstream release
219
220* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.5-2
221- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
222
223* Wed Nov 03 2010 Steve Grubb <sgrubb@redhat.com> 0.6.5-1
224- New upstream release fixing 2.6.36 kernel header issue
225
226* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.6.4-4
227- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
228
229* Thu Jun 17 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-3
230- Only open regular files in filecap
231
232* Mon May 24 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-2
233- In utils subpackage added a requires statement.
234
235* Thu May 06 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-1
236- New upstream release fixing multi-threading issue
237
238* Wed Apr 28 2010 Steve Grubb <sgrubb@redhat.com> 0.6.3-2
239- filecap shows full capabilities if a file has any
240
241* Thu Mar 11 2010 Steve Grubb <sgrubb@redhat.com> 0.6.3-1
242- New upstream release
243
244* Tue Feb 16 2010 Steve Grubb <sgrubb@redhat.com> 0.6.2-4
245- Use global macro and require pkgconfig for devel subpackage
246
247* Fri Oct 09 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-3
248- Apply patch to retain setpcap only if clearing bounding set
249
250* Sat Oct 03 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-2
251- Apply patch correcting pscap and netcap acct detection
252
253* Mon Sep 28 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-1
254- New upstream release
255
256* Sun Jul 26 2009 Steve Grubb <sgrubb@redhat.com> 0.6.1-1
257- New upstream release
258
259* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-2
260- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
261
262* Mon Jun 29 2009 Steve Grubb <sgrubb@redhat.com> 0.6-1
263- New upstream release
264
265* Sun Jun 21 2009 Steve Grubb <sgrubb@redhat.com> 0.5.1-1
266- New upstream release
267
268* Fri Jun 19 2009 Steve Grubb <sgrubb@redhat.com> 0.5-1
269- New upstream release
270
271* Fri Jun 12 2009 Steve Grubb <sgrubb@redhat.com> 0.4.2-1
272- New upstream release
273
274* Fri Jun 12 2009 Steve Grubb <sgrubb@redhat.com> 0.4.1-1
275- Initial build.
276
Note: See TracBrowser for help on using the repository browser.