source: projects/specs/trunk/c/curl/curl-vl.spec @ 12424

Revision 12424, 14.2 KB checked in by tomop, 4 years ago (diff)

updated 3 packages

curl-7.71.1-1

php74-7.4.8-1

squid-4.12-1

RevLine 
[521]1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
[10740]3%if %{?_dist_release} != "vl6"
4%global with_http2 1
5%endif
6
[521]7Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
8Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
9Name: curl
[12424]10Version: 7.71.1
[10740]11Release: 1%{?_dist_release}
[12415]12Group: Applications/Internet
13Vendor: Project Vine
14Distribution: Vine Linux
15Packager: daisuke
[7833]16
17License: MIT
[12424]18URL: https://curl.haxx.se/
19Source: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
[7833]20
[12131]21# avoid reporting spurious error in the HTTP2 framing layer (#1690971)
22Patch2:   0002-curl-7.65.3-h2-framing-layer-error.patch
23
[11840]24# patch making libcurl multilib ready
[12424]25Patch101: 0101-curl-7.71.1-multilib.patch
[11725]26
[7833]27# prevent configure script from discarding -g in CFLAGS (#496778)
[10071]28Patch102: 0102-curl-7.36.0-debug.patch
[11840]29
[11725]30# migrate tests/http_pipe.py to Python 3
31Patch103: 0103-curl-7.59.0-python3.patch
[11840]32
[7833]33# use localhost6 instead of ip6-localhost in the curl test-suite
34Patch104: 0104-curl-7.19.7-localhost6.patch
35
[12131]36# prevent valgrind from reporting false positives on x86_64
37Patch105: 0105-curl-7.63.0-lib1560-valgrind.patch
38
[521]39BuildRoot: %{_tmppath}/%{name}-%{version}-root
[11316]40BuildRequires: openssl-devel
41BuildRequires: gnutls-devel
42BuildRequires: libidn-devel zlib-devel
43BuildRequires: openldap-devel
[7833]44BuildRequires: openssh-server
[7033]45BuildRequires: openssh-clients
46BuildRequires: pkgconfig
[7833]47%if "%{?_dist_release}" != "vl6"
48BuildRequires: libssh2-devel
49%endif
[10740]50%if 0%{?with_http2}
51BuildRequires: libnghttp2-devel
52%endif
53
[7033]54Requires: ca-certificates
[521]55
56%description
57cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
58Dict servers, using any of the supported protocols. cURL is designed
59to work without user interaction or any kind of interactivity. cURL
60offers many useful capabilities, like proxy support, user
61authentication, FTP upload, HTTP post, and file transfer resume.
62
63%package devel
[890]64Summary: Files needed for building applications with libcurl.
[521]65Group: Development/Libraries
66Requires: %{name} = %{version}-%{release}
67Requires: openssl-devel libidn-devel zlib-devel
68
69%description devel
70cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
71Dict servers, using any of the supported protocols. The curl-devel
72package includes files needed for developing applications which can
73use cURL's capabilities internally.
74#'
75
76
77## to build compat32 for x86_64 architecture support
78%package -n compat32-%{name}
79Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
80Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
81Group: System Environment/Libraries
82
83%description -n compat32-%{name}
84cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
85Dict servers, using any of the supported protocols. cURL is designed
86to work without user interaction or any kind of interactivity. cURL
87offers many useful capabilities, like proxy support, user
88authentication, FTP upload, HTTP post, and file transfer resume.
89
90%package -n compat32-%{name}-devel
91Summary: Files needed for building applications with libcurl.
92Group: Development/Libraries
93
94%description -n compat32-%{name}-devel
95cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
96Dict servers, using any of the supported protocols. The curl-devel
97package includes files needed for developing applications which can
98use cURL's capabilities internally.
99#'
100
101%prep
102%setup -q
103
[11725]104# upstream patches
105
[7833]106# Fedora patches
107%patch101 -p1
108%patch102 -p1
[11840]109#patch103 -p1
[7833]110%patch104 -p1
[12131]111%patch105 -p1
[7833]112
[11725]113# make tests/*.py use Python 3
114sed -e '1 s|^#!/.*python|&3|' -i tests/*.py
115
[11840]116# regenerate Makefile.in files
117aclocal -I m4
118automake
119
120# disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
121# with errno 98: Address already in use' in Koji environment), and test 1801
[11725]122# <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
[11840]123# and test 1900, which is flaky and covers a deprecated feature of libcurl
124# <https://github.com/curl/curl/pull/2705>
125printf "1112\n1455\n1801\n1900\n" >> tests/data/DISABLED
[11725]126
[11840]127# disable test 1319 on ppc64 (server times out)
128%ifarch ppc64
129echo "1319" >> tests/data/DISABLED
130%endif
131
132# temporarily disable test 582 on s390x (client times out)
133%ifarch s390x
134echo "582" >> tests/data/DISABLED
135%endif
136
137# adapt test 323 for updated OpenSSL
138sed -e 's/^35$/35,52/' -i tests/data/test323
139
[521]140%build
[7033]141%configure \
142  --with-ssl=%{_prefix} \
143  --with-libidn \
144  --enable-ipv6 \
145  --enable-threaded-resolver \
[11316]146  --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
[7833]147%if "%{?_dist_release}" != "vl6"
[7033]148  --with-libssh2 \
[7833]149%endif
[10740]150%if 0%{?with_http2}
151  --with-nghttp2 \
152%endif
[7033]153  --enable-ldaps \
[8211]154  --disable-static \
155  --enable-hidden-symbols
[7033]156
[521]157make %{?_smp_mflags}
158
159%install
160rm -rf $RPM_BUILD_ROOT
161make DESTDIR=$RPM_BUILD_ROOT install
162
163rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
164
165%clean
166rm -rf $RPM_BUILD_ROOT
167
168%post -p /sbin/ldconfig
169
170%postun -p /sbin/ldconfig
171
172%files
173%defattr(-,root,root)
[10740]174%{!?_licensedir:%global license %%doc}
[10632]175%license COPYING
176%doc CHANGES README
[521]177%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
178%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
179%doc docs/TheArtOfHttpScripting docs/TODO
180%{_bindir}/curl
181#{_datadir}/curl/*
182%{_libdir}/*.so.*
[7033]183%{_mandir}/man1/*.1*
[521]184
185%files devel
186%defattr(-,root,root)
187%{_bindir}/curl-config
188%{_includedir}/curl
189%{_libdir}/*.so
190%{_libdir}/pkgconfig/*.pc
191%{_mandir}/man1/curl-config.1*
192%{_mandir}/man3/*
[8211]193%{_datadir}/aclocal/libcurl.m4
[521]194
195
196## to build compat32 for x86_64 architecture support
197%if %{build_compat32}
198%files -n compat32-%{name}
199%defattr(-,root,root)
200%{_libdir}/*.so.*
201
202%files -n compat32-%{name}-devel
203%defattr(-,root,root)
204%{_libdir}/*.so
205%endif
206
207%changelog
[12424]208* Fri Jul 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.71.1-1
209- new upstream release.
210
[12415]211* Tue Jun 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.70.0-1
212- new upstream release.
213
[12322]214* Sun Feb 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.68.0-1
215- new upstream release.
216
[12223]217* Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.66.0-1
218- new upstream release.
219- dropped Patch1 and 2: fixed in upstream.
220
[12131]221* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.65.3-1
222- new upstream release.
223- updated patches.
224- imported Patch1, 2 and 105 from rawhide.
225
[11840]226* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.62.0-1
227- new upstream release.
228- imported patches from rawhide.
229
[11725]230* Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
231- new upstream release.
232- imported Patch1 and 103 from rawhide.
233
[11470]234* Wed Feb  7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
235- new upstream release with security fix
236- update patch101
237
[11316]238* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
239- new upstream release.
240- updated Patch101-104.
241- dropped Patch107.
242
[11062]243* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
244- new upstream release.
245
[10933]246* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
247- new upstream release.
248
[10847]249* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
250- new upstream release.
251
[10740]252* Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
253- new upstream release.
254- disabled HTTP/2 on Vine6.
255
[10632]256* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
257- added HTTP/2 support.
258
[10418]259* Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
260- new upstream release with security fix.
261
[10302]262* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
263- new upstream release.
264
[10071]265* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
266- new upstream release
267- built with openssl 1.0.2g
268
[9628]269* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
270- new upstream release with security fix .
271- removed Patch108 (fixed in upstream).
272
[9068]273* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
274- new upstream release with security fix
275
[8211]276* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
277- new upstream release
278- add libcurl.m4 to -devel package
279
[7833]280* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
281- new upstream release
282- import upstream/fedora patches
283- disable libssh2 on Vine Linux 6
284
[7175]285* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
286- new upstream reelase
287
[7033]288* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
289- update to 7.28.0
290- add configure options
291  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
292- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
293 
294- use ca-certificates package
295  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
296  - R: ca-certificates
297
[5734]298* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
299- new upstream release
300
[4261]301* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
302- add patch100 for fix CVE-2011-2192 (gssapi)
303- add Vendor/Distri tags
304
[2487]305* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
306- rebuild with openssl-1.0.0c
307
[1919]308* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
309- rebuilt with rpm-4.8.1 for pkg-config
310
[890]311* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
312- new upstream release
313
[521]314* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
315- new upstream release with security fix
316
317* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
318- added compat32 subpackages
319
320* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
321- new upstream release
322- use "_smp_mflags" flag
323
324* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
325- rebuild with openldap-2.4.11
326- add BR: openldap-devel
327- remove static library
328
329* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
330- new upstream release with security fix (CVE-2009-0037)
331
332* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
333- new upstream release
334
335* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
336- new upstream release
337
338* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
339- new upstream release
340
341* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
342- new upstream release
343
344* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
345- new upstream release
346
347* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
348- rebuilt with openssl-0.9.8e
349
350* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
351- new upstream release
352
353* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
354- new upstream release
355
356* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
357- new upstream release
358- add pkgconfig file to devel package
359
360* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
361- new upstream release
362
363* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
364- new upstream release
365
366* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
367- new upstream release
368
369* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
370- added libidn, zlib in Requires
371- added libidn-devel, zlib-devel in BuildPrereq
372- added zlib-devel in curl-devel's Requires
373
374* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
375- added openssl-devel, libidn-devel in curl-devel's Requires
376
377* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
378- new upstream release
379
380* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
381- new upstream release
382- rebuild with openssl-0.9.7d
383
384* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
385- upstream release
386
387* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
388- add %%{_datadir}/curl/* to %%files section
389
390* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
391- source upgrade
392
393* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
394- source upgrade
395- add PreReq: ldconfig
396- add %%{_libdir}/*.la to %%files devel section
397
398* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
399- build for VineSeed
400- add Requires: openssl
401
402* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
403- automated rebuild
404
405* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
406- 7.9.2
407
408* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
409- include curl-config in curl-devel
410- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
411
412* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
413- added openssl-devel build req
414
415* Mon May 21 2001 Tim Powers <timp@redhat.com>
416- built for the distro
417
418* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
419- upgrade to curl-7.7.2.
420- enable IPv6.
421
422* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
423- rebuilt against openssl-0.9.6-1
424
425* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
426- fixed mising ldconfigs
427- updated to 7.5.2, bug fixes
428
429* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
430- updated to 7.5.1
431
432* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
433- update to 7.4.1 to fix bug #20337, problems with curl -c
434- not using patch anymore, it's included in the new source. Keeping
435  for reference
436
437* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
438- fix bogus req in -devel package
439
440* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
441- devel package needed defattr so that root owns the files
442
443* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
444- update to 7.3
445- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
446
447* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
448- enable SSL support
449- fix packager tag
450- move buildroot to %%{_tmppath}
451
452* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
453- fixed vendor tag for bug #15028
454
455* Mon Jul 24 2000 Prospector <prospector@redhat.com>
456- rebuilt
457
458* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
459- workaround alpha build problems with optimizations
460
461* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
462- rebuilt
463
464* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
465- put man pages in correct place
466- use %%makeinstall
467
468* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
469- updated to 6.5.2
470
471* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
472- updated sources to 6.2
473- gzip man page
474
475* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
476- changed group
477
478* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
479- changelog started
480- general cleanups, changed prefix to /usr, added manpage to files section
481- including in Powertools
Note: See TracBrowser for help on using the repository browser.