source: projects/specs/trunk/c/curl/curl-vl.spec @ 12537

Revision 12537, 14.4 KB checked in by tomop, 3 years ago (diff)

updated 8 packages

Field3D-1.7.3-3

OpenImageIO-2.2.11.1-1

c-ares-1.17.1-1

curl-7.75.0-1

galera-26.4.6-1

libboost-1.75.0-1

nghttp2-1.43.0-1

source-highlight-3.1.8-3

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%if %{?_dist_release} != "vl6"
4%global with_http2 1
5%endif
6
7Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
8Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
9Name: curl
10Version: 7.75.0
11Release: 1%{?_dist_release}
12Group: internet
13Vendor: Project Vine
14Distribution: Vine Linux
15Packager: daisuke
16
17License: MIT
18URL: https://curl.haxx.se/
19Source: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
20
21# avoid reporting spurious error in the HTTP2 framing layer (#1690971)
22Patch2:   0002-curl-7.65.3-h2-framing-layer-error.patch
23
24# patch making libcurl multilib ready
25Patch101: 0101-curl-7.73.0-multilib.patch
26
27# prevent configure script from discarding -g in CFLAGS (#496778)
28Patch102: 0102-curl-7.36.0-debug.patch
29
30# migrate tests/http_pipe.py to Python 3
31Patch103: 0103-curl-7.59.0-python3.patch
32
33# use localhost6 instead of ip6-localhost in the curl test-suite
34Patch104: 0104-curl-7.73.0-localhost6.patch
35
36# prevent valgrind from reporting false positives on x86_64
37Patch105: 0105-curl-7.63.0-lib1560-valgrind.patch
38
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40BuildRequires: openssl-devel
41BuildRequires: gnutls-devel
42BuildRequires: libidn-devel zlib-devel
43BuildRequires: openldap-devel
44BuildRequires: openssh-server
45BuildRequires: openssh-clients
46BuildRequires: pkgconfig
47%if "%{?_dist_release}" != "vl6"
48BuildRequires: libssh2-devel
49%endif
50%if 0%{?with_http2}
51BuildRequires: libnghttp2-devel
52%endif
53
54Requires: ca-certificates
55
56%description
57cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
58Dict servers, using any of the supported protocols. cURL is designed
59to work without user interaction or any kind of interactivity. cURL
60offers many useful capabilities, like proxy support, user
61authentication, FTP upload, HTTP post, and file transfer resume.
62
63
64%package devel
65Summary: Files needed for building applications with libcurl.
66Group: programming
67Requires: %{name} = %{version}-%{release}
68Requires: openssl-devel libidn-devel zlib-devel
69
70%description devel
71cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
72Dict servers, using any of the supported protocols. The curl-devel
73package includes files needed for developing applications which can
74use cURL's capabilities internally.
75#'
76
77
78## to build compat32 for x86_64 architecture support
79%package -n compat32-%{name}
80Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
81Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
82Group: system
83
84%description -n compat32-%{name}
85cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
86Dict servers, using any of the supported protocols. cURL is designed
87to work without user interaction or any kind of interactivity. cURL
88offers many useful capabilities, like proxy support, user
89authentication, FTP upload, HTTP post, and file transfer resume.
90
91
92%package -n compat32-%{name}-devel
93Summary: Files needed for building applications with libcurl.
94Group: programming
95
96%description -n compat32-%{name}-devel
97cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
98Dict servers, using any of the supported protocols. The curl-devel
99package includes files needed for developing applications which can
100use cURL's capabilities internally.
101#'
102
103
104%debug_package
105
106
107%prep
108%setup -q
109
110# upstream patches
111
112# Fedora patches
113%patch101 -p1
114%patch102 -p1
115#patch103 -p1
116%patch104 -p1
117%patch105 -p1
118
119# make tests/*.py use Python 3
120sed -e '1 s|^#!/.*python|&3|' -i tests/*.py
121
122# regenerate Makefile.in files
123aclocal -I m4
124automake
125
126# disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
127# with errno 98: Address already in use' in Koji environment), and test 1801
128# <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
129# and test 1900, which is flaky and covers a deprecated feature of libcurl
130# <https://github.com/curl/curl/pull/2705>
131printf "1112\n1455\n1801\n1900\n" >> tests/data/DISABLED
132
133# disable test 1319 on ppc64 (server times out)
134%ifarch ppc64
135echo "1319" >> tests/data/DISABLED
136%endif
137
138# temporarily disable test 582 on s390x (client times out)
139%ifarch s390x
140echo "582" >> tests/data/DISABLED
141%endif
142
143# adapt test 323 for updated OpenSSL
144sed -e 's/^35$/35,52/' -i tests/data/test323
145
146
147%build
148%configure \
149  --with-ssl=%{_prefix} \
150  --with-libidn \
151  --enable-ipv6 \
152  --enable-threaded-resolver \
153  --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
154%if "%{?_dist_release}" != "vl6"
155  --with-libssh2 \
156%endif
157%if 0%{?with_http2}
158  --with-nghttp2 \
159%endif
160  --enable-ldaps \
161  --disable-static \
162  --enable-hidden-symbols
163
164make %{?_smp_mflags}
165
166
167%install
168rm -rf $RPM_BUILD_ROOT
169make DESTDIR=$RPM_BUILD_ROOT install
170
171rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
172
173
174%clean
175rm -rf $RPM_BUILD_ROOT
176
177%post -p /sbin/ldconfig
178%postun -p /sbin/ldconfig
179
180
181%files
182%defattr(-,root,root)
183%{!?_licensedir:%global license %%doc}
184%license COPYING
185%doc CHANGES README
186%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
187%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
188%doc docs/TheArtOfHttpScripting docs/TODO
189%{_bindir}/curl
190#{_datadir}/curl/*
191%{_libdir}/*.so.*
192%{_mandir}/man1/*.1*
193
194%files devel
195%defattr(-,root,root)
196%{_bindir}/curl-config
197%{_includedir}/curl
198%{_libdir}/*.so
199%{_libdir}/pkgconfig/*.pc
200%{_mandir}/man1/curl-config.1*
201%{_mandir}/man3/*
202%{_datadir}/aclocal/libcurl.m4
203
204
205## to build compat32 for x86_64 architecture support
206%if %{build_compat32}
207%files -n compat32-%{name}
208%defattr(-,root,root)
209%{_libdir}/*.so.*
210
211%files -n compat32-%{name}-devel
212%defattr(-,root,root)
213%{_libdir}/*.so
214%endif
215
216
217%changelog
218* Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.75.0-1
219- new upstream release.
220
221* Wed Dec 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.74.0-1
222- new upstream release.
223
224* Tue Nov 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.73.0-1
225- new upstream release.
226- updated Patch0101 and Patch0104.
227
228* Fri Jul 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.71.1-1
229- new upstream release.
230
231* Tue Jun 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.70.0-1
232- new upstream release.
233
234* Sun Feb 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.68.0-1
235- new upstream release.
236
237* Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.66.0-1
238- new upstream release.
239- dropped Patch1 and 2: fixed in upstream.
240
241* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.65.3-1
242- new upstream release.
243- updated patches.
244- imported Patch1, 2 and 105 from rawhide.
245
246* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.62.0-1
247- new upstream release.
248- imported patches from rawhide.
249
250* Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
251- new upstream release.
252- imported Patch1 and 103 from rawhide.
253
254* Wed Feb  7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
255- new upstream release with security fix
256- update patch101
257
258* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
259- new upstream release.
260- updated Patch101-104.
261- dropped Patch107.
262
263* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
264- new upstream release.
265
266* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
267- new upstream release.
268
269* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
270- new upstream release.
271
272* Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
273- new upstream release.
274- disabled HTTP/2 on Vine6.
275
276* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
277- added HTTP/2 support.
278
279* Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
280- new upstream release with security fix.
281
282* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
283- new upstream release.
284
285* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
286- new upstream release
287- built with openssl 1.0.2g
288
289* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
290- new upstream release with security fix .
291- removed Patch108 (fixed in upstream).
292
293* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
294- new upstream release with security fix
295
296* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
297- new upstream release
298- add libcurl.m4 to -devel package
299
300* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
301- new upstream release
302- import upstream/fedora patches
303- disable libssh2 on Vine Linux 6
304
305* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
306- new upstream reelase
307
308* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
309- update to 7.28.0
310- add configure options
311  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
312- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
313 
314- use ca-certificates package
315  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
316  - R: ca-certificates
317
318* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
319- new upstream release
320
321* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
322- add patch100 for fix CVE-2011-2192 (gssapi)
323- add Vendor/Distri tags
324
325* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
326- rebuild with openssl-1.0.0c
327
328* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
329- rebuilt with rpm-4.8.1 for pkg-config
330
331* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
332- new upstream release
333
334* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
335- new upstream release with security fix
336
337* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
338- added compat32 subpackages
339
340* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
341- new upstream release
342- use "_smp_mflags" flag
343
344* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
345- rebuild with openldap-2.4.11
346- add BR: openldap-devel
347- remove static library
348
349* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
350- new upstream release with security fix (CVE-2009-0037)
351
352* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
353- new upstream release
354
355* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
356- new upstream release
357
358* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
359- new upstream release
360
361* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
362- new upstream release
363
364* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
365- new upstream release
366
367* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
368- rebuilt with openssl-0.9.8e
369
370* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
371- new upstream release
372
373* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
374- new upstream release
375
376* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
377- new upstream release
378- add pkgconfig file to devel package
379
380* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
381- new upstream release
382
383* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
384- new upstream release
385
386* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
387- new upstream release
388
389* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
390- added libidn, zlib in Requires
391- added libidn-devel, zlib-devel in BuildPrereq
392- added zlib-devel in curl-devel's Requires
393
394* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
395- added openssl-devel, libidn-devel in curl-devel's Requires
396
397* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
398- new upstream release
399
400* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
401- new upstream release
402- rebuild with openssl-0.9.7d
403
404* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
405- upstream release
406
407* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
408- add %%{_datadir}/curl/* to %%files section
409
410* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
411- source upgrade
412
413* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
414- source upgrade
415- add PreReq: ldconfig
416- add %%{_libdir}/*.la to %%files devel section
417
418* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
419- build for VineSeed
420- add Requires: openssl
421
422* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
423- automated rebuild
424
425* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
426- 7.9.2
427
428* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
429- include curl-config in curl-devel
430- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
431
432* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
433- added openssl-devel build req
434
435* Mon May 21 2001 Tim Powers <timp@redhat.com>
436- built for the distro
437
438* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
439- upgrade to curl-7.7.2.
440- enable IPv6.
441
442* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
443- rebuilt against openssl-0.9.6-1
444
445* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
446- fixed mising ldconfigs
447- updated to 7.5.2, bug fixes
448
449* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
450- updated to 7.5.1
451
452* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
453- update to 7.4.1 to fix bug #20337, problems with curl -c
454- not using patch anymore, it's included in the new source. Keeping
455  for reference
456
457* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
458- fix bogus req in -devel package
459
460* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
461- devel package needed defattr so that root owns the files
462
463* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
464- update to 7.3
465- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
466
467* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
468- enable SSL support
469- fix packager tag
470- move buildroot to %%{_tmppath}
471
472* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
473- fixed vendor tag for bug #15028
474
475* Mon Jul 24 2000 Prospector <prospector@redhat.com>
476- rebuilt
477
478* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
479- workaround alpha build problems with optimizations
480
481* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
482- rebuilt
483
484* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
485- put man pages in correct place
486- use %%makeinstall
487
488* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
489- updated to 6.5.2
490
491* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
492- updated sources to 6.2
493- gzip man page
494
495* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
496- changed group
497
498* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
499- changelog started
500- general cleanups, changed prefix to /usr, added manpage to files section
501- including in Powertools
Note: See TracBrowser for help on using the repository browser.