source: projects/specs/trunk/c/curl/curl-vl.spec @ 12507

Revision 12507, 14.3 KB checked in by tomop, 3 years ago (diff)

updated 4 packages

curl-7.73.0-1

php74-7.4.12-1

python3-3.8.6-2

samba-4.13.1-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%if %{?_dist_release} != "vl6"
4%global with_http2 1
5%endif
6
7Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
8Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
9Name: curl
10Version: 7.73.0
11Release: 1%{?_dist_release}
12Group: internet
13Vendor: Project Vine
14Distribution: Vine Linux
15Packager: daisuke
16
17License: MIT
18URL: https://curl.haxx.se/
19Source: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
20
21# avoid reporting spurious error in the HTTP2 framing layer (#1690971)
22Patch2:   0002-curl-7.65.3-h2-framing-layer-error.patch
23
24# patch making libcurl multilib ready
25Patch101: 0101-curl-7.73.0-multilib.patch
26
27# prevent configure script from discarding -g in CFLAGS (#496778)
28Patch102: 0102-curl-7.36.0-debug.patch
29
30# migrate tests/http_pipe.py to Python 3
31Patch103: 0103-curl-7.59.0-python3.patch
32
33# use localhost6 instead of ip6-localhost in the curl test-suite
34Patch104: 0104-curl-7.73.0-localhost6.patch
35
36# prevent valgrind from reporting false positives on x86_64
37Patch105: 0105-curl-7.63.0-lib1560-valgrind.patch
38
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40BuildRequires: openssl-devel
41BuildRequires: gnutls-devel
42BuildRequires: libidn-devel zlib-devel
43BuildRequires: openldap-devel
44BuildRequires: openssh-server
45BuildRequires: openssh-clients
46BuildRequires: pkgconfig
47%if "%{?_dist_release}" != "vl6"
48BuildRequires: libssh2-devel
49%endif
50%if 0%{?with_http2}
51BuildRequires: libnghttp2-devel
52%endif
53
54Requires: ca-certificates
55
56%description
57cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
58Dict servers, using any of the supported protocols. cURL is designed
59to work without user interaction or any kind of interactivity. cURL
60offers many useful capabilities, like proxy support, user
61authentication, FTP upload, HTTP post, and file transfer resume.
62
63
64%package devel
65Summary: Files needed for building applications with libcurl.
66Group: programming
67Requires: %{name} = %{version}-%{release}
68Requires: openssl-devel libidn-devel zlib-devel
69
70%description devel
71cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
72Dict servers, using any of the supported protocols. The curl-devel
73package includes files needed for developing applications which can
74use cURL's capabilities internally.
75#'
76
77
78## to build compat32 for x86_64 architecture support
79%package -n compat32-%{name}
80Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
81Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
82Group: system
83
84%description -n compat32-%{name}
85cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
86Dict servers, using any of the supported protocols. cURL is designed
87to work without user interaction or any kind of interactivity. cURL
88offers many useful capabilities, like proxy support, user
89authentication, FTP upload, HTTP post, and file transfer resume.
90
91
92%package -n compat32-%{name}-devel
93Summary: Files needed for building applications with libcurl.
94Group: programming
95
96%description -n compat32-%{name}-devel
97cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
98Dict servers, using any of the supported protocols. The curl-devel
99package includes files needed for developing applications which can
100use cURL's capabilities internally.
101#'
102
103
104%debug_package
105
106
107%prep
108%setup -q
109
110# upstream patches
111
112# Fedora patches
113%patch101 -p1
114%patch102 -p1
115#patch103 -p1
116%patch104 -p1
117%patch105 -p1
118
119# make tests/*.py use Python 3
120sed -e '1 s|^#!/.*python|&3|' -i tests/*.py
121
122# regenerate Makefile.in files
123aclocal -I m4
124automake
125
126# disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
127# with errno 98: Address already in use' in Koji environment), and test 1801
128# <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
129# and test 1900, which is flaky and covers a deprecated feature of libcurl
130# <https://github.com/curl/curl/pull/2705>
131printf "1112\n1455\n1801\n1900\n" >> tests/data/DISABLED
132
133# disable test 1319 on ppc64 (server times out)
134%ifarch ppc64
135echo "1319" >> tests/data/DISABLED
136%endif
137
138# temporarily disable test 582 on s390x (client times out)
139%ifarch s390x
140echo "582" >> tests/data/DISABLED
141%endif
142
143# adapt test 323 for updated OpenSSL
144sed -e 's/^35$/35,52/' -i tests/data/test323
145
146
147%build
148%configure \
149  --with-ssl=%{_prefix} \
150  --with-libidn \
151  --enable-ipv6 \
152  --enable-threaded-resolver \
153  --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
154%if "%{?_dist_release}" != "vl6"
155  --with-libssh2 \
156%endif
157%if 0%{?with_http2}
158  --with-nghttp2 \
159%endif
160  --enable-ldaps \
161  --disable-static \
162  --enable-hidden-symbols
163
164make %{?_smp_mflags}
165
166
167%install
168rm -rf $RPM_BUILD_ROOT
169make DESTDIR=$RPM_BUILD_ROOT install
170
171rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
172
173
174%clean
175rm -rf $RPM_BUILD_ROOT
176
177%post -p /sbin/ldconfig
178%postun -p /sbin/ldconfig
179
180
181%files
182%defattr(-,root,root)
183%{!?_licensedir:%global license %%doc}
184%license COPYING
185%doc CHANGES README
186%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
187%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
188%doc docs/TheArtOfHttpScripting docs/TODO
189%{_bindir}/curl
190#{_datadir}/curl/*
191%{_libdir}/*.so.*
192%{_mandir}/man1/*.1*
193
194%files devel
195%defattr(-,root,root)
196%{_bindir}/curl-config
197%{_includedir}/curl
198%{_libdir}/*.so
199%{_libdir}/pkgconfig/*.pc
200%{_mandir}/man1/curl-config.1*
201%{_mandir}/man3/*
202%{_datadir}/aclocal/libcurl.m4
203
204
205## to build compat32 for x86_64 architecture support
206%if %{build_compat32}
207%files -n compat32-%{name}
208%defattr(-,root,root)
209%{_libdir}/*.so.*
210
211%files -n compat32-%{name}-devel
212%defattr(-,root,root)
213%{_libdir}/*.so
214%endif
215
216
217%changelog
218* Tue Nov 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.73.0-1
219- new upstream release.
220- updated Patch0101 and Patch0104.
221
222* Fri Jul 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.71.1-1
223- new upstream release.
224
225* Tue Jun 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.70.0-1
226- new upstream release.
227
228* Sun Feb 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.68.0-1
229- new upstream release.
230
231* Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.66.0-1
232- new upstream release.
233- dropped Patch1 and 2: fixed in upstream.
234
235* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.65.3-1
236- new upstream release.
237- updated patches.
238- imported Patch1, 2 and 105 from rawhide.
239
240* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.62.0-1
241- new upstream release.
242- imported patches from rawhide.
243
244* Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
245- new upstream release.
246- imported Patch1 and 103 from rawhide.
247
248* Wed Feb  7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
249- new upstream release with security fix
250- update patch101
251
252* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
253- new upstream release.
254- updated Patch101-104.
255- dropped Patch107.
256
257* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
258- new upstream release.
259
260* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
261- new upstream release.
262
263* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
264- new upstream release.
265
266* Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
267- new upstream release.
268- disabled HTTP/2 on Vine6.
269
270* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
271- added HTTP/2 support.
272
273* Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
274- new upstream release with security fix.
275
276* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
277- new upstream release.
278
279* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
280- new upstream release
281- built with openssl 1.0.2g
282
283* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
284- new upstream release with security fix .
285- removed Patch108 (fixed in upstream).
286
287* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
288- new upstream release with security fix
289
290* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
291- new upstream release
292- add libcurl.m4 to -devel package
293
294* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
295- new upstream release
296- import upstream/fedora patches
297- disable libssh2 on Vine Linux 6
298
299* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
300- new upstream reelase
301
302* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
303- update to 7.28.0
304- add configure options
305  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
306- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
307 
308- use ca-certificates package
309  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
310  - R: ca-certificates
311
312* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
313- new upstream release
314
315* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
316- add patch100 for fix CVE-2011-2192 (gssapi)
317- add Vendor/Distri tags
318
319* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
320- rebuild with openssl-1.0.0c
321
322* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
323- rebuilt with rpm-4.8.1 for pkg-config
324
325* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
326- new upstream release
327
328* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
329- new upstream release with security fix
330
331* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
332- added compat32 subpackages
333
334* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
335- new upstream release
336- use "_smp_mflags" flag
337
338* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
339- rebuild with openldap-2.4.11
340- add BR: openldap-devel
341- remove static library
342
343* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
344- new upstream release with security fix (CVE-2009-0037)
345
346* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
347- new upstream release
348
349* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
350- new upstream release
351
352* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
353- new upstream release
354
355* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
356- new upstream release
357
358* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
359- new upstream release
360
361* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
362- rebuilt with openssl-0.9.8e
363
364* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
365- new upstream release
366
367* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
368- new upstream release
369
370* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
371- new upstream release
372- add pkgconfig file to devel package
373
374* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
375- new upstream release
376
377* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
378- new upstream release
379
380* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
381- new upstream release
382
383* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
384- added libidn, zlib in Requires
385- added libidn-devel, zlib-devel in BuildPrereq
386- added zlib-devel in curl-devel's Requires
387
388* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
389- added openssl-devel, libidn-devel in curl-devel's Requires
390
391* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
392- new upstream release
393
394* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
395- new upstream release
396- rebuild with openssl-0.9.7d
397
398* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
399- upstream release
400
401* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
402- add %%{_datadir}/curl/* to %%files section
403
404* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
405- source upgrade
406
407* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
408- source upgrade
409- add PreReq: ldconfig
410- add %%{_libdir}/*.la to %%files devel section
411
412* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
413- build for VineSeed
414- add Requires: openssl
415
416* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
417- automated rebuild
418
419* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
420- 7.9.2
421
422* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
423- include curl-config in curl-devel
424- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
425
426* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
427- added openssl-devel build req
428
429* Mon May 21 2001 Tim Powers <timp@redhat.com>
430- built for the distro
431
432* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
433- upgrade to curl-7.7.2.
434- enable IPv6.
435
436* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
437- rebuilt against openssl-0.9.6-1
438
439* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
440- fixed mising ldconfigs
441- updated to 7.5.2, bug fixes
442
443* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
444- updated to 7.5.1
445
446* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
447- update to 7.4.1 to fix bug #20337, problems with curl -c
448- not using patch anymore, it's included in the new source. Keeping
449  for reference
450
451* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
452- fix bogus req in -devel package
453
454* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
455- devel package needed defattr so that root owns the files
456
457* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
458- update to 7.3
459- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
460
461* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
462- enable SSL support
463- fix packager tag
464- move buildroot to %%{_tmppath}
465
466* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
467- fixed vendor tag for bug #15028
468
469* Mon Jul 24 2000 Prospector <prospector@redhat.com>
470- rebuilt
471
472* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
473- workaround alpha build problems with optimizations
474
475* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
476- rebuilt
477
478* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
479- put man pages in correct place
480- use %%makeinstall
481
482* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
483- updated to 6.5.2
484
485* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
486- updated sources to 6.2
487- gzip man page
488
489* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
490- changed group
491
492* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
493- changelog started
494- general cleanups, changed prefix to /usr, added manpage to files section
495- including in Powertools
Note: See TracBrowser for help on using the repository browser.