source: projects/specs/trunk/c/curl/curl-vl.spec @ 12415

Revision 12415, 14.1 KB checked in by tomop, 4 years ago (diff)

updated 6 packages

c-ares-1.16.1-1

curl-7.70.0-1

libjpeg-turbo-2.0.4-2

libtiff-4.1.0-1

nghttp2-1.41.0-1

sqlite3-3.32.2-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%if %{?_dist_release} != "vl6"
4%global with_http2 1
5%endif
6
7Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
8Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
9Name: curl
10Version: 7.70.0
11Release: 1%{?_dist_release}
12Group: Applications/Internet
13Vendor: Project Vine
14Distribution: Vine Linux
15Packager: daisuke
16
17License: MIT
18URL: http://curl.haxx.se/
19Source: http://curl.haxx.se/download/%{name}-%{version}.tar.xz
20
21# avoid reporting spurious error in the HTTP2 framing layer (#1690971)
22Patch2:   0002-curl-7.65.3-h2-framing-layer-error.patch
23
24# patch making libcurl multilib ready
25Patch101: 0101-curl-7.32.0-multilib.patch
26
27# prevent configure script from discarding -g in CFLAGS (#496778)
28Patch102: 0102-curl-7.36.0-debug.patch
29
30# migrate tests/http_pipe.py to Python 3
31Patch103: 0103-curl-7.59.0-python3.patch
32
33# use localhost6 instead of ip6-localhost in the curl test-suite
34Patch104: 0104-curl-7.19.7-localhost6.patch
35
36# prevent valgrind from reporting false positives on x86_64
37Patch105: 0105-curl-7.63.0-lib1560-valgrind.patch
38
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40BuildRequires: openssl-devel
41BuildRequires: gnutls-devel
42BuildRequires: libidn-devel zlib-devel
43BuildRequires: openldap-devel
44BuildRequires: openssh-server
45BuildRequires: openssh-clients
46BuildRequires: pkgconfig
47%if "%{?_dist_release}" != "vl6"
48BuildRequires: libssh2-devel
49%endif
50%if 0%{?with_http2}
51BuildRequires: libnghttp2-devel
52%endif
53
54Requires: ca-certificates
55
56%description
57cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
58Dict servers, using any of the supported protocols. cURL is designed
59to work without user interaction or any kind of interactivity. cURL
60offers many useful capabilities, like proxy support, user
61authentication, FTP upload, HTTP post, and file transfer resume.
62
63%package devel
64Summary: Files needed for building applications with libcurl.
65Group: Development/Libraries
66Requires: %{name} = %{version}-%{release}
67Requires: openssl-devel libidn-devel zlib-devel
68
69%description devel
70cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
71Dict servers, using any of the supported protocols. The curl-devel
72package includes files needed for developing applications which can
73use cURL's capabilities internally.
74#'
75
76
77## to build compat32 for x86_64 architecture support
78%package -n compat32-%{name}
79Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
80Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
81Group: System Environment/Libraries
82
83%description -n compat32-%{name}
84cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
85Dict servers, using any of the supported protocols. cURL is designed
86to work without user interaction or any kind of interactivity. cURL
87offers many useful capabilities, like proxy support, user
88authentication, FTP upload, HTTP post, and file transfer resume.
89
90%package -n compat32-%{name}-devel
91Summary: Files needed for building applications with libcurl.
92Group: Development/Libraries
93
94%description -n compat32-%{name}-devel
95cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
96Dict servers, using any of the supported protocols. The curl-devel
97package includes files needed for developing applications which can
98use cURL's capabilities internally.
99#'
100
101%prep
102%setup -q
103
104# upstream patches
105
106# Fedora patches
107%patch101 -p1
108%patch102 -p1
109#patch103 -p1
110%patch104 -p1
111%patch105 -p1
112
113# make tests/*.py use Python 3
114sed -e '1 s|^#!/.*python|&3|' -i tests/*.py
115
116# regenerate Makefile.in files
117aclocal -I m4
118automake
119
120# disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
121# with errno 98: Address already in use' in Koji environment), and test 1801
122# <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
123# and test 1900, which is flaky and covers a deprecated feature of libcurl
124# <https://github.com/curl/curl/pull/2705>
125printf "1112\n1455\n1801\n1900\n" >> tests/data/DISABLED
126
127# disable test 1319 on ppc64 (server times out)
128%ifarch ppc64
129echo "1319" >> tests/data/DISABLED
130%endif
131
132# temporarily disable test 582 on s390x (client times out)
133%ifarch s390x
134echo "582" >> tests/data/DISABLED
135%endif
136
137# adapt test 323 for updated OpenSSL
138sed -e 's/^35$/35,52/' -i tests/data/test323
139
140%build
141%configure \
142  --with-ssl=%{_prefix} \
143  --with-libidn \
144  --enable-ipv6 \
145  --enable-threaded-resolver \
146  --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
147%if "%{?_dist_release}" != "vl6"
148  --with-libssh2 \
149%endif
150%if 0%{?with_http2}
151  --with-nghttp2 \
152%endif
153  --enable-ldaps \
154  --disable-static \
155  --enable-hidden-symbols
156
157make %{?_smp_mflags}
158
159%install
160rm -rf $RPM_BUILD_ROOT
161make DESTDIR=$RPM_BUILD_ROOT install
162
163rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
164
165%clean
166rm -rf $RPM_BUILD_ROOT
167
168%post -p /sbin/ldconfig
169
170%postun -p /sbin/ldconfig
171
172%files
173%defattr(-,root,root)
174%{!?_licensedir:%global license %%doc}
175%license COPYING
176%doc CHANGES README
177%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
178%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
179%doc docs/TheArtOfHttpScripting docs/TODO
180%{_bindir}/curl
181#{_datadir}/curl/*
182%{_libdir}/*.so.*
183%{_mandir}/man1/*.1*
184
185%files devel
186%defattr(-,root,root)
187%{_bindir}/curl-config
188%{_includedir}/curl
189%{_libdir}/*.so
190%{_libdir}/pkgconfig/*.pc
191%{_mandir}/man1/curl-config.1*
192%{_mandir}/man3/*
193%{_datadir}/aclocal/libcurl.m4
194
195
196## to build compat32 for x86_64 architecture support
197%if %{build_compat32}
198%files -n compat32-%{name}
199%defattr(-,root,root)
200%{_libdir}/*.so.*
201
202%files -n compat32-%{name}-devel
203%defattr(-,root,root)
204%{_libdir}/*.so
205%endif
206
207%changelog
208* Tue Jun 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.70.0-1
209- new upstream release.
210
211* Sun Feb 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.68.0-1
212- new upstream release.
213
214* Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.66.0-1
215- new upstream release.
216- dropped Patch1 and 2: fixed in upstream.
217
218* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.65.3-1
219- new upstream release.
220- updated patches.
221- imported Patch1, 2 and 105 from rawhide.
222
223* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.62.0-1
224- new upstream release.
225- imported patches from rawhide.
226
227* Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
228- new upstream release.
229- imported Patch1 and 103 from rawhide.
230
231* Wed Feb  7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
232- new upstream release with security fix
233- update patch101
234
235* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
236- new upstream release.
237- updated Patch101-104.
238- dropped Patch107.
239
240* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
241- new upstream release.
242
243* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
244- new upstream release.
245
246* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
247- new upstream release.
248
249* Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
250- new upstream release.
251- disabled HTTP/2 on Vine6.
252
253* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
254- added HTTP/2 support.
255
256* Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
257- new upstream release with security fix.
258
259* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
260- new upstream release.
261
262* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
263- new upstream release
264- built with openssl 1.0.2g
265
266* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
267- new upstream release with security fix .
268- removed Patch108 (fixed in upstream).
269
270* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
271- new upstream release with security fix
272
273* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
274- new upstream release
275- add libcurl.m4 to -devel package
276
277* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
278- new upstream release
279- import upstream/fedora patches
280- disable libssh2 on Vine Linux 6
281
282* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
283- new upstream reelase
284
285* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
286- update to 7.28.0
287- add configure options
288  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
289- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
290 
291- use ca-certificates package
292  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
293  - R: ca-certificates
294
295* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
296- new upstream release
297
298* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
299- add patch100 for fix CVE-2011-2192 (gssapi)
300- add Vendor/Distri tags
301
302* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
303- rebuild with openssl-1.0.0c
304
305* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
306- rebuilt with rpm-4.8.1 for pkg-config
307
308* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
309- new upstream release
310
311* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
312- new upstream release with security fix
313
314* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
315- added compat32 subpackages
316
317* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
318- new upstream release
319- use "_smp_mflags" flag
320
321* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
322- rebuild with openldap-2.4.11
323- add BR: openldap-devel
324- remove static library
325
326* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
327- new upstream release with security fix (CVE-2009-0037)
328
329* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
330- new upstream release
331
332* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
333- new upstream release
334
335* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
336- new upstream release
337
338* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
339- new upstream release
340
341* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
342- new upstream release
343
344* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
345- rebuilt with openssl-0.9.8e
346
347* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
348- new upstream release
349
350* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
351- new upstream release
352
353* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
354- new upstream release
355- add pkgconfig file to devel package
356
357* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
358- new upstream release
359
360* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
361- new upstream release
362
363* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
364- new upstream release
365
366* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
367- added libidn, zlib in Requires
368- added libidn-devel, zlib-devel in BuildPrereq
369- added zlib-devel in curl-devel's Requires
370
371* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
372- added openssl-devel, libidn-devel in curl-devel's Requires
373
374* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
375- new upstream release
376
377* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
378- new upstream release
379- rebuild with openssl-0.9.7d
380
381* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
382- upstream release
383
384* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
385- add %%{_datadir}/curl/* to %%files section
386
387* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
388- source upgrade
389
390* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
391- source upgrade
392- add PreReq: ldconfig
393- add %%{_libdir}/*.la to %%files devel section
394
395* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
396- build for VineSeed
397- add Requires: openssl
398
399* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
400- automated rebuild
401
402* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
403- 7.9.2
404
405* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
406- include curl-config in curl-devel
407- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
408
409* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
410- added openssl-devel build req
411
412* Mon May 21 2001 Tim Powers <timp@redhat.com>
413- built for the distro
414
415* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
416- upgrade to curl-7.7.2.
417- enable IPv6.
418
419* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
420- rebuilt against openssl-0.9.6-1
421
422* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
423- fixed mising ldconfigs
424- updated to 7.5.2, bug fixes
425
426* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
427- updated to 7.5.1
428
429* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
430- update to 7.4.1 to fix bug #20337, problems with curl -c
431- not using patch anymore, it's included in the new source. Keeping
432  for reference
433
434* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
435- fix bogus req in -devel package
436
437* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
438- devel package needed defattr so that root owns the files
439
440* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
441- update to 7.3
442- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
443
444* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
445- enable SSL support
446- fix packager tag
447- move buildroot to %%{_tmppath}
448
449* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
450- fixed vendor tag for bug #15028
451
452* Mon Jul 24 2000 Prospector <prospector@redhat.com>
453- rebuilt
454
455* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
456- workaround alpha build problems with optimizations
457
458* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
459- rebuilt
460
461* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
462- put man pages in correct place
463- use %%makeinstall
464
465* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
466- updated to 6.5.2
467
468* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
469- updated sources to 6.2
470- gzip man page
471
472* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
473- changed group
474
475* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
476- changelog started
477- general cleanups, changed prefix to /usr, added manpage to files section
478- including in Powertools
Note: See TracBrowser for help on using the repository browser.