source: projects/specs/trunk/c/cmake/cmake-vl.spec @ 1442

Revision 1442, 3.0 KB checked in by inagaki, 14 years ago (diff)

updated: Qt4, cmake, qca2, uim

Line 
1Name: cmake
2Summary: Cross-platform make system
3Version: 2.8.2
4Release: 1%{?_dist_release}
5
6License: Insight Consortium
7Group: Development/Tools
8URL: http://www.cmake.org/
9
10Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
11Source1: macros.cmake
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15Vendor: Project Vine
16Distribution: Vine Linux
17
18%description
19CMake is used to control the software compilation process using simple
20platform and compiler independent configuration files. CMake generates
21native makefiles and workspaces that can be used in the compiler
22environment of your choice. CMake is quite sophisticated: it is possible
23to support complex environments requiring system configuration, pre-processor
24generation, code generation, and template instantiation.
25
26%prep
27%setup -q
28
29%build
30./bootstrap --prefix=%{_prefix} --datadir=/share/CMake --mandir=/share/man
31make %{?_smp_mflags}
32
33%install
34rm -rf $RPM_BUILD_ROOT
35%makeinstall DESTDIR=$RPM_BUILD_ROOT
36
37rm -rf $RPM_BUILD_ROOT/usr/doc
38
39# RPM macros
40install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
41sed -i -e "s|@@CMAKE_VERSION@@|%{version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
42touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
43
44%clean
45rm -rf $RPM_BUILD_ROOT
46
47%files
48%defattr(-,root,root)
49%doc CMakeLogo.gif ChangeLog.* Copyright.txt
50%doc Docs/*
51%doc Example/
52%config(noreplace) %{_sysconfdir}/rpm/macros.cmake
53%{_bindir}/*
54%{_datadir}/CMake/
55%{_mandir}/man1/*
56
57%changelog
58* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
59- new upstream release
60
61* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
62- rebuilt with new toolchain
63
64* Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
65- imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
66
67* Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
68- new upstream release
69- added Vendor/Distribution tag
70
71* Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
72- new upstream release
73
74* Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
75- new upstream release
76
77* Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
78- new upstream release
79
80* Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
81- new upstream release
82
83* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
84- new upstream release
85- drop Patch100
86- use bootstrap script instead of configure
87- delete caches from %%doc
88
89* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
90- rebuilt with new toolchain
91
92* Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
93- new upstream release
94- delete duped docs
95
96* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
97- added Patch100 (especially for ppc to solve ppc/powerpc issue)
98
99* Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
100- source version up
101
102* Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
103- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.