source: projects/specs/trunk/c/cmake/cmake-vl.spec @ 12555

Revision 12555, 8.2 KB checked in by tomop, 3 years ago (diff)

updated 7 packages

ImageMagick?-6.9.12.1-1

cmake-3.19.6-1

double-conversion-3.1.5-5

emacs-27.1-1

inkscape-1.0.2-1

potrace-1.16-1

pstoedit-3.75-2

Line 
1# Set to bcond_without or use --with bootstrap if bootstrapping a new release
2# or architecture
3%bcond_with bootstrap
4# Set to bcond_with or use --without gui to disable qt4 gui build
5%bcond_with gui
6
7Name: cmake
8Summary: Cross-platform make system
9Summary(ja): クロスプラットフォームな Make システム
10Version: 3.19.6
11Release: 1%{?_dist_release}
12Group: programming
13Vendor: Project Vine
14Distribution: Vine Linux
15
16License: BSD
17URL: https://www.cmake.org/
18Source0: https://github.com/Kitware/CMake/releases/download/v%{version}/cmake-%{version}.tar.gz
19Source1: macros.cmake
20Source3: %{name}.attr
21Source4: %{name}.prov
22Source5: %{name}.req
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires: curl-devel
26BuildRequires: expat-devel
27BuildRequires: gcc-gfortran
28BuildRequires: libarchive-devel
29#BuildRequires: libidn-devel
30BuildRequires: ncurses-devel
31BuildRequires: openssl-devel
32BuildRequires: zlib-devel
33BuildRequires: xz-devel
34BuildRequires: jsoncpp-devel
35%if %{with gui}
36BuildRequires: qt4-devel, desktop-file-utils
37%define qt_gui --qt-gui
38%else
39%define qt_gui --no-qt-gui
40%endif
41Provides:      %{name}-filesystem%{?_isa} = %{version}-%{release}
42 
43%global major_version %(echo %{version} | cut -d . -f 1)
44%global minor_version %(echo %{version} | cut -d . -f 2)
45
46%description
47CMake is used to control the software compilation process using simple
48platform and compiler independent configuration files. CMake generates
49native makefiles and workspaces that can be used in the compiler
50environment of your choice. CMake is quite sophisticated: it is possible
51to support complex environments requiring system configuration, pre-processor
52generation, code generation, and template instantiation.
53
54
55%package        gui
56Summary:        Qt GUI for %{name}
57Group:          programming
58Requires:       %{name} = %{version}-%{release}
59Requires(post): desktop-file-utils, shared-mime-info
60Requires(postun): desktop-file-utils, shared-mime-info
61
62%description    gui
63The %{name}-gui package contains the Qt based GUI for CMake.
64
65
66%debug_package
67
68
69%prep
70%setup -q
71
72
73%build
74./bootstrap \
75    --prefix=%{_prefix} \
76    --datadir=/share/%{name} \
77    --docdir=/share/doc/%{name} \
78    --mandir=/share/man \
79%if 0%{?with_bootstrap}
80    --no-system-libs \
81%else
82    --system-curl \
83    --system-expat \
84    --system-jsoncpp \
85    --system-zlib \
86    --system-bzip2 \
87    --system-liblzma \
88    --system-libarchive \
89    --no-system-librhash \
90%endif
91    --parallel=`/usr/bin/getconf _NPROCESSORS_ONLN` \
92    %{?qt_gui} \
93    -- -DCMAKE_USE_SYSTEM_LIBUV=OFF
94
95# sed -i 's/-lcurses/-lcurses -ltinfo/' Source/CMakeFiles/ccmake.dir/link.txt
96
97make VERBOSE=1 %{?_smp_mflags}
98
99
100%install
101rm -rf %{buildroot}
102make install DESTDIR=%{buildroot}
103
104find %{buildroot}/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
105rm -rf %{buildroot}/usr/doc
106
107# RPM macros
108install -p -m0644 -D %{SOURCE1} %{buildroot}%{_rpmmacrodir}/macros.cmake
109sed -i -e "s|@@CMAKE_MAJOR_VERSION@@|%{major_version}|" %{buildroot}%{_rpmmacrodir}/macros.cmake
110touch -r %{SOURCE1} %{buildroot}%{_rpmmacrodir}/macros.cmake
111
112# RPM auto provides
113install -p -m0644 -D %{SOURCE3} %{buildroot}%{_prefix}/lib/rpm/fileattrs/%{name}.attr
114install -p -m0755 -D %{SOURCE4} %{buildroot}%{_prefix}/lib/rpm/%{name}.prov
115install -p -m0755 -D %{SOURCE5} %{buildroot}%{_prefix}/lib/rpm/%{name}.req
116
117%if %{with gui}
118# Desktop file
119desktop-file-install --delete-original \
120  --dir=%{buildroot}%{_datadir}/applications \
121  %{buildroot}/%{_datadir}/applications/CMake.desktop
122%endif
123
124rm -rf doc
125mv -f %{buildroot}%{_docdir}/%{name} ./doc
126
127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
131
132%if %{with gui}
133%post gui
134update-desktop-database &> /dev/null || :
135update-mime-database %{_datadir}/mime &> /dev/null || :
136
137%postun gui
138update-desktop-database &> /dev/null || :
139update-mime-database %{_datadir}/mime &> /dev/null || :
140%endif
141
142
143%files
144%defattr(-,root,root)
145%doc CMakeLogo.gif README.* doc
146%doc Help
147%license Copyright.txt Licenses/*
148%config(noreplace) %{_rpmmacrodir}/macros.cmake
149%{_rpmconfigdir}/fileattrs/%{name}.attr
150%{_rpmconfigdir}/%{name}.prov
151%{_rpmconfigdir}/%{name}.req
152%{_bindir}/ccmake
153%{_bindir}/cmake
154%{_bindir}/cpack
155%{_bindir}/ctest
156%{_datadir}/%{name}/
157%{_datadir}/aclocal/cmake.m4
158%dir %{_datadir}/bash-completion
159%dir %{_datadir}/bash-completion/completions
160%{_datadir}/bash-completion/completions/*
161%exclude /usr/share/vim
162%exclude /usr/share/emacs
163
164%if %{with gui}
165%files gui
166%defattr(-,root,root,-)
167%{_bindir}/cmake-gui
168%{_datadir}/applications/CMake.desktop
169%{_datadir}/mime/packages/cmakecache.xml
170%{_datadir}/icons/hicolor/*/*/*
171%endif
172
173
174%changelog
175* Sat Feb 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.19.6-1
176- updated to 3.19.6.
177- updated macros.cmake.
178
179* Thu Jul 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.18.0-1
180- updated to 3.18.0.
181
182* Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.15.3-1
183- updated to 3.15.3.
184
185* Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.10.1-1
186- updated to 3.10.1.
187- updated macros.cmake.
188- disabled gui.
189
190* Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-2
191- rebuild with gcc-5.4.0
192
193* Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-1
194- update to 3.5.2
195- add BuildRequires: xz-devel, jsoncpp-devel
196- remove old patches
197
198* Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
199- update to 2.8.12.2
200
201* Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
202- update to 2.8.12.2
203- add Patch2 (cmake-2.8.12.2-ruby-2.2.x.patch)
204
205* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-2
206- rebuild with libarchive-3.1.2
207
208* Mon Dec 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-1
209- new upstream release
210- add Patch1 (cmake-2.8.12.1-FindFreetype.patch)
211
212* Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11.2-1
213- new upstream release
214
215* Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11-1
216- new upstream release
217
218* Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10.2-1
219- new upstream release
220- fixed desktop file warning
221
222* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-2
223- rebuild with libarchive-3.0.4
224
225* Sat Nov 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.6-1
226- new upstream release
227- forced to link with libtinfo.so (ccmake)
228- used --system-libs again
229
230* Sat Jan  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-1
231- new upstream release
232- used --no-system-libs, removed BR: curl-devel, expat-devel, zlib-devel
233
234* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
235- fixed typo (not --with-system-libs, but --system-libs)
236- added BR: curl-devel, expat-devel, zlib-devel
237
238* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
239- add BuildRequires: ncurses-devel
240
241* Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
242- generate gui package
243- renamed module directory
244
245* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
246- new upstream release
247
248* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
249- rebuilt with new toolchain
250
251* Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
252- imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
253
254* Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
255- new upstream release
256- added Vendor/Distribution tag
257
258* Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
259- new upstream release
260
261* Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
262- new upstream release
263
264* Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
265- new upstream release
266
267* Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
268- new upstream release
269
270* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
271- new upstream release
272- drop Patch100
273- use bootstrap script instead of configure
274- delete caches from %%doc
275
276* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
277- rebuilt with new toolchain
278
279* Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
280- new upstream release
281- delete duped docs
282
283* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
284- added Patch100 (especially for ppc to solve ppc/powerpc issue)
285
286* Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
287- source version up
288
289* Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
290- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.