source: projects/specs/trunk/c/cmake/cmake-vl.spec @ 521

Revision 521, 2.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Cross-platform make system
2Name: cmake
3Version: 2.6.4
4Release: 3%{?_dist_release}
5Source0: http://www.cmake.org/files/v2.6/%{name}-%{version}.tar.gz
6Source1: macros.cmake
7
8License: Insight Consortium
9Group: Development/Tools
10URL: http://www.cmake.org/
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13
14Vendor: Project Vine
15Distribution: Vine Linux
16
17%description
18CMake is used to control the software compilation process using simple
19platform and compiler independent configuration files. CMake generates
20native makefiles and workspaces that can be used in the compiler
21environment of your choice. CMake is quite sophisticated: it is possible
22to support complex environments requiring system configuration, pre-processor
23generation, code generation, and template instantiation.
24
25%prep
26%setup -q
27
28%build
29./bootstrap --prefix=%{_prefix} --datadir=/share/CMake --mandir=/share/man
30make %{?_smp_mflags}
31
32%install
33rm -rf $RPM_BUILD_ROOT
34%makeinstall DESTDIR=$RPM_BUILD_ROOT
35
36rm -rf $RPM_BUILD_ROOT/usr/doc
37
38# RPM macros
39install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
40sed -i -e "s|@@CMAKE_VERSION@@|%{version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
41touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
42
43%clean
44rm -rf $RPM_BUILD_ROOT
45
46%files
47%defattr(-,root,root)
48%doc CMakeLogo.gif ChangeLog.* Copyright.txt
49%doc Docs/*
50%doc Example/
51%config(noreplace) %{_sysconfdir}/rpm/macros.cmake
52%{_bindir}/*
53%{_datadir}/CMake/
54%{_mandir}/man1/*
55
56%changelog
57* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
58- rebuilt with new toolchain
59
60* Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
61- imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
62
63* Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
64- new upstream release
65- added Vendor/Distribution tag
66
67* Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
68- new upstream release
69
70* Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
71- new upstream release
72
73* Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
74- new upstream release
75
76* Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
77- new upstream release
78
79* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
80- new upstream release
81- drop Patch100
82- use bootstrap script instead of configure
83- delete caches from %%doc
84
85* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
86- rebuilt with new toolchain
87
88* Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
89- new upstream release
90- delete duped docs
91
92* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
93- added Patch100 (especially for ppc to solve ppc/powerpc issue)
94
95* Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
96- source version up
97
98* Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
99- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.