source: projects/specs/trunk/c/cmake/cmake-vl.spec @ 1640

Revision 1640, 4.5 KB checked in by inagaki, 14 years ago (diff)

update: cmake, qjson

Line 
1# Set to bcond_with or use --without gui to disable qt4 gui build
2%bcond_without gui
3
4Name: cmake
5Summary: Cross-platform make system
6Summary(ja): クロスプラットフォームな Make システム
7Version: 2.8.2
8Release: 2%{?_dist_release}
9
10Group: Development/Tools
11License: BSD
12URL: http://www.cmake.org/
13
14Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
15Source1: macros.cmake
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18%if %{with gui}
19BuildRequires: qt4-devel, desktop-file-utils
20%define qt_gui --qt-gui
21%endif
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26%description
27CMake is used to control the software compilation process using simple
28platform and compiler independent configuration files. CMake generates
29native makefiles and workspaces that can be used in the compiler
30environment of your choice. CMake is quite sophisticated: it is possible
31to support complex environments requiring system configuration, pre-processor
32generation, code generation, and template instantiation.
33
34%package        gui
35Summary:        Qt GUI for %{name}
36Group:          Development/Tools
37Requires:       %{name} = %{version}-%{release}
38Requires(post): desktop-file-utils, shared-mime-info
39Requires(postun): desktop-file-utils, shared-mime-info
40
41%description    gui
42The %{name}-gui package contains the Qt based GUI for CMake.
43
44
45%prep
46%setup -q
47# Fixup permissions
48find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
49
50%build
51./bootstrap --prefix=%{_prefix} --datadir=/share/%{name} \
52    --mandir=/share/man --with-system-libs %{?qt_gui}
53make VERBOSE=1 %{?_smp_mflags}
54
55%install
56rm -rf $RPM_BUILD_ROOT
57make install DESTDIR=$RPM_BUILD_ROOT
58
59find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
60rm -rf $RPM_BUILD_ROOT/usr/doc
61
62# RPM macros
63install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
64sed -i -e "s|@@CMAKE_VERSION@@|%{version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
65touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
66
67%if %{with gui}
68# Desktop file
69desktop-file-install --delete-original \
70  --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
71  $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
72%endif
73
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%if %{with gui}
79%post gui
80update-desktop-database &> /dev/null || :
81update-mime-database %{_datadir}/mime &> /dev/null || :
82
83%postun gui
84update-desktop-database &> /dev/null || :
85update-mime-database %{_datadir}/mime &> /dev/null || :
86%endif
87
88
89%files
90%defattr(-,root,root)
91%doc CMakeLogo.gif ChangeLog.* Copyright.txt
92%doc Docs/*
93%doc Example/
94%config(noreplace) %{_sysconfdir}/rpm/macros.cmake
95%{_bindir}/ccmake
96%{_bindir}/cmake
97%{_bindir}/cpack
98%{_bindir}/ctest
99%{_datadir}/%{name}/
100%{_mandir}/man1/*
101
102%if %{with gui}
103%files gui
104%defattr(-,root,root,-)
105%{_bindir}/cmake-gui
106%{_datadir}/applications/CMake.desktop
107%{_datadir}/mime/packages/cmakecache.xml
108%{_datadir}/pixmaps/CMakeSetup32.png
109%endif
110
111
112%changelog
113* Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
114- generate gui package
115- renamed module directory
116
117* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
118- new upstream release
119
120* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
121- rebuilt with new toolchain
122
123* Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
124- imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
125
126* Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
127- new upstream release
128- added Vendor/Distribution tag
129
130* Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
131- new upstream release
132
133* Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
134- new upstream release
135
136* Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
137- new upstream release
138
139* Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
140- new upstream release
141
142* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
143- new upstream release
144- drop Patch100
145- use bootstrap script instead of configure
146- delete caches from %%doc
147
148* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
149- rebuilt with new toolchain
150
151* Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
152- new upstream release
153- delete duped docs
154
155* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
156- added Patch100 (especially for ppc to solve ppc/powerpc issue)
157
158* Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
159- source version up
160
161* Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
162- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.