source: projects/specs/trunk/a/at-spi/at-spi-vl.spec @ 5701

Revision 5701, 13.8 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define atk_version 1.32.0
4%define gtk2_version 2.22.0
5%define libbonobo_version 2.32.0
6%define orbit2_version 2.14.19
7%define pango_version 1.28.3
8%define gconf2_version 2.32.0
9%define dbus_glib_version 0.88
10
11Summary: Assistive Technology Service Provider Interface
12
13Name: at-spi
14Version: 1.32.0
15Release: 3%{?_dist_release}
16URL: http://developer.gnome.org/projects/gap/
17Source0: http://download.gnome.org/sources/at-spi/1.32/%{name}-%{version}.tar.bz2
18
19License: LGPLv2+
20Group: System Environment/Libraries
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires: pango-devel >= %{pango_version}
23BuildRequires: gtk2-devel >= %{gtk2_version}
24BuildRequires: libbonobo-devel >= %{libbonobo_version}
25BuildRequires: ORBit2-devel >= %{orbit2_version}
26BuildRequires: atk-devel >= %{atk_version}
27BuildRequires: GConf2-devel >= %{gconf2_version}
28BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
29BuildRequires: popt-devel
30BuildRequires: fontconfig
31BuildRequires: gettext
32BuildRequires: intltool
33BuildRequires: perl(XML::Parser)
34BuildRequires: libX11-devel
35BuildRequires: libXtst-devel
36BuildRequires: libXi-devel
37BuildRequires: libXevie-devel
38BuildRequires: libXt-devel
39BuildRequires: desktop-file-utils
40
41Patch2: at-spi-silence-no-event-spew.patch
42
43%description
44at-spi allows assistive technologies to access GTK-based
45applications. Essentially it exposes the internals of applications for
46automation, so tools such as screen readers, magnifiers, or even
47scripting interfaces can query and interact with GUI controls.
48
49
50%package devel
51Summary: Development libraries and headers for at-spi
52Group: Development/Libraries
53Requires: %name = %{version}-%{release}
54Requires: atk-devel
55Requires: gtk2-devel
56Requires: libbonobo-devel
57Requires: ORBit2-devel
58Requires: pkgconfig
59
60%description devel
61Libraries and header files allowing compilation of apps that use at-spi.
62
63
64%package python
65Summary: Python bindings for at-spi
66Group: Development/Libraries
67Requires: %name = %{version}-%{release}
68Requires: python
69
70%description python
71Python bindings allowing to use at-spi in python programs.
72
73
74%prep
75%setup -q
76## %patch2 -p1 -b .spew
77
78
79%build
80%configure --disable-gtk-doc --disable-static --enable-relocate
81make
82
83%install
84rm -rf $RPM_BUILD_ROOT
85make install DESTDIR=$RPM_BUILD_ROOT
86
87%find_lang at-spi
88
89rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
90rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
91rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
92
93%post
94/sbin/ldconfig
95export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
96gconftool-2 --makefile-install-rule \
97        %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
98
99%pre
100if [ "$1" -gt 1 ]; then
101    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
102    gconftool-2 --makefile-uninstall-rule \
103            %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
104fi
105
106%preun
107if [ "$1" -eq 0 ]; then
108    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
109    gconftool-2 --makefile-uninstall-rule \
110            %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
111fi
112
113%postun -p /sbin/ldconfig
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%files -f at-spi.lang
119%defattr(-,root,root)
120%doc AUTHORS COPYING NEWS README
121%{_sysconfdir}/gconf/schemas/at-spi.schemas
122%{_sysconfdir}/xdg/autostart/at-spi-registryd.desktop
123%{_libdir}/lib*.so.*
124%{_libdir}/bonobo/servers/*
125%{_libdir}/orbit-2.0/*
126%{_libdir}/gtk-2.0/modules/at-spi-corba
127%{_libexecdir}/*
128
129%files devel
130%defattr(-,root,root)
131%{_datadir}/gtk-doc/html/*
132%{_datadir}/idl/*
133%{_libdir}/lib*.so
134%{_libdir}/pkgconfig/*
135%{_includedir}/*
136
137%files python
138%defattr(-,root,root)
139%{python_sitearch}/pyatspi_corba
140
141
142%changelog
143* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-3
144- rebuild with python-2.7.2
145
146* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-2
147- add configure option (--enable-relocate)
148
149* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-1
150- new upstream release
151
152* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-2
153- rebuild with rpm-4.8.1 for pkg-config file
154
155* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-1
156- new upstream release
157
158* Sat Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
159- new upstream release
160- drop Patch2
161- add BuildRequires: GConf2-devel, dbus-glib-devel, popt-devel, desktop-file-utils
162
163* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.24.0-3
164- rebuild with python-2.6
165
166* Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.24.0-2
167- remove BuildRequires gail-devel
168  (gtk2-2.14.x now includes/provides gail)
169
170* Sun Sep 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
171- initial build for Vine Linux
172
173* Mon Sep  8 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.92-1
174- Update to 1.23.92
175- Drop upstreamed patch
176
177* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-3
178- Fix an evo crash caused by the greeter crash fix
179
180* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-2
181- Fix a greeter crash
182
183* Tue Sep  2 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-1
184- Update to 1.23.91
185
186* Wed Aug 20 2008 Jarod Wilson <jarod@redhat.com> - 1.23.6-2
187- Silence incessant atk-bridge spew filling xsession-errors (#459275)
188
189* Mon Aug  4 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.6-1
190- Update to 1.23.6
191
192* Mon Jul 21 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.5-1
193- Update to 1.23.5
194
195* Tue Jun  3 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.3-1
196- Update to 1.23.3
197
198* Mon May  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-2
199- Bump rev
200
201* Mon Apr  7 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-1
202- Update to 1.22.1
203
204* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.0-1
205- Update to 1.22.0
206
207* Wed Mar  5 2008 Christopher Aillon <caillon@redhat.com> - 1.21-92-2
208- Perf improvement work from Ginn Chen to help a11y-enabled-firefox3
209
210* Mon Feb 25 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.92-1
211- Update to 1.21.92
212
213* Fri Feb  8 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-2
214- Rebuild for gcc 4.3
215
216* Mon Jan 14 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-1
217- Update to 1.21.5
218
219* Thu Dec  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.3-1
220- Update to 1.21.3
221
222* Tue Nov 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.1-1
223- Update to 1.21.1
224
225* Mon Oct 15 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.1-1
226- Update to 1.20.1
227
228* Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.0-1
229- Update to 1.20.0
230
231* Mon Aug  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-2
232- Update license field
233
234* Tue Jul 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-1
235- Update to 1.19.5
236
237* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.3-1
238- Update to 1.19.3
239- Add a -python subpackage
240
241* Sun May 20 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.1-1
242- Update to 1.19.1
243
244* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-2
245- Don't ship .la files
246
247* Mon Apr  9 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-1
248- Update to 1.18.1, which includes the previous patch
249- Drop obsolete patch
250- Fix a small memory leak
251
252* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-2
253- Backport a patch to fix deadlocks in applications
254
255* Tue Mar 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-1
256- Update to 1.18.0
257- Drop obsolete patch
258
259* Thu Mar  8 2007 Ray Strode <rstrode@redhat.com> - 1.17.2-2
260- add a patch that might fix some deadlock issues (bug 329454)
261
262* Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.2-1
263- Update to 1.17.2
264
265* Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.1-1
266- Update to 1.17.1
267
268* Thu Feb 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-2
269- Bump atk requirement
270
271* Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-1
272- Update to 1.17.0
273
274* Wed Jan 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.16-1
275- Update to 1.7.16
276
277* Wed Jan 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.15-1
278- Update to 1.7.15
279
280* Tue Dec 19 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.14-1
281- Update to 1.7.14
282
283* Sat Dec  9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-2
284- Small spec file cleanups
285
286* Tue Nov  7 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-1
287- Update to 1.7.13
288
289* Fri Oct 20 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.12-1
290- Update to 1.7.12
291
292* Wed Aug 23 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-2.fc6
293- Remove debug spew
294
295* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-1.fc6
296- Update to 1.7.11
297- Drop upstreamed patch
298- Require pkgconfig in the -devel package
299
300* Wed Aug  2 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.10-1.fc6
301- Update to 1.7.10
302
303* Fri Jul 28 2006 Alexander Larsson <alexl@redhat.com> - 1.7.9-3
304- Fix segfault if a11y enabled on x86-64 (#196063)
305
306* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-2
307- Rebuild
308
309* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-1
310- Update to 1.7.9
311
312* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.8-1
313- Update to 1.7.8
314
315* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.7-8.1
316- rebuild
317
318* Thu Jun  8 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-8
319- Add a BuildRequires
320
321* Mon May 22 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-7
322- Make it build in mock
323
324* Mon Apr 17 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-6
325- Revert the previous change
326
327* Tue Apr  4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-5
328- Fix a missing declaration
329- Fix segfaults on x86_64
330
331* Tue Apr  4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-1
332- Update to 1.7.7
333
334* Thu Mar  9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-2
335- Fix a crash on x86_64
336
337* Mon Feb 27 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-1
338- Update to 1.7.6
339
340* Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.5-1
341- Update to 1.7.5
342
343* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.2
344- bump again for double-long bug on ppc(64)
345
346* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.1
347- rebuilt for new gcc4.1 snapshot and glibc changes
348
349* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> 1.7.4-1
350- Update to 1.7.4
351
352* Mon Jan 30 2006 Matthias Clasen <mclasen@redhat.com> 1.7.3-1
353- Update to 1.7.3
354
355* Tue Jan 17 2006 Matthias Clasen <mclasen@redhat.com> 1.7.2-1
356- Update to 1.7.2
357
358* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
359- rebuilt
360
361* Mon Oct 31 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-2
362- Switch requires to modular X
363
364* Wed Sep  7 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-1
365- Update to 1.6.6
366
367* Tue Aug 16 2005 Matthias Clasen <mclasen@redhat.com>
368- Rebuilt
369
370* Tue Jun 28 2005 Matthias Clasen <mclasen@redhat.com> 1.6.4-1
371- Update to 1.6.4
372
373* Mon Mar 14 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
374- Update to 1.6.3
375
376* Wed Mar  2 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-2
377- Rebuilt with gcc4
378
379* Wed Jan 26 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
380- Update to 1.6.2
381
382* Wed Sep 29 2004 Elliot Lee <sopwith@redhat.com> 1.6.0-3
383- Remove dependency on linc-devel
384
385* Fri Sep 24 2004 Mark McLoughlin <markmc@redhat.com> 1.6.0-2
386- Fix some random spec file issues (fixes #133430?)
387
388* Thu Sep 23 2004 Jonathan Blandford <jrb@redhat.com> 1.6.0-1
389- bump version
390
391* Wed Aug  4 2004 Mark McLoughlin <markmc@redhat.com> 1.5.3-1
392- Update to 1.5.3
393
394* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
395- rebuilt
396
397* Wed Mar 31 2004 Mark McLoughlin <markmc@redhat.com> 1.4.0-1
398- Update to 1.4.0
399
400* Wed Mar 10 2004 Mark McLoughlin <markmc@redhat.com> 1.3.15
401- Update to 1.3.15
402
403* Thu Mar 04 2004 Mark McLoughlin <markmc@redhat.com> 1.3.14-1
404- Update to 1.3.14
405
406* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
407- rebuilt
408
409* Thu Feb 26 2004 Alexander Larsson <alexl@redhat.com> 1.3.13-1
410- update to 1.3.13
411
412* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
413- rebuilt
414
415* Fri Jan 30 2004 Jonathan Blandford <jrb@redhat.com> 1.3.11-1
416- new version
417
418* Thu Oct  2 2003 Jonathan Blandford <jrb@redhat.com> 1.3.7-1
419- new version
420
421* Wed Aug 20 2003 Elliot Lee <sopwith@redhat.com> 1.1.9-3
422- Fix rebuild failure (stderr.patch)
423
424* Tue Jul 15 2003 Havoc Pennington <hp@redhat.com> 1.1.9-2
425- disable gtk doc
426
427* Mon Jul 14 2003 Havoc Pennington <hp@redhat.com>
428- automated rebuild
429
430* Mon Jul  7 2003 Havoc Pennington <hp@redhat.com> 1.1.9-1
431- 1.1.9
432- remove multilib patch fixed upstream
433
434* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
435- rebuilt
436
437* Fri Feb 14 2003 Havoc Pennington <hp@redhat.com> 1.1.8-3
438- kill Xft buildreq
439
440* Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-2
441- rebuild to fix self-dependency
442
443* Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
444
445- extend multilib patch to cover -lXi
446
447* Tue Feb  4 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
448- 1.1.8
449
450* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
451- rebuilt
452
453* Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.0.1-6
454- Add patch to help multilib systems find libXtst
455
456* Fri Dec  6 2002 Havoc Pennington <hp@redhat.com>
457- rebuild
458
459* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
460- rebuild with new libbonobo and gail
461
462* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
463- automated rebuild
464
465* Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
466- add libatk-bridge.so to the file list
467
468* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
469- 1.0.1
470- add at-spi-registryd to file list
471
472* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
473- rebuild in different environment
474
475* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
476- 1.0.0
477- add post/postun ldconfig
478
479* Wed May 29 2002 Bill Nottingham <notting@redhat.com>
480- rebuild again?
481
482* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
483- rebuild in different environment
484
485* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
486- 0.12.1
487
488* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
489- Version 0.0.6
490
491* Mon Jan 28 2002 Havoc Pennington <hp@redhat.com>
492- rebuild in rawhide, seems to have been linked incorrectly
493
494* Thu Jan 24 2002 Havoc Pennington <hp@redhat.com>
495- rebuild in rawhide, upgrade to 0.0.5
496- add gail deps
497
498* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
499- Initial build.
500
501
Note: See TracBrowser for help on using the repository browser.