source: projects/specs/trunk/a/at-spi/at-spi-vl.spec @ 9559

Revision 9559, 14.0 KB checked in by Takemikaduchi, 9 years ago (diff)

cinnamon: new upstream release or rebuild
caja: fix typo
others: remove *.la files

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define atk_version 1.32.0
4%define gtk2_version 2.22.0
5%define libbonobo_version 2.32.0
6%define orbit2_version 2.14.19
7%define pango_version 1.28.3
8%define gconf2_version 2.32.0
9%define dbus_glib_version 0.88
10
11Summary: Assistive Technology Service Provider Interface
12
13Name: at-spi
14Version: 1.32.0
15Release: 5%{?_dist_release}
16URL: http://developer.gnome.org/projects/gap/
17Source0: http://download.gnome.org/sources/at-spi/1.32/%{name}-%{version}.tar.bz2
18
19License: LGPLv2+
20Group: System Environment/Libraries
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires: pango-devel >= %{pango_version}
23BuildRequires: gtk2-devel >= %{gtk2_version}
24BuildRequires: libbonobo-devel >= %{libbonobo_version}
25BuildRequires: ORBit2-devel >= %{orbit2_version}
26BuildRequires: atk-devel >= %{atk_version}
27BuildRequires: GConf2-devel >= %{gconf2_version}
28BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
29BuildRequires: popt-devel
30BuildRequires: fontconfig
31BuildRequires: gettext
32BuildRequires: intltool
33BuildRequires: perl(XML::Parser)
34BuildRequires: libX11-devel
35BuildRequires: libXtst-devel
36BuildRequires: libXi-devel
37BuildRequires: libXevie-devel
38BuildRequires: libXt-devel
39BuildRequires: desktop-file-utils
40
41Patch2: at-spi-silence-no-event-spew.patch
42
43Vendor: Project Vine
44Distribution: Vine Linux
45
46%description
47at-spi allows assistive technologies to access GTK-based
48applications. Essentially it exposes the internals of applications for
49automation, so tools such as screen readers, magnifiers, or even
50scripting interfaces can query and interact with GUI controls.
51
52
53%package devel
54Summary: Development libraries and headers for at-spi
55Group: Development/Libraries
56Requires: %name = %{version}-%{release}
57Requires: atk-devel
58Requires: gtk2-devel
59Requires: libbonobo-devel
60Requires: ORBit2-devel
61Requires: pkgconfig
62
63%description devel
64Libraries and header files allowing compilation of apps that use at-spi.
65
66
67%package python
68Summary: Python bindings for at-spi
69Group: Development/Libraries
70Requires: %name = %{version}-%{release}
71Requires: python
72
73%description python
74Python bindings allowing to use at-spi in python programs.
75
76
77%prep
78%setup -q
79## %patch2 -p1 -b .spew
80
81
82%build
83%configure --disable-gtk-doc --disable-static --enable-relocate
84make
85
86%install
87rm -rf $RPM_BUILD_ROOT
88make install DESTDIR=$RPM_BUILD_ROOT
89
90%find_lang at-spi
91
92find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
93
94
95%post
96/sbin/ldconfig
97export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
98gconftool-2 --makefile-install-rule \
99        %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
100
101%pre
102if [ "$1" -gt 1 ]; then
103    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
104    gconftool-2 --makefile-uninstall-rule \
105            %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
106fi
107
108%preun
109if [ "$1" -eq 0 ]; then
110    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
111    gconftool-2 --makefile-uninstall-rule \
112            %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
113fi
114
115%postun -p /sbin/ldconfig
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%files -f at-spi.lang
121%defattr(-,root,root)
122%doc AUTHORS COPYING NEWS README
123%{_sysconfdir}/gconf/schemas/at-spi.schemas
124%{_sysconfdir}/xdg/autostart/at-spi-registryd.desktop
125%{_libdir}/lib*.so.*
126%{_libdir}/bonobo/servers/*
127%{_libdir}/orbit-2.0/*
128%{_libdir}/gtk-2.0/modules/at-spi-corba
129%{_libexecdir}/*
130
131%files devel
132%defattr(-,root,root)
133%{_datadir}/gtk-doc/html/*
134%{_datadir}/idl/*
135%{_libdir}/lib*.so
136%{_libdir}/pkgconfig/*
137%{_includedir}/*
138
139%files python
140%defattr(-,root,root)
141%{python_sitearch}/pyatspi_corba
142
143
144%changelog
145* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-5
146- remove *.la files
147
148* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-4
149- rebuild with VineSeed environment
150
151* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-3
152- rebuild with python-2.7.2
153
154* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-2
155- add configure option (--enable-relocate)
156
157* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-1
158- new upstream release
159
160* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-2
161- rebuild with rpm-4.8.1 for pkg-config file
162
163* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-1
164- new upstream release
165
166* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
167- new upstream release
168- drop Patch2
169- add BuildRequires: GConf2-devel, dbus-glib-devel, popt-devel, desktop-file-utils
170
171* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.24.0-3
172- rebuild with python-2.6
173
174* Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.24.0-2
175- remove BuildRequires gail-devel
176  (gtk2-2.14.x now includes/provides gail)
177
178* Sun Sep 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
179- initial build for Vine Linux
180
181* Mon Sep  8 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.92-1
182- Update to 1.23.92
183- Drop upstreamed patch
184
185* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-3
186- Fix an evo crash caused by the greeter crash fix
187
188* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-2
189- Fix a greeter crash
190
191* Tue Sep  2 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-1
192- Update to 1.23.91
193
194* Wed Aug 20 2008 Jarod Wilson <jarod@redhat.com> - 1.23.6-2
195- Silence incessant atk-bridge spew filling xsession-errors (#459275)
196
197* Mon Aug  4 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.6-1
198- Update to 1.23.6
199
200* Mon Jul 21 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.5-1
201- Update to 1.23.5
202
203* Tue Jun  3 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.3-1
204- Update to 1.23.3
205
206* Mon May  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-2
207- Bump rev
208
209* Mon Apr  7 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-1
210- Update to 1.22.1
211
212* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.0-1
213- Update to 1.22.0
214
215* Wed Mar  5 2008 Christopher Aillon <caillon@redhat.com> - 1.21-92-2
216- Perf improvement work from Ginn Chen to help a11y-enabled-firefox3
217
218* Mon Feb 25 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.92-1
219- Update to 1.21.92
220
221* Fri Feb  8 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-2
222- Rebuild for gcc 4.3
223
224* Mon Jan 14 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-1
225- Update to 1.21.5
226
227* Thu Dec  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.3-1
228- Update to 1.21.3
229
230* Tue Nov 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.1-1
231- Update to 1.21.1
232
233* Mon Oct 15 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.1-1
234- Update to 1.20.1
235
236* Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.0-1
237- Update to 1.20.0
238
239* Mon Aug  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-2
240- Update license field
241
242* Tue Jul 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-1
243- Update to 1.19.5
244
245* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.3-1
246- Update to 1.19.3
247- Add a -python subpackage
248
249* Sun May 20 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.1-1
250- Update to 1.19.1
251
252* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-2
253- Don't ship .la files
254
255* Mon Apr  9 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-1
256- Update to 1.18.1, which includes the previous patch
257- Drop obsolete patch
258- Fix a small memory leak
259
260* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-2
261- Backport a patch to fix deadlocks in applications
262
263* Tue Mar 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-1
264- Update to 1.18.0
265- Drop obsolete patch
266
267* Thu Mar  8 2007 Ray Strode <rstrode@redhat.com> - 1.17.2-2
268- add a patch that might fix some deadlock issues (bug 329454)
269
270* Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.2-1
271- Update to 1.17.2
272
273* Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.1-1
274- Update to 1.17.1
275
276* Thu Feb 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-2
277- Bump atk requirement
278
279* Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-1
280- Update to 1.17.0
281
282* Mon Jan 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.16-1
283- Update to 1.7.16
284
285* Wed Jan 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.15-1
286- Update to 1.7.15
287
288* Tue Dec 19 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.14-1
289- Update to 1.7.14
290
291* Sat Dec  9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-2
292- Small spec file cleanups
293
294* Tue Nov  7 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-1
295- Update to 1.7.13
296
297* Fri Oct 20 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.12-1
298- Update to 1.7.12
299
300* Wed Aug 23 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-2.fc6
301- Remove debug spew
302
303* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-1.fc6
304- Update to 1.7.11
305- Drop upstreamed patch
306- Require pkgconfig in the -devel package
307
308* Wed Aug  2 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.10-1.fc6
309- Update to 1.7.10
310
311* Fri Jul 28 2006 Alexander Larsson <alexl@redhat.com> - 1.7.9-3
312- Fix segfault if a11y enabled on x86-64 (#196063)
313
314* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-2
315- Rebuild
316
317* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-1
318- Update to 1.7.9
319
320* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.8-1
321- Update to 1.7.8
322
323* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.7-8.1
324- rebuild
325
326* Thu Jun  8 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-8
327- Add a BuildRequires
328
329* Mon May 22 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-7
330- Make it build in mock
331
332* Mon Apr 17 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-6
333- Revert the previous change
334
335* Tue Apr  4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-5
336- Fix a missing declaration
337- Fix segfaults on x86_64
338
339* Tue Apr  4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-1
340- Update to 1.7.7
341
342* Thu Mar  9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-2
343- Fix a crash on x86_64
344
345* Mon Feb 27 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-1
346- Update to 1.7.6
347
348* Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.5-1
349- Update to 1.7.5
350
351* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.2
352- bump again for double-long bug on ppc(64)
353
354* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.1
355- rebuilt for new gcc4.1 snapshot and glibc changes
356
357* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> 1.7.4-1
358- Update to 1.7.4
359
360* Mon Jan 30 2006 Matthias Clasen <mclasen@redhat.com> 1.7.3-1
361- Update to 1.7.3
362
363* Tue Jan 17 2006 Matthias Clasen <mclasen@redhat.com> 1.7.2-1
364- Update to 1.7.2
365
366* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
367- rebuilt
368
369* Mon Oct 31 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-2
370- Switch requires to modular X
371
372* Wed Sep  7 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-1
373- Update to 1.6.6
374
375* Tue Aug 16 2005 Matthias Clasen <mclasen@redhat.com>
376- Rebuilt
377
378* Tue Jun 28 2005 Matthias Clasen <mclasen@redhat.com> 1.6.4-1
379- Update to 1.6.4
380
381* Mon Mar 14 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
382- Update to 1.6.3
383
384* Wed Mar  2 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-2
385- Rebuilt with gcc4
386
387* Wed Jan 26 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
388- Update to 1.6.2
389
390* Wed Sep 29 2004 Elliot Lee <sopwith@redhat.com> 1.6.0-3
391- Remove dependency on linc-devel
392
393* Fri Sep 24 2004 Mark McLoughlin <markmc@redhat.com> 1.6.0-2
394- Fix some random spec file issues (fixes #133430?)
395
396* Thu Sep 23 2004 Jonathan Blandford <jrb@redhat.com> 1.6.0-1
397- bump version
398
399* Wed Aug  4 2004 Mark McLoughlin <markmc@redhat.com> 1.5.3-1
400- Update to 1.5.3
401
402* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
403- rebuilt
404
405* Wed Mar 31 2004 Mark McLoughlin <markmc@redhat.com> 1.4.0-1
406- Update to 1.4.0
407
408* Wed Mar 10 2004 Mark McLoughlin <markmc@redhat.com> 1.3.15
409- Update to 1.3.15
410
411* Thu Mar 04 2004 Mark McLoughlin <markmc@redhat.com> 1.3.14-1
412- Update to 1.3.14
413
414* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
415- rebuilt
416
417* Thu Feb 26 2004 Alexander Larsson <alexl@redhat.com> 1.3.13-1
418- update to 1.3.13
419
420* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
421- rebuilt
422
423* Fri Jan 30 2004 Jonathan Blandford <jrb@redhat.com> 1.3.11-1
424- new version
425
426* Thu Oct  2 2003 Jonathan Blandford <jrb@redhat.com> 1.3.7-1
427- new version
428
429* Wed Aug 20 2003 Elliot Lee <sopwith@redhat.com> 1.1.9-3
430- Fix rebuild failure (stderr.patch)
431
432* Tue Jul 15 2003 Havoc Pennington <hp@redhat.com> 1.1.9-2
433- disable gtk doc
434
435* Mon Jul 14 2003 Havoc Pennington <hp@redhat.com>
436- automated rebuild
437
438* Mon Jul  7 2003 Havoc Pennington <hp@redhat.com> 1.1.9-1
439- 1.1.9
440- remove multilib patch fixed upstream
441
442* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
443- rebuilt
444
445* Fri Feb 14 2003 Havoc Pennington <hp@redhat.com> 1.1.8-3
446- kill Xft buildreq
447
448* Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-2
449- rebuild to fix self-dependency
450
451* Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
452
453- extend multilib patch to cover -lXi
454
455* Tue Feb  4 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
456- 1.1.8
457
458* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
459- rebuilt
460
461* Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.0.1-6
462- Add patch to help multilib systems find libXtst
463
464* Fri Dec  6 2002 Havoc Pennington <hp@redhat.com>
465- rebuild
466
467* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
468- rebuild with new libbonobo and gail
469
470* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
471- automated rebuild
472
473* Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
474- add libatk-bridge.so to the file list
475
476* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
477- 1.0.1
478- add at-spi-registryd to file list
479
480* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
481- rebuild in different environment
482
483* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
484- 1.0.0
485- add post/postun ldconfig
486
487* Wed May 29 2002 Bill Nottingham <notting@redhat.com>
488- rebuild again?
489
490* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
491- rebuild in different environment
492
493* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
494- 0.12.1
495
496* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
497- Version 0.0.6
498
499* Mon Jan 28 2002 Havoc Pennington <hp@redhat.com>
500- rebuild in rawhide, seems to have been linked incorrectly
501
502* Thu Jan 24 2002 Havoc Pennington <hp@redhat.com>
503- rebuild in rawhide, upgrade to 0.0.5
504- add gail deps
505
506* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
507- Initial build.
508
509
Note: See TracBrowser for help on using the repository browser.