source: projects/specs/trunk/a/at-spi/at-spi-vl.spec @ 4812

Revision 4812, 13.8 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.1.92

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define atk_version 1.32.0
4%define gtk2_version 2.22.0
5%define libbonobo_version 2.32.0
6%define orbit2_version 2.14.19
7%define pango_version 1.28.3
8%define gconf2_version 2.32.0
9%define dbus_glib_version 0.88
10
11Summary: Assistive Technology Service Provider Interface
12
13Name: at-spi
14Version: 1.32.0
15Release: 2%{?_dist_release}
16URL: http://developer.gnome.org/projects/gap/
17Source0: http://download.gnome.org/sources/at-spi/1.32/%{name}-%{version}.tar.bz2
18
19License: LGPLv2+
20Group: System Environment/Libraries
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires: pango-devel >= %{pango_version}
23BuildRequires: gtk2-devel >= %{gtk2_version}
24BuildRequires: libbonobo-devel >= %{libbonobo_version}
25BuildRequires: ORBit2-devel >= %{orbit2_version}
26BuildRequires: atk-devel >= %{atk_version}
27BuildRequires: GConf2-devel >= %{gconf2_version}
28BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
29BuildRequires: popt-devel
30BuildRequires: fontconfig
31BuildRequires: gettext
32BuildRequires: intltool
33BuildRequires: perl(XML::Parser)
34BuildRequires: libX11-devel
35BuildRequires: libXtst-devel
36BuildRequires: libXi-devel
37BuildRequires: libXevie-devel
38BuildRequires: libXt-devel
39BuildRequires: desktop-file-utils
40
41Patch2: at-spi-silence-no-event-spew.patch
42
43%description
44at-spi allows assistive technologies to access GTK-based
45applications. Essentially it exposes the internals of applications for
46automation, so tools such as screen readers, magnifiers, or even
47scripting interfaces can query and interact with GUI controls.
48
49
50%package devel
51Summary: Development libraries and headers for at-spi
52Group: Development/Libraries
53Requires: %name = %{version}-%{release}
54Requires: atk-devel
55Requires: gtk2-devel
56Requires: libbonobo-devel
57Requires: ORBit2-devel
58Requires: pkgconfig
59
60%description devel
61Libraries and header files allowing compilation of apps that use at-spi.
62
63
64%package python
65Summary: Python bindings for at-spi
66Group: Development/Libraries
67Requires: %name = %{version}-%{release}
68Requires: python
69
70%description python
71Python bindings allowing to use at-spi in python programs.
72
73
74%prep
75%setup -q
76## %patch2 -p1 -b .spew
77
78
79%build
80%configure --disable-gtk-doc --disable-static --enable-relocate
81make
82
83%install
84rm -rf $RPM_BUILD_ROOT
85make install DESTDIR=$RPM_BUILD_ROOT
86
87%find_lang at-spi
88
89rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
90rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
91rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
92
93%post
94/sbin/ldconfig
95export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
96gconftool-2 --makefile-install-rule \
97        %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
98
99%pre
100if [ "$1" -gt 1 ]; then
101    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
102    gconftool-2 --makefile-uninstall-rule \
103            %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
104fi
105
106%preun
107if [ "$1" -eq 0 ]; then
108    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
109    gconftool-2 --makefile-uninstall-rule \
110            %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
111fi
112
113%postun -p /sbin/ldconfig
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%files -f at-spi.lang
119%defattr(-,root,root)
120%doc AUTHORS COPYING NEWS README
121%{_sysconfdir}/gconf/schemas/at-spi.schemas
122%{_sysconfdir}/xdg/autostart/at-spi-registryd.desktop
123%{_libdir}/lib*.so.*
124%{_libdir}/bonobo/servers/*
125%{_libdir}/orbit-2.0/*
126%{_libdir}/gtk-2.0/modules/at-spi-corba
127%{_libexecdir}/*
128
129%files devel
130%defattr(-,root,root)
131%{_datadir}/gtk-doc/html/*
132%{_datadir}/idl/*
133%{_libdir}/lib*.so
134%{_libdir}/pkgconfig/*
135%{_includedir}/*
136
137%files python
138%defattr(-,root,root)
139%{python_sitearch}/pyatspi_corba
140
141
142%changelog
143* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-2
144- add configure option (--enable-relocate)
145
146* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-1
147- new upstream release
148
149* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-2
150- rebuild with rpm-4.8.1 for pkg-config file
151
152* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-1
153- new upstream release
154
155* Sat Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
156- new upstream release
157- drop Patch2
158- add BuildRequires: GConf2-devel, dbus-glib-devel, popt-devel, desktop-file-utils
159
160* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.24.0-3
161- rebuild with python-2.6
162
163* Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.24.0-2
164- remove BuildRequires gail-devel
165  (gtk2-2.14.x now includes/provides gail)
166
167* Sun Sep 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
168- initial build for Vine Linux
169
170* Mon Sep  8 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.92-1
171- Update to 1.23.92
172- Drop upstreamed patch
173
174* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-3
175- Fix an evo crash caused by the greeter crash fix
176
177* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-2
178- Fix a greeter crash
179
180* Tue Sep  2 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-1
181- Update to 1.23.91
182
183* Wed Aug 20 2008 Jarod Wilson <jarod@redhat.com> - 1.23.6-2
184- Silence incessant atk-bridge spew filling xsession-errors (#459275)
185
186* Mon Aug  4 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.6-1
187- Update to 1.23.6
188
189* Mon Jul 21 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.5-1
190- Update to 1.23.5
191
192* Tue Jun  3 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.3-1
193- Update to 1.23.3
194
195* Mon May  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-2
196- Bump rev
197
198* Mon Apr  7 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-1
199- Update to 1.22.1
200
201* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.0-1
202- Update to 1.22.0
203
204* Wed Mar  5 2008 Christopher Aillon <caillon@redhat.com> - 1.21-92-2
205- Perf improvement work from Ginn Chen to help a11y-enabled-firefox3
206
207* Mon Feb 25 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.92-1
208- Update to 1.21.92
209
210* Fri Feb  8 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-2
211- Rebuild for gcc 4.3
212
213* Mon Jan 14 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-1
214- Update to 1.21.5
215
216* Thu Dec  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.3-1
217- Update to 1.21.3
218
219* Tue Nov 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.1-1
220- Update to 1.21.1
221
222* Mon Oct 15 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.1-1
223- Update to 1.20.1
224
225* Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.0-1
226- Update to 1.20.0
227
228* Mon Aug  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-2
229- Update license field
230
231* Tue Jul 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-1
232- Update to 1.19.5
233
234* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.3-1
235- Update to 1.19.3
236- Add a -python subpackage
237
238* Sun May 20 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.1-1
239- Update to 1.19.1
240
241* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-2
242- Don't ship .la files
243
244* Mon Apr  9 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-1
245- Update to 1.18.1, which includes the previous patch
246- Drop obsolete patch
247- Fix a small memory leak
248
249* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-2
250- Backport a patch to fix deadlocks in applications
251
252* Tue Mar 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-1
253- Update to 1.18.0
254- Drop obsolete patch
255
256* Thu Mar  8 2007 Ray Strode <rstrode@redhat.com> - 1.17.2-2
257- add a patch that might fix some deadlock issues (bug 329454)
258
259* Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.2-1
260- Update to 1.17.2
261
262* Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.1-1
263- Update to 1.17.1
264
265* Thu Feb 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-2
266- Bump atk requirement
267
268* Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-1
269- Update to 1.17.0
270
271* Wed Jan 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.16-1
272- Update to 1.7.16
273
274* Wed Jan 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.15-1
275- Update to 1.7.15
276
277* Tue Dec 19 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.14-1
278- Update to 1.7.14
279
280* Sat Dec  9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-2
281- Small spec file cleanups
282
283* Tue Nov  7 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-1
284- Update to 1.7.13
285
286* Fri Oct 20 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.12-1
287- Update to 1.7.12
288
289* Wed Aug 23 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-2.fc6
290- Remove debug spew
291
292* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-1.fc6
293- Update to 1.7.11
294- Drop upstreamed patch
295- Require pkgconfig in the -devel package
296
297* Wed Aug  2 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.10-1.fc6
298- Update to 1.7.10
299
300* Fri Jul 28 2006 Alexander Larsson <alexl@redhat.com> - 1.7.9-3
301- Fix segfault if a11y enabled on x86-64 (#196063)
302
303* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-2
304- Rebuild
305
306* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-1
307- Update to 1.7.9
308
309* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.8-1
310- Update to 1.7.8
311
312* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.7-8.1
313- rebuild
314
315* Thu Jun  8 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-8
316- Add a BuildRequires
317
318* Mon May 22 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-7
319- Make it build in mock
320
321* Mon Apr 17 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-6
322- Revert the previous change
323
324* Tue Apr  4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-5
325- Fix a missing declaration
326- Fix segfaults on x86_64
327
328* Tue Apr  4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-1
329- Update to 1.7.7
330
331* Thu Mar  9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-2
332- Fix a crash on x86_64
333
334* Mon Feb 27 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-1
335- Update to 1.7.6
336
337* Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.5-1
338- Update to 1.7.5
339
340* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.2
341- bump again for double-long bug on ppc(64)
342
343* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.1
344- rebuilt for new gcc4.1 snapshot and glibc changes
345
346* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> 1.7.4-1
347- Update to 1.7.4
348
349* Mon Jan 30 2006 Matthias Clasen <mclasen@redhat.com> 1.7.3-1
350- Update to 1.7.3
351
352* Tue Jan 17 2006 Matthias Clasen <mclasen@redhat.com> 1.7.2-1
353- Update to 1.7.2
354
355* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
356- rebuilt
357
358* Mon Oct 31 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-2
359- Switch requires to modular X
360
361* Wed Sep  7 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-1
362- Update to 1.6.6
363
364* Tue Aug 16 2005 Matthias Clasen <mclasen@redhat.com>
365- Rebuilt
366
367* Tue Jun 28 2005 Matthias Clasen <mclasen@redhat.com> 1.6.4-1
368- Update to 1.6.4
369
370* Mon Mar 14 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
371- Update to 1.6.3
372
373* Wed Mar  2 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-2
374- Rebuilt with gcc4
375
376* Wed Jan 26 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
377- Update to 1.6.2
378
379* Wed Sep 29 2004 Elliot Lee <sopwith@redhat.com> 1.6.0-3
380- Remove dependency on linc-devel
381
382* Fri Sep 24 2004 Mark McLoughlin <markmc@redhat.com> 1.6.0-2
383- Fix some random spec file issues (fixes #133430?)
384
385* Thu Sep 23 2004 Jonathan Blandford <jrb@redhat.com> 1.6.0-1
386- bump version
387
388* Wed Aug  4 2004 Mark McLoughlin <markmc@redhat.com> 1.5.3-1
389- Update to 1.5.3
390
391* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
392- rebuilt
393
394* Wed Mar 31 2004 Mark McLoughlin <markmc@redhat.com> 1.4.0-1
395- Update to 1.4.0
396
397* Wed Mar 10 2004 Mark McLoughlin <markmc@redhat.com> 1.3.15
398- Update to 1.3.15
399
400* Thu Mar 04 2004 Mark McLoughlin <markmc@redhat.com> 1.3.14-1
401- Update to 1.3.14
402
403* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
404- rebuilt
405
406* Thu Feb 26 2004 Alexander Larsson <alexl@redhat.com> 1.3.13-1
407- update to 1.3.13
408
409* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
410- rebuilt
411
412* Fri Jan 30 2004 Jonathan Blandford <jrb@redhat.com> 1.3.11-1
413- new version
414
415* Thu Oct  2 2003 Jonathan Blandford <jrb@redhat.com> 1.3.7-1
416- new version
417
418* Wed Aug 20 2003 Elliot Lee <sopwith@redhat.com> 1.1.9-3
419- Fix rebuild failure (stderr.patch)
420
421* Tue Jul 15 2003 Havoc Pennington <hp@redhat.com> 1.1.9-2
422- disable gtk doc
423
424* Mon Jul 14 2003 Havoc Pennington <hp@redhat.com>
425- automated rebuild
426
427* Mon Jul  7 2003 Havoc Pennington <hp@redhat.com> 1.1.9-1
428- 1.1.9
429- remove multilib patch fixed upstream
430
431* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
432- rebuilt
433
434* Fri Feb 14 2003 Havoc Pennington <hp@redhat.com> 1.1.8-3
435- kill Xft buildreq
436
437* Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-2
438- rebuild to fix self-dependency
439
440* Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
441
442- extend multilib patch to cover -lXi
443
444* Tue Feb  4 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
445- 1.1.8
446
447* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
448- rebuilt
449
450* Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.0.1-6
451- Add patch to help multilib systems find libXtst
452
453* Fri Dec  6 2002 Havoc Pennington <hp@redhat.com>
454- rebuild
455
456* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
457- rebuild with new libbonobo and gail
458
459* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
460- automated rebuild
461
462* Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
463- add libatk-bridge.so to the file list
464
465* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
466- 1.0.1
467- add at-spi-registryd to file list
468
469* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
470- rebuild in different environment
471
472* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
473- 1.0.0
474- add post/postun ldconfig
475
476* Wed May 29 2002 Bill Nottingham <notting@redhat.com>
477- rebuild again?
478
479* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
480- rebuild in different environment
481
482* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
483- 0.12.1
484
485* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
486- Version 0.0.6
487
488* Mon Jan 28 2002 Havoc Pennington <hp@redhat.com>
489- rebuild in rawhide, seems to have been linked incorrectly
490
491* Thu Jan 24 2002 Havoc Pennington <hp@redhat.com>
492- rebuild in rawhide, upgrade to 0.0.5
493- add gail deps
494
495* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
496- Initial build.
497
498
Note: See TracBrowser for help on using the repository browser.