source: projects/specs/trunk/a/at-spi/at-spi-vl.spec @ 8084

Revision 8084, 14.0 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define atk_version 1.32.0
4%define gtk2_version 2.22.0
5%define libbonobo_version 2.32.0
6%define orbit2_version 2.14.19
7%define pango_version 1.28.3
8%define gconf2_version 2.32.0
9%define dbus_glib_version 0.88
10
11Summary: Assistive Technology Service Provider Interface
12
13Name: at-spi
14Version: 1.32.0
15Release: 4%{?_dist_release}
16URL: http://developer.gnome.org/projects/gap/
17Source0: http://download.gnome.org/sources/at-spi/1.32/%{name}-%{version}.tar.bz2
18
19License: LGPLv2+
20Group: System Environment/Libraries
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires: pango-devel >= %{pango_version}
23BuildRequires: gtk2-devel >= %{gtk2_version}
24BuildRequires: libbonobo-devel >= %{libbonobo_version}
25BuildRequires: ORBit2-devel >= %{orbit2_version}
26BuildRequires: atk-devel >= %{atk_version}
27BuildRequires: GConf2-devel >= %{gconf2_version}
28BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
29BuildRequires: popt-devel
30BuildRequires: fontconfig
31BuildRequires: gettext
32BuildRequires: intltool
33BuildRequires: perl(XML::Parser)
34BuildRequires: libX11-devel
35BuildRequires: libXtst-devel
36BuildRequires: libXi-devel
37BuildRequires: libXevie-devel
38BuildRequires: libXt-devel
39BuildRequires: desktop-file-utils
40
41Patch2: at-spi-silence-no-event-spew.patch
42
43Vendor: Project Vine
44Distribution: Vine Linux
45
46%description
47at-spi allows assistive technologies to access GTK-based
48applications. Essentially it exposes the internals of applications for
49automation, so tools such as screen readers, magnifiers, or even
50scripting interfaces can query and interact with GUI controls.
51
52
53%package devel
54Summary: Development libraries and headers for at-spi
55Group: Development/Libraries
56Requires: %name = %{version}-%{release}
57Requires: atk-devel
58Requires: gtk2-devel
59Requires: libbonobo-devel
60Requires: ORBit2-devel
61Requires: pkgconfig
62
63%description devel
64Libraries and header files allowing compilation of apps that use at-spi.
65
66
67%package python
68Summary: Python bindings for at-spi
69Group: Development/Libraries
70Requires: %name = %{version}-%{release}
71Requires: python
72
73%description python
74Python bindings allowing to use at-spi in python programs.
75
76
77%prep
78%setup -q
79## %patch2 -p1 -b .spew
80
81
82%build
83%configure --disable-gtk-doc --disable-static --enable-relocate
84make
85
86%install
87rm -rf $RPM_BUILD_ROOT
88make install DESTDIR=$RPM_BUILD_ROOT
89
90%find_lang at-spi
91
92rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
93rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
94rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
95
96%post
97/sbin/ldconfig
98export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
99gconftool-2 --makefile-install-rule \
100        %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
101
102%pre
103if [ "$1" -gt 1 ]; then
104    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
105    gconftool-2 --makefile-uninstall-rule \
106            %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
107fi
108
109%preun
110if [ "$1" -eq 0 ]; then
111    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
112    gconftool-2 --makefile-uninstall-rule \
113            %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
114fi
115
116%postun -p /sbin/ldconfig
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%files -f at-spi.lang
122%defattr(-,root,root)
123%doc AUTHORS COPYING NEWS README
124%{_sysconfdir}/gconf/schemas/at-spi.schemas
125%{_sysconfdir}/xdg/autostart/at-spi-registryd.desktop
126%{_libdir}/lib*.so.*
127%{_libdir}/bonobo/servers/*
128%{_libdir}/orbit-2.0/*
129%{_libdir}/gtk-2.0/modules/at-spi-corba
130%{_libexecdir}/*
131
132%files devel
133%defattr(-,root,root)
134%{_datadir}/gtk-doc/html/*
135%{_datadir}/idl/*
136%{_libdir}/lib*.so
137%{_libdir}/pkgconfig/*
138%{_includedir}/*
139
140%files python
141%defattr(-,root,root)
142%{python_sitearch}/pyatspi_corba
143
144
145%changelog
146* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-4
147- rebuild with VineSeed environment
148
149* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-3
150- rebuild with python-2.7.2
151
152* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-2
153- add configure option (--enable-relocate)
154
155* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-1
156- new upstream release
157
158* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-2
159- rebuild with rpm-4.8.1 for pkg-config file
160
161* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-1
162- new upstream release
163
164* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
165- new upstream release
166- drop Patch2
167- add BuildRequires: GConf2-devel, dbus-glib-devel, popt-devel, desktop-file-utils
168
169* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.24.0-3
170- rebuild with python-2.6
171
172* Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.24.0-2
173- remove BuildRequires gail-devel
174  (gtk2-2.14.x now includes/provides gail)
175
176* Sun Sep 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
177- initial build for Vine Linux
178
179* Mon Sep  8 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.92-1
180- Update to 1.23.92
181- Drop upstreamed patch
182
183* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-3
184- Fix an evo crash caused by the greeter crash fix
185
186* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-2
187- Fix a greeter crash
188
189* Tue Sep  2 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-1
190- Update to 1.23.91
191
192* Wed Aug 20 2008 Jarod Wilson <jarod@redhat.com> - 1.23.6-2
193- Silence incessant atk-bridge spew filling xsession-errors (#459275)
194
195* Mon Aug  4 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.6-1
196- Update to 1.23.6
197
198* Mon Jul 21 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.5-1
199- Update to 1.23.5
200
201* Tue Jun  3 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.3-1
202- Update to 1.23.3
203
204* Mon May  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-2
205- Bump rev
206
207* Mon Apr  7 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-1
208- Update to 1.22.1
209
210* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.0-1
211- Update to 1.22.0
212
213* Wed Mar  5 2008 Christopher Aillon <caillon@redhat.com> - 1.21-92-2
214- Perf improvement work from Ginn Chen to help a11y-enabled-firefox3
215
216* Mon Feb 25 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.92-1
217- Update to 1.21.92
218
219* Fri Feb  8 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-2
220- Rebuild for gcc 4.3
221
222* Mon Jan 14 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-1
223- Update to 1.21.5
224
225* Thu Dec  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.3-1
226- Update to 1.21.3
227
228* Tue Nov 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.1-1
229- Update to 1.21.1
230
231* Mon Oct 15 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.1-1
232- Update to 1.20.1
233
234* Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.0-1
235- Update to 1.20.0
236
237* Mon Aug  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-2
238- Update license field
239
240* Tue Jul 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-1
241- Update to 1.19.5
242
243* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.3-1
244- Update to 1.19.3
245- Add a -python subpackage
246
247* Sun May 20 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.1-1
248- Update to 1.19.1
249
250* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-2
251- Don't ship .la files
252
253* Mon Apr  9 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-1
254- Update to 1.18.1, which includes the previous patch
255- Drop obsolete patch
256- Fix a small memory leak
257
258* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-2
259- Backport a patch to fix deadlocks in applications
260
261* Tue Mar 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-1
262- Update to 1.18.0
263- Drop obsolete patch
264
265* Thu Mar  8 2007 Ray Strode <rstrode@redhat.com> - 1.17.2-2
266- add a patch that might fix some deadlock issues (bug 329454)
267
268* Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.2-1
269- Update to 1.17.2
270
271* Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.1-1
272- Update to 1.17.1
273
274* Thu Feb 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-2
275- Bump atk requirement
276
277* Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-1
278- Update to 1.17.0
279
280* Mon Jan 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.16-1
281- Update to 1.7.16
282
283* Wed Jan 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.15-1
284- Update to 1.7.15
285
286* Tue Dec 19 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.14-1
287- Update to 1.7.14
288
289* Sat Dec  9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-2
290- Small spec file cleanups
291
292* Tue Nov  7 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-1
293- Update to 1.7.13
294
295* Fri Oct 20 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.12-1
296- Update to 1.7.12
297
298* Wed Aug 23 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-2.fc6
299- Remove debug spew
300
301* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-1.fc6
302- Update to 1.7.11
303- Drop upstreamed patch
304- Require pkgconfig in the -devel package
305
306* Wed Aug  2 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.10-1.fc6
307- Update to 1.7.10
308
309* Fri Jul 28 2006 Alexander Larsson <alexl@redhat.com> - 1.7.9-3
310- Fix segfault if a11y enabled on x86-64 (#196063)
311
312* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-2
313- Rebuild
314
315* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-1
316- Update to 1.7.9
317
318* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.8-1
319- Update to 1.7.8
320
321* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.7-8.1
322- rebuild
323
324* Thu Jun  8 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-8
325- Add a BuildRequires
326
327* Mon May 22 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-7
328- Make it build in mock
329
330* Mon Apr 17 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-6
331- Revert the previous change
332
333* Tue Apr  4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-5
334- Fix a missing declaration
335- Fix segfaults on x86_64
336
337* Tue Apr  4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-1
338- Update to 1.7.7
339
340* Thu Mar  9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-2
341- Fix a crash on x86_64
342
343* Mon Feb 27 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-1
344- Update to 1.7.6
345
346* Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.5-1
347- Update to 1.7.5
348
349* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.2
350- bump again for double-long bug on ppc(64)
351
352* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.1
353- rebuilt for new gcc4.1 snapshot and glibc changes
354
355* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> 1.7.4-1
356- Update to 1.7.4
357
358* Mon Jan 30 2006 Matthias Clasen <mclasen@redhat.com> 1.7.3-1
359- Update to 1.7.3
360
361* Tue Jan 17 2006 Matthias Clasen <mclasen@redhat.com> 1.7.2-1
362- Update to 1.7.2
363
364* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
365- rebuilt
366
367* Mon Oct 31 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-2
368- Switch requires to modular X
369
370* Wed Sep  7 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-1
371- Update to 1.6.6
372
373* Tue Aug 16 2005 Matthias Clasen <mclasen@redhat.com>
374- Rebuilt
375
376* Tue Jun 28 2005 Matthias Clasen <mclasen@redhat.com> 1.6.4-1
377- Update to 1.6.4
378
379* Mon Mar 14 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
380- Update to 1.6.3
381
382* Wed Mar  2 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-2
383- Rebuilt with gcc4
384
385* Wed Jan 26 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
386- Update to 1.6.2
387
388* Wed Sep 29 2004 Elliot Lee <sopwith@redhat.com> 1.6.0-3
389- Remove dependency on linc-devel
390
391* Fri Sep 24 2004 Mark McLoughlin <markmc@redhat.com> 1.6.0-2
392- Fix some random spec file issues (fixes #133430?)
393
394* Thu Sep 23 2004 Jonathan Blandford <jrb@redhat.com> 1.6.0-1
395- bump version
396
397* Wed Aug  4 2004 Mark McLoughlin <markmc@redhat.com> 1.5.3-1
398- Update to 1.5.3
399
400* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
401- rebuilt
402
403* Wed Mar 31 2004 Mark McLoughlin <markmc@redhat.com> 1.4.0-1
404- Update to 1.4.0
405
406* Wed Mar 10 2004 Mark McLoughlin <markmc@redhat.com> 1.3.15
407- Update to 1.3.15
408
409* Thu Mar 04 2004 Mark McLoughlin <markmc@redhat.com> 1.3.14-1
410- Update to 1.3.14
411
412* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
413- rebuilt
414
415* Thu Feb 26 2004 Alexander Larsson <alexl@redhat.com> 1.3.13-1
416- update to 1.3.13
417
418* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
419- rebuilt
420
421* Fri Jan 30 2004 Jonathan Blandford <jrb@redhat.com> 1.3.11-1
422- new version
423
424* Thu Oct  2 2003 Jonathan Blandford <jrb@redhat.com> 1.3.7-1
425- new version
426
427* Wed Aug 20 2003 Elliot Lee <sopwith@redhat.com> 1.1.9-3
428- Fix rebuild failure (stderr.patch)
429
430* Tue Jul 15 2003 Havoc Pennington <hp@redhat.com> 1.1.9-2
431- disable gtk doc
432
433* Mon Jul 14 2003 Havoc Pennington <hp@redhat.com>
434- automated rebuild
435
436* Mon Jul  7 2003 Havoc Pennington <hp@redhat.com> 1.1.9-1
437- 1.1.9
438- remove multilib patch fixed upstream
439
440* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
441- rebuilt
442
443* Fri Feb 14 2003 Havoc Pennington <hp@redhat.com> 1.1.8-3
444- kill Xft buildreq
445
446* Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-2
447- rebuild to fix self-dependency
448
449* Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
450
451- extend multilib patch to cover -lXi
452
453* Tue Feb  4 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
454- 1.1.8
455
456* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
457- rebuilt
458
459* Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.0.1-6
460- Add patch to help multilib systems find libXtst
461
462* Fri Dec  6 2002 Havoc Pennington <hp@redhat.com>
463- rebuild
464
465* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
466- rebuild with new libbonobo and gail
467
468* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
469- automated rebuild
470
471* Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
472- add libatk-bridge.so to the file list
473
474* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
475- 1.0.1
476- add at-spi-registryd to file list
477
478* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
479- rebuild in different environment
480
481* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
482- 1.0.0
483- add post/postun ldconfig
484
485* Wed May 29 2002 Bill Nottingham <notting@redhat.com>
486- rebuild again?
487
488* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
489- rebuild in different environment
490
491* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
492- 0.12.1
493
494* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
495- Version 0.0.6
496
497* Mon Jan 28 2002 Havoc Pennington <hp@redhat.com>
498- rebuild in rawhide, seems to have been linked incorrectly
499
500* Thu Jan 24 2002 Havoc Pennington <hp@redhat.com>
501- rebuild in rawhide, upgrade to 0.0.5
502- add gail deps
503
504* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
505- Initial build.
506
507
Note: See TracBrowser for help on using the repository browser.