source: projects/specs/trunk/a/at-spi/at-spi-vl.spec @ 2041

Revision 2041, 13.6 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define atk_version 1.32.0
4%define gtk2_version 2.22.0
5%define libbonobo_version 2.32.0
6%define orbit2_version 2.14.19
7%define pango_version 1.28.3
8%define gconf2_version 2.32.0
9%define dbus_glib_version 0.88
10
11Summary: Assistive Technology Service Provider Interface
12
13Name: at-spi
14Version: 1.32.0
15Release: 1%{?_dist_release}
16URL: http://developer.gnome.org/projects/gap/
17Source0: http://download.gnome.org/sources/at-spi/1.32/%{name}-%{version}.tar.bz2
18
19License: LGPLv2+
20Group: System Environment/Libraries
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires: pango-devel >= %{pango_version}
23BuildRequires: gtk2-devel >= %{gtk2_version}
24BuildRequires: libbonobo-devel >= %{libbonobo_version}
25BuildRequires: ORBit2-devel >= %{orbit2_version}
26BuildRequires: atk-devel >= %{atk_version}
27BuildRequires: GConf2-devel >= %{gconf2_version}
28BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
29BuildRequires: popt-devel
30BuildRequires: fontconfig
31BuildRequires: gettext
32BuildRequires: intltool
33BuildRequires: perl(XML::Parser)
34BuildRequires: libX11-devel
35BuildRequires: libXtst-devel
36BuildRequires: libXi-devel
37BuildRequires: libXevie-devel
38BuildRequires: libXt-devel
39BuildRequires: desktop-file-utils
40
41Patch2: at-spi-silence-no-event-spew.patch
42
43%description
44at-spi allows assistive technologies to access GTK-based
45applications. Essentially it exposes the internals of applications for
46automation, so tools such as screen readers, magnifiers, or even
47scripting interfaces can query and interact with GUI controls.
48
49
50%package devel
51Summary: Development libraries and headers for at-spi
52Group: Development/Libraries
53Requires: %name = %{version}-%{release}
54Requires: atk-devel
55Requires: gtk2-devel
56Requires: libbonobo-devel
57Requires: ORBit2-devel
58Requires: pkgconfig
59
60%description devel
61Libraries and header files allowing compilation of apps that use at-spi.
62
63
64%package python
65Summary: Python bindings for at-spi
66Group: Development/Libraries
67Requires: %name = %{version}-%{release}
68Requires: python
69
70%description python
71Python bindings allowing to use at-spi in python programs.
72
73
74%prep
75%setup -q
76## %patch2 -p1 -b .spew
77
78
79%build
80%configure --disable-gtk-doc --disable-static
81make
82
83%install
84rm -rf $RPM_BUILD_ROOT
85make install DESTDIR=$RPM_BUILD_ROOT
86
87%find_lang at-spi
88
89rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
90rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
91rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
92
93%post
94/sbin/ldconfig
95export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
96gconftool-2 --makefile-install-rule \
97        %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
98
99%pre
100if [ "$1" -gt 1 ]; then
101    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
102    gconftool-2 --makefile-uninstall-rule \
103            %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
104fi
105
106%preun
107if [ "$1" -eq 0 ]; then
108    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
109    gconftool-2 --makefile-uninstall-rule \
110            %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
111fi
112
113%postun -p /sbin/ldconfig
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%files -f at-spi.lang
119%defattr(-,root,root)
120%doc AUTHORS COPYING NEWS README
121%{_sysconfdir}/gconf/schemas/at-spi.schemas
122%{_sysconfdir}/xdg/autostart/at-spi-registryd.desktop
123%{_libdir}/lib*.so.*
124%{_libdir}/bonobo/servers/*
125%{_libdir}/orbit-2.0/*
126%{_libdir}/gtk-2.0/modules/*
127%{_libexecdir}/*
128
129%files devel
130%defattr(-,root,root)
131%{_datadir}/gtk-doc/html/*
132%{_datadir}/idl/*
133%{_libdir}/lib*.so
134%{_libdir}/pkgconfig/*
135%{_includedir}/*
136
137%files python
138%defattr(-,root,root)
139%{python_sitearch}/pyatspi/
140
141
142%changelog
143* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-1
144- new upstream release
145
146* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-2
147- rebuild with rpm-4.8.1 for pkg-config file
148
149* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-1
150- new upstream release
151
152* Sat Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
153- new upstream release
154- drop Patch2
155- add BuildRequires: GConf2-devel, dbus-glib-devel, popt-devel, desktop-file-utils
156
157* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.24.0-3
158- rebuild with python-2.6
159
160* Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.24.0-2
161- remove BuildRequires gail-devel
162  (gtk2-2.14.x now includes/provides gail)
163
164* Sun Sep 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
165- initial build for Vine Linux
166
167* Mon Sep  8 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.92-1
168- Update to 1.23.92
169- Drop upstreamed patch
170
171* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-3
172- Fix an evo crash caused by the greeter crash fix
173
174* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-2
175- Fix a greeter crash
176
177* Tue Sep  2 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-1
178- Update to 1.23.91
179
180* Wed Aug 20 2008 Jarod Wilson <jarod@redhat.com> - 1.23.6-2
181- Silence incessant atk-bridge spew filling xsession-errors (#459275)
182
183* Mon Aug  4 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.6-1
184- Update to 1.23.6
185
186* Mon Jul 21 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.5-1
187- Update to 1.23.5
188
189* Tue Jun  3 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.3-1
190- Update to 1.23.3
191
192* Mon May  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-2
193- Bump rev
194
195* Mon Apr  7 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-1
196- Update to 1.22.1
197
198* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.0-1
199- Update to 1.22.0
200
201* Wed Mar  5 2008 Christopher Aillon <caillon@redhat.com> - 1.21-92-2
202- Perf improvement work from Ginn Chen to help a11y-enabled-firefox3
203
204* Mon Feb 25 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.92-1
205- Update to 1.21.92
206
207* Fri Feb  8 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-2
208- Rebuild for gcc 4.3
209
210* Mon Jan 14 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-1
211- Update to 1.21.5
212
213* Thu Dec  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.3-1
214- Update to 1.21.3
215
216* Tue Nov 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.1-1
217- Update to 1.21.1
218
219* Mon Oct 15 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.1-1
220- Update to 1.20.1
221
222* Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.0-1
223- Update to 1.20.0
224
225* Mon Aug  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-2
226- Update license field
227
228* Tue Jul 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-1
229- Update to 1.19.5
230
231* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.3-1
232- Update to 1.19.3
233- Add a -python subpackage
234
235* Sun May 20 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.1-1
236- Update to 1.19.1
237
238* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-2
239- Don't ship .la files
240
241* Mon Apr  9 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-1
242- Update to 1.18.1, which includes the previous patch
243- Drop obsolete patch
244- Fix a small memory leak
245
246* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-2
247- Backport a patch to fix deadlocks in applications
248
249* Tue Mar 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-1
250- Update to 1.18.0
251- Drop obsolete patch
252
253* Thu Mar  8 2007 Ray Strode <rstrode@redhat.com> - 1.17.2-2
254- add a patch that might fix some deadlock issues (bug 329454)
255
256* Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.2-1
257- Update to 1.17.2
258
259* Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.1-1
260- Update to 1.17.1
261
262* Thu Feb 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-2
263- Bump atk requirement
264
265* Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-1
266- Update to 1.17.0
267
268* Wed Jan 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.16-1
269- Update to 1.7.16
270
271* Wed Jan 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.15-1
272- Update to 1.7.15
273
274* Tue Dec 19 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.14-1
275- Update to 1.7.14
276
277* Sat Dec  9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-2
278- Small spec file cleanups
279
280* Tue Nov  7 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-1
281- Update to 1.7.13
282
283* Fri Oct 20 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.12-1
284- Update to 1.7.12
285
286* Wed Aug 23 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-2.fc6
287- Remove debug spew
288
289* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-1.fc6
290- Update to 1.7.11
291- Drop upstreamed patch
292- Require pkgconfig in the -devel package
293
294* Wed Aug  2 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.10-1.fc6
295- Update to 1.7.10
296
297* Fri Jul 28 2006 Alexander Larsson <alexl@redhat.com> - 1.7.9-3
298- Fix segfault if a11y enabled on x86-64 (#196063)
299
300* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-2
301- Rebuild
302
303* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-1
304- Update to 1.7.9
305
306* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.8-1
307- Update to 1.7.8
308
309* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.7-8.1
310- rebuild
311
312* Thu Jun  8 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-8
313- Add a BuildRequires
314
315* Mon May 22 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-7
316- Make it build in mock
317
318* Mon Apr 17 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-6
319- Revert the previous change
320
321* Tue Apr  4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-5
322- Fix a missing declaration
323- Fix segfaults on x86_64
324
325* Tue Apr  4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-1
326- Update to 1.7.7
327
328* Thu Mar  9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-2
329- Fix a crash on x86_64
330
331* Mon Feb 27 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-1
332- Update to 1.7.6
333
334* Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.5-1
335- Update to 1.7.5
336
337* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.2
338- bump again for double-long bug on ppc(64)
339
340* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.1
341- rebuilt for new gcc4.1 snapshot and glibc changes
342
343* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> 1.7.4-1
344- Update to 1.7.4
345
346* Mon Jan 30 2006 Matthias Clasen <mclasen@redhat.com> 1.7.3-1
347- Update to 1.7.3
348
349* Tue Jan 17 2006 Matthias Clasen <mclasen@redhat.com> 1.7.2-1
350- Update to 1.7.2
351
352* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
353- rebuilt
354
355* Mon Oct 31 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-2
356- Switch requires to modular X
357
358* Wed Sep  7 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-1
359- Update to 1.6.6
360
361* Tue Aug 16 2005 Matthias Clasen <mclasen@redhat.com>
362- Rebuilt
363
364* Tue Jun 28 2005 Matthias Clasen <mclasen@redhat.com> 1.6.4-1
365- Update to 1.6.4
366
367* Mon Mar 14 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
368- Update to 1.6.3
369
370* Wed Mar  2 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-2
371- Rebuilt with gcc4
372
373* Wed Jan 26 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
374- Update to 1.6.2
375
376* Wed Sep 29 2004 Elliot Lee <sopwith@redhat.com> 1.6.0-3
377- Remove dependency on linc-devel
378
379* Fri Sep 24 2004 Mark McLoughlin <markmc@redhat.com> 1.6.0-2
380- Fix some random spec file issues (fixes #133430?)
381
382* Thu Sep 23 2004 Jonathan Blandford <jrb@redhat.com> 1.6.0-1
383- bump version
384
385* Wed Aug  4 2004 Mark McLoughlin <markmc@redhat.com> 1.5.3-1
386- Update to 1.5.3
387
388* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
389- rebuilt
390
391* Wed Mar 31 2004 Mark McLoughlin <markmc@redhat.com> 1.4.0-1
392- Update to 1.4.0
393
394* Wed Mar 10 2004 Mark McLoughlin <markmc@redhat.com> 1.3.15
395- Update to 1.3.15
396
397* Thu Mar 04 2004 Mark McLoughlin <markmc@redhat.com> 1.3.14-1
398- Update to 1.3.14
399
400* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
401- rebuilt
402
403* Thu Feb 26 2004 Alexander Larsson <alexl@redhat.com> 1.3.13-1
404- update to 1.3.13
405
406* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
407- rebuilt
408
409* Fri Jan 30 2004 Jonathan Blandford <jrb@redhat.com> 1.3.11-1
410- new version
411
412* Thu Oct  2 2003 Jonathan Blandford <jrb@redhat.com> 1.3.7-1
413- new version
414
415* Wed Aug 20 2003 Elliot Lee <sopwith@redhat.com> 1.1.9-3
416- Fix rebuild failure (stderr.patch)
417
418* Tue Jul 15 2003 Havoc Pennington <hp@redhat.com> 1.1.9-2
419- disable gtk doc
420
421* Mon Jul 14 2003 Havoc Pennington <hp@redhat.com>
422- automated rebuild
423
424* Mon Jul  7 2003 Havoc Pennington <hp@redhat.com> 1.1.9-1
425- 1.1.9
426- remove multilib patch fixed upstream
427
428* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
429- rebuilt
430
431* Fri Feb 14 2003 Havoc Pennington <hp@redhat.com> 1.1.8-3
432- kill Xft buildreq
433
434* Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-2
435- rebuild to fix self-dependency
436
437* Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
438
439- extend multilib patch to cover -lXi
440
441* Tue Feb  4 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
442- 1.1.8
443
444* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
445- rebuilt
446
447* Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.0.1-6
448- Add patch to help multilib systems find libXtst
449
450* Fri Dec  6 2002 Havoc Pennington <hp@redhat.com>
451- rebuild
452
453* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
454- rebuild with new libbonobo and gail
455
456* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
457- automated rebuild
458
459* Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
460- add libatk-bridge.so to the file list
461
462* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
463- 1.0.1
464- add at-spi-registryd to file list
465
466* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
467- rebuild in different environment
468
469* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
470- 1.0.0
471- add post/postun ldconfig
472
473* Wed May 29 2002 Bill Nottingham <notting@redhat.com>
474- rebuild again?
475
476* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
477- rebuild in different environment
478
479* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
480- 0.12.1
481
482* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
483- Version 0.0.6
484
485* Mon Jan 28 2002 Havoc Pennington <hp@redhat.com>
486- rebuild in rawhide, seems to have been linked incorrectly
487
488* Thu Jan 24 2002 Havoc Pennington <hp@redhat.com>
489- rebuild in rawhide, upgrade to 0.0.5
490- add gail deps
491
492* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
493- Initial build.
494
495
Note: See TracBrowser for help on using the repository browser.