source: projects/specs/trunk/a/at-spi/at-spi-vl.spec @ 1883

Revision 1883, 13.5 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define atk_version 1.30.0
4%define gtk2_version 2.20.0
5%define libbonobo_version 2.24.0
6%define orbit2_version 2.6.0
7%define pango_version 1.28.0
8%define gconf2_version 2.28.0
9%define dbus_glib_version 0.76
10
11Summary: Assistive Technology Service Provider Interface
12
13Name: at-spi
14Version: 1.30.1
15Release: 2%{?_dist_release}
16URL: http://developer.gnome.org/projects/gap/
17Source0: http://download.gnome.org/sources/at-spi/1.24/%{name}-%{version}.tar.bz2
18
19License: LGPLv2+
20Group: System Environment/Libraries
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires: pango-devel >= %{pango_version}
23BuildRequires: gtk2-devel >= %{gtk2_version}
24BuildRequires: libbonobo-devel >= %{libbonobo_version}
25BuildRequires: ORBit2-devel >= %{orbit2_version}
26BuildRequires: atk-devel >= %{atk_version}
27BuildRequires: GConf2-devel >= %{gconf2_version}
28BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
29BuildRequires: popt-devel
30BuildRequires: fontconfig
31BuildRequires: gettext
32BuildRequires: intltool
33BuildRequires: perl(XML::Parser)
34BuildRequires: libX11-devel
35BuildRequires: libXtst-devel
36BuildRequires: libXi-devel
37BuildRequires: libXevie-devel
38BuildRequires: libXt-devel
39BuildRequires: desktop-file-utils
40
41Patch2: at-spi-silence-no-event-spew.patch
42
43%description
44at-spi allows assistive technologies to access GTK-based
45applications. Essentially it exposes the internals of applications for
46automation, so tools such as screen readers, magnifiers, or even
47scripting interfaces can query and interact with GUI controls.
48
49
50%package devel
51Summary: Development libraries and headers for at-spi
52Group: Development/Libraries
53Requires: %name = %{version}-%{release}
54Requires: atk-devel
55Requires: gtk2-devel
56Requires: libbonobo-devel
57Requires: ORBit2-devel
58Requires: pkgconfig
59
60%description devel
61Libraries and header files allowing compilation of apps that use at-spi.
62
63
64%package python
65Summary: Python bindings for at-spi
66Group: Development/Libraries
67Requires: %name = %{version}-%{release}
68Requires: python
69
70%description python
71Python bindings allowing to use at-spi in python programs.
72
73
74%prep
75%setup -q
76## %patch2 -p1 -b .spew
77
78
79%build
80%configure --disable-gtk-doc --disable-static
81make
82
83%install
84rm -rf $RPM_BUILD_ROOT
85make install DESTDIR=$RPM_BUILD_ROOT
86
87%find_lang at-spi
88
89rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
90rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
91rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
92
93%post
94/sbin/ldconfig
95export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
96gconftool-2 --makefile-install-rule \
97        %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
98
99%pre
100if [ "$1" -gt 1 ]; then
101    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
102    gconftool-2 --makefile-uninstall-rule \
103            %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
104fi
105
106%preun
107if [ "$1" -eq 0 ]; then
108    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
109    gconftool-2 --makefile-uninstall-rule \
110            %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
111fi
112
113%postun -p /sbin/ldconfig
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%files -f at-spi.lang
119%defattr(-,root,root)
120%doc AUTHORS COPYING NEWS README
121%{_sysconfdir}/gconf/schemas/at-spi.schemas
122%{_sysconfdir}/xdg/autostart/at-spi-registryd.desktop
123%{_libdir}/lib*.so.*
124%{_libdir}/bonobo/servers/*
125%{_libdir}/orbit-2.0/*
126%{_libdir}/gtk-2.0/modules/*
127%{_libexecdir}/*
128
129%files devel
130%defattr(-,root,root)
131%{_datadir}/gtk-doc/html/*
132%{_datadir}/idl/*
133%{_libdir}/lib*.so
134%{_libdir}/pkgconfig/*
135%{_includedir}/*
136
137%files python
138%defattr(-,root,root)
139%{python_sitearch}/pyatspi/
140
141
142%changelog
143* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-2
144- rebuild with rpm-4.8.1 for pkg-config file
145
146* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-1
147- new upstream release
148
149* Sat Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
150- new upstream release
151- drop Patch2
152- add BuildRequires: GConf2-devel, dbus-glib-devel, popt-devel, desktop-file-utils
153
154* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.24.0-3
155- rebuild with python-2.6
156
157* Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.24.0-2
158- remove BuildRequires gail-devel
159  (gtk2-2.14.x now includes/provides gail)
160
161* Sun Sep 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
162- initial build for Vine Linux
163
164* Mon Sep  8 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.92-1
165- Update to 1.23.92
166- Drop upstreamed patch
167
168* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-3
169- Fix an evo crash caused by the greeter crash fix
170
171* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-2
172- Fix a greeter crash
173
174* Tue Sep  2 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-1
175- Update to 1.23.91
176
177* Wed Aug 20 2008 Jarod Wilson <jarod@redhat.com> - 1.23.6-2
178- Silence incessant atk-bridge spew filling xsession-errors (#459275)
179
180* Mon Aug  4 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.6-1
181- Update to 1.23.6
182
183* Mon Jul 21 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.5-1
184- Update to 1.23.5
185
186* Tue Jun  3 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.3-1
187- Update to 1.23.3
188
189* Mon May  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-2
190- Bump rev
191
192* Mon Apr  7 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-1
193- Update to 1.22.1
194
195* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.0-1
196- Update to 1.22.0
197
198* Wed Mar  5 2008 Christopher Aillon <caillon@redhat.com> - 1.21-92-2
199- Perf improvement work from Ginn Chen to help a11y-enabled-firefox3
200
201* Mon Feb 25 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.92-1
202- Update to 1.21.92
203
204* Fri Feb  8 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-2
205- Rebuild for gcc 4.3
206
207* Mon Jan 14 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-1
208- Update to 1.21.5
209
210* Thu Dec  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.3-1
211- Update to 1.21.3
212
213* Tue Nov 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.1-1
214- Update to 1.21.1
215
216* Mon Oct 15 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.1-1
217- Update to 1.20.1
218
219* Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.0-1
220- Update to 1.20.0
221
222* Mon Aug  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-2
223- Update license field
224
225* Tue Jul 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-1
226- Update to 1.19.5
227
228* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.3-1
229- Update to 1.19.3
230- Add a -python subpackage
231
232* Sun May 20 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.1-1
233- Update to 1.19.1
234
235* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-2
236- Don't ship .la files
237
238* Mon Apr  9 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-1
239- Update to 1.18.1, which includes the previous patch
240- Drop obsolete patch
241- Fix a small memory leak
242
243* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-2
244- Backport a patch to fix deadlocks in applications
245
246* Tue Mar 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-1
247- Update to 1.18.0
248- Drop obsolete patch
249
250* Thu Mar  8 2007 Ray Strode <rstrode@redhat.com> - 1.17.2-2
251- add a patch that might fix some deadlock issues (bug 329454)
252
253* Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.2-1
254- Update to 1.17.2
255
256* Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.1-1
257- Update to 1.17.1
258
259* Thu Feb 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-2
260- Bump atk requirement
261
262* Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-1
263- Update to 1.17.0
264
265* Wed Jan 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.16-1
266- Update to 1.7.16
267
268* Wed Jan 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.15-1
269- Update to 1.7.15
270
271* Tue Dec 19 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.14-1
272- Update to 1.7.14
273
274* Sat Dec  9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-2
275- Small spec file cleanups
276
277* Tue Nov  7 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-1
278- Update to 1.7.13
279
280* Fri Oct 20 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.12-1
281- Update to 1.7.12
282
283* Wed Aug 23 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-2.fc6
284- Remove debug spew
285
286* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-1.fc6
287- Update to 1.7.11
288- Drop upstreamed patch
289- Require pkgconfig in the -devel package
290
291* Wed Aug  2 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.10-1.fc6
292- Update to 1.7.10
293
294* Fri Jul 28 2006 Alexander Larsson <alexl@redhat.com> - 1.7.9-3
295- Fix segfault if a11y enabled on x86-64 (#196063)
296
297* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-2
298- Rebuild
299
300* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-1
301- Update to 1.7.9
302
303* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.8-1
304- Update to 1.7.8
305
306* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.7-8.1
307- rebuild
308
309* Thu Jun  8 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-8
310- Add a BuildRequires
311
312* Mon May 22 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-7
313- Make it build in mock
314
315* Mon Apr 17 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-6
316- Revert the previous change
317
318* Tue Apr  4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-5
319- Fix a missing declaration
320- Fix segfaults on x86_64
321
322* Tue Apr  4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-1
323- Update to 1.7.7
324
325* Thu Mar  9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-2
326- Fix a crash on x86_64
327
328* Mon Feb 27 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-1
329- Update to 1.7.6
330
331* Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.5-1
332- Update to 1.7.5
333
334* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.2
335- bump again for double-long bug on ppc(64)
336
337* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.1
338- rebuilt for new gcc4.1 snapshot and glibc changes
339
340* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> 1.7.4-1
341- Update to 1.7.4
342
343* Mon Jan 30 2006 Matthias Clasen <mclasen@redhat.com> 1.7.3-1
344- Update to 1.7.3
345
346* Tue Jan 17 2006 Matthias Clasen <mclasen@redhat.com> 1.7.2-1
347- Update to 1.7.2
348
349* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
350- rebuilt
351
352* Mon Oct 31 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-2
353- Switch requires to modular X
354
355* Wed Sep  7 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-1
356- Update to 1.6.6
357
358* Tue Aug 16 2005 Matthias Clasen <mclasen@redhat.com>
359- Rebuilt
360
361* Tue Jun 28 2005 Matthias Clasen <mclasen@redhat.com> 1.6.4-1
362- Update to 1.6.4
363
364* Mon Mar 14 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
365- Update to 1.6.3
366
367* Wed Mar  2 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-2
368- Rebuilt with gcc4
369
370* Wed Jan 26 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
371- Update to 1.6.2
372
373* Wed Sep 29 2004 Elliot Lee <sopwith@redhat.com> 1.6.0-3
374- Remove dependency on linc-devel
375
376* Fri Sep 24 2004 Mark McLoughlin <markmc@redhat.com> 1.6.0-2
377- Fix some random spec file issues (fixes #133430?)
378
379* Thu Sep 23 2004 Jonathan Blandford <jrb@redhat.com> 1.6.0-1
380- bump version
381
382* Wed Aug  4 2004 Mark McLoughlin <markmc@redhat.com> 1.5.3-1
383- Update to 1.5.3
384
385* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
386- rebuilt
387
388* Wed Mar 31 2004 Mark McLoughlin <markmc@redhat.com> 1.4.0-1
389- Update to 1.4.0
390
391* Wed Mar 10 2004 Mark McLoughlin <markmc@redhat.com> 1.3.15
392- Update to 1.3.15
393
394* Thu Mar 04 2004 Mark McLoughlin <markmc@redhat.com> 1.3.14-1
395- Update to 1.3.14
396
397* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
398- rebuilt
399
400* Thu Feb 26 2004 Alexander Larsson <alexl@redhat.com> 1.3.13-1
401- update to 1.3.13
402
403* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
404- rebuilt
405
406* Fri Jan 30 2004 Jonathan Blandford <jrb@redhat.com> 1.3.11-1
407- new version
408
409* Thu Oct  2 2003 Jonathan Blandford <jrb@redhat.com> 1.3.7-1
410- new version
411
412* Wed Aug 20 2003 Elliot Lee <sopwith@redhat.com> 1.1.9-3
413- Fix rebuild failure (stderr.patch)
414
415* Tue Jul 15 2003 Havoc Pennington <hp@redhat.com> 1.1.9-2
416- disable gtk doc
417
418* Mon Jul 14 2003 Havoc Pennington <hp@redhat.com>
419- automated rebuild
420
421* Mon Jul  7 2003 Havoc Pennington <hp@redhat.com> 1.1.9-1
422- 1.1.9
423- remove multilib patch fixed upstream
424
425* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
426- rebuilt
427
428* Fri Feb 14 2003 Havoc Pennington <hp@redhat.com> 1.1.8-3
429- kill Xft buildreq
430
431* Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-2
432- rebuild to fix self-dependency
433
434* Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
435
436- extend multilib patch to cover -lXi
437
438* Tue Feb  4 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
439- 1.1.8
440
441* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
442- rebuilt
443
444* Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.0.1-6
445- Add patch to help multilib systems find libXtst
446
447* Fri Dec  6 2002 Havoc Pennington <hp@redhat.com>
448- rebuild
449
450* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
451- rebuild with new libbonobo and gail
452
453* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
454- automated rebuild
455
456* Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
457- add libatk-bridge.so to the file list
458
459* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
460- 1.0.1
461- add at-spi-registryd to file list
462
463* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
464- rebuild in different environment
465
466* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
467- 1.0.0
468- add post/postun ldconfig
469
470* Wed May 29 2002 Bill Nottingham <notting@redhat.com>
471- rebuild again?
472
473* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
474- rebuild in different environment
475
476* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
477- 0.12.1
478
479* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
480- Version 0.0.6
481
482* Mon Jan 28 2002 Havoc Pennington <hp@redhat.com>
483- rebuild in rawhide, seems to have been linked incorrectly
484
485* Thu Jan 24 2002 Havoc Pennington <hp@redhat.com>
486- rebuild in rawhide, upgrade to 0.0.5
487- add gail deps
488
489* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
490- Initial build.
491
492
Note: See TracBrowser for help on using the repository browser.