source: projects/specs/trunk/a/at-spi/at-spi-vl.spec @ 926

Revision 926, 13.4 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release (gnome packages)

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define atk_version 1.30.0
4%define gtk2_version 2.20.0
5%define libbonobo_version 2.24.0
6%define orbit2_version 2.6.0
7%define pango_version 1.28.0
8%define gconf2_version 2.28.0
9%define dbus_glib_version 0.76
10
11Summary: Assistive Technology Service Provider Interface
12
13Name: at-spi
14Version: 1.30.1
15Release: 1%{?_dist_release}
16URL: http://developer.gnome.org/projects/gap/
17Source0: http://download.gnome.org/sources/at-spi/1.24/%{name}-%{version}.tar.bz2
18
19License: LGPLv2+
20Group: System Environment/Libraries
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires: pango-devel >= %{pango_version}
23BuildRequires: gtk2-devel >= %{gtk2_version}
24BuildRequires: libbonobo-devel >= %{libbonobo_version}
25BuildRequires: ORBit2-devel >= %{orbit2_version}
26BuildRequires: atk-devel >= %{atk_version}
27BuildRequires: GConf2-devel >= %{gconf2_version}
28BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
29BuildRequires: popt-devel
30BuildRequires: fontconfig
31BuildRequires: gettext
32BuildRequires: intltool
33BuildRequires: perl(XML::Parser)
34BuildRequires: libX11-devel
35BuildRequires: libXtst-devel
36BuildRequires: libXi-devel
37BuildRequires: libXevie-devel
38BuildRequires: libXt-devel
39BuildRequires: desktop-file-utils
40
41Patch2: at-spi-silence-no-event-spew.patch
42
43%description
44at-spi allows assistive technologies to access GTK-based
45applications. Essentially it exposes the internals of applications for
46automation, so tools such as screen readers, magnifiers, or even
47scripting interfaces can query and interact with GUI controls.
48
49
50%package devel
51Summary: Development libraries and headers for at-spi
52Group: Development/Libraries
53Requires: %name = %{version}-%{release}
54Requires: atk-devel
55Requires: gtk2-devel
56Requires: libbonobo-devel
57Requires: ORBit2-devel
58Requires: pkgconfig
59
60%description devel
61Libraries and header files allowing compilation of apps that use at-spi.
62
63
64%package python
65Summary: Python bindings for at-spi
66Group: Development/Libraries
67Requires: %name = %{version}-%{release}
68Requires: python
69
70%description python
71Python bindings allowing to use at-spi in python programs.
72
73
74%prep
75%setup -q
76## %patch2 -p1 -b .spew
77
78
79%build
80%configure --disable-gtk-doc --disable-static
81make
82
83%install
84rm -rf $RPM_BUILD_ROOT
85make install DESTDIR=$RPM_BUILD_ROOT
86
87%find_lang at-spi
88
89rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
90rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
91rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
92
93%post
94/sbin/ldconfig
95export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
96gconftool-2 --makefile-install-rule \
97        %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
98
99%pre
100if [ "$1" -gt 1 ]; then
101    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
102    gconftool-2 --makefile-uninstall-rule \
103            %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
104fi
105
106%preun
107if [ "$1" -eq 0 ]; then
108    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
109    gconftool-2 --makefile-uninstall-rule \
110            %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
111fi
112
113%postun -p /sbin/ldconfig
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%files -f at-spi.lang
119%defattr(-,root,root)
120%doc AUTHORS COPYING NEWS README
121%{_sysconfdir}/gconf/schemas/at-spi.schemas
122%{_sysconfdir}/xdg/autostart/at-spi-registryd.desktop
123%{_libdir}/lib*.so.*
124%{_libdir}/bonobo/servers/*
125%{_libdir}/orbit-2.0/*
126%{_libdir}/gtk-2.0/modules/*
127%{_libexecdir}/*
128
129%files devel
130%defattr(-,root,root)
131%{_datadir}/gtk-doc/html/*
132%{_datadir}/idl/*
133%{_libdir}/lib*.so
134%{_libdir}/pkgconfig/*
135%{_includedir}/*
136
137%files python
138%defattr(-,root,root)
139%{python_sitearch}/pyatspi/
140
141
142%changelog
143* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-1
144- new upstream release
145
146* Sat Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
147- new upstream release
148- drop Patch2
149- add BuildRequires: GConf2-devel, dbus-glib-devel, popt-devel, desktop-file-utils
150
151* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.24.0-3
152- rebuild with python-2.6
153
154* Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.24.0-2
155- remove BuildRequires gail-devel
156  (gtk2-2.14.x now includes/provides gail)
157
158* Sun Sep 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
159- initial build for Vine Linux
160
161* Mon Sep  8 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.92-1
162- Update to 1.23.92
163- Drop upstreamed patch
164
165* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-3
166- Fix an evo crash caused by the greeter crash fix
167
168* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-2
169- Fix a greeter crash
170
171* Tue Sep  2 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-1
172- Update to 1.23.91
173
174* Wed Aug 20 2008 Jarod Wilson <jarod@redhat.com> - 1.23.6-2
175- Silence incessant atk-bridge spew filling xsession-errors (#459275)
176
177* Mon Aug  4 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.6-1
178- Update to 1.23.6
179
180* Mon Jul 21 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.5-1
181- Update to 1.23.5
182
183* Tue Jun  3 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.3-1
184- Update to 1.23.3
185
186* Mon May  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-2
187- Bump rev
188
189* Mon Apr  7 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-1
190- Update to 1.22.1
191
192* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.0-1
193- Update to 1.22.0
194
195* Wed Mar  5 2008 Christopher Aillon <caillon@redhat.com> - 1.21-92-2
196- Perf improvement work from Ginn Chen to help a11y-enabled-firefox3
197
198* Mon Feb 25 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.92-1
199- Update to 1.21.92
200
201* Fri Feb  8 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-2
202- Rebuild for gcc 4.3
203
204* Mon Jan 14 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-1
205- Update to 1.21.5
206
207* Thu Dec  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.3-1
208- Update to 1.21.3
209
210* Tue Nov 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.1-1
211- Update to 1.21.1
212
213* Mon Oct 15 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.1-1
214- Update to 1.20.1
215
216* Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.0-1
217- Update to 1.20.0
218
219* Mon Aug  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-2
220- Update license field
221
222* Tue Jul 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-1
223- Update to 1.19.5
224
225* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.3-1
226- Update to 1.19.3
227- Add a -python subpackage
228
229* Sun May 20 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.1-1
230- Update to 1.19.1
231
232* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-2
233- Don't ship .la files
234
235* Mon Apr  9 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-1
236- Update to 1.18.1, which includes the previous patch
237- Drop obsolete patch
238- Fix a small memory leak
239
240* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-2
241- Backport a patch to fix deadlocks in applications
242
243* Tue Mar 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-1
244- Update to 1.18.0
245- Drop obsolete patch
246
247* Thu Mar  8 2007 Ray Strode <rstrode@redhat.com> - 1.17.2-2
248- add a patch that might fix some deadlock issues (bug 329454)
249
250* Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.2-1
251- Update to 1.17.2
252
253* Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.1-1
254- Update to 1.17.1
255
256* Thu Feb 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-2
257- Bump atk requirement
258
259* Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-1
260- Update to 1.17.0
261
262* Wed Jan 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.16-1
263- Update to 1.7.16
264
265* Wed Jan 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.15-1
266- Update to 1.7.15
267
268* Tue Dec 19 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.14-1
269- Update to 1.7.14
270
271* Sat Dec  9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-2
272- Small spec file cleanups
273
274* Tue Nov  7 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-1
275- Update to 1.7.13
276
277* Fri Oct 20 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.12-1
278- Update to 1.7.12
279
280* Wed Aug 23 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-2.fc6
281- Remove debug spew
282
283* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-1.fc6
284- Update to 1.7.11
285- Drop upstreamed patch
286- Require pkgconfig in the -devel package
287
288* Wed Aug  2 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.10-1.fc6
289- Update to 1.7.10
290
291* Fri Jul 28 2006 Alexander Larsson <alexl@redhat.com> - 1.7.9-3
292- Fix segfault if a11y enabled on x86-64 (#196063)
293
294* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-2
295- Rebuild
296
297* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-1
298- Update to 1.7.9
299
300* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.8-1
301- Update to 1.7.8
302
303* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.7-8.1
304- rebuild
305
306* Thu Jun  8 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-8
307- Add a BuildRequires
308
309* Mon May 22 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-7
310- Make it build in mock
311
312* Mon Apr 17 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-6
313- Revert the previous change
314
315* Tue Apr  4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-5
316- Fix a missing declaration
317- Fix segfaults on x86_64
318
319* Tue Apr  4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-1
320- Update to 1.7.7
321
322* Thu Mar  9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-2
323- Fix a crash on x86_64
324
325* Mon Feb 27 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-1
326- Update to 1.7.6
327
328* Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.5-1
329- Update to 1.7.5
330
331* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.2
332- bump again for double-long bug on ppc(64)
333
334* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.1
335- rebuilt for new gcc4.1 snapshot and glibc changes
336
337* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> 1.7.4-1
338- Update to 1.7.4
339
340* Mon Jan 30 2006 Matthias Clasen <mclasen@redhat.com> 1.7.3-1
341- Update to 1.7.3
342
343* Tue Jan 17 2006 Matthias Clasen <mclasen@redhat.com> 1.7.2-1
344- Update to 1.7.2
345
346* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
347- rebuilt
348
349* Mon Oct 31 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-2
350- Switch requires to modular X
351
352* Wed Sep  7 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-1
353- Update to 1.6.6
354
355* Tue Aug 16 2005 Matthias Clasen <mclasen@redhat.com>
356- Rebuilt
357
358* Tue Jun 28 2005 Matthias Clasen <mclasen@redhat.com> 1.6.4-1
359- Update to 1.6.4
360
361* Mon Mar 14 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
362- Update to 1.6.3
363
364* Wed Mar  2 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-2
365- Rebuilt with gcc4
366
367* Wed Jan 26 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
368- Update to 1.6.2
369
370* Wed Sep 29 2004 Elliot Lee <sopwith@redhat.com> 1.6.0-3
371- Remove dependency on linc-devel
372
373* Fri Sep 24 2004 Mark McLoughlin <markmc@redhat.com> 1.6.0-2
374- Fix some random spec file issues (fixes #133430?)
375
376* Thu Sep 23 2004 Jonathan Blandford <jrb@redhat.com> 1.6.0-1
377- bump version
378
379* Wed Aug  4 2004 Mark McLoughlin <markmc@redhat.com> 1.5.3-1
380- Update to 1.5.3
381
382* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
383- rebuilt
384
385* Wed Mar 31 2004 Mark McLoughlin <markmc@redhat.com> 1.4.0-1
386- Update to 1.4.0
387
388* Wed Mar 10 2004 Mark McLoughlin <markmc@redhat.com> 1.3.15
389- Update to 1.3.15
390
391* Thu Mar 04 2004 Mark McLoughlin <markmc@redhat.com> 1.3.14-1
392- Update to 1.3.14
393
394* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
395- rebuilt
396
397* Thu Feb 26 2004 Alexander Larsson <alexl@redhat.com> 1.3.13-1
398- update to 1.3.13
399
400* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
401- rebuilt
402
403* Fri Jan 30 2004 Jonathan Blandford <jrb@redhat.com> 1.3.11-1
404- new version
405
406* Thu Oct  2 2003 Jonathan Blandford <jrb@redhat.com> 1.3.7-1
407- new version
408
409* Wed Aug 20 2003 Elliot Lee <sopwith@redhat.com> 1.1.9-3
410- Fix rebuild failure (stderr.patch)
411
412* Tue Jul 15 2003 Havoc Pennington <hp@redhat.com> 1.1.9-2
413- disable gtk doc
414
415* Mon Jul 14 2003 Havoc Pennington <hp@redhat.com>
416- automated rebuild
417
418* Mon Jul  7 2003 Havoc Pennington <hp@redhat.com> 1.1.9-1
419- 1.1.9
420- remove multilib patch fixed upstream
421
422* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
423- rebuilt
424
425* Fri Feb 14 2003 Havoc Pennington <hp@redhat.com> 1.1.8-3
426- kill Xft buildreq
427
428* Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-2
429- rebuild to fix self-dependency
430
431* Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
432
433- extend multilib patch to cover -lXi
434
435* Tue Feb  4 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
436- 1.1.8
437
438* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
439- rebuilt
440
441* Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.0.1-6
442- Add patch to help multilib systems find libXtst
443
444* Fri Dec  6 2002 Havoc Pennington <hp@redhat.com>
445- rebuild
446
447* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
448- rebuild with new libbonobo and gail
449
450* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
451- automated rebuild
452
453* Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
454- add libatk-bridge.so to the file list
455
456* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
457- 1.0.1
458- add at-spi-registryd to file list
459
460* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
461- rebuild in different environment
462
463* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
464- 1.0.0
465- add post/postun ldconfig
466
467* Wed May 29 2002 Bill Nottingham <notting@redhat.com>
468- rebuild again?
469
470* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
471- rebuild in different environment
472
473* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
474- 0.12.1
475
476* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
477- Version 0.0.6
478
479* Mon Jan 28 2002 Havoc Pennington <hp@redhat.com>
480- rebuild in rawhide, seems to have been linked incorrectly
481
482* Thu Jan 24 2002 Havoc Pennington <hp@redhat.com>
483- rebuild in rawhide, upgrade to 0.0.5
484- add gail deps
485
486* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
487- Initial build.
488
489
Note: See TracBrowser for help on using the repository browser.