source: projects/specs/trunk/a/at-spi/at-spi-vl.spec @ 805

Revision 805, 13.3 KB checked in by Takemikaduchi, 14 years ago (diff)

change spec file of gnome-2.30

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define atk_version 1.30.0
4%define gtk2_version 2.20.0
5%define libbonobo_version 2.24.0
6%define orbit2_version 2.6.0
7%define pango_version 1.28.0
8%define gconf2_version 2.28.0
9%define dbus_glib_version 0.76
10
11Summary: Assistive Technology Service Provider Interface
12
13Name: at-spi
14Version: 1.30.0
15Release: 1%{?_dist_release}
16URL: http://developer.gnome.org/projects/gap/
17Source0: http://download.gnome.org/sources/at-spi/1.24/%{name}-%{version}.tar.bz2
18
19License: LGPLv2+
20Group: System Environment/Libraries
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires: pango-devel >= %{pango_version}
23BuildRequires: gtk2-devel >= %{gtk2_version}
24BuildRequires: libbonobo-devel >= %{libbonobo_version}
25BuildRequires: ORBit2-devel >= %{orbit2_version}
26BuildRequires: atk-devel >= %{atk_version}
27BuildRequires: GConf2-devel >= %{gconf2_version}
28BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
29BuildRequires: popt-devel
30BuildRequires: fontconfig
31BuildRequires: gettext
32BuildRequires: intltool
33BuildRequires: perl(XML::Parser)
34BuildRequires: libX11-devel
35BuildRequires: libXtst-devel
36BuildRequires: libXi-devel
37BuildRequires: libXevie-devel
38BuildRequires: libXt-devel
39BuildRequires: desktop-file-utils
40
41Patch2: at-spi-silence-no-event-spew.patch
42
43%description
44at-spi allows assistive technologies to access GTK-based
45applications. Essentially it exposes the internals of applications for
46automation, so tools such as screen readers, magnifiers, or even
47scripting interfaces can query and interact with GUI controls.
48
49
50%package devel
51Summary: Development libraries and headers for at-spi
52Group: Development/Libraries
53Requires: %name = %{version}-%{release}
54Requires: atk-devel
55Requires: gtk2-devel
56Requires: libbonobo-devel
57Requires: ORBit2-devel
58Requires: pkgconfig
59
60%description devel
61Libraries and header files allowing compilation of apps that use at-spi.
62
63
64%package python
65Summary: Python bindings for at-spi
66Group: Development/Libraries
67Requires: %name = %{version}-%{release}
68Requires: python
69
70%description python
71Python bindings allowing to use at-spi in python programs.
72
73
74%prep
75%setup -q
76## %patch2 -p1 -b .spew
77
78
79%build
80%configure --disable-gtk-doc --disable-static
81make
82
83%install
84rm -rf $RPM_BUILD_ROOT
85make install DESTDIR=$RPM_BUILD_ROOT
86
87%find_lang at-spi
88
89rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
90rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
91rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
92
93%post
94/sbin/ldconfig
95export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
96gconftool-2 --makefile-install-rule \
97        %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
98
99%pre
100if [ "$1" -gt 1 ]; then
101    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
102    gconftool-2 --makefile-uninstall-rule \
103            %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
104fi
105
106%preun
107if [ "$1" -eq 0 ]; then
108    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
109    gconftool-2 --makefile-uninstall-rule \
110            %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
111fi
112
113%postun -p /sbin/ldconfig
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%files -f at-spi.lang
119%defattr(-,root,root)
120%doc AUTHORS COPYING NEWS README
121%{_sysconfdir}/gconf/schemas/at-spi.schemas
122%{_sysconfdir}/xdg/autostart/at-spi-registryd.desktop
123%{_libdir}/lib*.so.*
124%{_libdir}/bonobo/servers/*
125%{_libdir}/orbit-2.0/*
126%{_libdir}/gtk-2.0/modules/*
127%{_libexecdir}/*
128
129%files devel
130%defattr(-,root,root)
131%{_datadir}/gtk-doc/html/*
132%{_datadir}/idl/*
133%{_libdir}/lib*.so
134%{_libdir}/pkgconfig/*
135%{_includedir}/*
136
137%files python
138%defattr(-,root,root)
139%{python_sitearch}/pyatspi/
140
141
142%changelog
143* Sat Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
144- new upstream release
145- drop Patch2
146- add BuildRequires: GConf2-devel, dbus-glib-devel, popt-devel, desktop-file-utils
147
148* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.24.0-3
149- rebuild with python-2.6
150
151* Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.24.0-2
152- remove BuildRequires gail-devel
153  (gtk2-2.14.x now includes/provides gail)
154
155* Sun Sep 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
156- initial build for Vine Linux
157
158* Mon Sep  8 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.92-1
159- Update to 1.23.92
160- Drop upstreamed patch
161
162* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-3
163- Fix an evo crash caused by the greeter crash fix
164
165* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-2
166- Fix a greeter crash
167
168* Tue Sep  2 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-1
169- Update to 1.23.91
170
171* Wed Aug 20 2008 Jarod Wilson <jarod@redhat.com> - 1.23.6-2
172- Silence incessant atk-bridge spew filling xsession-errors (#459275)
173
174* Mon Aug  4 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.6-1
175- Update to 1.23.6
176
177* Mon Jul 21 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.5-1
178- Update to 1.23.5
179
180* Tue Jun  3 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.3-1
181- Update to 1.23.3
182
183* Mon May  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-2
184- Bump rev
185
186* Mon Apr  7 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-1
187- Update to 1.22.1
188
189* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.0-1
190- Update to 1.22.0
191
192* Wed Mar  5 2008 Christopher Aillon <caillon@redhat.com> - 1.21-92-2
193- Perf improvement work from Ginn Chen to help a11y-enabled-firefox3
194
195* Mon Feb 25 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.92-1
196- Update to 1.21.92
197
198* Fri Feb  8 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-2
199- Rebuild for gcc 4.3
200
201* Mon Jan 14 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-1
202- Update to 1.21.5
203
204* Thu Dec  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.3-1
205- Update to 1.21.3
206
207* Tue Nov 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.1-1
208- Update to 1.21.1
209
210* Mon Oct 15 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.1-1
211- Update to 1.20.1
212
213* Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.0-1
214- Update to 1.20.0
215
216* Mon Aug  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-2
217- Update license field
218
219* Tue Jul 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-1
220- Update to 1.19.5
221
222* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.3-1
223- Update to 1.19.3
224- Add a -python subpackage
225
226* Sun May 20 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.1-1
227- Update to 1.19.1
228
229* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-2
230- Don't ship .la files
231
232* Mon Apr  9 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-1
233- Update to 1.18.1, which includes the previous patch
234- Drop obsolete patch
235- Fix a small memory leak
236
237* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-2
238- Backport a patch to fix deadlocks in applications
239
240* Tue Mar 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-1
241- Update to 1.18.0
242- Drop obsolete patch
243
244* Thu Mar  8 2007 Ray Strode <rstrode@redhat.com> - 1.17.2-2
245- add a patch that might fix some deadlock issues (bug 329454)
246
247* Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.2-1
248- Update to 1.17.2
249
250* Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.1-1
251- Update to 1.17.1
252
253* Thu Feb 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-2
254- Bump atk requirement
255
256* Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-1
257- Update to 1.17.0
258
259* Wed Jan 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.16-1
260- Update to 1.7.16
261
262* Wed Jan 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.15-1
263- Update to 1.7.15
264
265* Tue Dec 19 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.14-1
266- Update to 1.7.14
267
268* Sat Dec  9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-2
269- Small spec file cleanups
270
271* Tue Nov  7 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-1
272- Update to 1.7.13
273
274* Fri Oct 20 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.12-1
275- Update to 1.7.12
276
277* Wed Aug 23 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-2.fc6
278- Remove debug spew
279
280* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-1.fc6
281- Update to 1.7.11
282- Drop upstreamed patch
283- Require pkgconfig in the -devel package
284
285* Wed Aug  2 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.10-1.fc6
286- Update to 1.7.10
287
288* Fri Jul 28 2006 Alexander Larsson <alexl@redhat.com> - 1.7.9-3
289- Fix segfault if a11y enabled on x86-64 (#196063)
290
291* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-2
292- Rebuild
293
294* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-1
295- Update to 1.7.9
296
297* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.8-1
298- Update to 1.7.8
299
300* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.7-8.1
301- rebuild
302
303* Thu Jun  8 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-8
304- Add a BuildRequires
305
306* Mon May 22 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-7
307- Make it build in mock
308
309* Mon Apr 17 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-6
310- Revert the previous change
311
312* Tue Apr  4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-5
313- Fix a missing declaration
314- Fix segfaults on x86_64
315
316* Tue Apr  4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-1
317- Update to 1.7.7
318
319* Thu Mar  9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-2
320- Fix a crash on x86_64
321
322* Mon Feb 27 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-1
323- Update to 1.7.6
324
325* Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.5-1
326- Update to 1.7.5
327
328* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.2
329- bump again for double-long bug on ppc(64)
330
331* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.1
332- rebuilt for new gcc4.1 snapshot and glibc changes
333
334* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> 1.7.4-1
335- Update to 1.7.4
336
337* Mon Jan 30 2006 Matthias Clasen <mclasen@redhat.com> 1.7.3-1
338- Update to 1.7.3
339
340* Tue Jan 17 2006 Matthias Clasen <mclasen@redhat.com> 1.7.2-1
341- Update to 1.7.2
342
343* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
344- rebuilt
345
346* Mon Oct 31 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-2
347- Switch requires to modular X
348
349* Wed Sep  7 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-1
350- Update to 1.6.6
351
352* Tue Aug 16 2005 Matthias Clasen <mclasen@redhat.com>
353- Rebuilt
354
355* Tue Jun 28 2005 Matthias Clasen <mclasen@redhat.com> 1.6.4-1
356- Update to 1.6.4
357
358* Mon Mar 14 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
359- Update to 1.6.3
360
361* Wed Mar  2 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-2
362- Rebuilt with gcc4
363
364* Wed Jan 26 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
365- Update to 1.6.2
366
367* Wed Sep 29 2004 Elliot Lee <sopwith@redhat.com> 1.6.0-3
368- Remove dependency on linc-devel
369
370* Fri Sep 24 2004 Mark McLoughlin <markmc@redhat.com> 1.6.0-2
371- Fix some random spec file issues (fixes #133430?)
372
373* Thu Sep 23 2004 Jonathan Blandford <jrb@redhat.com> 1.6.0-1
374- bump version
375
376* Wed Aug  4 2004 Mark McLoughlin <markmc@redhat.com> 1.5.3-1
377- Update to 1.5.3
378
379* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
380- rebuilt
381
382* Wed Mar 31 2004 Mark McLoughlin <markmc@redhat.com> 1.4.0-1
383- Update to 1.4.0
384
385* Wed Mar 10 2004 Mark McLoughlin <markmc@redhat.com> 1.3.15
386- Update to 1.3.15
387
388* Thu Mar 04 2004 Mark McLoughlin <markmc@redhat.com> 1.3.14-1
389- Update to 1.3.14
390
391* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
392- rebuilt
393
394* Thu Feb 26 2004 Alexander Larsson <alexl@redhat.com> 1.3.13-1
395- update to 1.3.13
396
397* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
398- rebuilt
399
400* Fri Jan 30 2004 Jonathan Blandford <jrb@redhat.com> 1.3.11-1
401- new version
402
403* Thu Oct  2 2003 Jonathan Blandford <jrb@redhat.com> 1.3.7-1
404- new version
405
406* Wed Aug 20 2003 Elliot Lee <sopwith@redhat.com> 1.1.9-3
407- Fix rebuild failure (stderr.patch)
408
409* Tue Jul 15 2003 Havoc Pennington <hp@redhat.com> 1.1.9-2
410- disable gtk doc
411
412* Mon Jul 14 2003 Havoc Pennington <hp@redhat.com>
413- automated rebuild
414
415* Mon Jul  7 2003 Havoc Pennington <hp@redhat.com> 1.1.9-1
416- 1.1.9
417- remove multilib patch fixed upstream
418
419* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
420- rebuilt
421
422* Fri Feb 14 2003 Havoc Pennington <hp@redhat.com> 1.1.8-3
423- kill Xft buildreq
424
425* Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-2
426- rebuild to fix self-dependency
427
428* Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
429
430- extend multilib patch to cover -lXi
431
432* Tue Feb  4 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
433- 1.1.8
434
435* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
436- rebuilt
437
438* Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.0.1-6
439- Add patch to help multilib systems find libXtst
440
441* Fri Dec  6 2002 Havoc Pennington <hp@redhat.com>
442- rebuild
443
444* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
445- rebuild with new libbonobo and gail
446
447* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
448- automated rebuild
449
450* Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
451- add libatk-bridge.so to the file list
452
453* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
454- 1.0.1
455- add at-spi-registryd to file list
456
457* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
458- rebuild in different environment
459
460* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
461- 1.0.0
462- add post/postun ldconfig
463
464* Wed May 29 2002 Bill Nottingham <notting@redhat.com>
465- rebuild again?
466
467* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
468- rebuild in different environment
469
470* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
471- 0.12.1
472
473* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
474- Version 0.0.6
475
476* Mon Jan 28 2002 Havoc Pennington <hp@redhat.com>
477- rebuild in rawhide, seems to have been linked incorrectly
478
479* Thu Jan 24 2002 Havoc Pennington <hp@redhat.com>
480- rebuild in rawhide, upgrade to 0.0.5
481- add gail deps
482
483* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
484- Initial build.
485
486
Note: See TracBrowser for help on using the repository browser.