source: projects/specs/trunk/M/ModemManager/ModemManager-vl.spec @ 7786

Revision 7786, 11.7 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1#%define git_snapshot .git20130607
2%define git_snapshot %{nil}
3%define ppp_version 2.4.5
4%define glib2_version 2.36
5
6Summary: Mobile broadband modem management service
7Summary(ja): Mobile broadband modem management service
8Name: ModemManager
9Version: 1.0.0
10Release: 1%{git_snapshot}%{?_dist_release}
11License: GPLv2+
12Group: System Environment/Base
13URL: http://www.gnome.org/projects/NetworkManager/
14
15#
16# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
17# tarball built with:
18#    ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
19#    make distcheck
20#
21#Source: %{name}-%{version}%{git_snapshot}.tar.bz2
22
23Source: http://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
24
25Patch0: buildsys-hates-openpty.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28Requires: dbus-glib
29Requires: glib2
30BuildRequires: glib2-devel >= %{glib2_version}
31BuildRequires: dbus-glib-devel >= 0.92
32BuildRequires: libgudev1-devel >= 143
33BuildRequires: ppp = %{ppp_version}
34BuildRequires: ppp-devel = %{ppp_version}
35BuildRequires: automake autoconf intltool libtool
36BuildRequires: gtk-doc
37# for xsltproc
38BuildRequires: libxslt
39
40%description
41The ModemManager service manages WWAN modems and provides a consistent API for
42interacting with these devices to client applications.
43
44
45%package        devel
46Summary:        Development tools for %{name}
47Summary(ja):    %{name} の開発環境
48Group:          Development/Libraries
49Requires:       %{name} = %{version}-%{release}
50Requires:       pkgconfig
51
52%description    devel
53Header files and libraries for building a extension library for the %{name}.
54
55
56%package        glib
57Summary:        Libraries for adding ModemManager support to applications that use glib.
58Group:          Development/Libraries
59Requires:       glib2 >= %{glib2_version}
60
61%description    glib
62This package contains the libraries that make it easier to use some ModemManager
63functionality from applications that use glib.
64
65
66%package        glib-devel
67Summary:        Development tools for %{name}-glib
68Summary(ja):    %{name}-glib の開発環境
69Group:          Development/Libraries
70Requires:       %{name}-glib = %{version}-%{release}
71Requires:       %{name}-devel = %{version}-%{release}
72Requires:       glib2-devel
73Requires:       pkgconfig
74
75%description    glib-devel
76Header files and libraries for building a extension library for the %{name}-glib.
77
78%prep
79%setup -q
80%patch0 -p1 -b .pty
81
82%build
83autoreconf -if
84intltoolize --force
85pppddir=`ls -1d %{_libdir}/pppd/2*`
86%configure \
87        --enable-more-warnings=yes \
88        --with-udev-base-dir=/lib/udev \
89        --with-tests=yes \
90        --enable-gtk-doc=yes \
91        --without-qmi \
92        --disable-static \
93        --with-pppd-plugin-dir=$pppddir \
94        --with-polkit=no \
95        --with-mbim=no
96
97make %{?_smp_mflags}
98
99%check
100make check
101
102%install
103make install DESTDIR=$RPM_BUILD_ROOT
104
105find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
106rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
107
108%post
109/sbin/ldconfig
110touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
111
112%postun
113/sbin/ldconfig
114if [ $1 -eq 0 ]; then
115  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
116  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
117fi
118
119%posttrans
120gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
121
122%post   glib -p /sbin/ldconfig
123%postun glib -p /sbin/ldconfig
124
125%files
126%defattr(0644, root, root, 0755)
127%doc COPYING README
128%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
129%{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
130%attr(0755,root,root) %{_sbindir}/ModemManager
131%attr(0755,root,root) %{_bindir}/mmcli
132%dir %{_libdir}/%{name}
133%attr(0755,root,root) %{_libdir}/%{name}/*.so*
134/lib/udev/rules.d/*
135%{_datadir}/dbus-1/interfaces/*.xml
136%{_datadir}/icons/hicolor/22x22/apps/*.png
137%{_mandir}/man8/*
138
139%files devel
140%defattr(0644, root, root, 0755)
141%{_includedir}/ModemManager/*.h
142%dir %{_datadir}/gtk-doc/html/%{name}
143%{_datadir}/gtk-doc/html/%{name}/*
144%{_libdir}/pkgconfig/%{name}.pc
145
146%files glib
147%defattr(0644, root, root, 0755)
148%{_libdir}/libmm-glib.so.*
149
150%files glib-devel
151%defattr(0644, root, root, 0755)
152%{_libdir}/libmm-glib.so
153%dir %{_includedir}/libmm-glib
154%{_includedir}/libmm-glib/*.h
155%{_libdir}/pkgconfig/mm-glib.pc
156%dir %{_datadir}/gtk-doc/html/libmm-glib
157%{_datadir}/gtk-doc/html/libmm-glib/*
158
159
160%changelog
161* Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
162- new upstream release
163- update Patch0
164
165* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
166- update to 0.7.991 snapshot
167- fix spec file based on FC package
168  * Fri Jun  7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
169  - Update to 0.7.991 snapshot
170  - Fix SMS validity parsing
171  - Allow registration changes to 'searching' without disconnecting
172  - Fix reading SMS messages from some QMI-based devices
173  - Increase connection timeout for Novatel E362
174  - Fix PIN retries checking when unlocking Ericsson devices
175  - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
176- add configure option (--enable-gtk-doc=yes, --without-qmi)
177
178* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
179- new upstream release
180
181* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
182- new upstream release
183
184* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
185- delete Patch20
186
187* Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
188- update Patch20 (ModemManager-0.4-git20110428.patch)
189- delete Patch21,22
190
191* Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
192- update to 0.4
193- add Patch20 (ModemManager-0.4-git20100720.patch)
194- add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
195- add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
196
197* Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
198- initial build for Vine Linux
199
200* Sun May  2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
201- core: ignore some failures on disconnect (rh #578280)
202- core: add support for platform serial devices
203- gsm: better Blackberry DUN support
204- gsm: periodically poll access technology
205- cdma: prevent crash on modem removal (rh #571921)
206- mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
207- novatel: better signal strength reporting on CDMA cards
208- novatel: add access technology and mode preference support on GSM cards
209- zte: fix mode preference retrieval
210- longcheer: add support for Zoom modems (4595, 4596, etc)
211- longcheer: add access technology and mode preference support
212
213* Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
214- Silence %%post
215- Update scripts
216
217* Fri Apr  9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
218- gsm: fix parsing Blackberry supported character sets response
219
220* Thu Apr  8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
221- mbm: fix retrieval of current allowed mode
222- gsm: fix initialization issues with some devices (like Blackberries)
223
224* Mon Apr  5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
225- core: fix detection of some generic devices (rh #579247)
226- core: fix detection regression of some Huawei devices in 0.3-5
227- cdma: periodically poll registration state and signal quality
228- cdma: really fix registration detection on various devices (rh #569067)
229
230* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
231- core: fix PPC/SPARC/etc builds
232
233* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
234- core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
235- cdma: handle signal quality requests while connected for more devices
236- cdma: handle serving system requests while connected for more devices
237- gsm: determine current access technology earlier
238- huawei: work around automatic registration issues on some devices
239
240* Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
241- core: ensure enabled modems are disabled when MM stops
242- core: better capability detection for Blackberry devices (rh #573510)
243- cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
244- gsm: don't block modem when it requires PIN2
245- option: fix access technology updates
246
247* Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
248- mbm: add device IDs for C3607w
249- mbm: fail earlier during connection failures
250- mbm: fix username/password authentication when checked by the network
251- hso: implement asynchronous signal quality updates
252- option: implement asynchronous signal quality updates
253- novatel: correctly handle CDMA signal quality
254- core: basic PolicyKit support
255- core: fix direct GSM registration information requests
256- core: general GSM PIN/PUK unlock fixes
257- core: poll GSM registration state internally for quicker status updates
258- core: implement GSM 2G/3G preference
259- core: implement GSM roaming allowed/disallowed preference
260- core: emit signals on access technology changes
261- core: better handling of disconnections
262- core: fix simple CDMA status requests
263
264* Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
265- core: startup speed improvements
266- core: GSM PIN checking improvements
267- huawei: fix EVDO-only connections on various devices (rh #553199)
268- longcheer: add support for more devices
269
270* Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
271- anydata: new plugin for AnyData CDMA modems (rh #547294)
272- core: fix crashes when devices are unplugged during operation (rh #553953)
273- cdma: prefer primary port for status/registration queries
274- core: fix probing/detection of some PIN-locked devices (rh #551376)
275- longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
276- gsm: fix Nokia N80 network scan parsing
277
278* Fri Jan  1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
279- core: fix apparent hangs by limiting retried serial writes
280- gsm: ensure modem state is reset when disabled
281
282* Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
283- sierra: fix CDMA registration detection in some cases (rh #547513)
284
285* Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
286- sierra: ensure CDMA device is powered up when trying to use it
287- cdma: better signal quality parsing (fixes ex Huawei EC168C)
288- zte: handle unsolicited messages better during probing
289
290* Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
291- cdma: fix signal strength reporting on some devices
292- cdma: better registration state detection when dialing (ex Sierra 5275)
293- option: always use the correct tty for dialing commands
294
295* Mon Dec  7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
296- core: fix reconnect after manual disconnect (rh #541314)
297- core: fix various segfaults during registration
298- core: fix probing of various modems on big-endian architectures (ie PPC)
299- core: implement modem states to avoid duplicate operations
300- hso: fix authentication for Icera-based devices like iCON 505
301- zte: use correct port for new devices
302- nozomi: fix detection
303
304* Thu Nov  5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
305- Update to latest git
306- core: fix pppd 2.4.5 errors about 'baudrate 0'
307- cdma: wait for network registration before trying to connect
308- gsm: add cell access technology reporting
309- gsm: allow longer-running network scans
310- mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
311- nokia: don't power down phones on disconnect
312- hso: fix disconnection/disable
313
314* Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
315- Fixes for Motorola and Ericsson devices
316- Fixes for CDMA "serving-system" command parsing
317
318* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
319- Fix a typo in one of the udev rules files
320
321* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
322- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
323
324* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
325- Fix source repo location
326- Fix directory ownership
327
328* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
329- Initial version
330
Note: See TracBrowser for help on using the repository browser.