source: projects/specs/trunk/M/ModemManager/ModemManager-vl.spec @ 12529

Revision 12529, 14.5 KB checked in by tomop, 3 years ago (diff)

updated 5 packages

ModemManager?-1.14.10-1

NetworkManager-1.28.0-1

libpcap-1.10.0-1

ppp-2.4.9-1

xl2tpd-1.3.16-1

Line 
1%bcond_with systemd
2
3#%define git_snapshot .git20130607
4%define git_snapshot %{nil}
5#define ppp_version 2.4.7
6%define glib2_version 2.40
7
8Name: ModemManager
9Summary: Mobile broadband modem management service
10Summary(ja): モバイルブロードバンドモデム運用サービス
11Version: 1.14.10
12Release: 1%{git_snapshot}%{?_dist_release}%{?with_systemd:.systemd}
13Group: network,system
14Vendor: Project Vine
15Distribution: Vine Linux
16
17License: GPLv2+
18URL: https://www.freedesktop.org/wiki/Software/ModemManager/
19Source: https://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
20
21Patch0: buildsys-hates-openpty.patch
22Patch1: ModemManager-1.8.2-elogind-1.patch
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25BuildRequires: glib2-devel >= %{glib2_version}
26BuildRequires: automake autoconf intltool libtool
27BuildRequires: gobject-introspection-devel
28BuildRequires: vala-devel
29BuildRequires: vala-tools
30BuildRequires: polkit-devel
31BuildRequires: gtk-doc
32# for xsltproc
33BuildRequires: libxslt
34%if %{with systemd}
35BuildRequires: systemd-devel
36%{?systemd_requires}
37%else
38BuildRequires: libgudev-devel
39BuildRequires: elogind-devel
40%endif
41Requires: dbus-glib
42
43%description
44The ModemManager service manages WWAN modems and provides a consistent API for
45interacting with these devices to client applications.
46
47
48%package        devel
49Summary:        Development tools for %{name}
50Summary(ja):    %{name} の開発環境
51Group:          programming
52Requires:       %{name} = %{version}-%{release}
53Requires:       pkgconfig
54
55%description    devel
56Header files and libraries for building a extension library for the %{name}.
57
58
59%package        glib
60Summary:        Libraries for adding ModemManager support to applications that use glib.
61Summary(ja):    Glib を使用するアプリケーションに ModemManager サポートを追加するためのライブラリ
62Group:          system
63Requires:       glib2 >= %{glib2_version}
64
65%description    glib
66This package contains the libraries that make it easier to use some ModemManager
67functionality from applications that use glib.
68
69
70%package        glib-devel
71Summary:        Development tools for %{name}-glib
72Summary(ja):    %{name}-glib の開発環境
73Group:          programming
74Requires:       %{name}-glib = %{version}-%{release}
75Requires:       %{name}-devel = %{version}-%{release}
76Requires:       glib2-devel
77Requires:       pkgconfig
78
79%description    glib-devel
80Header files and libraries for building a extension library for the %{name}-glib.
81
82
83%debug_package
84
85
86%prep
87%setup -q
88%patch0 -p1 -b .pty
89%if !%{with systemd}
90%patch1 -p1 -b .elogind
91%endif
92
93
94%build
95autoreconf -vif
96#pppddir=`ls -1d %{_libdir}/pppd/2*`
97%configure \
98        --disable-static \
99        --enable-gtk-doc=yes \
100        --enable-vala=yes \
101        --enable-more-warnings=yes \
102        --with-udev-base-dir=/lib/udev \
103        --without-mbim \
104        --without-qmi \
105        --with-dist-version=%{version}-%{release} \
106%if %{with systemd}
107        --with-systemdsystemunitdir=%{_unitdir}
108%else
109        --with-elogind-suspend-resume=yes
110%endif
111
112
113make %{?_smp_mflags}
114
115%check
116make check
117
118%install
119make install DESTDIR=$RPM_BUILD_ROOT
120
121find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
122#rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
123
124%find_lang %{name}
125
126%post
127/sbin/ldconfig
128touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
129%if %{with systemd}
130%systemd_post ModemManager.service
131%endif
132
133%if %{with systemd}
134%preun
135%systemd_preun ModemManager.service
136%endif
137
138%postun
139/sbin/ldconfig
140if [ $1 -eq 0 ]; then
141  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
142  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
143fi
144%if %{with systemd}
145%systemd_postun ModemManager.service
146%endif
147
148%posttrans
149gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
150
151%post   glib -p /sbin/ldconfig
152%postun glib -p /sbin/ldconfig
153
154
155%files -f %{name}.lang
156%defattr(-,root, root,-)
157%license COPYING
158%doc README
159%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
160%{_libdir}/girepository-1.0/ModemManager-1.0.typelib
161%{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
162%attr(0755,root,root) %{_sbindir}/ModemManager
163%attr(0755,root,root) %{_bindir}/mmcli
164%dir %{_libdir}/%{name}
165%attr(0755,root,root) %{_libdir}/%{name}/*.so*
166%dir %{_datadir}/%{name}
167%{_datadir}/%{name}/*
168/lib/udev/rules.d/*
169%{_datadir}/dbus-1/interfaces/*.xml
170%{_datadir}/icons/hicolor/22x22/apps/*.png
171%{_datadir}/polkit-1/actions/org.freedesktop.ModemManager1.policy
172%{_mandir}/man1/*
173%{_mandir}/man8/*
174%dir %{_datadir}/bash-completion
175%dir %{_datadir}/bash-completion/completions
176%{_datadir}/bash-completion/completions/*
177%if %{with systemd}
178%{_unitdir}/*.service
179%endif
180
181%files devel
182%defattr(-,root,root,-)
183%{_includedir}/ModemManager/*.h
184%dir %{_datadir}/gtk-doc/html/%{name}
185%{_datadir}/gir-1.0/ModemManager-1.0.gir
186%{_datadir}/gtk-doc/html/%{name}/*
187%{_libdir}/pkgconfig/%{name}.pc
188
189%files glib
190%defattr(-,root,root,-)
191%{_libdir}/libmm-glib.so.*
192
193%files glib-devel
194%defattr(-,root,root,-)
195%{_libdir}/libmm-glib.so
196%dir %{_includedir}/libmm-glib
197%{_includedir}/libmm-glib/*.h
198%{_libdir}/pkgconfig/mm-glib.pc
199%dir %{_datadir}/vala
200%dir %{_datadir}/vala/vapi
201%{_datadir}/vala/vapi/libmm-glib.*
202%dir %{_datadir}/gtk-doc/html/libmm-glib
203%{_datadir}/gtk-doc/html/libmm-glib/*
204
205
206%changelog
207* Mon Feb 15 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.10-1
208- new upstream release.
209
210* Mon Aug  3 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.0-1
211- new upstream release.
212
213* Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.4-1
214- new upstream release.
215
216* Mon Dec 17 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.2-1
217- new upstream release.
218- added elogind support.
219
220* Sat Mar 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.12-1
221- new upstream release.
222
223* Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
224- new upstream release
225- change BuildRequires: libgudev-devel instead of eudev-libgudev1-devel
226
227* Sun Feb 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-3
228- fix spec file
229
230* Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-2
231- fix spec file
232
233* Fri Oct 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-1
234- new upstream release
235- add BuildRequires: gobject-introspection-devel, polkit-devel
236
237* Sun Jul 26 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.10-1
238- new upstream release
239
240* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.8-1
241- new upstream release
242
243* Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
244- new upstream release
245
246* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
247- new upstream release
248
249* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
250- new upstream release
251
252* Tue Oct  7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.0-2
253- moved ModemManager-glib to System Environment/Libraries Group
254- removed BR: ppp, ppp-devel and dbus-glib-devel
255
256* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
257- new upstream release
258- remove Patch1 (ModemManager-1.0.0-git20130911.patch)
259
260* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
261- add Patch1 (ModemManager-1.0.0-git20130911.patch)
262
263* Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
264- new upstream release
265- update Patch0
266
267* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
268- update to 0.7.991 snapshot
269- fix spec file based on FC package
270  * Fri Jun  7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
271  - Update to 0.7.991 snapshot
272  - Fix SMS validity parsing
273  - Allow registration changes to 'searching' without disconnecting
274  - Fix reading SMS messages from some QMI-based devices
275  - Increase connection timeout for Novatel E362
276  - Fix PIN retries checking when unlocking Ericsson devices
277  - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
278- add configure option (--enable-gtk-doc=yes, --without-qmi)
279
280* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
281- new upstream release
282
283* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
284- new upstream release
285
286* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
287- delete Patch20
288
289* Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
290- update Patch20 (ModemManager-0.4-git20110428.patch)
291- delete Patch21,22
292
293* Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
294- update to 0.4
295- add Patch20 (ModemManager-0.4-git20100720.patch)
296- add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
297- add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
298
299* Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
300- initial build for Vine Linux
301
302* Sun May  2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
303- core: ignore some failures on disconnect (rh #578280)
304- core: add support for platform serial devices
305- gsm: better Blackberry DUN support
306- gsm: periodically poll access technology
307- cdma: prevent crash on modem removal (rh #571921)
308- mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
309- novatel: better signal strength reporting on CDMA cards
310- novatel: add access technology and mode preference support on GSM cards
311- zte: fix mode preference retrieval
312- longcheer: add support for Zoom modems (4595, 4596, etc)
313- longcheer: add access technology and mode preference support
314
315* Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
316- Silence %%post
317- Update scripts
318
319* Fri Apr  9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
320- gsm: fix parsing Blackberry supported character sets response
321
322* Thu Apr  8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
323- mbm: fix retrieval of current allowed mode
324- gsm: fix initialization issues with some devices (like Blackberries)
325
326* Mon Apr  5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
327- core: fix detection of some generic devices (rh #579247)
328- core: fix detection regression of some Huawei devices in 0.3-5
329- cdma: periodically poll registration state and signal quality
330- cdma: really fix registration detection on various devices (rh #569067)
331
332* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
333- core: fix PPC/SPARC/etc builds
334
335* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
336- core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
337- cdma: handle signal quality requests while connected for more devices
338- cdma: handle serving system requests while connected for more devices
339- gsm: determine current access technology earlier
340- huawei: work around automatic registration issues on some devices
341
342* Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
343- core: ensure enabled modems are disabled when MM stops
344- core: better capability detection for Blackberry devices (rh #573510)
345- cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
346- gsm: don't block modem when it requires PIN2
347- option: fix access technology updates
348
349* Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
350- mbm: add device IDs for C3607w
351- mbm: fail earlier during connection failures
352- mbm: fix username/password authentication when checked by the network
353- hso: implement asynchronous signal quality updates
354- option: implement asynchronous signal quality updates
355- novatel: correctly handle CDMA signal quality
356- core: basic PolicyKit support
357- core: fix direct GSM registration information requests
358- core: general GSM PIN/PUK unlock fixes
359- core: poll GSM registration state internally for quicker status updates
360- core: implement GSM 2G/3G preference
361- core: implement GSM roaming allowed/disallowed preference
362- core: emit signals on access technology changes
363- core: better handling of disconnections
364- core: fix simple CDMA status requests
365
366* Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
367- core: startup speed improvements
368- core: GSM PIN checking improvements
369- huawei: fix EVDO-only connections on various devices (rh #553199)
370- longcheer: add support for more devices
371
372* Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
373- anydata: new plugin for AnyData CDMA modems (rh #547294)
374- core: fix crashes when devices are unplugged during operation (rh #553953)
375- cdma: prefer primary port for status/registration queries
376- core: fix probing/detection of some PIN-locked devices (rh #551376)
377- longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
378- gsm: fix Nokia N80 network scan parsing
379
380* Fri Jan  1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
381- core: fix apparent hangs by limiting retried serial writes
382- gsm: ensure modem state is reset when disabled
383
384* Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
385- sierra: fix CDMA registration detection in some cases (rh #547513)
386
387* Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
388- sierra: ensure CDMA device is powered up when trying to use it
389- cdma: better signal quality parsing (fixes ex Huawei EC168C)
390- zte: handle unsolicited messages better during probing
391
392* Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
393- cdma: fix signal strength reporting on some devices
394- cdma: better registration state detection when dialing (ex Sierra 5275)
395- option: always use the correct tty for dialing commands
396
397* Mon Dec  7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
398- core: fix reconnect after manual disconnect (rh #541314)
399- core: fix various segfaults during registration
400- core: fix probing of various modems on big-endian architectures (ie PPC)
401- core: implement modem states to avoid duplicate operations
402- hso: fix authentication for Icera-based devices like iCON 505
403- zte: use correct port for new devices
404- nozomi: fix detection
405
406* Thu Nov  5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
407- Update to latest git
408- core: fix pppd 2.4.5 errors about 'baudrate 0'
409- cdma: wait for network registration before trying to connect
410- gsm: add cell access technology reporting
411- gsm: allow longer-running network scans
412- mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
413- nokia: don't power down phones on disconnect
414- hso: fix disconnection/disable
415
416* Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
417- Fixes for Motorola and Ericsson devices
418- Fixes for CDMA "serving-system" command parsing
419
420* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
421- Fix a typo in one of the udev rules files
422
423* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
424- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
425
426* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
427- Fix source repo location
428- Fix directory ownership
429
430* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
431- Initial version
432
Note: See TracBrowser for help on using the repository browser.