source: projects/specs/trunk/M/ModemManager/ModemManager-vl.spec @ 8073

Revision 8073, 11.9 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1#%define git_snapshot .git20130607
2%define git_snapshot %{nil}
3%define ppp_version 2.4.5
4%define glib2_version 2.36
5
6Summary: Mobile broadband modem management service
7Summary(ja): Mobile broadband modem management service
8Name: ModemManager
9Version: 1.0.0
10Release: 2%{git_snapshot}%{?_dist_release}
11License: GPLv2+
12Group: System Environment/Base
13URL: http://www.gnome.org/projects/NetworkManager/
14
15#
16# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
17# tarball built with:
18#    ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
19#    make distcheck
20#
21#Source: %{name}-%{version}%{git_snapshot}.tar.bz2
22
23Source: http://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
24
25Patch0: buildsys-hates-openpty.patch
26Patch1: ModemManager-1.0.0-git20130911.patch
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29Requires: dbus-glib
30Requires: glib2
31BuildRequires: glib2-devel >= %{glib2_version}
32BuildRequires: dbus-glib-devel >= 0.92
33BuildRequires: libgudev1-devel >= 143
34BuildRequires: ppp = %{ppp_version}
35BuildRequires: ppp-devel = %{ppp_version}
36BuildRequires: automake autoconf intltool libtool
37BuildRequires: gtk-doc
38# for xsltproc
39BuildRequires: libxslt
40
41%description
42The ModemManager service manages WWAN modems and provides a consistent API for
43interacting with these devices to client applications.
44
45
46%package        devel
47Summary:        Development tools for %{name}
48Summary(ja):    %{name} の開発環境
49Group:          Development/Libraries
50Requires:       %{name} = %{version}-%{release}
51Requires:       pkgconfig
52
53%description    devel
54Header files and libraries for building a extension library for the %{name}.
55
56
57%package        glib
58Summary:        Libraries for adding ModemManager support to applications that use glib.
59Group:          Development/Libraries
60Requires:       glib2 >= %{glib2_version}
61
62%description    glib
63This package contains the libraries that make it easier to use some ModemManager
64functionality from applications that use glib.
65
66
67%package        glib-devel
68Summary:        Development tools for %{name}-glib
69Summary(ja):    %{name}-glib の開発環境
70Group:          Development/Libraries
71Requires:       %{name}-glib = %{version}-%{release}
72Requires:       %{name}-devel = %{version}-%{release}
73Requires:       glib2-devel
74Requires:       pkgconfig
75
76%description    glib-devel
77Header files and libraries for building a extension library for the %{name}-glib.
78
79%prep
80%setup -q
81%patch0 -p1 -b .pty
82%patch1 -p1
83
84%build
85autoreconf -if
86intltoolize --force
87pppddir=`ls -1d %{_libdir}/pppd/2*`
88%configure \
89        --enable-more-warnings=yes \
90        --with-udev-base-dir=/lib/udev \
91        --with-tests=yes \
92        --enable-gtk-doc=yes \
93        --without-qmi \
94        --disable-static \
95        --with-pppd-plugin-dir=$pppddir \
96        --with-polkit=no \
97        --with-mbim=no
98
99make %{?_smp_mflags}
100
101%check
102make check
103
104%install
105make install DESTDIR=$RPM_BUILD_ROOT
106
107find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
108rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
109
110%post
111/sbin/ldconfig
112touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
113
114%postun
115/sbin/ldconfig
116if [ $1 -eq 0 ]; then
117  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
118  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
119fi
120
121%posttrans
122gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
123
124%post   glib -p /sbin/ldconfig
125%postun glib -p /sbin/ldconfig
126
127%files
128%defattr(0644, root, root, 0755)
129%doc COPYING README
130%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
131%{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
132%attr(0755,root,root) %{_sbindir}/ModemManager
133%attr(0755,root,root) %{_bindir}/mmcli
134%dir %{_libdir}/%{name}
135%attr(0755,root,root) %{_libdir}/%{name}/*.so*
136/lib/udev/rules.d/*
137%{_datadir}/dbus-1/interfaces/*.xml
138%{_datadir}/icons/hicolor/22x22/apps/*.png
139%{_mandir}/man8/*
140
141%files devel
142%defattr(0644, root, root, 0755)
143%{_includedir}/ModemManager/*.h
144%dir %{_datadir}/gtk-doc/html/%{name}
145%{_datadir}/gtk-doc/html/%{name}/*
146%{_libdir}/pkgconfig/%{name}.pc
147
148%files glib
149%defattr(0644, root, root, 0755)
150%{_libdir}/libmm-glib.so.*
151
152%files glib-devel
153%defattr(0644, root, root, 0755)
154%{_libdir}/libmm-glib.so
155%dir %{_includedir}/libmm-glib
156%{_includedir}/libmm-glib/*.h
157%{_libdir}/pkgconfig/mm-glib.pc
158%dir %{_datadir}/gtk-doc/html/libmm-glib
159%{_datadir}/gtk-doc/html/libmm-glib/*
160
161
162%changelog
163* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
164- add Patch1 (ModemManager-1.0.0-git20130911.patch)
165
166* Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
167- new upstream release
168- update Patch0
169
170* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
171- update to 0.7.991 snapshot
172- fix spec file based on FC package
173  * Fri Jun  7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
174  - Update to 0.7.991 snapshot
175  - Fix SMS validity parsing
176  - Allow registration changes to 'searching' without disconnecting
177  - Fix reading SMS messages from some QMI-based devices
178  - Increase connection timeout for Novatel E362
179  - Fix PIN retries checking when unlocking Ericsson devices
180  - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
181- add configure option (--enable-gtk-doc=yes, --without-qmi)
182
183* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
184- new upstream release
185
186* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
187- new upstream release
188
189* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
190- delete Patch20
191
192* Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
193- update Patch20 (ModemManager-0.4-git20110428.patch)
194- delete Patch21,22
195
196* Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
197- update to 0.4
198- add Patch20 (ModemManager-0.4-git20100720.patch)
199- add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
200- add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
201
202* Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
203- initial build for Vine Linux
204
205* Sun May  2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
206- core: ignore some failures on disconnect (rh #578280)
207- core: add support for platform serial devices
208- gsm: better Blackberry DUN support
209- gsm: periodically poll access technology
210- cdma: prevent crash on modem removal (rh #571921)
211- mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
212- novatel: better signal strength reporting on CDMA cards
213- novatel: add access technology and mode preference support on GSM cards
214- zte: fix mode preference retrieval
215- longcheer: add support for Zoom modems (4595, 4596, etc)
216- longcheer: add access technology and mode preference support
217
218* Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
219- Silence %%post
220- Update scripts
221
222* Fri Apr  9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
223- gsm: fix parsing Blackberry supported character sets response
224
225* Thu Apr  8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
226- mbm: fix retrieval of current allowed mode
227- gsm: fix initialization issues with some devices (like Blackberries)
228
229* Mon Apr  5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
230- core: fix detection of some generic devices (rh #579247)
231- core: fix detection regression of some Huawei devices in 0.3-5
232- cdma: periodically poll registration state and signal quality
233- cdma: really fix registration detection on various devices (rh #569067)
234
235* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
236- core: fix PPC/SPARC/etc builds
237
238* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
239- core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
240- cdma: handle signal quality requests while connected for more devices
241- cdma: handle serving system requests while connected for more devices
242- gsm: determine current access technology earlier
243- huawei: work around automatic registration issues on some devices
244
245* Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
246- core: ensure enabled modems are disabled when MM stops
247- core: better capability detection for Blackberry devices (rh #573510)
248- cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
249- gsm: don't block modem when it requires PIN2
250- option: fix access technology updates
251
252* Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
253- mbm: add device IDs for C3607w
254- mbm: fail earlier during connection failures
255- mbm: fix username/password authentication when checked by the network
256- hso: implement asynchronous signal quality updates
257- option: implement asynchronous signal quality updates
258- novatel: correctly handle CDMA signal quality
259- core: basic PolicyKit support
260- core: fix direct GSM registration information requests
261- core: general GSM PIN/PUK unlock fixes
262- core: poll GSM registration state internally for quicker status updates
263- core: implement GSM 2G/3G preference
264- core: implement GSM roaming allowed/disallowed preference
265- core: emit signals on access technology changes
266- core: better handling of disconnections
267- core: fix simple CDMA status requests
268
269* Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
270- core: startup speed improvements
271- core: GSM PIN checking improvements
272- huawei: fix EVDO-only connections on various devices (rh #553199)
273- longcheer: add support for more devices
274
275* Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
276- anydata: new plugin for AnyData CDMA modems (rh #547294)
277- core: fix crashes when devices are unplugged during operation (rh #553953)
278- cdma: prefer primary port for status/registration queries
279- core: fix probing/detection of some PIN-locked devices (rh #551376)
280- longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
281- gsm: fix Nokia N80 network scan parsing
282
283* Fri Jan  1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
284- core: fix apparent hangs by limiting retried serial writes
285- gsm: ensure modem state is reset when disabled
286
287* Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
288- sierra: fix CDMA registration detection in some cases (rh #547513)
289
290* Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
291- sierra: ensure CDMA device is powered up when trying to use it
292- cdma: better signal quality parsing (fixes ex Huawei EC168C)
293- zte: handle unsolicited messages better during probing
294
295* Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
296- cdma: fix signal strength reporting on some devices
297- cdma: better registration state detection when dialing (ex Sierra 5275)
298- option: always use the correct tty for dialing commands
299
300* Mon Dec  7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
301- core: fix reconnect after manual disconnect (rh #541314)
302- core: fix various segfaults during registration
303- core: fix probing of various modems on big-endian architectures (ie PPC)
304- core: implement modem states to avoid duplicate operations
305- hso: fix authentication for Icera-based devices like iCON 505
306- zte: use correct port for new devices
307- nozomi: fix detection
308
309* Thu Nov  5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
310- Update to latest git
311- core: fix pppd 2.4.5 errors about 'baudrate 0'
312- cdma: wait for network registration before trying to connect
313- gsm: add cell access technology reporting
314- gsm: allow longer-running network scans
315- mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
316- nokia: don't power down phones on disconnect
317- hso: fix disconnection/disable
318
319* Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
320- Fixes for Motorola and Ericsson devices
321- Fixes for CDMA "serving-system" command parsing
322
323* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
324- Fix a typo in one of the udev rules files
325
326* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
327- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
328
329* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
330- Fix source repo location
331- Fix directory ownership
332
333* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
334- Initial version
335
Note: See TracBrowser for help on using the repository browser.