source: projects/specs/trunk/M/ModemManager/ModemManager-vl.spec @ 7712

Revision 7712, 11.5 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1%define git_snapshot .git20130607
2#%define snapshot %{nil}
3%define ppp_version 2.4.5
4%define glib2_version 2.32
5
6Summary: Mobile broadband modem management service
7Summary(ja): Mobile broadband modem management service
8Name: ModemManager
9Version: 0.7.991
10Release: 1%{git_snapshot}%{?_dist_release}
11License: GPLv2+
12Group: System Environment/Base
13URL: http://www.gnome.org/projects/NetworkManager/
14
15#
16# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
17# tarball built with:
18#    ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
19#    make distcheck
20#
21Source: %{name}-%{version}%{git_snapshot}.tar.bz2
22
23Patch0: buildsys-hates-openpty.patch
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26Requires: dbus-glib
27Requires: glib2
28BuildRequires: glib2-devel >= %{glib2_version}
29BuildRequires: dbus-glib-devel >= 0.92
30BuildRequires: libgudev1-devel >= 143
31BuildRequires: ppp = %{ppp_version}
32BuildRequires: ppp-devel = %{ppp_version}
33BuildRequires: automake autoconf intltool libtool
34BuildRequires: gtk-doc
35# for xsltproc
36BuildRequires: libxslt
37
38%description
39The ModemManager service manages WWAN modems and provides a consistent API for
40interacting with these devices to client applications.
41
42
43%package        devel
44Summary:        Development tools for %{name}
45Summary(ja):    %{name} の開発環境
46Group:          Development/Libraries
47Requires:       %{name} = %{version}-%{release}
48Requires:       pkgconfig
49
50%description    devel
51Header files and libraries for building a extension library for the %{name}.
52
53
54%package        glib
55Summary:        Libraries for adding ModemManager support to applications that use glib.
56Group:          Development/Libraries
57Requires:       glib2 >= %{glib2_version}
58
59%description    glib
60This package contains the libraries that make it easier to use some ModemManager
61functionality from applications that use glib.
62
63
64%package        glib-devel
65Summary:        Development tools for %{name}-glib
66Summary(ja):    %{name}-glib の開発環境
67Group:          Development/Libraries
68Requires:       %{name}-glib = %{version}-%{release}
69Requires:       %{name}-devel = %{version}-%{release}
70Requires:       glib2-devel
71Requires:       pkgconfig
72
73%description    glib-devel
74Header files and libraries for building a extension library for the %{name}-glib.
75
76%prep
77%setup -q
78%patch0 -p1 -b .pty
79
80%build
81autoreconf -if
82intltoolize --force
83pppddir=`ls -1d %{_libdir}/pppd/2*`
84%configure \
85        --enable-more-warnings=yes \
86        --with-udev-base-dir=/lib/udev \
87        --with-tests=yes \
88        --enable-gtk-doc=yes \
89        --without-qmi \
90        --disable-static \
91        --with-pppd-plugin-dir=$pppddir \
92        --with-polkit=no
93
94make %{?_smp_mflags}
95
96%check
97make check
98
99%install
100make install DESTDIR=$RPM_BUILD_ROOT
101
102find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
103rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
104
105%post
106/sbin/ldconfig
107touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
108
109%postun
110/sbin/ldconfig
111if [ $1 -eq 0 ]; then
112  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
113  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
114fi
115
116%posttrans
117gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
118
119%post   glib -p /sbin/ldconfig
120%postun glib -p /sbin/ldconfig
121
122%files
123%defattr(0644, root, root, 0755)
124%doc COPYING README
125%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
126%{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
127%attr(0755,root,root) %{_sbindir}/ModemManager
128%attr(0755,root,root) %{_bindir}/mmcli
129%dir %{_libdir}/%{name}
130%attr(0755,root,root) %{_libdir}/%{name}/*.so*
131/lib/udev/rules.d/*
132%{_datadir}/dbus-1/interfaces/*.xml
133%{_datadir}/icons/hicolor/22x22/apps/*.png
134%{_mandir}/man8/*
135
136%files devel
137%defattr(0644, root, root, 0755)
138%{_includedir}/ModemManager/*.h
139%dir %{_datadir}/gtk-doc/html/%{name}
140%{_datadir}/gtk-doc/html/%{name}/*
141%{_libdir}/pkgconfig/%{name}.pc
142
143%files glib
144%defattr(0644, root, root, 0755)
145%{_libdir}/libmm-glib.so.*
146
147%files glib-devel
148%defattr(0644, root, root, 0755)
149%{_libdir}/libmm-glib.so
150%dir %{_includedir}/libmm-glib
151%{_includedir}/libmm-glib/*.h
152%{_libdir}/pkgconfig/mm-glib.pc
153%dir %{_datadir}/gtk-doc/html/libmm-glib
154%{_datadir}/gtk-doc/html/libmm-glib/*
155
156
157%changelog
158* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
159- update to 0.7.991 snapshot
160- fix spec file based on FC package
161  * Fri Jun  7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
162  - Update to 0.7.991 snapshot
163  - Fix SMS validity parsing
164  - Allow registration changes to 'searching' without disconnecting
165  - Fix reading SMS messages from some QMI-based devices
166  - Increase connection timeout for Novatel E362
167  - Fix PIN retries checking when unlocking Ericsson devices
168  - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
169- add configure option (--enable-gtk-doc=yes, --without-qmi)
170
171* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
172- new upstream release
173
174* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
175- new upstream release
176
177* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
178- delete Patch20
179
180* Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
181- update Patch20 (ModemManager-0.4-git20110428.patch)
182- delete Patch21,22
183
184* Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
185- update to 0.4
186- add Patch20 (ModemManager-0.4-git20100720.patch)
187- add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
188- add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
189
190* Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
191- initial build for Vine Linux
192
193* Sun May  2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
194- core: ignore some failures on disconnect (rh #578280)
195- core: add support for platform serial devices
196- gsm: better Blackberry DUN support
197- gsm: periodically poll access technology
198- cdma: prevent crash on modem removal (rh #571921)
199- mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
200- novatel: better signal strength reporting on CDMA cards
201- novatel: add access technology and mode preference support on GSM cards
202- zte: fix mode preference retrieval
203- longcheer: add support for Zoom modems (4595, 4596, etc)
204- longcheer: add access technology and mode preference support
205
206* Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
207- Silence %%post
208- Update scripts
209
210* Fri Apr  9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
211- gsm: fix parsing Blackberry supported character sets response
212
213* Thu Apr  8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
214- mbm: fix retrieval of current allowed mode
215- gsm: fix initialization issues with some devices (like Blackberries)
216
217* Mon Apr  5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
218- core: fix detection of some generic devices (rh #579247)
219- core: fix detection regression of some Huawei devices in 0.3-5
220- cdma: periodically poll registration state and signal quality
221- cdma: really fix registration detection on various devices (rh #569067)
222
223* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
224- core: fix PPC/SPARC/etc builds
225
226* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
227- core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
228- cdma: handle signal quality requests while connected for more devices
229- cdma: handle serving system requests while connected for more devices
230- gsm: determine current access technology earlier
231- huawei: work around automatic registration issues on some devices
232
233* Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
234- core: ensure enabled modems are disabled when MM stops
235- core: better capability detection for Blackberry devices (rh #573510)
236- cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
237- gsm: don't block modem when it requires PIN2
238- option: fix access technology updates
239
240* Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
241- mbm: add device IDs for C3607w
242- mbm: fail earlier during connection failures
243- mbm: fix username/password authentication when checked by the network
244- hso: implement asynchronous signal quality updates
245- option: implement asynchronous signal quality updates
246- novatel: correctly handle CDMA signal quality
247- core: basic PolicyKit support
248- core: fix direct GSM registration information requests
249- core: general GSM PIN/PUK unlock fixes
250- core: poll GSM registration state internally for quicker status updates
251- core: implement GSM 2G/3G preference
252- core: implement GSM roaming allowed/disallowed preference
253- core: emit signals on access technology changes
254- core: better handling of disconnections
255- core: fix simple CDMA status requests
256
257* Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
258- core: startup speed improvements
259- core: GSM PIN checking improvements
260- huawei: fix EVDO-only connections on various devices (rh #553199)
261- longcheer: add support for more devices
262
263* Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
264- anydata: new plugin for AnyData CDMA modems (rh #547294)
265- core: fix crashes when devices are unplugged during operation (rh #553953)
266- cdma: prefer primary port for status/registration queries
267- core: fix probing/detection of some PIN-locked devices (rh #551376)
268- longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
269- gsm: fix Nokia N80 network scan parsing
270
271* Fri Jan  1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
272- core: fix apparent hangs by limiting retried serial writes
273- gsm: ensure modem state is reset when disabled
274
275* Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
276- sierra: fix CDMA registration detection in some cases (rh #547513)
277
278* Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
279- sierra: ensure CDMA device is powered up when trying to use it
280- cdma: better signal quality parsing (fixes ex Huawei EC168C)
281- zte: handle unsolicited messages better during probing
282
283* Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
284- cdma: fix signal strength reporting on some devices
285- cdma: better registration state detection when dialing (ex Sierra 5275)
286- option: always use the correct tty for dialing commands
287
288* Mon Dec  7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
289- core: fix reconnect after manual disconnect (rh #541314)
290- core: fix various segfaults during registration
291- core: fix probing of various modems on big-endian architectures (ie PPC)
292- core: implement modem states to avoid duplicate operations
293- hso: fix authentication for Icera-based devices like iCON 505
294- zte: use correct port for new devices
295- nozomi: fix detection
296
297* Thu Nov  5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
298- Update to latest git
299- core: fix pppd 2.4.5 errors about 'baudrate 0'
300- cdma: wait for network registration before trying to connect
301- gsm: add cell access technology reporting
302- gsm: allow longer-running network scans
303- mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
304- nokia: don't power down phones on disconnect
305- hso: fix disconnection/disable
306
307* Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
308- Fixes for Motorola and Ericsson devices
309- Fixes for CDMA "serving-system" command parsing
310
311* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
312- Fix a typo in one of the udev rules files
313
314* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
315- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
316
317* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
318- Fix source repo location
319- Fix directory ownership
320
321* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
322- Initial version
323
Note: See TracBrowser for help on using the repository browser.