source: projects/specs/branches/6/g/gettext/gettext-vl.spec @ 2197

Revision 2197, 12.0 KB checked in by iwamoto, 13 years ago (diff)

gettext: new upstream release

Line 
1%define libtoolize :
2
3%define src_ver 0.18.1.1
4%define so_ver 0.18.1
5
6Summary: GNU libraries and utilities for producing multi-lingual messages.
7Summary(ja): マルチリンガルメッセージを生成するためのGNU ライブラリ/ユーティリティ
8Name: gettext
9Version: %{src_ver}
10Release: 1%{?_dist_release}
11License: GPLv3 and LGPLv2+
12Group: Development/Tools
13Source: ftp://ftp.gnu.org/gnu/gettext/%{name}-%{version}.tar.gz
14URL: http://www.gnu.org/software/gettext/
15Source2: msghack.py
16# Patch5: gettext-0.17-open-args.patch
17# Patch6: gettext-0.17-autopoint-CVS-441481.patch
18# Patch7: gettext-0.17-rpathFix.patch
19# Patch8: gettext-xgettext-python-unicode-surrogate-473946.patch
20
21BuildRequires: libtool, bison, gcc-c++
22BuildRequires: expat-devel
23BuildRequires: libacl-devel, libcroco-devel
24
25Requires(post): /sbin/install-info
26Requires(preun): /sbin/install-info
27Buildroot: %{_tmppath}/%{name}-%{version}-root
28
29Packager: daisuke
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34The GNU gettext package provides a set of tools and documentation for
35producing multi-lingual messages in programs.  Tools include a set of
36conventions about how programs should be written to support message
37catalogs, a directory and file naming organization for the message
38catalogs, a runtime library which supports the retrieval of translated
39messages, and stand-alone programs for handling the translatable and
40the already translated strings.  Gettext provides an easy to use
41library and tools for creating, using, and modifying natural language
42catalogs and is a powerful and simple method for internationalizing
43programs.
44
45%description -l ja
46GNU gettext パッケージはプログラム中でマルチリンガルメッセージを生成する
47ためのツールと文書を提供します. ツールはメッセージカタログをサポートするために
48プログラムがどのように書かれるべきかの申し合わせと, メッセージカタログのための
49ディレクトリとファイル名の組織化と, 翻訳されたメッセージの埋め合わせを
50サポートするためのランタイムライブラリと, 翻訳可能でかつすでに翻訳された文字列
51を取り扱う独立したプログラムを含みます. gettext は簡単に使えるライブラリ
52と自然言語のカタログを生成, 使用, 修正するツールと, 国際化プログラム
53のための強力かつシンプルな方法を提供します.
54
55%package devel
56Summary: Development files for gettext
57Summary(ja): gettext 用開発ファイル
58Group: Development/Tools
59License: LGPLv2+
60Requires: %{name} = %{version}-%{release}
61Requires: %{name}-libs = %{version}-%{release}
62Requires(post): /sbin/install-info
63Requires(preun): /sbin/install-info
64
65
66%description devel
67This package contains all development related files necessary for
68developing or compiling applications/libraries that needs
69internationalization capability. You also need this package if you
70want to add gettext support for your project.
71
72%description devel -l ja
73このパッケージには、マルチリンガル機能を持つアプリケーションや
74ライブラリを開発・コンパイルするのに必要な開発関連ファイルが収録
75されています。
76
77
78%package libs
79Summary: Libraries for gettext
80Summary(ja): gettext 用共有ライブラリ
81Group: System Environment/Libraries
82License: LGPLv2+
83
84
85%description libs
86This package contains libraries used internationalization support.
87
88%description libs -l ja
89このパッケージには国際化サポートに必要な共有ライブラリが収録されています。
90
91
92%prep
93%setup -q
94# %patch5 -p0 -b .5-open-args~
95# %patch6 -p0 -b .6-autopoint~
96# %patch7 -p0 -b .rpathFix~
97# %patch8 -p0 -b .unicode~
98
99
100%build
101## running autoreconf for automake-1.11.1
102autoreconf -fi
103[ -f  /usr/share/automake/depcomp ] && cp -f /usr/share/automake/{depcomp,ylwrap} . || :
104%configure --without-included-gettext --enable-nls \
105        --enable-shared --disable-static --with-pic=yes \
106        --disable-csharp --disable-java
107make %{?_smp_mflags}
108
109
110%install
111rm -rf $RPM_BUILD_ROOT
112
113# Fix busted no-emacs install for $lispdir/po-mode.el
114%makeinstall lispdir=%{buildroot}/usr/share/emacs/site-lisp \
115    aclocaldir=%{buildroot}/usr/share/aclocal
116
117# delete po-mode
118%{__rm} -rf %{buildroot}/usr/share/emacs/site-lisp
119
120mkdir -p %{buildroot}/bin
121mv %{buildroot}/%{_bindir}/gettext %{buildroot}/bin
122ln -s ../../bin/gettext %{buildroot}/%{_bindir}/gettext
123install -m 755 %{SOURCE2} $RPM_BUILD_ROOT/%{_bindir}/msghack
124
125pushd %{buildroot}
126rm -f .%{_infodir}/dir .%{_includedir}/libintl.h
127popd
128
129%find_lang %{name}-runtime
130%find_lang %{name}-tools
131cat %{name}-*.lang > %{name}.lang
132
133# remove unpackaged files from the buildroot
134rm -rf $RPM_BUILD_ROOT/usr/share/doc
135rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
136rm -f $RPM_BUILD_ROOT%{_datadir}/locale/locale.alias
137
138%__rm -rf %{buildroot}%{_docdir}/%{name}
139
140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144
145%post
146/sbin/ldconfig
147/sbin/install-info %{_infodir}/gettext.info.gz %{_infodir}/dir || :
148
149
150%preun
151if [ "$1" = 0 ]; then
152    /sbin/install-info --delete %{_infodir}/gettext.info.gz %{_infodir}/dir || :
153fi
154exit 0
155
156%postun -p /sbin/ldconfig
157
158
159%post devel
160/sbin/ldconfig
161/sbin/install-info %{_infodir}/autosprintf.info %{_infodir}/dir || :
162
163%preun devel
164if [ "$1" = 0 ]; then
165    /sbin/install-info --delete %{_infodir}/autosprintf.info %{_infodir}/dir || :
166fi
167
168%postun devel -p /sbin/ldconfig
169
170
171%post libs -p /sbin/ldconfig
172%postun libs -p /sbin/ldconfig
173
174
175%files -f gettext.lang
176%defattr(-,root,root,-)
177%doc gettext-runtime/ABOUT-NLS AUTHORS gettext-runtime/BUGS
178%doc COPYING ChangeLog gettext-tools/misc/DISCLAIM README
179%doc NEWS THANKS
180%doc gettext-runtime/man/*.1.html
181%doc gettext-runtime/intl/COPYING*
182/bin/*
183%{_bindir}/*
184%{_libdir}/libgettextlib-%{so_ver}.so
185%{_libdir}/libgettextsrc-%{so_ver}.so
186%{_infodir}/gettext*
187%{_mandir}/man1/*
188%{_libdir}/gettext
189%{_datadir}/gettext/archive*.tar.gz
190%{_datadir}/gettext/styles
191
192%files devel
193%defattr(-,root,root,-)
194%doc gettext-runtime/man/*.3.html ChangeLog
195%{_datadir}/gettext/ABOUT-NLS
196%{_datadir}/gettext/projects/
197%{_datadir}/gettext/config.rpath
198%{_datadir}/gettext/*.h
199%{_datadir}/gettext/intl
200%{_datadir}/gettext/po
201%{_datadir}/gettext/msgunfmt.tcl
202%{_datadir}/aclocal/*
203%{_includedir}/*
204%{_infodir}/autosprintf*
205%{_libdir}/libasprintf.so
206%{_libdir}/libgettextpo.so
207%{_libdir}/libgettextlib.so
208%{_libdir}/libgettextsrc.so
209%{_libdir}/preloadable_libintl.so
210%{_mandir}/man3/*
211%{_datadir}/%{name}/javaversion.class
212%doc gettext-runtime/intl-java/javadoc*
213
214
215%files libs
216%defattr(-,root,root,-)
217
218%{_libdir}/libasprintf.so.*
219%{_libdir}/libgettextpo.so.*
220
221
222%changelog
223* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 0.18.1.1-1
224- new upstream release
225- drop old patches
226- update msghack.py from fc14
227- add BRs: libacl-devel, libcroco-devel
228- fix files list
229
230* Wed Feb 24 2010 IWAI, Masaharu <iwai@alib.jp> - 0.17-5
231- split to po-mode package: [VineSeed:20076]
232- update Packager value: update format
233- running autoreconf for automake-1.11.1 in %%build
234
235* Tue Dec 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> - 0.17-4
236- correct some output messages on po-mode-install.sh
237- use %%emacsen_pkgdir
238
239* Sun May 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.17-3
240- we better not to use BuildConflicts very often :-P
241  instead we pass --disable-java to configure here
242- add --enable-shared --disable-static --without-included-gettext to configure
243- remove .la files
244- add -devel and --libs subpackages
245
246* Wed May  6 2009 IWAI, Masaharu <iwai@alib.jp> 0.17-2
247- apply vine-default
248  - update po-mode-init.el (Source1)
249  - update po-mode-install.sh (Source3)
250  - update po-mode-remove.sh (Source4)
251  - add vine-default-po-mode.el (Source5): based 0.17-1's po-mode-init.el
252- update %%doc: gettext-runtime/libasprintf/autosprintf_all.html
253
254* Sat Aug 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-1
255- new upstream release
256
257* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.1-1vl5
258- applied new versioning policy, spec in utf-8
259
260* Wed Jan 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl2
261- changelog update missing
262
263* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl1
264- new upstream release
265
266* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl6
267- changed po-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
268
269* Mon Aug 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl5
270- add BuildConflicts: libgcj34-devel not to depend on libgcj34
271
272* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl4
273- add BuildConflicts: libgcj-devel not to depend on libgcj
274- add BuildRequires: emacsen (if emacsen_pkg is enabled)
275- remove unneeded files at the %%install
276
277* Mon Aug 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl3
278- rebuilt without libgcj package
279
280* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl2
281- modified emacsen-common path
282
283* Wed Jun 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl1
284- new upstream release
285- updated Source3
286- added --disable-csharp
287
288* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl2
289- remove dependency to libgcj
290
291* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl1
292- new upstream release
293
294* Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 0.12.1-1vl2
295- build without libgcj package
296- create po-mode package for Emacsen
297
298* Sun Sep 21 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.1-1vl1
299- based on Redhat Rawhide 0.12.1-1
300- dropped all patches (Rawhide does so)
301- Source100(ja.po) is much older than source, dropped
302- s/Copyright/License/
303
304* Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.5-0vl1
305- new upstream release
306
307* Mon Jun 10 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
308- sync with rawhide 0.11.2-2 and Mandrake 0.11.2-4mdk
309
310* Wed Jun  7 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
311- sync with RH6.2
312
313* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
314- minor configure tweaks for ia64
315
316* Sun Feb 27 2000 Cristian Gafton <gafton@redhat.com>
317- add --comments to msghack
318
319* Thu Feb 10 2000 Cristian Gafton <gafton@redhat.com>
320- fix bug #9240 - gettextize has the right aclocal patch
321
322* Wed Jan 12 2000 Cristian Gafton <gafton@redhat.com>
323- add the --diff and --dummy options
324
325* Wed Oct 06 1999 Cristian Gafton <gafton@redhat.com>
326- add the --missing option to msghack
327
328* Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
329- updated msghack not to merge in fuzzies in the master catalogs
330
331* Sat Sep 18 1999 Norihito Ohmori <ohmori@flatout.org>
332- update ja.po
333
334* Tue Sep 14 1999 Jun Nishii <jun@flatout.org>
335- use message.c.diff-2
336
337* Thu Aug 26 1999 Cristian Gafton <gafton@redhat.com>
338- updated msghack to understand --append
339
340* Wed Aug 11 1999 Cristian Gafton <gafton@redhat.com>
341- updated msghack to correctly deal with sorting files
342
343* Tue Jun 29 1999 Norihito Ohmori <ohmori@flatout.org>
344- added multibyte patch for msgmerge
345
346* Sun Jun 27 1999 Norihito Ohmori <ohmori@flatout.org>
347- ja locale support from JaPO Project
348
349* Thu May 06 1999 Cristian Gafton <gafton@redhat.com>
350- msghack updates
351
352* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
353- auto rebuild in the new build environment (release 8)
354
355* Mon Mar 08 1999 Cristian Gafton <gafton@redhat.com>
356- added patch for misc hacks to facilitate rpm translations
357
358* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
359- patch to allow to build on ARM
360
361* Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
362- add Emacs po-mode.el files.
363
364* Sun Sep 13 1998 Cristian Gafton <gafton@redhat.com>
365- include the aclocal support files
366
367* Fri Sep  3 1998 Bill Nottingham <notting@redhat.com>
368- remove devel package (functionality is in glibc)
369
370* Tue Sep  1 1998 Jeff Johnson <jbj@redhat.com>
371- update to 0.10.35.
372
373* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
374- add gettextize.
375- create devel package for libintl.a and libgettext.h.
376
377* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
378- translations modified for de, fr, tr
379
380* Sun Nov 02 1997 Cristian Gafton <gafton@redhat.com>
381- added info handling
382- added misc-patch (skip emacs-lisp modofications)
383
384* Sat Nov 01 1997 Erik Troan <ewt@redhat.com>
385- removed locale.aliases as we get it from glibc now
386- uses a buildroot
387
388* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
389- Built against glibc
Note: See TracBrowser for help on using the repository browser.