source: projects/specs/trunk/g/gettext/gettext-vl.spec @ 7536

Revision 7536, 12.1 KB checked in by kudoh, 11 years ago (diff)

--force-log

Line 
1%define libtoolize :
2
3%define src_ver 0.18.2.1
4%define so_ver 0.18.2
5
6Summary: GNU libraries and utilities for producing multi-lingual messages.
7Summary(ja): マルチリンガルメッセージを生成するためのGNU ライブラリ/ユーティリティ
8Name: gettext
9Version: %{src_ver}
10Release: 1%{?_dist_release}
11License: GPLv3 and LGPLv2+
12Group: Development/Tools
13Source: ftp://ftp.gnu.org/gnu/gettext/%{name}-%{version}.tar.gz
14URL: http://www.gnu.org/software/gettext/
15Source2: msghack.py
16# Patch5: gettext-0.17-open-args.patch
17# Patch6: gettext-0.17-autopoint-CVS-441481.patch
18# Patch7: gettext-0.17-rpathFix.patch
19# Patch8: gettext-xgettext-python-unicode-surrogate-473946.patch
20
21BuildRequires: libtool, bison, gcc-c++
22BuildRequires: expat-devel
23BuildRequires: libacl-devel, libcroco-devel
24
25Requires(post): /sbin/install-info
26Requires(preun): /sbin/install-info
27Buildroot: %{_tmppath}/%{name}-%{version}-root
28
29Packager: daisuke
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34The GNU gettext package provides a set of tools and documentation for
35producing multi-lingual messages in programs.  Tools include a set of
36conventions about how programs should be written to support message
37catalogs, a directory and file naming organization for the message
38catalogs, a runtime library which supports the retrieval of translated
39messages, and stand-alone programs for handling the translatable and
40the already translated strings.  Gettext provides an easy to use
41library and tools for creating, using, and modifying natural language
42catalogs and is a powerful and simple method for internationalizing
43programs.
44
45%description -l ja
46GNU gettext パッケージはプログラム中でマルチリンガルメッセージを生成する
47ためのツールと文書を提供します. ツールはメッセージカタログをサポートするために
48プログラムがどのように書かれるべきかの申し合わせと, メッセージカタログのための
49ディレクトリとファイル名の組織化と, 翻訳されたメッセージの埋め合わせを
50サポートするためのランタイムライブラリと, 翻訳可能でかつすでに翻訳された文字列
51を取り扱う独立したプログラムを含みます. gettext は簡単に使えるライブラリ
52と自然言語のカタログを生成, 使用, 修正するツールと, 国際化プログラム
53のための強力かつシンプルな方法を提供します.
54
55%package devel
56Summary: Development files for gettext
57Summary(ja): gettext 用開発ファイル
58Group: Development/Tools
59License: LGPLv2+
60Requires: %{name} = %{version}-%{release}
61Requires: %{name}-libs = %{version}-%{release}
62Requires(post): /sbin/install-info
63Requires(preun): /sbin/install-info
64
65
66%description devel
67This package contains all development related files necessary for
68developing or compiling applications/libraries that needs
69internationalization capability. You also need this package if you
70want to add gettext support for your project.
71
72%description devel -l ja
73このパッケージには、マルチリンガル機能を持つアプリケーションや
74ライブラリを開発・コンパイルするのに必要な開発関連ファイルが収録
75されています。
76
77
78%package libs
79Summary: Libraries for gettext
80Summary(ja): gettext 用共有ライブラリ
81Group: System Environment/Libraries
82License: LGPLv2+
83
84
85%description libs
86This package contains libraries used internationalization support.
87
88%description libs -l ja
89このパッケージには国際化サポートに必要な共有ライブラリが収録されています。
90
91
92%prep
93%setup -q
94# %patch5 -p0 -b .5-open-args~
95# %patch6 -p0 -b .6-autopoint~
96# %patch7 -p0 -b .rpathFix~
97# %patch8 -p0 -b .unicode~
98
99
100%build
101## running autoreconf for automake-1.11.1
102autoreconf -fi
103[ -f  /usr/share/automake/depcomp ] && cp -f /usr/share/automake/{depcomp,ylwrap} . || :
104%configure --without-included-gettext --enable-nls \
105        --enable-shared --disable-static --with-pic=yes \
106        --disable-csharp --disable-java
107make %{?_smp_mflags}
108
109
110%install
111rm -rf $RPM_BUILD_ROOT
112
113# Fix busted no-emacs install for $lispdir/po-mode.el
114%makeinstall lispdir=%{buildroot}/usr/share/emacs/site-lisp \
115    aclocaldir=%{buildroot}/usr/share/aclocal
116
117# delete po-mode
118%{__rm} -rf %{buildroot}/usr/share/emacs/site-lisp
119
120mkdir -p %{buildroot}/bin
121mv %{buildroot}/%{_bindir}/gettext %{buildroot}/bin
122ln -s ../../bin/gettext %{buildroot}/%{_bindir}/gettext
123install -m 755 %{SOURCE2} $RPM_BUILD_ROOT/%{_bindir}/msghack
124
125pushd %{buildroot}
126rm -f .%{_infodir}/dir .%{_includedir}/libintl.h
127popd
128
129%find_lang %{name}-runtime
130%find_lang %{name}-tools
131cat %{name}-*.lang > %{name}.lang
132
133# remove unpackaged files from the buildroot
134rm -rf $RPM_BUILD_ROOT/usr/share/doc
135rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
136rm -f $RPM_BUILD_ROOT%{_datadir}/locale/locale.alias
137
138%__rm -rf %{buildroot}%{_docdir}/%{name}
139
140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144
145%post
146/sbin/ldconfig
147/sbin/install-info %{_infodir}/gettext.info.gz %{_infodir}/dir || :
148
149
150%preun
151if [ "$1" = 0 ]; then
152    /sbin/install-info --delete %{_infodir}/gettext.info.gz %{_infodir}/dir || :
153fi
154exit 0
155
156%postun -p /sbin/ldconfig
157
158
159%post devel
160/sbin/ldconfig
161/sbin/install-info %{_infodir}/autosprintf.info %{_infodir}/dir || :
162
163%preun devel
164if [ "$1" = 0 ]; then
165    /sbin/install-info --delete %{_infodir}/autosprintf.info %{_infodir}/dir || :
166fi
167
168%postun devel -p /sbin/ldconfig
169
170
171%post libs -p /sbin/ldconfig
172%postun libs -p /sbin/ldconfig
173
174
175%files -f gettext.lang
176%defattr(-,root,root,-)
177%doc gettext-runtime/ABOUT-NLS AUTHORS gettext-runtime/BUGS
178%doc COPYING ChangeLog gettext-tools/misc/DISCLAIM README
179%doc NEWS THANKS
180%doc gettext-runtime/man/*.1.html
181%doc gettext-runtime/intl/COPYING*
182/bin/*
183%{_bindir}/*
184%{_libdir}/libgettextlib-%{so_ver}.so
185%{_libdir}/libgettextsrc-%{so_ver}.so
186%{_infodir}/gettext*
187%{_mandir}/man1/*
188%{_libdir}/gettext
189%{_datadir}/gettext/archive.dir.tar.xz
190%{_datadir}/gettext/styles
191
192%files devel
193%defattr(-,root,root,-)
194%doc gettext-runtime/man/*.3.html ChangeLog
195%{_datadir}/gettext/ABOUT-NLS
196%{_datadir}/gettext/projects/
197%{_datadir}/gettext/config.rpath
198%{_datadir}/gettext/*.h
199%{_datadir}/gettext/intl
200%{_datadir}/gettext/po
201%{_datadir}/gettext/msgunfmt.tcl
202%{_datadir}/aclocal/*
203%{_includedir}/*
204%{_infodir}/autosprintf*
205%{_libdir}/libasprintf.so
206%{_libdir}/libgettextpo.so
207%{_libdir}/libgettextlib.so
208%{_libdir}/libgettextsrc.so
209%{_libdir}/preloadable_libintl.so
210%{_mandir}/man3/*
211%{_datadir}/%{name}/javaversion.class
212%doc gettext-runtime/intl-java/javadoc*
213
214
215%files libs
216%defattr(-,root,root,-)
217
218%{_libdir}/libasprintf.so.*
219%{_libdir}/libgettextpo.so.*
220
221
222%changelog
223* Thu Mar 07 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.18.2.1-1
224- new upstream release
225
226* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 0.18.1.1-1
227- new upstream release
228- drop old patches
229- update msghack.py from fc14
230- add BRs: libacl-devel, libcroco-devel
231- fix files list
232
233* Wed Feb 24 2010 IWAI, Masaharu <iwai@alib.jp> - 0.17-5
234- split to po-mode package: [VineSeed:20076]
235- update Packager value: update format
236- running autoreconf for automake-1.11.1 in %%build
237
238* Tue Dec 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> - 0.17-4
239- correct some output messages on po-mode-install.sh
240- use %%emacsen_pkgdir
241
242* Sun May 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.17-3
243- we better not to use BuildConflicts very often :-P
244  instead we pass --disable-java to configure here
245- add --enable-shared --disable-static --without-included-gettext to configure
246- remove .la files
247- add -devel and --libs subpackages
248
249* Wed May  6 2009 IWAI, Masaharu <iwai@alib.jp> 0.17-2
250- apply vine-default
251  - update po-mode-init.el (Source1)
252  - update po-mode-install.sh (Source3)
253  - update po-mode-remove.sh (Source4)
254  - add vine-default-po-mode.el (Source5): based 0.17-1's po-mode-init.el
255- update %%doc: gettext-runtime/libasprintf/autosprintf_all.html
256
257* Sat Aug 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-1
258- new upstream release
259
260* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.1-1vl5
261- applied new versioning policy, spec in utf-8
262
263* Wed Jan 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl2
264- changelog update missing
265
266* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl1
267- new upstream release
268
269* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl6
270- changed po-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
271
272* Mon Aug 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl5
273- add BuildConflicts: libgcj34-devel not to depend on libgcj34
274
275* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl4
276- add BuildConflicts: libgcj-devel not to depend on libgcj
277- add BuildRequires: emacsen (if emacsen_pkg is enabled)
278- remove unneeded files at the %%install
279
280* Mon Aug 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl3
281- rebuilt without libgcj package
282
283* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl2
284- modified emacsen-common path
285
286* Wed Jun 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl1
287- new upstream release
288- updated Source3
289- added --disable-csharp
290
291* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl2
292- remove dependency to libgcj
293
294* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl1
295- new upstream release
296
297* Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 0.12.1-1vl2
298- build without libgcj package
299- create po-mode package for Emacsen
300
301* Sun Sep 21 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.1-1vl1
302- based on Redhat Rawhide 0.12.1-1
303- dropped all patches (Rawhide does so)
304- Source100(ja.po) is much older than source, dropped
305- s/Copyright/License/
306
307* Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.5-0vl1
308- new upstream release
309
310* Mon Jun 10 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
311- sync with rawhide 0.11.2-2 and Mandrake 0.11.2-4mdk
312
313* Wed Jun  7 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
314- sync with RH6.2
315
316* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
317- minor configure tweaks for ia64
318
319* Sun Feb 27 2000 Cristian Gafton <gafton@redhat.com>
320- add --comments to msghack
321
322* Thu Feb 10 2000 Cristian Gafton <gafton@redhat.com>
323- fix bug #9240 - gettextize has the right aclocal patch
324
325* Wed Jan 12 2000 Cristian Gafton <gafton@redhat.com>
326- add the --diff and --dummy options
327
328* Wed Oct 06 1999 Cristian Gafton <gafton@redhat.com>
329- add the --missing option to msghack
330
331* Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
332- updated msghack not to merge in fuzzies in the master catalogs
333
334* Sat Sep 18 1999 Norihito Ohmori <ohmori@flatout.org>
335- update ja.po
336
337* Tue Sep 14 1999 Jun Nishii <jun@flatout.org>
338- use message.c.diff-2
339
340* Thu Aug 26 1999 Cristian Gafton <gafton@redhat.com>
341- updated msghack to understand --append
342
343* Wed Aug 11 1999 Cristian Gafton <gafton@redhat.com>
344- updated msghack to correctly deal with sorting files
345
346* Tue Jun 29 1999 Norihito Ohmori <ohmori@flatout.org>
347- added multibyte patch for msgmerge
348
349* Sun Jun 27 1999 Norihito Ohmori <ohmori@flatout.org>
350- ja locale support from JaPO Project
351
352* Thu May 06 1999 Cristian Gafton <gafton@redhat.com>
353- msghack updates
354
355* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
356- auto rebuild in the new build environment (release 8)
357
358* Mon Mar 08 1999 Cristian Gafton <gafton@redhat.com>
359- added patch for misc hacks to facilitate rpm translations
360
361* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
362- patch to allow to build on ARM
363
364* Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
365- add Emacs po-mode.el files.
366
367* Sun Sep 13 1998 Cristian Gafton <gafton@redhat.com>
368- include the aclocal support files
369
370* Fri Sep  3 1998 Bill Nottingham <notting@redhat.com>
371- remove devel package (functionality is in glibc)
372
373* Tue Sep  1 1998 Jeff Johnson <jbj@redhat.com>
374- update to 0.10.35.
375
376* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
377- add gettextize.
378- create devel package for libintl.a and libgettext.h.
379
380* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
381- translations modified for de, fr, tr
382
383* Sun Nov 02 1997 Cristian Gafton <gafton@redhat.com>
384- added info handling
385- added misc-patch (skip emacs-lisp modofications)
386
387* Sat Nov 01 1997 Erik Troan <ewt@redhat.com>
388- removed locale.aliases as we get it from glibc now
389- uses a buildroot
390
391* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
392- Built against glibc
Note: See TracBrowser for help on using the repository browser.