source: projects/specs/trunk/g/gettext/gettext-vl.spec @ 521

Revision 521, 11.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define libtoolize :
2
3Summary: GNU libraries and utilities for producing multi-lingual messages.
4Summary(ja): マルチリンガルメッセージを生成するためのGNU ライブラリ/ユーティリティ
5Name: gettext
6Version: 0.17
7Release: 5%{?_dist_release}
8License: GPLv3 and LGPLv2+
9Group: Development/Tools
10Source: ftp://ftp.gnu.org/gnu/gettext/%{name}-%{version}.tar.gz
11URL: http://www.gnu.org/software/gettext/
12Source2: msghack.py
13Patch5: gettext-0.17-open-args.patch
14Patch6: gettext-0.17-autopoint-CVS-441481.patch
15Patch7: gettext-0.17-rpathFix.patch
16Patch8: gettext-xgettext-python-unicode-surrogate-473946.patch
17
18BuildRequires: libtool, bison, gcc-c++
19BuildRequires: expat-devel
20
21Requires(post): /sbin/install-info
22Requires(preun): /sbin/install-info
23Buildroot: %{_tmppath}/%{name}-%{version}-root
24
25Packager: daisuke
26Vendor: Project Vine
27Distribution: Vine Linux
28
29%description
30The GNU gettext package provides a set of tools and documentation for
31producing multi-lingual messages in programs.  Tools include a set of
32conventions about how programs should be written to support message
33catalogs, a directory and file naming organization for the message
34catalogs, a runtime library which supports the retrieval of translated
35messages, and stand-alone programs for handling the translatable and
36the already translated strings.  Gettext provides an easy to use
37library and tools for creating, using, and modifying natural language
38catalogs and is a powerful and simple method for internationalizing
39programs.
40
41%description -l ja
42GNU gettext パッケージはプログラム中でマルチリンガルメッセージを生成する
43ためのツールと文書を提供します. ツールはメッセージカタログをサポートするために
44プログラムがどのように書かれるべきかの申し合わせと, メッセージカタログのための
45ディレクトリとファイル名の組織化と, 翻訳されたメッセージの埋め合わせを
46サポートするためのランタイムライブラリと, 翻訳可能でかつすでに翻訳された文字列
47を取り扱う独立したプログラムを含みます. gettext は簡単に使えるライブラリ
48と自然言語のカタログを生成, 使用, 修正するツールと, 国際化プログラム
49のための強力かつシンプルな方法を提供します.
50
51%package devel
52Summary: Development files for gettext
53Summary(ja): gettext 用開発ファイル
54Group: Development/Tools
55License: LGPLv2+
56Requires: %{name} = %{version}-%{release}
57Requires: %{name}-libs = %{version}-%{release}
58Requires(post): /sbin/install-info
59Requires(preun): /sbin/install-info
60
61
62%description devel
63This package contains all development related files necessary for
64developing or compiling applications/libraries that needs
65internationalization capability. You also need this package if you
66want to add gettext support for your project.
67
68%description devel -l ja
69このパッケージには、マルチリンガル機能を持つアプリケーションや
70ライブラリを開発・コンパイルするのに必要な開発関連ファイルが収録
71されています。
72
73
74%package libs
75Summary: Libraries for gettext
76Summary(ja): gettext 用共有ライブラリ
77Group: System Environment/Libraries
78License: LGPLv2+
79
80
81%description libs
82This package contains libraries used internationalization support.
83
84%description libs -l ja
85このパッケージには国際化サポートに必要な共有ライブラリが収録されています。
86
87
88%prep
89%setup -q
90%patch5 -p0 -b .5-open-args~
91%patch6 -p0 -b .6-autopoint~
92%patch7 -p0 -b .rpathFix~
93%patch8 -p0 -b .unicode~
94
95
96%build
97## running autoreconf for automake-1.11.1
98autoreconf -fi
99[ -f  /usr/share/automake/depcomp ] && cp -f /usr/share/automake/{depcomp,ylwrap} . || :
100%configure --without-included-gettext --enable-nls \
101        --enable-shared --disable-static --with-pic=yes \
102        --disable-csharp --disable-java
103make %{?_smp_mflags}
104
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109# Fix busted no-emacs install for $lispdir/po-mode.el
110%makeinstall lispdir=%{buildroot}/usr/share/emacs/site-lisp \
111    aclocaldir=%{buildroot}/usr/share/aclocal
112
113# delete po-mode
114%{__rm} -rf %{buildroot}/usr/share/emacs/site-lisp
115
116mkdir -p %{buildroot}/bin
117mv %{buildroot}/%{_bindir}/gettext %{buildroot}/bin
118ln -s ../../bin/gettext %{buildroot}/%{_bindir}/gettext
119install -m 755 %{SOURCE2} $RPM_BUILD_ROOT/%{_bindir}/msghack
120
121pushd %{buildroot}
122rm -f .%{_infodir}/dir .%{_includedir}/libintl.h
123popd
124
125%find_lang %{name}-runtime
126%find_lang %{name}-tools
127cat %{name}-*.lang > %{name}.lang
128
129# remove unpackaged files from the buildroot
130rm -rf $RPM_BUILD_ROOT/usr/share/doc
131rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
132rm -f $RPM_BUILD_ROOT%{_datadir}/locale/locale.alias
133
134%__rm -rf %{buildroot}%{_docdir}/%{name}
135
136
137%clean
138rm -rf $RPM_BUILD_ROOT
139
140
141%post
142/sbin/ldconfig
143/sbin/install-info %{_infodir}/gettext.info.gz %{_infodir}/dir || :
144
145
146%preun
147if [ "$1" = 0 ]; then
148    /sbin/install-info --delete %{_infodir}/gettext.info.gz %{_infodir}/dir || :
149fi
150exit 0
151
152%postun -p /sbin/ldconfig
153
154
155%post devel
156/sbin/ldconfig
157/sbin/install-info %{_infodir}/autosprintf.info %{_infodir}/dir || :
158
159%preun devel
160if [ "$1" = 0 ]; then
161    /sbin/install-info --delete %{_infodir}/autosprintf.info %{_infodir}/dir || :
162fi
163
164%postun devel -p /sbin/ldconfig
165
166
167%post libs -p /sbin/ldconfig
168%postun libs -p /sbin/ldconfig
169
170
171%files -f gettext.lang
172%defattr(-,root,root,-)
173%doc gettext-runtime/ABOUT-NLS AUTHORS gettext-runtime/BUGS
174%doc COPYING ChangeLog gettext-tools/misc/DISCLAIM README
175%doc NEWS THANKS
176%doc gettext-runtime/man/*.1.html
177%doc gettext-runtime/intl/COPYING*
178/bin/*
179%{_bindir}/*
180%{_libdir}/libgettextlib-%{version}.so
181%{_libdir}/libgettextsrc-%{version}.so
182%{_infodir}/gettext*
183%{_mandir}/man1/*
184%{_libdir}/gettext
185%{_datadir}/gettext/archive.tar.gz
186%{_datadir}/gettext/styles
187
188%files devel
189%defattr(-,root,root,-)
190%doc gettext-runtime/man/*.3.html ChangeLog
191%{_datadir}/gettext/ABOUT-NLS
192%{_datadir}/gettext/projects/
193%{_datadir}/gettext/config.rpath
194%{_datadir}/gettext/*.h
195%{_datadir}/gettext/intl
196%{_datadir}/gettext/po
197%{_datadir}/gettext/msgunfmt.tcl
198%{_datadir}/aclocal/*
199%{_includedir}/*
200%{_infodir}/autosprintf*
201%{_libdir}/libasprintf.so
202%{_libdir}/libgettextpo.so
203%{_libdir}/libgettextlib.so
204%{_libdir}/libgettextsrc.so
205%{_libdir}/preloadable_libintl.so
206%{_mandir}/man3/*
207%{_datadir}/%{name}/javaversion.class
208%doc gettext-runtime/intl-java/javadoc*
209
210
211%files libs
212%defattr(-,root,root,-)
213
214%{_libdir}/libasprintf.so.*
215%{_libdir}/libgettextpo.so.*
216
217
218%changelog
219* Wed Feb 24 2010 IWAI, Masaharu <iwai@alib.jp> - 0.17-5
220- split to po-mode package: [VineSeed:20076]
221- update Packager value: update format
222- running autoreconf for automake-1.11.1 in %%build
223
224* Tue Dec 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> - 0.17-4
225- correct some output messages on po-mode-install.sh
226- use %%emacsen_pkgdir
227
228* Sun May 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.17-3
229- we better not to use BuildConflicts very often :-P
230  instead we pass --disable-java to configure here
231- add --enable-shared --disable-static --without-included-gettext to configure
232- remove .la files
233- add -devel and --libs subpackages
234
235* Wed May  6 2009 IWAI, Masaharu <iwai@alib.jp> 0.17-2
236- apply vine-default
237  - update po-mode-init.el (Source1)
238  - update po-mode-install.sh (Source3)
239  - update po-mode-remove.sh (Source4)
240  - add vine-default-po-mode.el (Source5): based 0.17-1's po-mode-init.el
241- update %%doc: gettext-runtime/libasprintf/autosprintf_all.html
242
243* Sat Aug 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-1
244- new upstream release
245
246* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.1-1vl5
247- applied new versioning policy, spec in utf-8
248
249* Wed Jan 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl2
250- changelog update missing
251
252* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl1
253- new upstream release
254
255* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl6
256- changed po-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
257
258* Mon Aug 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl5
259- add BuildConflicts: libgcj34-devel not to depend on libgcj34
260
261* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl4
262- add BuildConflicts: libgcj-devel not to depend on libgcj
263- add BuildRequires: emacsen (if emacsen_pkg is enabled)
264- remove unneeded files at the %%install
265
266* Mon Aug 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl3
267- rebuilt without libgcj package
268
269* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl2
270- modified emacsen-common path
271
272* Wed Jun 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl1
273- new upstream release
274- updated Source3
275- added --disable-csharp
276
277* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl2
278- remove dependency to libgcj
279
280* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl1
281- new upstream release
282
283* Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 0.12.1-1vl2
284- build without libgcj package
285- create po-mode package for Emacsen
286
287* Sun Sep 21 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.1-1vl1
288- based on Redhat Rawhide 0.12.1-1
289- dropped all patches (Rawhide does so)
290- Source100(ja.po) is much older than source, dropped
291- s/Copyright/License/
292
293* Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.5-0vl1
294- new upstream release
295
296* Mon Jun 10 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
297- sync with rawhide 0.11.2-2 and Mandrake 0.11.2-4mdk
298
299* Wed Jun  7 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
300- sync with RH6.2
301
302* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
303- minor configure tweaks for ia64
304
305* Sun Feb 27 2000 Cristian Gafton <gafton@redhat.com>
306- add --comments to msghack
307
308* Thu Feb 10 2000 Cristian Gafton <gafton@redhat.com>
309- fix bug #9240 - gettextize has the right aclocal patch
310
311* Wed Jan 12 2000 Cristian Gafton <gafton@redhat.com>
312- add the --diff and --dummy options
313
314* Wed Oct 06 1999 Cristian Gafton <gafton@redhat.com>
315- add the --missing option to msghack
316
317* Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
318- updated msghack not to merge in fuzzies in the master catalogs
319
320* Sat Sep 18 1999 Norihito Ohmori <ohmori@flatout.org>
321- update ja.po
322
323* Tue Sep 14 1999 Jun Nishii <jun@flatout.org>
324- use message.c.diff-2
325
326* Thu Aug 26 1999 Cristian Gafton <gafton@redhat.com>
327- updated msghack to understand --append
328
329* Wed Aug 11 1999 Cristian Gafton <gafton@redhat.com>
330- updated msghack to correctly deal with sorting files
331
332* Tue Jun 29 1999 Norihito Ohmori <ohmori@flatout.org>
333- added multibyte patch for msgmerge
334
335* Sun Jun 27 1999 Norihito Ohmori <ohmori@flatout.org>
336- ja locale support from JaPO Project
337
338* Thu May 06 1999 Cristian Gafton <gafton@redhat.com>
339- msghack updates
340
341* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
342- auto rebuild in the new build environment (release 8)
343
344* Mon Mar 08 1999 Cristian Gafton <gafton@redhat.com>
345- added patch for misc hacks to facilitate rpm translations
346
347* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
348- patch to allow to build on ARM
349
350* Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
351- add Emacs po-mode.el files.
352
353* Sun Sep 13 1998 Cristian Gafton <gafton@redhat.com>
354- include the aclocal support files
355
356* Fri Sep  3 1998 Bill Nottingham <notting@redhat.com>
357- remove devel package (functionality is in glibc)
358
359* Tue Sep  1 1998 Jeff Johnson <jbj@redhat.com>
360- update to 0.10.35.
361
362* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
363- add gettextize.
364- create devel package for libintl.a and libgettext.h.
365
366* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
367- translations modified for de, fr, tr
368
369* Sun Nov 02 1997 Cristian Gafton <gafton@redhat.com>
370- added info handling
371- added misc-patch (skip emacs-lisp modofications)
372
373* Sat Nov 01 1997 Erik Troan <ewt@redhat.com>
374- removed locale.aliases as we get it from glibc now
375- uses a buildroot
376
377* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
378- Built against glibc
Note: See TracBrowser for help on using the repository browser.