source: projects/specs/branches/6/f/flex/flex-vl.spec @ 3396

Revision 3396, 6.5 KB checked in by inagaki, 13 years ago (diff)

update: flex, psmisc

Line 
1Summary: A tool for creating scanners (text pattern recognizers).
2Summary(ja): スキャナ (テキストパターン認識器) 作成ツール
3Name: flex
4Version: 2.5.35
5Release: 3%{?_dist_release}
6
7Group: Development/Tools
8License: BSD
9URL: http://flex.sourceforge.net/
10
11Source: flex-%{version}.tar.bz2
12Patch0: flex-2.5.35-sign.patch
13Patch1: flex-2.5.35-hardening.patch
14Patch2: flex-2.5.35-gcc44.patch
15Patch3: flex-2.5.35-missing-prototypes.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: gettext bison m4
19Requires: m4
20Requires(post): /sbin/install-info
21Requires(preun): /sbin/install-info
22
23%description
24The flex program generates scanners.  Scanners are programs which can
25recognize lexical patterns in text.  Flex takes pairs of regular
26expressions and C code as input and generates a C source file as
27output.  The output file is compiled and linked with a library to
28produce an executable.  The executable searches through its input for
29occurrences of the regular expressions.  When a match is found, it
30executes the corresponding C code.  Flex was designed to work with
31both Yacc and Bison, and is used by many programs as part of their
32build process.
33
34You should install flex if you are going to use your system for
35application development.
36
37%description -l ja
38flex はスキャナを生成するプログラムです.スキャナとは,
39テキストの語彙を認識するプログラムです.flex は正規表現と
40C のコードを入力とし,C のソースファイルを出力します.
41出力されたファイルはコンパイルされ,ライブラリとリンクされて
42実行ファイルが作られます.この実行ファイルは入力を調べ,正規表現に
43マッチするものがないか探します.もしマッチするものが見付かれば,
44対応する C コードが実行されます.flex は yacc と bison と共に
45動作する様設計されており,多くのプログラムを作成する際に使われます.
46
47アプリケーション開発を行う場合は flex をインストールして下さい.
48
49
50%prep
51%setup -q
52%patch0 -p1
53%patch1 -p1
54%patch2 -p1
55%patch3 -p1
56
57%build
58%configure --disable-dependency-tracking CFLAGS="-fPIC $RPM_OPT_FLAGS"
59make %{?_smp_mflags}
60
61%install
62rm -rf $RPM_BUILD_ROOT
63make DESTDIR=$RPM_BUILD_ROOT install
64rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
65
66( cd ${RPM_BUILD_ROOT}
67  strip .%{_bindir}/flex
68  ln -sf flex .%{_bindir}/lex
69  ln -s flex.1 .%{_mandir}/man1/lex.1
70  ln -s flex.1 .%{_mandir}/man1/flex++.1
71  ln -s libfl.a .%{_libdir}/libl.a
72)
73
74%find_lang %{name}
75
76%check
77echo ============TESTING===============
78make check
79echo ============END TESTING===========
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post
85/sbin/install-info %{_infodir}/flex.info.gz --dir-file=%{_infodir}/dir ||:
86
87%preun
88if [ $1 = 0 ]; then
89    /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir ||:
90fi
91
92%files -f %{name}.lang
93%defattr(-,root,root)
94%doc COPYING NEWS README
95%{_bindir}/*
96%{_mandir}/man1/*
97%{_libdir}/*.a
98%{_includedir}/FlexLexer.h
99%{_infodir}/flex.info*
100
101%changelog
102* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.35-3
103- rebuilt with current VineSeed
104- inserted the "-fPIC" on configure command-line and dropt the -fPIC patch.
105- removed BR: info
106- added Patch0-3 from Fedora
107  * Tue Jul 13 2010 Petr Machata <pmachata@redhat.com> - 2.5.35-10
108  - Declare yyget_column and yyset_column in reentrant mode.
109  - Resolves: #612465
110  * Mon Apr 20 2009 Debarshi Ray <rishi@fedoraproject.org> - 2.5.35-5
111  - Resolves: #496548.
112  * Mon Apr 20 2009 Petr Machata <pmachata@redhat.com> - 2.5.35-4
113  - Get rid of warning caused by ignoring return value of fwrite() in
114    ECHO macro.  Debian patch.
115  - Resolves: #484961
116  * Mon May 12 2008 Petr Machata <pmachata@redhat.com> - 2.5.35-2
117  - Resolves: #445950
118
119* Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.35-2
120- spec in utf-8
121
122* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.35-1
123- new upstream release
124- updated Patch0, dropped Patch1
125
126* Tue Nov 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.33-5vl1
127- rebuilt with new toolchains
128- updated to 2.5.33 based on Fedora packages
129  * Fri Mar 30 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-5
130  - Make yy-prefixed variables available to scanner even with -P.
131  * Fri Feb  2 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-4
132  - Use %%find_lang to package locale files.
133  * Wed Jan 31 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-3
134  - Compile with -fPIC.
135  * Fri Jan 19 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-1
136  - Rebase to 2.5.33
137
138* Sat Jan 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4a-30vl2
139- rebuild with gcc 3.3.6
140
141* Sun Jul  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4a-30vl1
142- rebuild with new toolchains
143- based on Redhat Rawhide 2.5.4-30
144  - Mon Nov  4 2002 Than Ngo <than@redhat.com> 2.5.4a-27
145  - YY_NO_INPUT patch from Jean Marie
146  - Tue Apr  2 2002 Than Ngo <than@redhat.com> 2.5.4a-23
147  - More ISO C++ 98 fixes (#59670)
148  - Wed Feb 20 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.5.4a-21
149  - More ISO C++ 98 fixes (#59670)
150- s/Copyright/License/
151
152* Mon Feb 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
153- 2.5.4a-13vl1
154- based on 2.5.4a-13 from Rawhide
155- use better macros (%%{_tmppath})
156- added Japanese summary and description
157
158* Sat Sep 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
159- Fix generation of broken code (conflicting isatty() prototype w/ glibc 2.2)
160  This broke, among other things, the kdelibs 2.0 build
161- Fix source URL
162
163* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
164- FHS packaging (64bit systems need to use libdir).
165
166* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
167- automatic rebuild
168
169* Tue Jun  6 2000 Bill Nottingham <notting@redhat.com>
170- rebuild, FHS stuff.
171
172* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
173- handle compressed man pages
174
175* Fri Jan 28 2000 Bill Nottingham <notting@redhat.com>
176- add a libl.a link to libfl.a
177
178* Wed Aug 25 1999 Jeff Johnson <jbj@redhat.com>
179- avoid uninitialized variable warning (Erez Zadok).
180
181* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
182- auto rebuild in the new build environment (release 6)
183
184* Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
185- build for 6.0 tree
186
187* Mon Aug 10 1998 Jeff Johnson <jbj@redhat.com>
188- build root
189
190* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
191- translations modified for de, fr, tr
192
193* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
194- updated from 2.5.4 to 2.5.4a
195
196* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
197- built against glibc
198
199* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
200- Updated to v. 2.5.4
Note: See TracBrowser for help on using the repository browser.