source: projects/specs/trunk/f/flex/flex-vl.spec @ 521

Revision 521, 5.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A tool for creating scanners (text pattern recognizers).
2Summary(ja): スキャナ (テキストパターン認識器) 作成ツール
3Name: flex
4Version: 2.5.35
5Release: 2%{?_dist_release}
6License: BSD
7Group: Development/Tools
8URL: http://flex.sourceforge.net/
9Source: flex-%{version}.tar.bz2
10Patch0: flex-2.5.35-pic.patch
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: gettext info bison m4
14Requires: m4
15Requires(post): /sbin/install-info
16Requires(preun): /sbin/install-info
17
18%description
19The flex program generates scanners.  Scanners are programs which can
20recognize lexical patterns in text.  Flex takes pairs of regular
21expressions and C code as input and generates a C source file as
22output.  The output file is compiled and linked with a library to
23produce an executable.  The executable searches through its input for
24occurrences of the regular expressions.  When a match is found, it
25executes the corresponding C code.  Flex was designed to work with
26both Yacc and Bison, and is used by many programs as part of their
27build process.
28
29You should install flex if you are going to use your system for
30application development.
31
32%description -l ja
33flex はスキャナを生成するプログラムです.スキャナとは,
34テキストの語彙を認識するプログラムです.flex は正規表現と
35C のコードを入力とし,C のソースファイルを出力します.
36出力されたファイルはコンパイルされ,ライブラリとリンクされて
37実行ファイルが作られます.この実行ファイルは入力を調べ,正規表現に
38マッチするものがないか探します.もしマッチするものが見付かれば,
39対応する C コードが実行されます.flex は yacc と bison と共に
40動作する様設計されており,多くのプログラムを作成する際に使われます.
41
42アプリケーション開発を行う場合は flex をインストールして下さい.
43
44
45%prep
46%setup -q
47%patch0 -p1
48
49%build
50%configure --disable-dependency-tracking
51make
52
53%install
54rm -rf $RPM_BUILD_ROOT
55make DESTDIR=$RPM_BUILD_ROOT install
56rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
57
58( cd ${RPM_BUILD_ROOT}
59  strip .%{_bindir}/flex
60  ln -sf flex .%{_bindir}/lex
61  ln -s flex.1 .%{_mandir}/man1/lex.1
62  ln -s flex.1 .%{_mandir}/man1/flex++.1
63  ln -s libfl.a .%{_libdir}/libl.a
64)
65
66%find_lang %{name}
67
68%check
69echo ============TESTING===============
70make check
71echo ============END TESTING===========
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%post
77/sbin/install-info %{_infodir}/flex.info.gz --dir-file=%{_infodir}/dir ||:
78
79%preun
80if [ $1 = 0 ]; then
81    /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir ||:
82fi
83
84%files -f %{name}.lang
85%defattr(-,root,root)
86%doc COPYING NEWS README
87%{_bindir}/*
88%{_mandir}/man1/*
89%{_libdir}/*.a
90%{_includedir}/FlexLexer.h
91%{_infodir}/flex.info*
92
93%changelog
94* Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.35-2
95- spec in utf-8
96
97* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.35-1
98- new upstream release
99- updated Patch0, dropped Patch1
100
101* Tue Nov 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.33-5vl1
102- rebuilt with new toolchains
103- updated to 2.5.33 based on Fedora packages
104  * Fri Mar 30 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-5
105  - Make yy-prefixed variables available to scanner even with -P.
106  * Fri Feb  2 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-4
107  - Use %%find_lang to package locale files.
108  * Wed Jan 31 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-3
109  - Compile with -fPIC.
110  * Fri Jan 19 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-1
111  - Rebase to 2.5.33
112
113* Sat Jan 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4a-30vl2
114- rebuild with gcc 3.3.6
115
116* Sun Jul  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4a-30vl1
117- rebuild with new toolchains
118- based on Redhat Rawhide 2.5.4-30
119  - Mon Nov  4 2002 Than Ngo <than@redhat.com> 2.5.4a-27
120  - YY_NO_INPUT patch from Jean Marie
121  - Tue Apr  2 2002 Than Ngo <than@redhat.com> 2.5.4a-23
122  - More ISO C++ 98 fixes (#59670)
123  - Wed Feb 20 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.5.4a-21
124  - More ISO C++ 98 fixes (#59670)
125- s/Copyright/License/
126
127* Mon Feb 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
128- 2.5.4a-13vl1
129- based on 2.5.4a-13 from Rawhide
130- use better macros (%%{_tmppath})
131- added Japanese summary and description
132
133* Sat Sep 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
134- Fix generation of broken code (conflicting isatty() prototype w/ glibc 2.2)
135  This broke, among other things, the kdelibs 2.0 build
136- Fix source URL
137
138* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
139- FHS packaging (64bit systems need to use libdir).
140
141* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
142- automatic rebuild
143
144* Tue Jun  6 2000 Bill Nottingham <notting@redhat.com>
145- rebuild, FHS stuff.
146
147* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
148- handle compressed man pages
149
150* Fri Jan 28 2000 Bill Nottingham <notting@redhat.com>
151- add a libl.a link to libfl.a
152
153* Wed Aug 25 1999 Jeff Johnson <jbj@redhat.com>
154- avoid uninitialized variable warning (Erez Zadok).
155
156* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
157- auto rebuild in the new build environment (release 6)
158
159* Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
160- build for 6.0 tree
161
162* Mon Aug 10 1998 Jeff Johnson <jbj@redhat.com>
163- build root
164
165* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
166- translations modified for de, fr, tr
167
168* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
169- updated from 2.5.4 to 2.5.4a
170
171* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
172- built against glibc
173
174* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
175- Updated to v. 2.5.4
Note: See TracBrowser for help on using the repository browser.