source: projects/specs/trunk/f/flex/flex-vl.spec @ 8067

Revision 8067, 6.6 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1Summary: A tool for creating scanners (text pattern recognizers).
2Summary(ja): スキャナ (テキストパターン認識器) 作成ツール
3Name: flex
4Version: 2.5.37
5Release: 1%{?_dist_release}
6
7Group: Development/Tools
8License: BSD
9URL: http://flex.sourceforge.net/
10
11Source: flex-%{version}.tar.bz2
12Patch0: flex-2.5.36-bison-2.6.1.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: gettext bison m4
16Requires: m4
17Requires(post): /sbin/install-info
18Requires(preun): /sbin/install-info
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24The flex program generates scanners.  Scanners are programs which can
25recognize lexical patterns in text.  Flex takes pairs of regular
26expressions and C code as input and generates a C source file as
27output.  The output file is compiled and linked with a library to
28produce an executable.  The executable searches through its input for
29occurrences of the regular expressions.  When a match is found, it
30executes the corresponding C code.  Flex was designed to work with
31both Yacc and Bison, and is used by many programs as part of their
32build process.
33
34You should install flex if you are going to use your system for
35application development.
36
37%description -l ja
38flex はスキャナを生成するプログラムです.スキャナとは,
39テキストの語彙を認識するプログラムです.flex は正規表現と
40C のコードを入力とし,C のソースファイルを出力します.
41出力されたファイルはコンパイルされ,ライブラリとリンクされて
42実行ファイルが作られます.この実行ファイルは入力を調べ,正規表現に
43マッチするものがないか探します.もしマッチするものが見付かれば,
44対応する C コードが実行されます.flex は yacc と bison と共に
45動作する様設計されており,多くのプログラムを作成する際に使われます.
46
47アプリケーション開発を行う場合は flex をインストールして下さい.
48
49
50%prep
51%setup -q
52%patch0 -p1
53
54%build
55%configure --disable-dependency-tracking CFLAGS="-fPIC $RPM_OPT_FLAGS"
56make %{?_smp_mflags}
57
58%install
59rm -rf $RPM_BUILD_ROOT
60make DESTDIR=$RPM_BUILD_ROOT install
61rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
62
63( cd ${RPM_BUILD_ROOT}
64  strip .%{_bindir}/flex
65  ln -sf flex .%{_bindir}/lex
66  ln -s flex.1 .%{_mandir}/man1/lex.1
67  ln -s flex.1 .%{_mandir}/man1/flex++.1
68  ln -s libfl.a .%{_libdir}/libl.a
69)
70
71%find_lang %{name}
72
73rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
74
75%check
76echo ============TESTING===============
77make check
78echo ============END TESTING===========
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%post
84/sbin/install-info %{_infodir}/flex.info.gz --dir-file=%{_infodir}/dir ||:
85
86%preun
87if [ $1 = 0 ]; then
88    /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir ||:
89fi
90
91%files -f %{name}.lang
92%defattr(-,root,root)
93%doc COPYING NEWS README
94%{_bindir}/*
95%{_mandir}/man1/*
96%{_libdir}/*.a
97%{_includedir}/FlexLexer.h
98%{_infodir}/flex.info*
99
100%changelog
101* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.37-1
102- update to 2.5.37
103- remove old patches
104- add Patch0 (flex-2.5.36-bison-2.6.1.patch) from Fedora
105
106* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.35-3
107- rebuilt with current VineSeed
108- inserted the "-fPIC" on configure command-line and dropt the -fPIC patch.
109- removed BR: info
110- added Patch0-3 from Fedora
111  * Tue Jul 13 2010 Petr Machata <pmachata@redhat.com> - 2.5.35-10
112  - Declare yyget_column and yyset_column in reentrant mode.
113  - Resolves: #612465
114  * Mon Apr 20 2009 Debarshi Ray <rishi@fedoraproject.org> - 2.5.35-5
115  - Resolves: #496548.
116  * Mon Apr 20 2009 Petr Machata <pmachata@redhat.com> - 2.5.35-4
117  - Get rid of warning caused by ignoring return value of fwrite() in
118    ECHO macro.  Debian patch.
119  - Resolves: #484961
120  * Mon May 12 2008 Petr Machata <pmachata@redhat.com> - 2.5.35-2
121  - Resolves: #445950
122
123* Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.35-2
124- spec in utf-8
125
126* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.35-1
127- new upstream release
128- updated Patch0, dropped Patch1
129
130* Tue Nov 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.33-5vl1
131- rebuilt with new toolchains
132- updated to 2.5.33 based on Fedora packages
133  * Fri Mar 30 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-5
134  - Make yy-prefixed variables available to scanner even with -P.
135  * Fri Feb  2 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-4
136  - Use %%find_lang to package locale files.
137  * Wed Jan 31 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-3
138  - Compile with -fPIC.
139  * Fri Jan 19 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-1
140  - Rebase to 2.5.33
141
142* Sat Jan 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4a-30vl2
143- rebuild with gcc 3.3.6
144
145* Sun Jul  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4a-30vl1
146- rebuild with new toolchains
147- based on Redhat Rawhide 2.5.4-30
148  - Mon Nov  4 2002 Than Ngo <than@redhat.com> 2.5.4a-27
149  - YY_NO_INPUT patch from Jean Marie
150  - Tue Apr  2 2002 Than Ngo <than@redhat.com> 2.5.4a-23
151  - More ISO C++ 98 fixes (#59670)
152  - Wed Feb 20 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.5.4a-21
153  - More ISO C++ 98 fixes (#59670)
154- s/Copyright/License/
155
156* Mon Feb 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
157- 2.5.4a-13vl1
158- based on 2.5.4a-13 from Rawhide
159- use better macros (%%{_tmppath})
160- added Japanese summary and description
161
162* Sat Sep 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
163- Fix generation of broken code (conflicting isatty() prototype w/ glibc 2.2)
164  This broke, among other things, the kdelibs 2.0 build
165- Fix source URL
166
167* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
168- FHS packaging (64bit systems need to use libdir).
169
170* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
171- automatic rebuild
172
173* Tue Jun  6 2000 Bill Nottingham <notting@redhat.com>
174- rebuild, FHS stuff.
175
176* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
177- handle compressed man pages
178
179* Fri Jan 28 2000 Bill Nottingham <notting@redhat.com>
180- add a libl.a link to libfl.a
181
182* Wed Aug 25 1999 Jeff Johnson <jbj@redhat.com>
183- avoid uninitialized variable warning (Erez Zadok).
184
185* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
186- auto rebuild in the new build environment (release 6)
187
188* Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
189- build for 6.0 tree
190
191* Mon Aug 10 1998 Jeff Johnson <jbj@redhat.com>
192- build root
193
194* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
195- translations modified for de, fr, tr
196
197* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
198- updated from 2.5.4 to 2.5.4a
199
200* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
201- built against glibc
202
203* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
204- Updated to v. 2.5.4
Note: See TracBrowser for help on using the repository browser.