source: projects/specs/branches/6/c/compiz/compiz-vl.spec @ 3373

Revision 3373, 28.4 KB checked in by daisuke, 13 years ago (diff)

compiz:

  • add Patch3000
    • disable Sync to vblank
    • increase drop-shadow radius
    • set default decorator to gtk-window-decorator
    • change default daces in cube plugin
    • use "smart" placement mode


Line 
1# build with kde4
2%bcond_with kde
3
4%define         dialogversion   0.7.18
5%define         kde_dialogversion 0.0.5
6
7%define         core_plugins    blur clone commands cube dbus decoration fade ini inotify minimize move obs place png regex resize rotate scale screenshot switcher video water wobbly zoom fs
8
9%define         gnome_plugins   annotate gconf glib svg gnomecompat
10
11# List of plugins passed to ./configure.  The order is important
12
13%define         plugins         core,glib,gconf,dbus,png,svg,video,screenshot,decoration,clone,place,fade,minimize,move,resize,switcher,scale,wall
14
15Summary:        OpenGL window and compositing manager
16Summary(ja):    OpenGL ウィンドウ・コンポジットマネージャ
17Name:           compiz
18URL:            http://www.go-compiz.org
19License:        X11/MIT/GPL
20Group:          User Interface/Desktops
21Version:        0.8.6
22Release:        5%{?_dist_release}
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26# libdrm is not available on these arches
27ExcludeArch:    s390 s390x ppc64
28
29Requires:       xorg-x11-server-Xorg
30Requires:       mesa-libGL
31
32Requires(post): desktop-file-utils
33
34BuildRequires:  libX11-devel, libdrm-devel, libwnck-devel
35BuildRequires:  libXfixes-devel, libXrandr-devel, libXrender-devel
36BuildRequires:  libXcomposite-devel, libXdamage-devel, libXext-devel
37BuildRequires:  libXt-devel, libXmu-devel, libICE-devel, libSM-devel
38BuildRequires:  control-center-devel, GConf2-devel
39BuildRequires:  gnome-desktop-devel >= 2.30.0
40BuildRequires:  metacity-devel
41BuildRequires:  desktop-file-utils
42BuildRequires:  intltool >= 0.35
43BuildRequires:  gettext
44BuildRequires:  dbus-devel
45BuildRequires:  librsvg2-devel
46BuildRequires:  mesa-libGLU-devel
47BuildRequires:  fuse-devel
48%if %{with kde}
49BuildRequires:  kdebase-workspace-devel
50BUildRequires:  dbus-qt-devel
51%endif
52Conflicts:      control-center < 2.32.1-2
53
54Source0:        http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
55Source1:        desktop-effects-%{dialogversion}.tar.bz2
56Source2:        kde-desktop-effects-%{kde_dialogversion}.tar.bz2
57
58# Make sure that former beryl users still have bling
59Obsoletes: beryl-core
60
61# Patches from fedora
62Patch102: desktop-effects-0.7.17-wall-plugin.patch
63Patch103: composite-cube-logo.patch
64Patch111: gconf-core-plugin-loopfix.patch
65
66# Make sure configuration plugins never get unloaded
67Patch123: compiz-0.7.8-pin-initial-plugins.patch
68
69# Patches from ubuntu
70Patch1140: 014-fix-gtk-window-decorator-no-argb-crash.patch
71Patch1150: 015_optional-fbo.patch
72Patch1160: 016_call_glxwaitx_before_drawing.patch
73Patch1170: 017_always_unredirect_screensaver_on_nvidia.patch
74Patch1200: 020_disable_gdk_gtk_disable_deprecated.patch
75Patch1490: 049-damage-report-non-empty.patch
76Patch1600: 060_move_checks_to_compiz.patch
77
78# Patches from upstream
79Patch2000: compiz-0.8.6-replace-gdk_draw_drawable-with-cairo-equiv.patch
80Patch2010: compiz-0.8.6-fix-pixmap-size-calculation.patch
81
82# Vine default options
83Patch3000: compiz-0.8.6-vine-default.patch
84
85%description
86Compiz is one of the first OpenGL-accelerated compositing window
87managers for the X Window System. The integration allows it to perform
88compositing effects in window management, such as a minimization
89effect and a cube workspace.  Compiz is an OpenGL compositing manager
90that use Compiz use EXT_texture_from_pixmap OpenGL extension for
91binding redirected top-level windows to texture objects.
92
93%package devel
94Summary: Development packages for compiz
95Summary(ja): compiz の開発パッケージ
96Group: Development/Libraries
97Requires: compiz = %{version}-%{release}
98Requires: pkgconfig
99Requires: libXcomposite-devel libXfixes-devel libXdamage-devel libXrandr-devel
100Requires: libXinerama-devel libICE-devel libSM-devel libxml2-devel
101Requires: libxslt-devel startup-notification-devel
102
103%description devel
104The compiz-devel package includes the header files,
105and developer docs for the compiz package.
106
107Install compiz-devel if you want to develop plugins for the compiz
108windows and compositing manager.
109
110%package gnome
111Summary: Compiz gnome integration bits
112Summary(ja): Compiz gnome integration bits
113Group: User Interface/Desktops
114Requires: gnome-session
115Requires: metacity
116Requires: libwnck
117Requires: glx-utils
118Requires: %{name} = %{version}
119Requires(pre): GConf2
120Requires(post): GConf2
121Requires(preun): GConf2
122Obsoletes: compiz < 0.5.2-8
123Obsoletes: beryl-gnome
124
125%description gnome
126The compiz-gnome package contains gtk-window-decorator,
127and other gnome integration related stuff.
128
129%if %{with kde}
130%package kde
131Summary: Compiz kde integration bits
132Summary(ja): Compiz kde integration bits
133Group: User Interface/Desktops
134Requires: %{name} = %{version}
135Requires: compiz-manager
136Obsoletes: beryl-kde
137
138%description kde
139The compiz-kde package contains kde-window-decorator,
140and other kde integration related stuff.
141%endif
142
143%prep
144%setup -q -T -b1 -n desktop-effects-%{dialogversion}
145#%setup -q -T -b2 -n kde-desktop-effects-%{kde_dialogversion}
146%setup -q
147
148pushd ../desktop-effects-%{dialogversion}
149%patch102 -p1 -b .wall-plugin
150popd
151
152%patch103 -p1 -b .composite-cube-logo
153%patch111 -p1 -b .gconf-core-loop
154
155## %patch123 -p1 -b .initial-plugins
156
157# ubuntu patch
158%patch1140 -p1 -b .fix-gtk-window-decorator-no-argb-crash
159%patch1150 -p1 -b .disable-fbo
160%patch1160 -p1 -b .call_glxwaitx_before_drawing
161%patch1170 -p1 -b .always_unredirect_screensaver_on_nvidia
162%patch1200 -p1 -b .disable_gdk_gtk_disable_deprecated
163%patch1490 -p1 -b .damage-report-non-empty
164%patch1600 -p1 -b .move-check-to-compiz
165
166# upstream patch
167%patch2000 -p1 -b .replace-gdk_draw_drawable-with-cairo-equiv
168%patch2010 -p1 -b .fix-pixmap-size-calculation
169
170# vine patch
171%patch3000 -p1 -b .vine-default
172
173%build
174rm -rf $RPM_BUILD_ROOT
175
176CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
177export CPPFLAGS
178
179#needed to find kde4 libs
180#LDFLAGS="$LDFLAGS -L%{_libdir}/kde4/devel"
181#export LDFLAGS
182
183libtoolize
184autoreconf
185%configure                                      \
186%{?with_kde: --enable-kde4 }                    \
187%{!?with_kde: --disable-kde4 }                  \
188        --disable-kde                           \
189        --enable-gconf                          \
190        --enable-dbus                           \
191        --enable-place                          \
192        --enable-librsvg                        \
193        --enable-gtk                            \
194        --enable-metacity                       \
195        --enable-gnome                          \
196        --with-default-plugins=%{plugins}       \
197        --enable-gnome-keybindings           
198
199
200make %{?_smp_mflags} imagedir=%{_datadir}/pixmaps
201
202# desktop-effects
203cd ../desktop-effects-%{dialogversion}
204%configure
205
206
207%install
208rm -rf $RPM_BUILD_ROOT
209export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
210make DESTDIR=$RPM_BUILD_ROOT install || exit 1
211unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
212
213echo INSTALLING DESKTOP EFFECTS
214pushd ../desktop-effects-%{dialogversion}
215make DESTDIR=$RPM_BUILD_ROOT install || exit 1
216#desktop-file-install --vendor vine --delete-original      \
217#  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
218#  $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
219rm -f $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
220popd
221
222%if %{with kde}
223# kde-desktop-effects
224echo INSTALLING KDE DESKTOP EFFECTS
225pushd ../kde-desktop-effects-%{kde_dialogversion}
226cp -a kde-desktop-effects.sh $RPM_BUILD_ROOT/%{_bindir}/
227mkdir -p $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
228cp -a ChangeLog COPYING README $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
229
230iconlist="16 24 32 36 48 96"
231for i in $iconlist; do
232 mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/
233 cp -p ../desktop-effects-%{dialogversion}/desktop-effects$i.png $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/kde-desktop-effects.png
234done
235
236desktop-file-install --vendor=""           \
237  --dir=%{buildroot}%{_datadir}/applications/kde       \
238  kde-desktop-effects.desktop
239popd
240%endif
241
242%if !%{with kde}
243rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/kconfig.xml
244%endif
245
246
247find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
248find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
249
250
251%find_lang compiz
252%find_lang desktop-effects
253
254cat compiz.lang > core-files.txt
255cat desktop-effects.lang > gnome-files.txt
256
257for f in %{core_plugins}; do
258  echo %{_libdir}/compiz/lib$f.so
259  echo %{_datadir}/compiz/$f.xml
260done >> core-files.txt
261
262for f in %{gnome_plugins}; do
263  echo %{_libdir}/compiz/lib$f.so
264  echo %{_datadir}/compiz/$f.xml
265done >> gnome-files.txt
266
267
268%post -p /sbin/ldconfig
269
270%postun -p /sbin/ldconfig
271
272%post gnome
273update-desktop-database -q %{_datadir}/applications
274
275export GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source`
276for f in %{core_plugins} %{gnome_plugins} core; do
277  echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
278  | xargs gconftool-2 --makefile-install-rule >& /dev/null || :
279
280gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
281
282touch --no-create %{_datadir}/icons/hicolor
283if [ -x /usr/bin/gtk-update-icon-cache ]; then
284        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
285fi
286
287
288%pre gnome
289if [ "$1" -gt 1 ]; then
290  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
291  for f in %{core_plugins} %{gnome_plugins} core; do
292    echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
293    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
294
295  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
296fi
297
298
299%preun gnome
300if [ "$1" -eq 0 ]; then
301  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
302  for f in %{core_plugins} %{gnome_plugins} core; do
303    echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
304    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
305
306  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
307fi
308
309
310%postun gnome
311touch --no-create %{_datadir}/icons/hicolor
312if [ -x /usr/bin/gtk-update-icon-cache ]; then
313        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
314fi
315
316%if %{with kde}
317%post kde
318update-desktop-database -q %{_datadir}/applications/kde
319touch --no-create %{_datadir}/icons/hicolor
320
321%postun kde
322touch --no-create %{_datadir}/icons/hicolor
323%endif
324
325%clean
326rm -rf $RPM_BUILD_ROOT
327
328
329%files -f core-files.txt
330%defattr(-, root, root)
331%doc AUTHORS ChangeLog COPYING* README TODO
332%{_bindir}/compiz
333%{_libdir}/libdecoration.so.*
334%dir %{_libdir}/compiz
335%dir %{_datadir}/compiz
336%{_datadir}/compiz/*.png
337%{_datadir}/compiz/core.xml
338
339
340%files gnome -f gnome-files.txt
341%defattr(-, root, root)
342%{_bindir}/gtk-window-decorator
343%{_bindir}/desktop-effects
344%{_libdir}/window-manager-settings/libcompiz.so
345%{_datadir}/gnome/wm-properties/compiz-wm.desktop
346%{_datadir}/applications/compiz.desktop
347%{_datadir}/gnome-control-center/keybindings/50-compiz-desktop-key.xml
348%{_datadir}/gnome-control-center/keybindings/50-compiz-key.xml
349%{_datadir}/compiz/desktop-effects.glade
350%{_datadir}/icons/hicolor/16x16/apps/desktop-effects.png
351%{_datadir}/icons/hicolor/24x24/apps/desktop-effects.png
352%{_datadir}/icons/hicolor/32x32/apps/desktop-effects.png
353%{_datadir}/icons/hicolor/36x36/apps/desktop-effects.png
354%{_datadir}/icons/hicolor/48x48/apps/desktop-effects.png
355%{_datadir}/icons/hicolor/96x96/apps/desktop-effects.png
356%{_sysconfdir}/gconf/schemas/*.schemas
357
358%if %{with kde}
359%files kde
360%defattr(-, root, root)
361%{_bindir}/kde4-window-decorator
362%{_docdir}/compiz-kde-%{version}
363%{_bindir}/kde-desktop-effects.sh
364%{_datadir}/applications/kde/kde-desktop-effects.desktop
365%{_datadir}/icons/hicolor/*/apps/kde-desktop-effects.png
366%{_datadir}/compiz/kconfig.xml
367%endif
368
369%files devel
370%defattr(-, root, root)
371%{_libdir}/pkgconfig/compiz.pc
372%{_libdir}/pkgconfig/libdecoration.pc
373%{_libdir}/pkgconfig/compiz-cube.pc
374%{_libdir}/pkgconfig/compiz-gconf.pc
375%{_libdir}/pkgconfig/compiz-scale.pc
376%{_datadir}/compiz/schemas.xslt
377%{_includedir}/compiz
378%{_libdir}/libdecoration.so
379
380
381%changelog
382* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-5
383- add Patch3000
384  - disable Sync to vblank
385  - increase drop-shadow radius
386  - set default decorator to gtk-window-decorator
387  - change default daces in cube plugin
388  - use "smart" placement mode
389
390* Sun Mar 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-4
391- drop compiz-gtk
392  - add Conflicts: control-center < 2.32.1-2
393
394* Sat Mar 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-3
395- rebuild with mesa-7.10.1
396- add cherry picked ubuntu patch
397  - Patch1150: add --no-fbo option
398  - Patch1200: disable GDK|GTK_DISABLE_DEPRECATED
399  - Patch1160: call glxwaitx before drawing
400  - Patch1170: always unredirect screensaver on nvidia
401  - Patch1490: damage report non empty
402  - Patch1600: move check to compiz
403- add upstream patch
404  - Patch2000: replace gdk_draw_drawable with cairo equivalents
405  - Patch2010: fix pixmap size calculation
406
407* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-2
408- rebuild with rpm-4.8.1 for pkg-config file
409
410* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
411- new upstream release (build on GNOME-2.30)
412- drop Patch123, Patch300
413
414* Sat Nov 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-4
415- rebuild with mesa-7.6
416- add Patch300 to build with gconf-2.28
417
418* Thu Jun 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-3
419- disable glib plugin in compiz-gtk
420- use direct rendering on virtualbox video adaptor.
421
422* Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-2
423- add Requires: glx-utils to compiz-gnome
424
425* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
426- new upstream release
427
428* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-8
429- re-enable metacity decoration on gtk-window-decorator
430  - BR: metacity-devel instead of metacity
431
432* Fri May 01 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.8-7
433- fix pre/post scripts for speeding up gconf schema installation
434
435* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-6
436- add ccp compiz option to compiz-gtk
437
438* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-5
439- remove desktop-effect.desktop
440  - we use gnome-appearance-properties integrated version.
441
442* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-4
443- add Patch121,122 from upstream fix.
444- add Patch123: make sure configuration plugins never get unloaded
445- add Patch124: memleak fix from upstream
446- add Patch125: make the terminal keybind work
447- add Patch120,126,127 for kde42
448- add Patch128: gwd fix from upstream
449
450* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-3
451- rebuild with gnome-desktop-2.26.0
452
453* Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-2
454- add compiz-gtk scripts and desktop file from fedora
455
456* Thu Oct 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
457- new upstream release
458
459* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-2
460- rebuild with gnome-desktop-2.24.0
461
462* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
463- new upstream release
464
465* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
466- new upstream release
467
468* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
469- initial build for Vine Linux
470
471* Thu Mar 27 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-3
472- Fix gconf plugin loop RH #438794, patch based on
473  older one from Guillaume Seguin
474- Add core to default plugin list
475
476* Wed Mar 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.7.2-2
477- Reword kde-desktop-effects messages to mention Compiz by name (#438883)
478
479* Mon Mar 24 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-1
480- Update to 0.7.2
481
482* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.2-7
483- Autorebuild for GCC 4.3
484
485* Thu Jan 17 2008 Kristian H淡gsberg <krh@redhat.com> - 0.6.2-6
486- Update to desktop-effects version 0.7.17 which include more
487  translations and move desktop-effects translations to compiz-gnome.
488- Fix spelling in beryl-core obsoletes.
489
490* Mon Jan 07 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-5
491- Update buildrequires (kwd uses the kde3 api)
492
493* Tue Nov  6 2007 Stepan Kasal <skasal@redhat.com> - 0.6.2-4
494- Fix a typo in description of the main package.
495- All descriptions should end with a dot (unlike the summary line)
496
497* Thu Oct 25 2007 Sebastian Vahl <fedora@deadbabylon.de> - 0.6.2-3
498- Include kde-desktop-effects in kde subpackage
499
500* Tue Oct 23 2007 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-2
501- Obsolete berly-core
502
503* Mon Oct 22 2007 Warren Togami <wtogami@redhat.com> - 0.6.2-1
504- 0.6.2
505
506* Fri Oct 12 2007 Kristian H淡gsberg <krh@redhat.com> - 0.6.0-2
507- Disable scale corner initiate and install a GNOME key config entry.
508
509* Wed Oct 10 2007 Warren Togami <wtogami@redhat.com> - 0.6.0-1
510- 0.6.0 final
511- always-restack-windows-on-map
512
513* Tue Oct  9 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-14
514- Make compiz behave with gnome-terminal (#304051)
515
516* Fri Oct  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.2-13
517- Also install gwd.schemas (#319621)
518
519* Thu Sep 20 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-12
520- Update to more recent 0.6 branch snapshot (fixes #253575).
521
522* Fri Sep 14 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-11
523- compiz-gnome: install core schema so it actually works
524- remove unnecessary gconf stuff from %%install
525
526* Tue Aug 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-9
527- Make compiz-gnome Obsolete the older compiz package so yum/anaconda
528  will pull it in (thans to Adel Gadllah).
529
530* Wed Aug 22 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-8
531- Bump to desktop-effects 0.7.7 to avoid kill decorator when popping
532  up dialog.
533- Fix broken gconf install and uninstall rules.
534- Pick up shadowman logo for RHEL builds (#232398).
535
536* Tue Aug 21 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-7.0ec3ec
537- Add more-sm-junk.patch so we set SM restart style to
538  SmRestartIfRunning on exit (#247163, #245971).
539- Add Requires to compiz-devel (#253407).
540- Update to desktop-effects 0.7.6, which terminates decorator when
541  switching to metacity or on compiz failure (#215247, #215032).
542
543* Fri Aug 17 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.5.2-6.0ec3ec
544- Split into gnome and kde subpackages
545- Minor cleanups
546
547* Wed Aug 15 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-5.0ec3ec
548- Reorder plugin list to avoid 'place' getting removed on startup.
549- Add run-command-key.patch to put the run command key in the GNOME
550  keyboard shortcut dialog (#213576).
551- Drop a bunch of obsolete patches.
552- Bump mesa-libGL and X server requires to fix TFP bugs for
553  power-of-two textures (#251935).
554- Rebase fedora-logo and composite-cube-logo patch.
555
556* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-4.0ec3ec
557- Build with desktop-effects so we don't pick up metacity work spaces.
558  Fixes #250568.
559
560* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3.0ec3ec
561- Build git snapshot from fedora branch at
562  git://people.freedesktop.org/~krh/compiz, brances from 0.6 upstream
563  branch.
564- Fixes #237486.
565
566* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3
567- Require desktop-effects 0.7.3 and gnome-session 2.19.6-5 which pass
568  'glib' on the command line too.
569
570* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-2
571- Move xml meta data files to main package.
572
573* Thu Aug  9 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-1
574- Update to 0.5.2.
575- Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz
576  with LIBGL_ALWAYS_INDIRECT set.
577
578* Wed Jun 27 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.0-1
579- Update to 0.5.0
580
581* Tue Jun  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
582- Update to 0.4.0
583
584* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-10
585- Rebuild against new libwnck
586
587* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-9
588- Don't install INSTALL
589
590* Mon Apr 16 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-8
591- Update metacity build requires to metacity-devel.
592
593* Wed Apr  4 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-7
594- Fix typo in ./configure option.
595
596* Wed Apr  4 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-6
597- Add place and clone plugins to default plugin list.
598
599* Wed Mar 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-5
600- Update URL (#208214).
601- Require at least metacity 2.18 (#232831).
602- Add close-session.patch to deregister from SM when replaced (#229113).
603
604* Tue Mar 27 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6-4
605- Explicitly disable KDE parts (#234128).
606
607* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> 0.3.6-3
608- Fix some directory ownership issues (#233825)
609- Small spec cleanups
610
611* Tue Feb  6 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6
612- Require gnome-session > 2.16 so it starts gtk-window-decorator.
613- Update to desktop-effects 0.7.1 that doesn't refuse to work with Xinerama.
614
615* Tue Jan 16 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-1
616- Update to 0.3.6, update patches.
617- Drop autotool build requires.
618- Drop glfinish.patch, cow.patch, resize-offset.patch and icon-menu-patch.
619- Add libdecoration.so
620- Update to desktop-effects-0.7.0, which spawns the right decorator
621  and plays nicely with unknown plugins.
622
623* Sat Nov 25 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-2
624- Update the fedora logo patch (#217224)
625
626* Thu Nov 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
627- Update to 0.3.4
628
629* Wed Nov 15 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
630- Use cow by default, bug 208044
631
632* Fri Nov 10 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
633- Update to 0.3.2
634- Drop upstreamed patches
635- Work with new metacity theme api
636
637* Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.32.20060818git.fc6
638- Install the .desktop file with desktop-file-install. Add X-Red-Hat-Base to make it appear in "Preferences", rather than "More Preferences".
639
640* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
641- Add buildrequires on intltool
642
643* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
644- Build
645
646* Fri Sep 29 2006 Soren Sandmann <sandmann@redhat.com>
647- Update to desktop-effects-0.6.163, which has translation enabled. (Bug 208257)
648
649* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.30.20060817git.fc6
650- Add patch to terminate keyboard moves when a mouse buttons is pressed. (Bug 207792).
651
652* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com>
653- Change default plugin list to not include the plane plugin. (Bug 208448).
654- Change default keybinding for shrink to be Pause (Bug 206187).
655
656* Wed Sep 27 2006 Soren Sandmann <sandmann@redhat.com>
657- Add patch to show a menu when the window icon is clicked. (Bug 201629).
658
659* Tue Sep 26 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.29.20060817git.fc6
660- Add restart.patch to make compiz ask the session manager to restart it
661  if it crashes (bug 200280).
662
663* Mon Sep 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.28.20060817git.fc6
664- Change plane.patch to not do cyclical window movement in dimensions
665  where the desktop has size 1 (bug 207263).
666
667* Thu Sep 21 2006 Soren Sandmann <sandmann@redhat.com>
668- Add patch to fix resizing smaller than minimum size (resize-offset.patch, bug 201623).
669
670* Tue Sep 19 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.27.20060817git.fc6
671- Change .plane patch to
672  (a) not set the background color to pink in the plane plugin.
673  (b) allow workspaces with horizontal sizes less then 4.
674
675* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.26.20060817git.fc6
676- Change plane patch to correctly initialize the screen size to the
677  defaults (bug 206088).
678
679* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
680- Run update-desktop-database and gtk-update-icon-cache in post. Add icons
681  to list of packaged files. Also bump to 0.6.137 of dialog (which just makes
682  directories before attempting to install to them).
683
684* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
685- Upgrade to 0.6.107 of the desktop-effects dialog box. Only change is
686  that the new version has icons.
687
688* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
689- Add patch to fix mispositioning of window decorator event windows (bug 201624)
690
691* Fri Sep 15 2006 Soren Sandmann <sandamnn@redhat.com>
692- Upgrade to version 0.6.83 of desktop-effects. (bug 206500)
693
694* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
695- Add patch to only accept button 1 for close/minimize/maximize (bug 201628)
696
697* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
698- Add patch to fix thumbnail sorting (bug 201605)
699
700* Thu Sep 14 2006 Soren Sandmann <sandmann@redhat.com>
701- Add patch to fix double clicking (bug 201783).
702
703* Tue Sep 12 2006 Soren Sandmann <sandmann@redhat.com>
704- Don't attempt to move the viewport when dx = dy = 0.(last bit of 206088).
705
706* Tue Sep 12 2006 Soren Sandmann <sandamnn@redhat.com>
707- Fix plane.patch to draw correctly when no timeout is running. (206088).
708
709* Wed Sep  6 2006 Kristian H淡gsberg <krh@redhat.com>
710- Update fbconfig-depth-fix.patch to also skip fbconfigs without
711  corresponding visuals.
712
713* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.25.20060817git.fc6
714- Make number of vertical size configurable
715
716* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.24.20060817git.fc6
717- Fix vertical viewport support in the plane patch.
718
719* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.23.20060817git.fc6
720- Upgrade to 0.6.61 of the dialog
721
722* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
723- Add libtool to BuildRequires
724
725* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
726- Add automake and autoconf to BuildRequires
727
728* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
729- Add a patch to put viewports on a plane.
730
731* Wed Aug 30 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.21.20060817git.fc6
732- Drop gl-include-inferiors.patch now that compiz uses COW and the X
733  server evicts offscreen pixmaps automatically on
734  GLX_EXT_texture_from_pixmap usage.
735
736* Tue Aug 29 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.20.20060817git.fc6
737- Add cow.patch to make compiz use the composite overlay window.
738
739* Fri Aug 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.19-20060817git.fc6
740- Rebase to desktop-effects 0.6.41
741
742* Fri Aug 25 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.18.20060817git.fc6
743- Rebase to desktop-effects 0.6.19 and drop
744  desktop-effects-0.6.1-delete-session.patch
745
746* Tue Aug 22 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.17.20060817git.fc6
747- Add patch from upstream to also use sync protocol for override
748  redirect windows (sync-override-redirect-windows.patch).
749
750* Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.16.20060817git.fc6
751- Rebase to latest upstream changes which has the rest of the bindings
752  rewrite.  Add resize-move-keybindings.patch to make move and resize
753  bindings work like metacity.
754- Add back scale plugin.
755
756* Thu Aug 10 2006 Ray Strode <rstrode@redhat.com> 0.0.13-0.15.20060721git.fc5.aiglx
757- Add Requires: gnome-session 2.15.90-2.fc6 (bug 201473)
758- unlink session file on changing wms (bug 201473)
759
760* Thu Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.14.20060721git.fc5.aiglx
761- Add Requires: gnome-session 2.15.4-3
762
763* Wed Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
764- New version of dialog box. Macro the version number.
765
766* Wed Aug  2 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
767- Add 'desktop effects' dialog box.
768
769* Mon Jul 31 2006 Kristian H淡gsberg <krh@redhat.com> 0.0.13-0.12.20060721git.fc5.aiglx
770- Add libwnck requires.
771
772* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.11.20060721git.fc5.aiglx
773- Bump and build for fc5 AIGLX repo.
774
775* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.12.20060721git
776- Fix gconf hooks.
777
778* Tue Jul 25 2006 Kristian H淡gsberg <krh@redhat.com>
779- Require system-logos instead.
780
781* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.10.20060721git
782- Bump version to work around tagging weirdness.
783
784* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.9.20060721git
785- Add devel package and require redhat-logos instead of fedora-logos (#199757).
786
787* Fri Jul 21 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.8.20060720git
788- Add workaround for AIGLX throttling problem.
789
790* Thu Jul 20 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.7.20060720git
791- Drop scale plugin from snapshot.
792
793* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.6.20060717git
794- Don't build on s390
795
796* Mon Jul 17 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.5.20060717git
797- Do some changes forced upon us by package review
798
799* Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-5.1
800- Use sane numbering scheme.
801
802* Fri Jul  7 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-4
803- Drop the fullscreen hardcode patch and require X server that has
804  GLX_MESA_copy_sub_buffer.
805
806* Tue Jun 27 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-3
807- Unbreak --replace.
808
809* Thu Jun 15 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-2
810- Add Requires, fix start-compiz.sh.
811
812* Wed Jun 14 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-1
813- Spec file for compiz, borrowing bits and pieces from Alphonse Van
814  Assches spec file (#192432).
Note: See TracBrowser for help on using the repository browser.