source: projects/specs/trunk/c/compiz/compiz-vl.spec @ 9791

Revision 9791, 29.5 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1# build with kde4
2%bcond_with kde
3
4%define         dialogversion   0.7.18
5%define         kde_dialogversion 0.0.5
6
7%define         core_plugins    blur clone commands cube dbus decoration fade ini inotify minimize move obs place png regex resize rotate scale screenshot switcher video water wobbly zoom fs
8
9%define         mate_plugins    annotate glib svg gnomecompat
10
11# List of plugins passed to ./configure.  The order is important
12
13%define         plugins         core,glib,dbus,png,svg,video,screenshot,decoration,clone,place,fade,minimize,move,resize,switcher,scale,wall
14
15Summary:        OpenGL window and compositing manager
16Summary(ja):    OpenGL ウィンドウ・コンポジットマネージャ
17Name:           compiz
18URL:            http://www.go-compiz.org
19License:        X11/MIT/GPL
20Group:          User Interface/Desktops
21Version:        0.8.8
22Release:        8%{?_dist_release}
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26# libdrm is not available on these arches
27ExcludeArch:    s390 s390x ppc64
28
29Requires:       xorg-x11-server-Xorg
30Requires:       mesa-libGL
31
32Requires(post,postun): desktop-file-utils
33Requires(post,postun): gtk2
34
35BuildRequires:  mesa-libGLU-devel
36BuildRequires:  libdrm-devel
37BuildRequires:  libwnck-devel
38BuildRequires:  libX11-devel
39BuildRequires:  libXcomposite-devel
40BuildRequires:  libXdamage-devel
41BuildRequires:  libXext-devel
42BuildRequires:  libXfixes-devel
43BuildRequires:  libXmu-devel
44BuildRequires:  libXrandr-devel
45BuildRequires:  libXrender-devel
46BuildRequires:  libXt-devel
47BuildRequires:  libSM-devel
48
49BuildRequires:  dbus-devel
50BuildRequires:  dbus-glib-devel
51BuildRequires:  fuse-devel
52BuildRequires:  gnome-desktop-devel >= 2.30.0
53BuildRequires:  libglade2-devel
54BuildRequires:  librsvg2-devel
55BuildRequires:  libxslt-devel
56BuildRequires:  marco-devel
57BuildRequires:  mate-control-center-devel
58
59BuildRequires:  desktop-file-utils
60BuildRequires:  intltool >= 0.35
61BuildRequires:  gettext
62
63%if %{with kde}
64BuildRequires:  kdebase-workspace-devel
65BUildRequires:  dbus-qt-devel
66%endif
67Conflicts:      control-center < 2.32.1-2
68
69# Make sure that former beryl users still have bling
70Obsoletes:      beryl-core
71
72Obsoletes:  %{name}-gnome < 0.8.8-7
73
74Source0:        http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
75Source1:        desktop-effects-%{dialogversion}.tar.bz2
76Source2:        kde-desktop-effects-%{kde_dialogversion}.tar.bz2
77
78# Sources from fedora
79#Source11:      compiz-gtk
80#Source12:      compiz-gtk.desktop
81#Source13:      compiz-gnome.desktop
82#Source14:      compiz-gnome.session
83
84# Patches from fedora
85Patch102: desktop-effects-0.7.17-wall-plugin.patch
86Patch103: composite-cube-logo.patch
87Patch111: gconf-core-plugin-loopfix.patch
88
89# Make sure configuration plugins never get unloaded
90Patch123: compiz-0.7.8-pin-initial-plugins.patch
91
92# Patches from ubuntu
93Patch1140: 014-fix-gtk-window-decorator-no-argb-crash.patch
94Patch1150: 015_optional-fbo.patch
95Patch1160: 016_call_glxwaitx_before_drawing.patch
96Patch1170: 017_always_unredirect_screensaver_on_nvidia.patch
97Patch1200: 020_disable_gdk_gtk_disable_deprecated.patch
98Patch1490: 049-damage-report-non-empty.patch
99Patch1600: 060_move_checks_to_compiz.patch
100
101# Patches from upstream
102Patch2000: compiz-0.8.6-replace-gdk_draw_drawable-with-cairo-equiv.patch
103Patch2010: compiz-0.8.6-fix-pixmap-size-calculation.patch
104
105# Vine default options
106Patch3000: compiz-0.8.6-vine-default.patch
107Patch3001: compiz-mate.patch
108
109Vendor: Project Vine
110Distribution: Vine Linux
111
112%description
113Compiz is one of the first OpenGL-accelerated compositing window
114managers for the X Window System. The integration allows it to perform
115compositing effects in window management, such as a minimization
116effect and a cube workspace.  Compiz is an OpenGL compositing manager
117that use Compiz use EXT_texture_from_pixmap OpenGL extension for
118binding redirected top-level windows to texture objects.
119
120%package devel
121Summary: Development packages for compiz
122Summary(ja): compiz の開発パッケージ
123Group: Development/Libraries
124Requires: compiz = %{version}-%{release}
125Requires: pkgconfig
126Requires: libXcomposite-devel libXfixes-devel libXdamage-devel libXrandr-devel
127Requires: libXinerama-devel libICE-devel libSM-devel libxml2-devel
128Requires: libxslt-devel startup-notification-devel
129
130%description devel
131The compiz-devel package includes the header files,
132and developer docs for the compiz package.
133
134Install compiz-devel if you want to develop plugins for the compiz
135windows and compositing manager.
136
137%package mate
138Summary: Compiz mate integration bits
139Summary(ja): Compiz mate integration bits
140Group: User Interface/Desktops
141Requires: mate-session-manager
142Requires: marco
143Requires: libwnck
144Requires: glx-utils
145Requires: %{name} = %{version}
146
147%description mate
148The compiz-mate package contains gtk-window-decorator,
149and other mate integration related stuff.
150
151%if %{with kde}
152%package kde
153Summary: Compiz kde integration bits
154Summary(ja): Compiz kde integration bits
155Group: User Interface/Desktops
156Requires: %{name} = %{version}
157Requires: compiz-manager
158Obsoletes: beryl-kde
159
160%description kde
161The compiz-kde package contains kde-window-decorator,
162and other kde integration related stuff.
163%endif
164
165%prep
166%setup -q -T -b1 -n desktop-effects-%{dialogversion}
167#%setup -q -T -b2 -n kde-desktop-effects-%{kde_dialogversion}
168%setup -q
169
170pushd ../desktop-effects-%{dialogversion}
171%patch102 -p1 -b .wall-plugin
172popd
173
174%patch103 -p1 -b .composite-cube-logo
175%patch111 -p1 -b .gconf-core-loop
176
177## %patch123 -p1 -b .initial-plugins
178
179# ubuntu patch
180%patch1140 -p1 -b .fix-gtk-window-decorator-no-argb-crash
181%patch1150 -p1 -b .disable-fbo
182%patch1160 -p1 -b .call_glxwaitx_before_drawing
183%patch1170 -p1 -b .always_unredirect_screensaver_on_nvidia
184%patch1200 -p1 -b .disable_gdk_gtk_disable_deprecated
185%patch1490 -p1 -b .damage-report-non-empty
186%patch1600 -p1 -b .move-check-to-compiz
187
188# upstream patch
189#%patch2000 -p1 -b .replace-gdk_draw_drawable-with-cairo-equiv
190#%patch2010 -p1 -b .fix-pixmap-size-calculation
191
192# vine patch
193%patch3000 -p1 -b .vine-default
194%patch3001 -p1 -b .mate
195
196%build
197rm -rf $RPM_BUILD_ROOT
198
199CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
200export CPPFLAGS
201
202#needed to find kde4 libs
203#LDFLAGS="$LDFLAGS -L%{_libdir}/kde4/devel"
204#export LDFLAGS
205
206#libtoolize
207autoreconf -if
208%configure                                      \
209%{?with_kde: --enable-kde4 }                    \
210%{!?with_kde: --disable-kde4 }                  \
211        --disable-kde                           \
212        --disable-gconf                         \
213        --enable-dbus                           \
214        --enable-librsvg                        \
215        --enable-gtk                            \
216        --enable-marco                          \
217        --enable-mate                           \
218        --with-default-plugins=%{plugins}       \
219        --enable-gnome-keybindings           
220
221
222make LIBTOOL=/usr/bin/libtool %{?_smp_mflags} imagedir=%{_datadir}/pixmaps
223
224# desktop-effects
225cd ../desktop-effects-%{dialogversion}
226%configure
227
228
229%install
230rm -rf $RPM_BUILD_ROOT
231make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install || exit 1
232
233echo INSTALLING DESKTOP EFFECTS
234pushd ../desktop-effects-%{dialogversion}
235make LIBTOOL=/usr/bin/libtool LIBS=-lX11 DESTDIR=$RPM_BUILD_ROOT install || exit 1
236#desktop-file-install --vendor vine --delete-original      \
237#  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
238#  $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
239rm -f $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
240popd
241
242%if %{with kde}
243# kde-desktop-effects
244echo INSTALLING KDE DESKTOP EFFECTS
245pushd ../kde-desktop-effects-%{kde_dialogversion}
246cp -a kde-desktop-effects.sh $RPM_BUILD_ROOT/%{_bindir}/
247mkdir -p $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
248cp -a ChangeLog COPYING README $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
249
250iconlist="16 24 32 36 48 96"
251for i in $iconlist; do
252 mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/
253 cp -p ../desktop-effects-%{dialogversion}/desktop-effects$i.png $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/kde-desktop-effects.png
254done
255
256desktop-file-install --vendor=""           \
257  --dir=%{buildroot}%{_datadir}/applications/kde       \
258  kde-desktop-effects.desktop
259popd
260%endif
261
262%if !%{with kde}
263rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/kconfig.xml
264%endif
265
266
267#install -m 0755 %{SOURCE11} $RPM_BUILD_ROOT%{_bindir}
268#desktop-file-install --vendor="" \
269#  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
270#  %{SOURCE12}
271# set up an X session
272#mkdir -p $RPM_BUILD_ROOT%{_datadir}/xsessions
273#install %{SOURCE13} $RPM_BUILD_ROOT%{_datadir}/xsessions
274#mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome-session/sessions
275#install %{SOURCE14} $RPM_BUILD_ROOT%{_datadir}/gnome-session/sessions
276
277
278find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
279find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
280
281
282%find_lang compiz
283%find_lang desktop-effects
284
285cat compiz.lang > core-files.txt
286cat desktop-effects.lang > mate-files.txt
287
288for f in %{core_plugins}; do
289  echo %{_libdir}/compiz/lib$f.so
290  echo %{_datadir}/compiz/$f.xml
291done >> core-files.txt
292
293for f in %{mate_plugins}; do
294  echo %{_libdir}/compiz/lib$f.so
295  echo %{_datadir}/compiz/$f.xml
296done >> mate-files.txt
297
298rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/gconf.xml
299
300
301%post
302/sbin/ldconfig
303update-desktop-database -q %{_datadir}/applications
304
305%postun
306/sbin/ldconfig
307update-desktop-database -q %{_datadir}/applications
308
309%post mate
310update-desktop-database -q %{_datadir}/applications
311touch --no-create %{_datadir}/icons/hicolor
312/usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
313
314%postun mate
315update-desktop-database -q %{_datadir}/applications
316touch --no-create %{_datadir}/icons/hicolor
317/usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
318
319%if %{with kde}
320%post kde
321update-desktop-database -q %{_datadir}/applications/kde
322touch --no-create %{_datadir}/icons/hicolor
323/usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
324
325%postun kde
326update-desktop-database -q %{_datadir}/applications
327touch --no-create %{_datadir}/icons/hicolor
328/usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
329%endif
330
331%clean
332rm -rf $RPM_BUILD_ROOT
333
334
335%files -f core-files.txt
336%defattr(-, root, root)
337%doc AUTHORS ChangeLog COPYING* README TODO
338%{_bindir}/compiz
339%{_libdir}/libdecoration.so.*
340%dir %{_libdir}/compiz
341%dir %{_datadir}/compiz
342%{_datadir}/applications/compiz.desktop
343%{_datadir}/compiz/*.png
344%{_datadir}/compiz/core.xml
345
346%files mate -f mate-files.txt
347%defattr(-, root, root)
348%{_bindir}/gtk-window-decorator
349%{_bindir}/desktop-effects
350%{_libdir}/window-manager-settings/libcompiz.so
351%{_datadir}/compiz/desktop-effects.glade
352%{_datadir}/icons/hicolor/16x16/apps/desktop-effects.png
353%{_datadir}/icons/hicolor/24x24/apps/desktop-effects.png
354%{_datadir}/icons/hicolor/32x32/apps/desktop-effects.png
355%{_datadir}/icons/hicolor/36x36/apps/desktop-effects.png
356%{_datadir}/icons/hicolor/48x48/apps/desktop-effects.png
357%{_datadir}/icons/hicolor/96x96/apps/desktop-effects.png
358%{_datadir}/mate/wm-properties/compiz-wm.desktop
359%{_datadir}/mate-control-center/keybindings/50-compiz-desktop-key.xml
360%{_datadir}/mate-control-center/keybindings/50-compiz-key.xml
361
362%if %{with kde}
363%files kde
364%defattr(-, root, root)
365%{_bindir}/kde4-window-decorator
366%{_docdir}/compiz-kde-%{version}
367%{_bindir}/kde-desktop-effects.sh
368%{_datadir}/applications/kde/kde-desktop-effects.desktop
369%{_datadir}/icons/hicolor/*/apps/kde-desktop-effects.png
370%{_datadir}/compiz/kconfig.xml
371%endif
372
373%files devel
374%defattr(-, root, root)
375%{_libdir}/pkgconfig/compiz.pc
376%{_libdir}/pkgconfig/libdecoration.pc
377%{_libdir}/pkgconfig/compiz-cube.pc
378%{_libdir}/pkgconfig/compiz-scale.pc
379%{_includedir}/compiz
380%{_libdir}/libdecoration.so
381
382
383%changelog
384* Fri Nov 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-8
385- add compiz.desktop
386
387* Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-7
388- add Patch3001 (compiz-mate.patch)
389- add BuildRequires: marco-devel, mate-control-center-devel
390- remove BuildRequires: GConf2-devel, control-center-devel, metacity-devel
391- create %%{name}-mate subpackage
392- remove %%{name}-gnome subpackage
393
394* Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-6
395- rebuild with VineSeed environment
396
397* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-5
398- rebuild with VineSeed environment
399
400* Sun Sep 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-4
401- remove follow files
402    Source11 (compiz-gtk)
403    Source12 (compiz-gtk.desktop)
404    Source13 (compiz-gnome.desktop)
405    Source14 (compiz-gnome.session)
406
407* Mon Mar 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.8-3
408- remove SandyBridge chipset from blacklist
409- add BR: dbus-glib-devel
410
411* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-2
412- add Source files from Fedora
413    Source11 (compiz-gtk)
414    Source12 (compiz-gtk.desktop)
415    Source13 (compiz-gnome.desktop)
416    Source14 (compiz-gnome.session)
417
418* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-1
419- new upstream release
420- add BuildRequires: libxslt-devel, libglade2-devel
421- drop Patch2000,2010
422
423* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-5
424- add Patch3000
425  - disable Sync to vblank
426  - increase drop-shadow radius
427  - set default decorator to gtk-window-decorator
428  - change default daces in cube plugin
429  - use "smart" placement mode
430
431* Sun Mar 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-4
432- drop compiz-gtk
433  - add Conflicts: control-center < 2.32.1-2
434
435* Sat Mar 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-3
436- rebuild with mesa-7.10.1
437- add cherry picked ubuntu patch
438  - Patch1150: add --no-fbo option
439  - Patch1200: disable GDK|GTK_DISABLE_DEPRECATED
440  - Patch1160: call glxwaitx before drawing
441  - Patch1170: always unredirect screensaver on nvidia
442  - Patch1490: damage report non empty
443  - Patch1600: move check to compiz
444- add upstream patch
445  - Patch2000: replace gdk_draw_drawable with cairo equivalents
446  - Patch2010: fix pixmap size calculation
447
448* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-2
449- rebuild with rpm-4.8.1 for pkg-config file
450
451* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
452- new upstream release (build on GNOME-2.30)
453- drop Patch123, Patch300
454
455* Sat Nov 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-4
456- rebuild with mesa-7.6
457- add Patch300 to build with gconf-2.28
458
459* Thu Jun 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-3
460- disable glib plugin in compiz-gtk
461- use direct rendering on virtualbox video adaptor.
462
463* Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-2
464- add Requires: glx-utils to compiz-gnome
465
466* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
467- new upstream release
468
469* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-8
470- re-enable metacity decoration on gtk-window-decorator
471  - BR: metacity-devel instead of metacity
472
473* Fri May 01 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.8-7
474- fix pre/post scripts for speeding up gconf schema installation
475
476* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-6
477- add ccp compiz option to compiz-gtk
478
479* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-5
480- remove desktop-effect.desktop
481  - we use gnome-appearance-properties integrated version.
482
483* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-4
484- add Patch121,122 from upstream fix.
485- add Patch123: make sure configuration plugins never get unloaded
486- add Patch124: memleak fix from upstream
487- add Patch125: make the terminal keybind work
488- add Patch120,126,127 for kde42
489- add Patch128: gwd fix from upstream
490
491* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-3
492- rebuild with gnome-desktop-2.26.0
493
494* Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-2
495- add compiz-gtk scripts and desktop file from fedora
496
497* Thu Oct 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
498- new upstream release
499
500* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-2
501- rebuild with gnome-desktop-2.24.0
502
503* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
504- new upstream release
505
506* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
507- new upstream release
508
509* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
510- initial build for Vine Linux
511
512* Thu Mar 27 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-3
513- Fix gconf plugin loop RH #438794, patch based on
514  older one from Guillaume Seguin
515- Add core to default plugin list
516
517* Wed Mar 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.7.2-2
518- Reword kde-desktop-effects messages to mention Compiz by name (#438883)
519
520* Mon Mar 24 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-1
521- Update to 0.7.2
522
523* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.2-7
524- Autorebuild for GCC 4.3
525
526* Thu Jan 17 2008 Kristian H淡gsberg <krh@redhat.com> - 0.6.2-6
527- Update to desktop-effects version 0.7.17 which include more
528  translations and move desktop-effects translations to compiz-gnome.
529- Fix spelling in beryl-core obsoletes.
530
531* Mon Jan 07 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-5
532- Update buildrequires (kwd uses the kde3 api)
533
534* Tue Nov  6 2007 Stepan Kasal <skasal@redhat.com> - 0.6.2-4
535- Fix a typo in description of the main package.
536- All descriptions should end with a dot (unlike the summary line)
537
538* Thu Oct 25 2007 Sebastian Vahl <fedora@deadbabylon.de> - 0.6.2-3
539- Include kde-desktop-effects in kde subpackage
540
541* Tue Oct 23 2007 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-2
542- Obsolete berly-core
543
544* Mon Oct 22 2007 Warren Togami <wtogami@redhat.com> - 0.6.2-1
545- 0.6.2
546
547* Fri Oct 12 2007 Kristian H淡gsberg <krh@redhat.com> - 0.6.0-2
548- Disable scale corner initiate and install a GNOME key config entry.
549
550* Wed Oct 10 2007 Warren Togami <wtogami@redhat.com> - 0.6.0-1
551- 0.6.0 final
552- always-restack-windows-on-map
553
554* Tue Oct  9 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-14
555- Make compiz behave with gnome-terminal (#304051)
556
557* Fri Oct  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.2-13
558- Also install gwd.schemas (#319621)
559
560* Thu Sep 20 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-12
561- Update to more recent 0.6 branch snapshot (fixes #253575).
562
563* Fri Sep 14 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-11
564- compiz-gnome: install core schema so it actually works
565- remove unnecessary gconf stuff from %%install
566
567* Tue Aug 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-9
568- Make compiz-gnome Obsolete the older compiz package so yum/anaconda
569  will pull it in (thans to Adel Gadllah).
570
571* Wed Aug 22 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-8
572- Bump to desktop-effects 0.7.7 to avoid kill decorator when popping
573  up dialog.
574- Fix broken gconf install and uninstall rules.
575- Pick up shadowman logo for RHEL builds (#232398).
576
577* Tue Aug 21 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-7.0ec3ec
578- Add more-sm-junk.patch so we set SM restart style to
579  SmRestartIfRunning on exit (#247163, #245971).
580- Add Requires to compiz-devel (#253407).
581- Update to desktop-effects 0.7.6, which terminates decorator when
582  switching to metacity or on compiz failure (#215247, #215032).
583
584* Fri Aug 17 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.5.2-6.0ec3ec
585- Split into gnome and kde subpackages
586- Minor cleanups
587
588* Wed Aug 15 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-5.0ec3ec
589- Reorder plugin list to avoid 'place' getting removed on startup.
590- Add run-command-key.patch to put the run command key in the GNOME
591  keyboard shortcut dialog (#213576).
592- Drop a bunch of obsolete patches.
593- Bump mesa-libGL and X server requires to fix TFP bugs for
594  power-of-two textures (#251935).
595- Rebase fedora-logo and composite-cube-logo patch.
596
597* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-4.0ec3ec
598- Build with desktop-effects so we don't pick up metacity work spaces.
599  Fixes #250568.
600
601* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3.0ec3ec
602- Build git snapshot from fedora branch at
603  git://people.freedesktop.org/~krh/compiz, brances from 0.6 upstream
604  branch.
605- Fixes #237486.
606
607* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3
608- Require desktop-effects 0.7.3 and gnome-session 2.19.6-5 which pass
609  'glib' on the command line too.
610
611* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-2
612- Move xml meta data files to main package.
613
614* Thu Aug  9 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-1
615- Update to 0.5.2.
616- Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz
617  with LIBGL_ALWAYS_INDIRECT set.
618
619* Wed Jun 27 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.0-1
620- Update to 0.5.0
621
622* Tue Jun  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
623- Update to 0.4.0
624
625* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-10
626- Rebuild against new libwnck
627
628* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-9
629- Don't install INSTALL
630
631* Mon Apr 16 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-8
632- Update metacity build requires to metacity-devel.
633
634* Wed Apr  4 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-7
635- Fix typo in ./configure option.
636
637* Wed Apr  4 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-6
638- Add place and clone plugins to default plugin list.
639
640* Wed Mar 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-5
641- Update URL (#208214).
642- Require at least metacity 2.18 (#232831).
643- Add close-session.patch to deregister from SM when replaced (#229113).
644
645* Tue Mar 27 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6-4
646- Explicitly disable KDE parts (#234128).
647
648* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> 0.3.6-3
649- Fix some directory ownership issues (#233825)
650- Small spec cleanups
651
652* Tue Feb  6 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6
653- Require gnome-session > 2.16 so it starts gtk-window-decorator.
654- Update to desktop-effects 0.7.1 that doesn't refuse to work with Xinerama.
655
656* Tue Jan 16 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-1
657- Update to 0.3.6, update patches.
658- Drop autotool build requires.
659- Drop glfinish.patch, cow.patch, resize-offset.patch and icon-menu-patch.
660- Add libdecoration.so
661- Update to desktop-effects-0.7.0, which spawns the right decorator
662  and plays nicely with unknown plugins.
663
664* Sat Nov 25 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-2
665- Update the fedora logo patch (#217224)
666
667* Thu Nov 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
668- Update to 0.3.4
669
670* Wed Nov 15 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
671- Use cow by default, bug 208044
672
673* Fri Nov 10 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
674- Update to 0.3.2
675- Drop upstreamed patches
676- Work with new metacity theme api
677
678* Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.32.20060818git.fc6
679- Install the .desktop file with desktop-file-install. Add X-Red-Hat-Base to make it appear in "Preferences", rather than "More Preferences".
680
681* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
682- Add buildrequires on intltool
683
684* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
685- Build
686
687* Fri Sep 29 2006 Soren Sandmann <sandmann@redhat.com>
688- Update to desktop-effects-0.6.163, which has translation enabled. (Bug 208257)
689
690* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.30.20060817git.fc6
691- Add patch to terminate keyboard moves when a mouse buttons is pressed. (Bug 207792).
692
693* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com>
694- Change default plugin list to not include the plane plugin. (Bug 208448).
695- Change default keybinding for shrink to be Pause (Bug 206187).
696
697* Wed Sep 27 2006 Soren Sandmann <sandmann@redhat.com>
698- Add patch to show a menu when the window icon is clicked. (Bug 201629).
699
700* Tue Sep 26 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.29.20060817git.fc6
701- Add restart.patch to make compiz ask the session manager to restart it
702  if it crashes (bug 200280).
703
704* Mon Sep 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.28.20060817git.fc6
705- Change plane.patch to not do cyclical window movement in dimensions
706  where the desktop has size 1 (bug 207263).
707
708* Thu Sep 21 2006 Soren Sandmann <sandmann@redhat.com>
709- Add patch to fix resizing smaller than minimum size (resize-offset.patch, bug 201623).
710
711* Tue Sep 19 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.27.20060817git.fc6
712- Change .plane patch to
713  (a) not set the background color to pink in the plane plugin.
714  (b) allow workspaces with horizontal sizes less then 4.
715
716* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.26.20060817git.fc6
717- Change plane patch to correctly initialize the screen size to the
718  defaults (bug 206088).
719
720* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
721- Run update-desktop-database and gtk-update-icon-cache in post. Add icons
722  to list of packaged files. Also bump to 0.6.137 of dialog (which just makes
723  directories before attempting to install to them).
724
725* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
726- Upgrade to 0.6.107 of the desktop-effects dialog box. Only change is
727  that the new version has icons.
728
729* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
730- Add patch to fix mispositioning of window decorator event windows (bug 201624)
731
732* Fri Sep 15 2006 Soren Sandmann <sandamnn@redhat.com>
733- Upgrade to version 0.6.83 of desktop-effects. (bug 206500)
734
735* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
736- Add patch to only accept button 1 for close/minimize/maximize (bug 201628)
737
738* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
739- Add patch to fix thumbnail sorting (bug 201605)
740
741* Thu Sep 14 2006 Soren Sandmann <sandmann@redhat.com>
742- Add patch to fix double clicking (bug 201783).
743
744* Tue Sep 12 2006 Soren Sandmann <sandmann@redhat.com>
745- Don't attempt to move the viewport when dx = dy = 0.(last bit of 206088).
746
747* Tue Sep 12 2006 Soren Sandmann <sandamnn@redhat.com>
748- Fix plane.patch to draw correctly when no timeout is running. (206088).
749
750* Wed Sep  6 2006 Kristian H淡gsberg <krh@redhat.com>
751- Update fbconfig-depth-fix.patch to also skip fbconfigs without
752  corresponding visuals.
753
754* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.25.20060817git.fc6
755- Make number of vertical size configurable
756
757* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.24.20060817git.fc6
758- Fix vertical viewport support in the plane patch.
759
760* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.23.20060817git.fc6
761- Upgrade to 0.6.61 of the dialog
762
763* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
764- Add libtool to BuildRequires
765
766* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
767- Add automake and autoconf to BuildRequires
768
769* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
770- Add a patch to put viewports on a plane.
771
772* Wed Aug 30 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.21.20060817git.fc6
773- Drop gl-include-inferiors.patch now that compiz uses COW and the X
774  server evicts offscreen pixmaps automatically on
775  GLX_EXT_texture_from_pixmap usage.
776
777* Tue Aug 29 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.20.20060817git.fc6
778- Add cow.patch to make compiz use the composite overlay window.
779
780* Fri Aug 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.19-20060817git.fc6
781- Rebase to desktop-effects 0.6.41
782
783* Fri Aug 25 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.18.20060817git.fc6
784- Rebase to desktop-effects 0.6.19 and drop
785  desktop-effects-0.6.1-delete-session.patch
786
787* Tue Aug 22 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.17.20060817git.fc6
788- Add patch from upstream to also use sync protocol for override
789  redirect windows (sync-override-redirect-windows.patch).
790
791* Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.16.20060817git.fc6
792- Rebase to latest upstream changes which has the rest of the bindings
793  rewrite.  Add resize-move-keybindings.patch to make move and resize
794  bindings work like metacity.
795- Add back scale plugin.
796
797* Thu Aug 10 2006 Ray Strode <rstrode@redhat.com> 0.0.13-0.15.20060721git.fc5.aiglx
798- Add Requires: gnome-session 2.15.90-2.fc6 (bug 201473)
799- unlink session file on changing wms (bug 201473)
800
801* Thu Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.14.20060721git.fc5.aiglx
802- Add Requires: gnome-session 2.15.4-3
803
804* Thu Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
805- New version of dialog box. Macro the version number.
806
807* Wed Aug  2 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
808- Add 'desktop effects' dialog box.
809
810* Mon Jul 31 2006 Kristian H淡gsberg <krh@redhat.com> 0.0.13-0.12.20060721git.fc5.aiglx
811- Add libwnck requires.
812
813* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.11.20060721git.fc5.aiglx
814- Bump and build for fc5 AIGLX repo.
815
816* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.12.20060721git
817- Fix gconf hooks.
818
819* Tue Jul 25 2006 Kristian H淡gsberg <krh@redhat.com>
820- Require system-logos instead.
821
822* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.10.20060721git
823- Bump version to work around tagging weirdness.
824
825* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.9.20060721git
826- Add devel package and require redhat-logos instead of fedora-logos (#199757).
827
828* Fri Jul 21 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.8.20060720git
829- Add workaround for AIGLX throttling problem.
830
831* Thu Jul 20 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.7.20060720git
832- Drop scale plugin from snapshot.
833
834* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.6.20060717git
835- Don't build on s390
836
837* Mon Jul 17 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.5.20060717git
838- Do some changes forced upon us by package review
839
840* Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-5.1
841- Use sane numbering scheme.
842
843* Fri Jul  7 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-4
844- Drop the fullscreen hardcode patch and require X server that has
845  GLX_MESA_copy_sub_buffer.
846
847* Tue Jun 27 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-3
848- Unbreak --replace.
849
850* Thu Jun 15 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-2
851- Add Requires, fix start-compiz.sh.
852
853* Wed Jun 14 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-1
854- Spec file for compiz, borrowing bits and pieces from Alphonse Van
855  Assches spec file (#192432).
Note: See TracBrowser for help on using the repository browser.