source: projects/specs/trunk/c/compiz/compiz-vl.spec @ 4616

Revision 4616, 28.8 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1# build with kde4
2%bcond_with kde
3
4%define         dialogversion   0.7.18
5%define         kde_dialogversion 0.0.5
6
7%define         core_plugins    blur clone commands cube dbus decoration fade ini inotify minimize move obs place png regex resize rotate scale screenshot switcher video water wobbly zoom fs
8
9%define         gnome_plugins   annotate gconf glib svg gnomecompat
10
11# List of plugins passed to ./configure.  The order is important
12
13%define         plugins         core,glib,gconf,dbus,png,svg,video,screenshot,decoration,clone,place,fade,minimize,move,resize,switcher,scale,wall
14
15Summary:        OpenGL window and compositing manager
16Summary(ja):    OpenGL ウィンドウ・コンポジットマネージャ
17Name:           compiz
18URL:            http://www.go-compiz.org
19License:        X11/MIT/GPL
20Group:          User Interface/Desktops
21Version:        0.8.8
22Release:        1%{?_dist_release}
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26# libdrm is not available on these arches
27ExcludeArch:    s390 s390x ppc64
28
29Requires:       xorg-x11-server-Xorg
30Requires:       mesa-libGL
31
32Requires(post): desktop-file-utils
33
34BuildRequires:  mesa-libGLU-devel
35BuildRequires:  libdrm-devel
36BuildRequires:  libwnck-devel
37BuildRequires:  libX11-devel
38BuildRequires:  libXcomposite-devel
39BuildRequires:  libXdamage-devel
40BuildRequires:  libXext-devel
41BuildRequires:  libXfixes-devel
42BuildRequires:  libXmu-devel
43BuildRequires:  libXrandr-devel
44BuildRequires:  libXrender-devel
45BuildRequires:  libXt-devel
46BuildRequires:  libSM-devel
47
48BuildRequires:  GConf2-devel
49BuildRequires:  control-center-devel
50BuildRequires:  dbus-devel
51BuildRequires:  fuse-devel
52BuildRequires:  gnome-desktop-devel >= 2.30.0
53BuildRequires:  libglade2-devel
54BuildRequires:  librsvg2-devel
55BuildRequires:  libxslt-devel
56BuildRequires:  metacity-devel
57
58BuildRequires:  desktop-file-utils
59BuildRequires:  intltool >= 0.35
60BuildRequires:  gettext
61
62%if %{with kde}
63BuildRequires:  kdebase-workspace-devel
64BUildRequires:  dbus-qt-devel
65%endif
66Conflicts:      control-center < 2.32.1-2
67
68# Make sure that former beryl users still have bling
69Obsoletes:      beryl-core
70
71Source0:        http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
72Source1:        desktop-effects-%{dialogversion}.tar.bz2
73Source2:        kde-desktop-effects-%{kde_dialogversion}.tar.bz2
74
75# Patches from fedora
76Patch102: desktop-effects-0.7.17-wall-plugin.patch
77Patch103: composite-cube-logo.patch
78Patch111: gconf-core-plugin-loopfix.patch
79
80# Make sure configuration plugins never get unloaded
81Patch123: compiz-0.7.8-pin-initial-plugins.patch
82
83# Patches from ubuntu
84Patch1140: 014-fix-gtk-window-decorator-no-argb-crash.patch
85Patch1150: 015_optional-fbo.patch
86Patch1160: 016_call_glxwaitx_before_drawing.patch
87Patch1170: 017_always_unredirect_screensaver_on_nvidia.patch
88Patch1200: 020_disable_gdk_gtk_disable_deprecated.patch
89Patch1490: 049-damage-report-non-empty.patch
90Patch1600: 060_move_checks_to_compiz.patch
91
92# Patches from upstream
93Patch2000: compiz-0.8.6-replace-gdk_draw_drawable-with-cairo-equiv.patch
94Patch2010: compiz-0.8.6-fix-pixmap-size-calculation.patch
95
96# Vine default options
97Patch3000: compiz-0.8.6-vine-default.patch
98
99Vendor: Project Vine
100Distribution: Vine Linux
101
102%description
103Compiz is one of the first OpenGL-accelerated compositing window
104managers for the X Window System. The integration allows it to perform
105compositing effects in window management, such as a minimization
106effect and a cube workspace.  Compiz is an OpenGL compositing manager
107that use Compiz use EXT_texture_from_pixmap OpenGL extension for
108binding redirected top-level windows to texture objects.
109
110%package devel
111Summary: Development packages for compiz
112Summary(ja): compiz の開発パッケージ
113Group: Development/Libraries
114Requires: compiz = %{version}-%{release}
115Requires: pkgconfig
116Requires: libXcomposite-devel libXfixes-devel libXdamage-devel libXrandr-devel
117Requires: libXinerama-devel libICE-devel libSM-devel libxml2-devel
118Requires: libxslt-devel startup-notification-devel
119
120%description devel
121The compiz-devel package includes the header files,
122and developer docs for the compiz package.
123
124Install compiz-devel if you want to develop plugins for the compiz
125windows and compositing manager.
126
127%package gnome
128Summary: Compiz gnome integration bits
129Summary(ja): Compiz gnome integration bits
130Group: User Interface/Desktops
131Requires: gnome-session
132Requires: metacity
133Requires: libwnck
134Requires: glx-utils
135Requires: %{name} = %{version}
136Requires(pre): GConf2
137Requires(post): GConf2
138Requires(preun): GConf2
139Obsoletes: compiz < 0.5.2-8
140Obsoletes: beryl-gnome
141
142%description gnome
143The compiz-gnome package contains gtk-window-decorator,
144and other gnome integration related stuff.
145
146%if %{with kde}
147%package kde
148Summary: Compiz kde integration bits
149Summary(ja): Compiz kde integration bits
150Group: User Interface/Desktops
151Requires: %{name} = %{version}
152Requires: compiz-manager
153Obsoletes: beryl-kde
154
155%description kde
156The compiz-kde package contains kde-window-decorator,
157and other kde integration related stuff.
158%endif
159
160%prep
161%setup -q -T -b1 -n desktop-effects-%{dialogversion}
162#%setup -q -T -b2 -n kde-desktop-effects-%{kde_dialogversion}
163%setup -q
164
165pushd ../desktop-effects-%{dialogversion}
166%patch102 -p1 -b .wall-plugin
167popd
168
169%patch103 -p1 -b .composite-cube-logo
170%patch111 -p1 -b .gconf-core-loop
171
172## %patch123 -p1 -b .initial-plugins
173
174# ubuntu patch
175%patch1140 -p1 -b .fix-gtk-window-decorator-no-argb-crash
176%patch1150 -p1 -b .disable-fbo
177%patch1160 -p1 -b .call_glxwaitx_before_drawing
178%patch1170 -p1 -b .always_unredirect_screensaver_on_nvidia
179%patch1200 -p1 -b .disable_gdk_gtk_disable_deprecated
180%patch1490 -p1 -b .damage-report-non-empty
181%patch1600 -p1 -b .move-check-to-compiz
182
183# upstream patch
184#%patch2000 -p1 -b .replace-gdk_draw_drawable-with-cairo-equiv
185#%patch2010 -p1 -b .fix-pixmap-size-calculation
186
187# vine patch
188%patch3000 -p1 -b .vine-default
189
190%build
191rm -rf $RPM_BUILD_ROOT
192
193CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
194export CPPFLAGS
195
196#needed to find kde4 libs
197#LDFLAGS="$LDFLAGS -L%{_libdir}/kde4/devel"
198#export LDFLAGS
199
200libtoolize
201autoreconf
202%configure                                      \
203%{?with_kde: --enable-kde4 }                    \
204%{!?with_kde: --disable-kde4 }                  \
205        --disable-kde                           \
206        --enable-gconf                          \
207        --enable-dbus                           \
208        --enable-place                          \
209        --enable-librsvg                        \
210        --enable-gtk                            \
211        --enable-metacity                       \
212        --enable-gnome                          \
213        --with-default-plugins=%{plugins}       \
214        --enable-gnome-keybindings           
215
216
217make LIBTOOL=/usr/bin/libtool %{?_smp_mflags} imagedir=%{_datadir}/pixmaps
218
219# desktop-effects
220cd ../desktop-effects-%{dialogversion}
221%configure
222
223
224%install
225rm -rf $RPM_BUILD_ROOT
226export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
227make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install || exit 1
228unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
229
230echo INSTALLING DESKTOP EFFECTS
231pushd ../desktop-effects-%{dialogversion}
232make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install || exit 1
233#desktop-file-install --vendor vine --delete-original      \
234#  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
235#  $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
236rm -f $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
237popd
238
239%if %{with kde}
240# kde-desktop-effects
241echo INSTALLING KDE DESKTOP EFFECTS
242pushd ../kde-desktop-effects-%{kde_dialogversion}
243cp -a kde-desktop-effects.sh $RPM_BUILD_ROOT/%{_bindir}/
244mkdir -p $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
245cp -a ChangeLog COPYING README $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
246
247iconlist="16 24 32 36 48 96"
248for i in $iconlist; do
249 mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/
250 cp -p ../desktop-effects-%{dialogversion}/desktop-effects$i.png $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/kde-desktop-effects.png
251done
252
253desktop-file-install --vendor=""           \
254  --dir=%{buildroot}%{_datadir}/applications/kde       \
255  kde-desktop-effects.desktop
256popd
257%endif
258
259%if !%{with kde}
260rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/kconfig.xml
261%endif
262
263
264find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
265find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
266
267
268%find_lang compiz
269%find_lang desktop-effects
270
271cat compiz.lang > core-files.txt
272cat desktop-effects.lang > gnome-files.txt
273
274for f in %{core_plugins}; do
275  echo %{_libdir}/compiz/lib$f.so
276  echo %{_datadir}/compiz/$f.xml
277done >> core-files.txt
278
279for f in %{gnome_plugins}; do
280  echo %{_libdir}/compiz/lib$f.so
281  echo %{_datadir}/compiz/$f.xml
282done >> gnome-files.txt
283
284
285%post -p /sbin/ldconfig
286
287%postun -p /sbin/ldconfig
288
289%post gnome
290update-desktop-database -q %{_datadir}/applications
291
292export GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source`
293for f in %{core_plugins} %{gnome_plugins} core; do
294  echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
295  | xargs gconftool-2 --makefile-install-rule >& /dev/null || :
296
297gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
298
299touch --no-create %{_datadir}/icons/hicolor
300if [ -x /usr/bin/gtk-update-icon-cache ]; then
301        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
302fi
303
304
305%pre gnome
306if [ "$1" -gt 1 ]; then
307  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
308  for f in %{core_plugins} %{gnome_plugins} core; do
309    echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
310    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
311
312  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
313fi
314
315
316%preun gnome
317if [ "$1" -eq 0 ]; then
318  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
319  for f in %{core_plugins} %{gnome_plugins} core; do
320    echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
321    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
322
323  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
324fi
325
326
327%postun gnome
328touch --no-create %{_datadir}/icons/hicolor
329if [ -x /usr/bin/gtk-update-icon-cache ]; then
330        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
331fi
332
333%if %{with kde}
334%post kde
335update-desktop-database -q %{_datadir}/applications/kde
336touch --no-create %{_datadir}/icons/hicolor
337
338%postun kde
339touch --no-create %{_datadir}/icons/hicolor
340%endif
341
342%clean
343rm -rf $RPM_BUILD_ROOT
344
345
346%files -f core-files.txt
347%defattr(-, root, root)
348%doc AUTHORS ChangeLog COPYING* README TODO
349%{_bindir}/compiz
350%{_libdir}/libdecoration.so.*
351%dir %{_libdir}/compiz
352%dir %{_datadir}/compiz
353%{_datadir}/compiz/*.png
354%{_datadir}/compiz/core.xml
355
356
357%files gnome -f gnome-files.txt
358%defattr(-, root, root)
359%{_bindir}/gtk-window-decorator
360%{_bindir}/desktop-effects
361#%{_libdir}/window-manager-settings/libcompiz.so
362#%{_datadir}/gnome/wm-properties/compiz-wm.desktop
363#%{_datadir}/applications/compiz.desktop
364#%{_datadir}/gnome-control-center/keybindings/50-compiz-desktop-key.xml
365#%{_datadir}/gnome-control-center/keybindings/50-compiz-key.xml
366%{_datadir}/compiz/desktop-effects.glade
367%{_datadir}/icons/hicolor/16x16/apps/desktop-effects.png
368%{_datadir}/icons/hicolor/24x24/apps/desktop-effects.png
369%{_datadir}/icons/hicolor/32x32/apps/desktop-effects.png
370%{_datadir}/icons/hicolor/36x36/apps/desktop-effects.png
371%{_datadir}/icons/hicolor/48x48/apps/desktop-effects.png
372%{_datadir}/icons/hicolor/96x96/apps/desktop-effects.png
373%{_sysconfdir}/gconf/schemas/*.schemas
374
375%if %{with kde}
376%files kde
377%defattr(-, root, root)
378%{_bindir}/kde4-window-decorator
379%{_docdir}/compiz-kde-%{version}
380%{_bindir}/kde-desktop-effects.sh
381%{_datadir}/applications/kde/kde-desktop-effects.desktop
382%{_datadir}/icons/hicolor/*/apps/kde-desktop-effects.png
383%{_datadir}/compiz/kconfig.xml
384%endif
385
386%files devel
387%defattr(-, root, root)
388%{_libdir}/pkgconfig/compiz.pc
389%{_libdir}/pkgconfig/libdecoration.pc
390%{_libdir}/pkgconfig/compiz-cube.pc
391%{_libdir}/pkgconfig/compiz-gconf.pc
392%{_libdir}/pkgconfig/compiz-scale.pc
393%{_datadir}/compiz/schemas.xslt
394%{_includedir}/compiz
395%{_libdir}/libdecoration.so
396
397
398%changelog
399* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-1
400- new upstream release
401- add BuildRequires: libxslt-devel, libglade2-devel
402- drop Patch2000,2010
403
404* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-5
405- add Patch3000
406  - disable Sync to vblank
407  - increase drop-shadow radius
408  - set default decorator to gtk-window-decorator
409  - change default daces in cube plugin
410  - use "smart" placement mode
411
412* Sun Mar 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-4
413- drop compiz-gtk
414  - add Conflicts: control-center < 2.32.1-2
415
416* Sat Mar 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-3
417- rebuild with mesa-7.10.1
418- add cherry picked ubuntu patch
419  - Patch1150: add --no-fbo option
420  - Patch1200: disable GDK|GTK_DISABLE_DEPRECATED
421  - Patch1160: call glxwaitx before drawing
422  - Patch1170: always unredirect screensaver on nvidia
423  - Patch1490: damage report non empty
424  - Patch1600: move check to compiz
425- add upstream patch
426  - Patch2000: replace gdk_draw_drawable with cairo equivalents
427  - Patch2010: fix pixmap size calculation
428
429* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-2
430- rebuild with rpm-4.8.1 for pkg-config file
431
432* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
433- new upstream release (build on GNOME-2.30)
434- drop Patch123, Patch300
435
436* Sat Nov 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-4
437- rebuild with mesa-7.6
438- add Patch300 to build with gconf-2.28
439
440* Thu Jun 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-3
441- disable glib plugin in compiz-gtk
442- use direct rendering on virtualbox video adaptor.
443
444* Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-2
445- add Requires: glx-utils to compiz-gnome
446
447* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
448- new upstream release
449
450* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-8
451- re-enable metacity decoration on gtk-window-decorator
452  - BR: metacity-devel instead of metacity
453
454* Fri May 01 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.8-7
455- fix pre/post scripts for speeding up gconf schema installation
456
457* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-6
458- add ccp compiz option to compiz-gtk
459
460* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-5
461- remove desktop-effect.desktop
462  - we use gnome-appearance-properties integrated version.
463
464* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-4
465- add Patch121,122 from upstream fix.
466- add Patch123: make sure configuration plugins never get unloaded
467- add Patch124: memleak fix from upstream
468- add Patch125: make the terminal keybind work
469- add Patch120,126,127 for kde42
470- add Patch128: gwd fix from upstream
471
472* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-3
473- rebuild with gnome-desktop-2.26.0
474
475* Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-2
476- add compiz-gtk scripts and desktop file from fedora
477
478* Thu Oct 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
479- new upstream release
480
481* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-2
482- rebuild with gnome-desktop-2.24.0
483
484* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
485- new upstream release
486
487* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
488- new upstream release
489
490* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
491- initial build for Vine Linux
492
493* Thu Mar 27 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-3
494- Fix gconf plugin loop RH #438794, patch based on
495  older one from Guillaume Seguin
496- Add core to default plugin list
497
498* Wed Mar 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.7.2-2
499- Reword kde-desktop-effects messages to mention Compiz by name (#438883)
500
501* Mon Mar 24 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-1
502- Update to 0.7.2
503
504* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.2-7
505- Autorebuild for GCC 4.3
506
507* Thu Jan 17 2008 Kristian H淡gsberg <krh@redhat.com> - 0.6.2-6
508- Update to desktop-effects version 0.7.17 which include more
509  translations and move desktop-effects translations to compiz-gnome.
510- Fix spelling in beryl-core obsoletes.
511
512* Mon Jan 07 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-5
513- Update buildrequires (kwd uses the kde3 api)
514
515* Tue Nov  6 2007 Stepan Kasal <skasal@redhat.com> - 0.6.2-4
516- Fix a typo in description of the main package.
517- All descriptions should end with a dot (unlike the summary line)
518
519* Thu Oct 25 2007 Sebastian Vahl <fedora@deadbabylon.de> - 0.6.2-3
520- Include kde-desktop-effects in kde subpackage
521
522* Tue Oct 23 2007 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-2
523- Obsolete berly-core
524
525* Mon Oct 22 2007 Warren Togami <wtogami@redhat.com> - 0.6.2-1
526- 0.6.2
527
528* Fri Oct 12 2007 Kristian H淡gsberg <krh@redhat.com> - 0.6.0-2
529- Disable scale corner initiate and install a GNOME key config entry.
530
531* Wed Oct 10 2007 Warren Togami <wtogami@redhat.com> - 0.6.0-1
532- 0.6.0 final
533- always-restack-windows-on-map
534
535* Tue Oct  9 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-14
536- Make compiz behave with gnome-terminal (#304051)
537
538* Fri Oct  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.2-13
539- Also install gwd.schemas (#319621)
540
541* Thu Sep 20 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-12
542- Update to more recent 0.6 branch snapshot (fixes #253575).
543
544* Fri Sep 14 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-11
545- compiz-gnome: install core schema so it actually works
546- remove unnecessary gconf stuff from %%install
547
548* Tue Aug 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-9
549- Make compiz-gnome Obsolete the older compiz package so yum/anaconda
550  will pull it in (thans to Adel Gadllah).
551
552* Wed Aug 22 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-8
553- Bump to desktop-effects 0.7.7 to avoid kill decorator when popping
554  up dialog.
555- Fix broken gconf install and uninstall rules.
556- Pick up shadowman logo for RHEL builds (#232398).
557
558* Tue Aug 21 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-7.0ec3ec
559- Add more-sm-junk.patch so we set SM restart style to
560  SmRestartIfRunning on exit (#247163, #245971).
561- Add Requires to compiz-devel (#253407).
562- Update to desktop-effects 0.7.6, which terminates decorator when
563  switching to metacity or on compiz failure (#215247, #215032).
564
565* Fri Aug 17 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.5.2-6.0ec3ec
566- Split into gnome and kde subpackages
567- Minor cleanups
568
569* Wed Aug 15 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-5.0ec3ec
570- Reorder plugin list to avoid 'place' getting removed on startup.
571- Add run-command-key.patch to put the run command key in the GNOME
572  keyboard shortcut dialog (#213576).
573- Drop a bunch of obsolete patches.
574- Bump mesa-libGL and X server requires to fix TFP bugs for
575  power-of-two textures (#251935).
576- Rebase fedora-logo and composite-cube-logo patch.
577
578* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-4.0ec3ec
579- Build with desktop-effects so we don't pick up metacity work spaces.
580  Fixes #250568.
581
582* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3.0ec3ec
583- Build git snapshot from fedora branch at
584  git://people.freedesktop.org/~krh/compiz, brances from 0.6 upstream
585  branch.
586- Fixes #237486.
587
588* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3
589- Require desktop-effects 0.7.3 and gnome-session 2.19.6-5 which pass
590  'glib' on the command line too.
591
592* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-2
593- Move xml meta data files to main package.
594
595* Thu Aug  9 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-1
596- Update to 0.5.2.
597- Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz
598  with LIBGL_ALWAYS_INDIRECT set.
599
600* Wed Jun 27 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.0-1
601- Update to 0.5.0
602
603* Tue Jun  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
604- Update to 0.4.0
605
606* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-10
607- Rebuild against new libwnck
608
609* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-9
610- Don't install INSTALL
611
612* Mon Apr 16 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-8
613- Update metacity build requires to metacity-devel.
614
615* Wed Apr  4 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-7
616- Fix typo in ./configure option.
617
618* Wed Apr  4 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-6
619- Add place and clone plugins to default plugin list.
620
621* Wed Mar 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-5
622- Update URL (#208214).
623- Require at least metacity 2.18 (#232831).
624- Add close-session.patch to deregister from SM when replaced (#229113).
625
626* Tue Mar 27 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6-4
627- Explicitly disable KDE parts (#234128).
628
629* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> 0.3.6-3
630- Fix some directory ownership issues (#233825)
631- Small spec cleanups
632
633* Tue Feb  6 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6
634- Require gnome-session > 2.16 so it starts gtk-window-decorator.
635- Update to desktop-effects 0.7.1 that doesn't refuse to work with Xinerama.
636
637* Tue Jan 16 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-1
638- Update to 0.3.6, update patches.
639- Drop autotool build requires.
640- Drop glfinish.patch, cow.patch, resize-offset.patch and icon-menu-patch.
641- Add libdecoration.so
642- Update to desktop-effects-0.7.0, which spawns the right decorator
643  and plays nicely with unknown plugins.
644
645* Sat Nov 25 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-2
646- Update the fedora logo patch (#217224)
647
648* Thu Nov 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
649- Update to 0.3.4
650
651* Wed Nov 15 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
652- Use cow by default, bug 208044
653
654* Fri Nov 10 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
655- Update to 0.3.2
656- Drop upstreamed patches
657- Work with new metacity theme api
658
659* Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.32.20060818git.fc6
660- Install the .desktop file with desktop-file-install. Add X-Red-Hat-Base to make it appear in "Preferences", rather than "More Preferences".
661
662* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
663- Add buildrequires on intltool
664
665* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
666- Build
667
668* Fri Sep 29 2006 Soren Sandmann <sandmann@redhat.com>
669- Update to desktop-effects-0.6.163, which has translation enabled. (Bug 208257)
670
671* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.30.20060817git.fc6
672- Add patch to terminate keyboard moves when a mouse buttons is pressed. (Bug 207792).
673
674* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com>
675- Change default plugin list to not include the plane plugin. (Bug 208448).
676- Change default keybinding for shrink to be Pause (Bug 206187).
677
678* Wed Sep 27 2006 Soren Sandmann <sandmann@redhat.com>
679- Add patch to show a menu when the window icon is clicked. (Bug 201629).
680
681* Tue Sep 26 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.29.20060817git.fc6
682- Add restart.patch to make compiz ask the session manager to restart it
683  if it crashes (bug 200280).
684
685* Mon Sep 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.28.20060817git.fc6
686- Change plane.patch to not do cyclical window movement in dimensions
687  where the desktop has size 1 (bug 207263).
688
689* Thu Sep 21 2006 Soren Sandmann <sandmann@redhat.com>
690- Add patch to fix resizing smaller than minimum size (resize-offset.patch, bug 201623).
691
692* Tue Sep 19 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.27.20060817git.fc6
693- Change .plane patch to
694  (a) not set the background color to pink in the plane plugin.
695  (b) allow workspaces with horizontal sizes less then 4.
696
697* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.26.20060817git.fc6
698- Change plane patch to correctly initialize the screen size to the
699  defaults (bug 206088).
700
701* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
702- Run update-desktop-database and gtk-update-icon-cache in post. Add icons
703  to list of packaged files. Also bump to 0.6.137 of dialog (which just makes
704  directories before attempting to install to them).
705
706* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
707- Upgrade to 0.6.107 of the desktop-effects dialog box. Only change is
708  that the new version has icons.
709
710* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
711- Add patch to fix mispositioning of window decorator event windows (bug 201624)
712
713* Fri Sep 15 2006 Soren Sandmann <sandamnn@redhat.com>
714- Upgrade to version 0.6.83 of desktop-effects. (bug 206500)
715
716* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
717- Add patch to only accept button 1 for close/minimize/maximize (bug 201628)
718
719* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
720- Add patch to fix thumbnail sorting (bug 201605)
721
722* Thu Sep 14 2006 Soren Sandmann <sandmann@redhat.com>
723- Add patch to fix double clicking (bug 201783).
724
725* Tue Sep 12 2006 Soren Sandmann <sandmann@redhat.com>
726- Don't attempt to move the viewport when dx = dy = 0.(last bit of 206088).
727
728* Tue Sep 12 2006 Soren Sandmann <sandamnn@redhat.com>
729- Fix plane.patch to draw correctly when no timeout is running. (206088).
730
731* Wed Sep  6 2006 Kristian H淡gsberg <krh@redhat.com>
732- Update fbconfig-depth-fix.patch to also skip fbconfigs without
733  corresponding visuals.
734
735* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.25.20060817git.fc6
736- Make number of vertical size configurable
737
738* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.24.20060817git.fc6
739- Fix vertical viewport support in the plane patch.
740
741* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.23.20060817git.fc6
742- Upgrade to 0.6.61 of the dialog
743
744* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
745- Add libtool to BuildRequires
746
747* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
748- Add automake and autoconf to BuildRequires
749
750* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
751- Add a patch to put viewports on a plane.
752
753* Wed Aug 30 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.21.20060817git.fc6
754- Drop gl-include-inferiors.patch now that compiz uses COW and the X
755  server evicts offscreen pixmaps automatically on
756  GLX_EXT_texture_from_pixmap usage.
757
758* Tue Aug 29 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.20.20060817git.fc6
759- Add cow.patch to make compiz use the composite overlay window.
760
761* Fri Aug 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.19-20060817git.fc6
762- Rebase to desktop-effects 0.6.41
763
764* Fri Aug 25 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.18.20060817git.fc6
765- Rebase to desktop-effects 0.6.19 and drop
766  desktop-effects-0.6.1-delete-session.patch
767
768* Tue Aug 22 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.17.20060817git.fc6
769- Add patch from upstream to also use sync protocol for override
770  redirect windows (sync-override-redirect-windows.patch).
771
772* Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.16.20060817git.fc6
773- Rebase to latest upstream changes which has the rest of the bindings
774  rewrite.  Add resize-move-keybindings.patch to make move and resize
775  bindings work like metacity.
776- Add back scale plugin.
777
778* Thu Aug 10 2006 Ray Strode <rstrode@redhat.com> 0.0.13-0.15.20060721git.fc5.aiglx
779- Add Requires: gnome-session 2.15.90-2.fc6 (bug 201473)
780- unlink session file on changing wms (bug 201473)
781
782* Thu Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.14.20060721git.fc5.aiglx
783- Add Requires: gnome-session 2.15.4-3
784
785* Wed Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
786- New version of dialog box. Macro the version number.
787
788* Wed Aug  2 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
789- Add 'desktop effects' dialog box.
790
791* Mon Jul 31 2006 Kristian H淡gsberg <krh@redhat.com> 0.0.13-0.12.20060721git.fc5.aiglx
792- Add libwnck requires.
793
794* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.11.20060721git.fc5.aiglx
795- Bump and build for fc5 AIGLX repo.
796
797* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.12.20060721git
798- Fix gconf hooks.
799
800* Tue Jul 25 2006 Kristian H淡gsberg <krh@redhat.com>
801- Require system-logos instead.
802
803* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.10.20060721git
804- Bump version to work around tagging weirdness.
805
806* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.9.20060721git
807- Add devel package and require redhat-logos instead of fedora-logos (#199757).
808
809* Fri Jul 21 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.8.20060720git
810- Add workaround for AIGLX throttling problem.
811
812* Thu Jul 20 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.7.20060720git
813- Drop scale plugin from snapshot.
814
815* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.6.20060717git
816- Don't build on s390
817
818* Mon Jul 17 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.5.20060717git
819- Do some changes forced upon us by package review
820
821* Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-5.1
822- Use sane numbering scheme.
823
824* Fri Jul  7 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-4
825- Drop the fullscreen hardcode patch and require X server that has
826  GLX_MESA_copy_sub_buffer.
827
828* Tue Jun 27 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-3
829- Unbreak --replace.
830
831* Thu Jun 15 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-2
832- Add Requires, fix start-compiz.sh.
833
834* Wed Jun 14 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-1
835- Spec file for compiz, borrowing bits and pieces from Alphonse Van
836  Assches spec file (#192432).
Note: See TracBrowser for help on using the repository browser.