source: projects/specs/trunk/c/compiz/compiz-vl.spec @ 2999

Revision 2999, 28.0 KB checked in by daisuke, 13 years ago (diff)

compiz:

  • drop compiz-gtk
    • add Conflicts: control-center < 2.32.1-2


Line 
1# build with kde4
2%bcond_with kde
3
4%define         dialogversion   0.7.18
5%define         kde_dialogversion 0.0.5
6
7%define         core_plugins    blur clone commands cube dbus decoration fade ini inotify minimize move obs place png regex resize rotate scale screenshot switcher video water wobbly zoom fs
8
9%define         gnome_plugins   annotate gconf glib svg gnomecompat
10
11# List of plugins passed to ./configure.  The order is important
12
13%define         plugins         core,glib,gconf,dbus,png,svg,video,screenshot,decoration,clone,place,fade,minimize,move,resize,switcher,scale,wall
14
15Summary:        OpenGL window and compositing manager
16Summary(ja):    OpenGL ウィンドウ・コンポジットマネージャ
17Name:           compiz
18URL:            http://www.go-compiz.org
19License:        X11/MIT/GPL
20Group:          User Interface/Desktops
21Version:        0.8.6
22Release:        4%{?_dist_release}
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26# libdrm is not available on these arches
27ExcludeArch:    s390 s390x ppc64
28
29Requires:       xorg-x11-server-Xorg
30Requires:       mesa-libGL
31
32Requires(post): desktop-file-utils
33
34BuildRequires:  libX11-devel, libdrm-devel, libwnck-devel
35BuildRequires:  libXfixes-devel, libXrandr-devel, libXrender-devel
36BuildRequires:  libXcomposite-devel, libXdamage-devel, libXext-devel
37BuildRequires:  libXt-devel, libXmu-devel, libICE-devel, libSM-devel
38BuildRequires:  control-center-devel, GConf2-devel
39BuildRequires:  gnome-desktop-devel >= 2.30.0
40BuildRequires:  metacity-devel
41BuildRequires:  desktop-file-utils
42BuildRequires:  intltool >= 0.35
43BuildRequires:  gettext
44BuildRequires:  dbus-devel
45BuildRequires:  librsvg2-devel
46BuildRequires:  mesa-libGLU-devel
47BuildRequires:  fuse-devel
48%if %{with kde}
49BuildRequires:  kdebase-workspace-devel
50BUildRequires:  dbus-qt-devel
51%endif
52Conflicts:      control-center < 2.32.1-2
53
54Source0:        http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
55Source1:        desktop-effects-%{dialogversion}.tar.bz2
56Source2:        kde-desktop-effects-%{kde_dialogversion}.tar.bz2
57
58# Make sure that former beryl users still have bling
59Obsoletes: beryl-core
60
61# Patches from fedora
62Patch102: desktop-effects-0.7.17-wall-plugin.patch
63Patch103: composite-cube-logo.patch
64Patch111: gconf-core-plugin-loopfix.patch
65
66# Make sure configuration plugins never get unloaded
67Patch123: compiz-0.7.8-pin-initial-plugins.patch
68
69# Patches from ubuntu
70Patch1140: 014-fix-gtk-window-decorator-no-argb-crash.patch
71Patch1150: 015_optional-fbo.patch
72Patch1160: 016_call_glxwaitx_before_drawing.patch
73Patch1170: 017_always_unredirect_screensaver_on_nvidia.patch
74Patch1200: 020_disable_gdk_gtk_disable_deprecated.patch
75Patch1490: 049-damage-report-non-empty.patch
76Patch1600: 060_move_checks_to_compiz.patch
77
78# Patches from upstream
79Patch2000: compiz-0.8.6-replace-gdk_draw_drawable-with-cairo-equiv.patch
80Patch2010: compiz-0.8.6-fix-pixmap-size-calculation.patch
81
82%description
83Compiz is one of the first OpenGL-accelerated compositing window
84managers for the X Window System. The integration allows it to perform
85compositing effects in window management, such as a minimization
86effect and a cube workspace.  Compiz is an OpenGL compositing manager
87that use Compiz use EXT_texture_from_pixmap OpenGL extension for
88binding redirected top-level windows to texture objects.
89
90%package devel
91Summary: Development packages for compiz
92Summary(ja): compiz の開発パッケージ
93Group: Development/Libraries
94Requires: compiz = %{version}-%{release}
95Requires: pkgconfig
96Requires: libXcomposite-devel libXfixes-devel libXdamage-devel libXrandr-devel
97Requires: libXinerama-devel libICE-devel libSM-devel libxml2-devel
98Requires: libxslt-devel startup-notification-devel
99
100%description devel
101The compiz-devel package includes the header files,
102and developer docs for the compiz package.
103
104Install compiz-devel if you want to develop plugins for the compiz
105windows and compositing manager.
106
107%package gnome
108Summary: Compiz gnome integration bits
109Summary(ja): Compiz gnome integration bits
110Group: User Interface/Desktops
111Requires: gnome-session
112Requires: metacity
113Requires: libwnck
114Requires: glx-utils
115Requires: %{name} = %{version}
116Requires(pre): GConf2
117Requires(post): GConf2
118Requires(preun): GConf2
119Obsoletes: compiz < 0.5.2-8
120Obsoletes: beryl-gnome
121
122%description gnome
123The compiz-gnome package contains gtk-window-decorator,
124and other gnome integration related stuff.
125
126%if %{with kde}
127%package kde
128Summary: Compiz kde integration bits
129Summary(ja): Compiz kde integration bits
130Group: User Interface/Desktops
131Requires: %{name} = %{version}
132Requires: compiz-manager
133Obsoletes: beryl-kde
134
135%description kde
136The compiz-kde package contains kde-window-decorator,
137and other kde integration related stuff.
138%endif
139
140%prep
141%setup -q -T -b1 -n desktop-effects-%{dialogversion}
142#%setup -q -T -b2 -n kde-desktop-effects-%{kde_dialogversion}
143%setup -q
144
145pushd ../desktop-effects-%{dialogversion}
146%patch102 -p1 -b .wall-plugin
147popd
148
149%patch103 -p1 -b .composite-cube-logo
150%patch111 -p1 -b .gconf-core-loop
151
152## %patch123 -p1 -b .initial-plugins
153
154# ubuntu patch
155%patch1140 -p1 -b .fix-gtk-window-decorator-no-argb-crash
156%patch1150 -p1 -b .disable-fbo
157%patch1160 -p1 -b .call_glxwaitx_before_drawing
158%patch1170 -p1 -b .always_unredirect_screensaver_on_nvidia
159%patch1200 -p1 -b .disable_gdk_gtk_disable_deprecated
160%patch1490 -p1 -b .damage-report-non-empty
161%patch1600 -p1 -b .move-check-to-compiz
162
163# upstream patch
164%patch2000 -p1 -b .replace-gdk_draw_drawable-with-cairo-equiv
165%patch2010 -p1 -b .fix-pixmap-size-calculation
166%build
167rm -rf $RPM_BUILD_ROOT
168
169CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
170export CPPFLAGS
171
172#needed to find kde4 libs
173#LDFLAGS="$LDFLAGS -L%{_libdir}/kde4/devel"
174#export LDFLAGS
175
176libtoolize
177autoreconf
178%configure                                      \
179%{?with_kde: --enable-kde4 }                    \
180%{!?with_kde: --disable-kde4 }                  \
181        --disable-kde                           \
182        --enable-gconf                          \
183        --enable-dbus                           \
184        --enable-place                          \
185        --enable-librsvg                        \
186        --enable-gtk                            \
187        --enable-metacity                       \
188        --enable-gnome                          \
189        --with-default-plugins=%{plugins}       \
190        --enable-gnome-keybindings           
191
192
193make %{?_smp_mflags} imagedir=%{_datadir}/pixmaps
194
195# desktop-effects
196cd ../desktop-effects-%{dialogversion}
197%configure
198
199
200%install
201rm -rf $RPM_BUILD_ROOT
202export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
203make DESTDIR=$RPM_BUILD_ROOT install || exit 1
204unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
205
206echo INSTALLING DESKTOP EFFECTS
207pushd ../desktop-effects-%{dialogversion}
208make DESTDIR=$RPM_BUILD_ROOT install || exit 1
209#desktop-file-install --vendor vine --delete-original      \
210#  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
211#  $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
212rm -f $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
213popd
214
215%if %{with kde}
216# kde-desktop-effects
217echo INSTALLING KDE DESKTOP EFFECTS
218pushd ../kde-desktop-effects-%{kde_dialogversion}
219cp -a kde-desktop-effects.sh $RPM_BUILD_ROOT/%{_bindir}/
220mkdir -p $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
221cp -a ChangeLog COPYING README $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
222
223iconlist="16 24 32 36 48 96"
224for i in $iconlist; do
225 mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/
226 cp -p ../desktop-effects-%{dialogversion}/desktop-effects$i.png $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/kde-desktop-effects.png
227done
228
229desktop-file-install --vendor=""           \
230  --dir=%{buildroot}%{_datadir}/applications/kde       \
231  kde-desktop-effects.desktop
232popd
233%endif
234
235%if !%{with kde}
236rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/kconfig.xml
237%endif
238
239
240find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
241find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
242
243
244%find_lang compiz
245%find_lang desktop-effects
246
247cat compiz.lang > core-files.txt
248cat desktop-effects.lang > gnome-files.txt
249
250for f in %{core_plugins}; do
251  echo %{_libdir}/compiz/lib$f.so
252  echo %{_datadir}/compiz/$f.xml
253done >> core-files.txt
254
255for f in %{gnome_plugins}; do
256  echo %{_libdir}/compiz/lib$f.so
257  echo %{_datadir}/compiz/$f.xml
258done >> gnome-files.txt
259
260
261%post -p /sbin/ldconfig
262
263%postun -p /sbin/ldconfig
264
265%post gnome
266update-desktop-database -q %{_datadir}/applications
267
268export GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source`
269for f in %{core_plugins} %{gnome_plugins} core; do
270  echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
271  | xargs gconftool-2 --makefile-install-rule >& /dev/null || :
272
273gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
274
275touch --no-create %{_datadir}/icons/hicolor
276if [ -x /usr/bin/gtk-update-icon-cache ]; then
277        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
278fi
279
280
281%pre gnome
282if [ "$1" -gt 1 ]; then
283  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
284  for f in %{core_plugins} %{gnome_plugins} core; do
285    echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
286    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
287
288  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
289fi
290
291
292%preun gnome
293if [ "$1" -eq 0 ]; then
294  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
295  for f in %{core_plugins} %{gnome_plugins} core; do
296    echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
297    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
298
299  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
300fi
301
302
303%postun gnome
304touch --no-create %{_datadir}/icons/hicolor
305if [ -x /usr/bin/gtk-update-icon-cache ]; then
306        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
307fi
308
309%if %{with kde}
310%post kde
311update-desktop-database -q %{_datadir}/applications/kde
312touch --no-create %{_datadir}/icons/hicolor
313
314%postun kde
315touch --no-create %{_datadir}/icons/hicolor
316%endif
317
318%clean
319rm -rf $RPM_BUILD_ROOT
320
321
322%files -f core-files.txt
323%defattr(-, root, root)
324%doc AUTHORS ChangeLog COPYING* README TODO
325%{_bindir}/compiz
326%{_libdir}/libdecoration.so.*
327%dir %{_libdir}/compiz
328%dir %{_datadir}/compiz
329%{_datadir}/compiz/*.png
330%{_datadir}/compiz/core.xml
331
332
333%files gnome -f gnome-files.txt
334%defattr(-, root, root)
335%{_bindir}/gtk-window-decorator
336%{_bindir}/desktop-effects
337%{_libdir}/window-manager-settings/libcompiz.so
338%{_datadir}/gnome/wm-properties/compiz-wm.desktop
339%{_datadir}/applications/compiz.desktop
340%{_datadir}/gnome-control-center/keybindings/50-compiz-desktop-key.xml
341%{_datadir}/gnome-control-center/keybindings/50-compiz-key.xml
342%{_datadir}/compiz/desktop-effects.glade
343%{_datadir}/icons/hicolor/16x16/apps/desktop-effects.png
344%{_datadir}/icons/hicolor/24x24/apps/desktop-effects.png
345%{_datadir}/icons/hicolor/32x32/apps/desktop-effects.png
346%{_datadir}/icons/hicolor/36x36/apps/desktop-effects.png
347%{_datadir}/icons/hicolor/48x48/apps/desktop-effects.png
348%{_datadir}/icons/hicolor/96x96/apps/desktop-effects.png
349%{_sysconfdir}/gconf/schemas/*.schemas
350
351%if %{with kde}
352%files kde
353%defattr(-, root, root)
354%{_bindir}/kde4-window-decorator
355%{_docdir}/compiz-kde-%{version}
356%{_bindir}/kde-desktop-effects.sh
357%{_datadir}/applications/kde/kde-desktop-effects.desktop
358%{_datadir}/icons/hicolor/*/apps/kde-desktop-effects.png
359%{_datadir}/compiz/kconfig.xml
360%endif
361
362%files devel
363%defattr(-, root, root)
364%{_libdir}/pkgconfig/compiz.pc
365%{_libdir}/pkgconfig/libdecoration.pc
366%{_libdir}/pkgconfig/compiz-cube.pc
367%{_libdir}/pkgconfig/compiz-gconf.pc
368%{_libdir}/pkgconfig/compiz-scale.pc
369%{_datadir}/compiz/schemas.xslt
370%{_includedir}/compiz
371%{_libdir}/libdecoration.so
372
373
374%changelog
375* Sun Mar 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-4
376- drop compiz-gtk
377  - add Conflicts: control-center < 2.32.1-2
378
379* Sat Mar 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-3
380- rebuild with mesa-7.10.1
381- add cherry picked ubuntu patch
382  - Patch1150: add --no-fbo option
383  - Patch1200: disable GDK|GTK_DISABLE_DEPRECATED
384  - Patch1160: call glxwaitx before drawing
385  - Patch1170: always unredirect screensaver on nvidia
386  - Patch1490: damage report non empty
387  - Patch1600: move check to compiz
388- add upstream patch
389  - Patch2000: replace gdk_draw_drawable with cairo equivalents
390  - Patch2010: fix pixmap size calculation
391
392* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-2
393- rebuild with rpm-4.8.1 for pkg-config file
394
395* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
396- new upstream release (build on GNOME-2.30)
397- drop Patch123, Patch300
398
399* Sat Nov 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-4
400- rebuild with mesa-7.6
401- add Patch300 to build with gconf-2.28
402
403* Thu Jun 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-3
404- disable glib plugin in compiz-gtk
405- use direct rendering on virtualbox video adaptor.
406
407* Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-2
408- add Requires: glx-utils to compiz-gnome
409
410* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
411- new upstream release
412
413* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-8
414- re-enable metacity decoration on gtk-window-decorator
415  - BR: metacity-devel instead of metacity
416
417* Fri May 01 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.8-7
418- fix pre/post scripts for speeding up gconf schema installation
419
420* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-6
421- add ccp compiz option to compiz-gtk
422
423* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-5
424- remove desktop-effect.desktop
425  - we use gnome-appearance-properties integrated version.
426
427* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-4
428- add Patch121,122 from upstream fix.
429- add Patch123: make sure configuration plugins never get unloaded
430- add Patch124: memleak fix from upstream
431- add Patch125: make the terminal keybind work
432- add Patch120,126,127 for kde42
433- add Patch128: gwd fix from upstream
434
435* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-3
436- rebuild with gnome-desktop-2.26.0
437
438* Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-2
439- add compiz-gtk scripts and desktop file from fedora
440
441* Thu Oct 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
442- new upstream release
443
444* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-2
445- rebuild with gnome-desktop-2.24.0
446
447* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
448- new upstream release
449
450* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
451- new upstream release
452
453* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
454- initial build for Vine Linux
455
456* Thu Mar 27 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-3
457- Fix gconf plugin loop RH #438794, patch based on
458  older one from Guillaume Seguin
459- Add core to default plugin list
460
461* Wed Mar 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.7.2-2
462- Reword kde-desktop-effects messages to mention Compiz by name (#438883)
463
464* Mon Mar 24 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-1
465- Update to 0.7.2
466
467* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.2-7
468- Autorebuild for GCC 4.3
469
470* Thu Jan 17 2008 Kristian H淡gsberg <krh@redhat.com> - 0.6.2-6
471- Update to desktop-effects version 0.7.17 which include more
472  translations and move desktop-effects translations to compiz-gnome.
473- Fix spelling in beryl-core obsoletes.
474
475* Mon Jan 07 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-5
476- Update buildrequires (kwd uses the kde3 api)
477
478* Tue Nov  6 2007 Stepan Kasal <skasal@redhat.com> - 0.6.2-4
479- Fix a typo in description of the main package.
480- All descriptions should end with a dot (unlike the summary line)
481
482* Thu Oct 25 2007 Sebastian Vahl <fedora@deadbabylon.de> - 0.6.2-3
483- Include kde-desktop-effects in kde subpackage
484
485* Tue Oct 23 2007 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-2
486- Obsolete berly-core
487
488* Mon Oct 22 2007 Warren Togami <wtogami@redhat.com> - 0.6.2-1
489- 0.6.2
490
491* Fri Oct 12 2007 Kristian H淡gsberg <krh@redhat.com> - 0.6.0-2
492- Disable scale corner initiate and install a GNOME key config entry.
493
494* Wed Oct 10 2007 Warren Togami <wtogami@redhat.com> - 0.6.0-1
495- 0.6.0 final
496- always-restack-windows-on-map
497
498* Tue Oct  9 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-14
499- Make compiz behave with gnome-terminal (#304051)
500
501* Fri Oct  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.2-13
502- Also install gwd.schemas (#319621)
503
504* Thu Sep 20 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-12
505- Update to more recent 0.6 branch snapshot (fixes #253575).
506
507* Fri Sep 14 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-11
508- compiz-gnome: install core schema so it actually works
509- remove unnecessary gconf stuff from %%install
510
511* Tue Aug 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-9
512- Make compiz-gnome Obsolete the older compiz package so yum/anaconda
513  will pull it in (thans to Adel Gadllah).
514
515* Wed Aug 22 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-8
516- Bump to desktop-effects 0.7.7 to avoid kill decorator when popping
517  up dialog.
518- Fix broken gconf install and uninstall rules.
519- Pick up shadowman logo for RHEL builds (#232398).
520
521* Tue Aug 21 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-7.0ec3ec
522- Add more-sm-junk.patch so we set SM restart style to
523  SmRestartIfRunning on exit (#247163, #245971).
524- Add Requires to compiz-devel (#253407).
525- Update to desktop-effects 0.7.6, which terminates decorator when
526  switching to metacity or on compiz failure (#215247, #215032).
527
528* Fri Aug 17 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.5.2-6.0ec3ec
529- Split into gnome and kde subpackages
530- Minor cleanups
531
532* Wed Aug 15 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-5.0ec3ec
533- Reorder plugin list to avoid 'place' getting removed on startup.
534- Add run-command-key.patch to put the run command key in the GNOME
535  keyboard shortcut dialog (#213576).
536- Drop a bunch of obsolete patches.
537- Bump mesa-libGL and X server requires to fix TFP bugs for
538  power-of-two textures (#251935).
539- Rebase fedora-logo and composite-cube-logo patch.
540
541* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-4.0ec3ec
542- Build with desktop-effects so we don't pick up metacity work spaces.
543  Fixes #250568.
544
545* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3.0ec3ec
546- Build git snapshot from fedora branch at
547  git://people.freedesktop.org/~krh/compiz, brances from 0.6 upstream
548  branch.
549- Fixes #237486.
550
551* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3
552- Require desktop-effects 0.7.3 and gnome-session 2.19.6-5 which pass
553  'glib' on the command line too.
554
555* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-2
556- Move xml meta data files to main package.
557
558* Thu Aug  9 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-1
559- Update to 0.5.2.
560- Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz
561  with LIBGL_ALWAYS_INDIRECT set.
562
563* Wed Jun 27 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.0-1
564- Update to 0.5.0
565
566* Tue Jun  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
567- Update to 0.4.0
568
569* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-10
570- Rebuild against new libwnck
571
572* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-9
573- Don't install INSTALL
574
575* Mon Apr 16 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-8
576- Update metacity build requires to metacity-devel.
577
578* Wed Apr  4 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-7
579- Fix typo in ./configure option.
580
581* Wed Apr  4 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-6
582- Add place and clone plugins to default plugin list.
583
584* Wed Mar 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-5
585- Update URL (#208214).
586- Require at least metacity 2.18 (#232831).
587- Add close-session.patch to deregister from SM when replaced (#229113).
588
589* Tue Mar 27 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6-4
590- Explicitly disable KDE parts (#234128).
591
592* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> 0.3.6-3
593- Fix some directory ownership issues (#233825)
594- Small spec cleanups
595
596* Tue Feb  6 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6
597- Require gnome-session > 2.16 so it starts gtk-window-decorator.
598- Update to desktop-effects 0.7.1 that doesn't refuse to work with Xinerama.
599
600* Tue Jan 16 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-1
601- Update to 0.3.6, update patches.
602- Drop autotool build requires.
603- Drop glfinish.patch, cow.patch, resize-offset.patch and icon-menu-patch.
604- Add libdecoration.so
605- Update to desktop-effects-0.7.0, which spawns the right decorator
606  and plays nicely with unknown plugins.
607
608* Sat Nov 25 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-2
609- Update the fedora logo patch (#217224)
610
611* Thu Nov 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
612- Update to 0.3.4
613
614* Wed Nov 15 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
615- Use cow by default, bug 208044
616
617* Fri Nov 10 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
618- Update to 0.3.2
619- Drop upstreamed patches
620- Work with new metacity theme api
621
622* Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.32.20060818git.fc6
623- Install the .desktop file with desktop-file-install. Add X-Red-Hat-Base to make it appear in "Preferences", rather than "More Preferences".
624
625* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
626- Add buildrequires on intltool
627
628* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
629- Build
630
631* Fri Sep 29 2006 Soren Sandmann <sandmann@redhat.com>
632- Update to desktop-effects-0.6.163, which has translation enabled. (Bug 208257)
633
634* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.30.20060817git.fc6
635- Add patch to terminate keyboard moves when a mouse buttons is pressed. (Bug 207792).
636
637* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com>
638- Change default plugin list to not include the plane plugin. (Bug 208448).
639- Change default keybinding for shrink to be Pause (Bug 206187).
640
641* Wed Sep 27 2006 Soren Sandmann <sandmann@redhat.com>
642- Add patch to show a menu when the window icon is clicked. (Bug 201629).
643
644* Tue Sep 26 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.29.20060817git.fc6
645- Add restart.patch to make compiz ask the session manager to restart it
646  if it crashes (bug 200280).
647
648* Mon Sep 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.28.20060817git.fc6
649- Change plane.patch to not do cyclical window movement in dimensions
650  where the desktop has size 1 (bug 207263).
651
652* Thu Sep 21 2006 Soren Sandmann <sandmann@redhat.com>
653- Add patch to fix resizing smaller than minimum size (resize-offset.patch, bug 201623).
654
655* Tue Sep 19 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.27.20060817git.fc6
656- Change .plane patch to
657  (a) not set the background color to pink in the plane plugin.
658  (b) allow workspaces with horizontal sizes less then 4.
659
660* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.26.20060817git.fc6
661- Change plane patch to correctly initialize the screen size to the
662  defaults (bug 206088).
663
664* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
665- Run update-desktop-database and gtk-update-icon-cache in post. Add icons
666  to list of packaged files. Also bump to 0.6.137 of dialog (which just makes
667  directories before attempting to install to them).
668
669* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
670- Upgrade to 0.6.107 of the desktop-effects dialog box. Only change is
671  that the new version has icons.
672
673* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
674- Add patch to fix mispositioning of window decorator event windows (bug 201624)
675
676* Fri Sep 15 2006 Soren Sandmann <sandamnn@redhat.com>
677- Upgrade to version 0.6.83 of desktop-effects. (bug 206500)
678
679* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
680- Add patch to only accept button 1 for close/minimize/maximize (bug 201628)
681
682* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
683- Add patch to fix thumbnail sorting (bug 201605)
684
685* Thu Sep 14 2006 Soren Sandmann <sandmann@redhat.com>
686- Add patch to fix double clicking (bug 201783).
687
688* Tue Sep 12 2006 Soren Sandmann <sandmann@redhat.com>
689- Don't attempt to move the viewport when dx = dy = 0.(last bit of 206088).
690
691* Tue Sep 12 2006 Soren Sandmann <sandamnn@redhat.com>
692- Fix plane.patch to draw correctly when no timeout is running. (206088).
693
694* Wed Sep  6 2006 Kristian H淡gsberg <krh@redhat.com>
695- Update fbconfig-depth-fix.patch to also skip fbconfigs without
696  corresponding visuals.
697
698* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.25.20060817git.fc6
699- Make number of vertical size configurable
700
701* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.24.20060817git.fc6
702- Fix vertical viewport support in the plane patch.
703
704* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.23.20060817git.fc6
705- Upgrade to 0.6.61 of the dialog
706
707* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
708- Add libtool to BuildRequires
709
710* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
711- Add automake and autoconf to BuildRequires
712
713* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
714- Add a patch to put viewports on a plane.
715
716* Wed Aug 30 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.21.20060817git.fc6
717- Drop gl-include-inferiors.patch now that compiz uses COW and the X
718  server evicts offscreen pixmaps automatically on
719  GLX_EXT_texture_from_pixmap usage.
720
721* Tue Aug 29 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.20.20060817git.fc6
722- Add cow.patch to make compiz use the composite overlay window.
723
724* Fri Aug 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.19-20060817git.fc6
725- Rebase to desktop-effects 0.6.41
726
727* Fri Aug 25 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.18.20060817git.fc6
728- Rebase to desktop-effects 0.6.19 and drop
729  desktop-effects-0.6.1-delete-session.patch
730
731* Tue Aug 22 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.17.20060817git.fc6
732- Add patch from upstream to also use sync protocol for override
733  redirect windows (sync-override-redirect-windows.patch).
734
735* Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.16.20060817git.fc6
736- Rebase to latest upstream changes which has the rest of the bindings
737  rewrite.  Add resize-move-keybindings.patch to make move and resize
738  bindings work like metacity.
739- Add back scale plugin.
740
741* Thu Aug 10 2006 Ray Strode <rstrode@redhat.com> 0.0.13-0.15.20060721git.fc5.aiglx
742- Add Requires: gnome-session 2.15.90-2.fc6 (bug 201473)
743- unlink session file on changing wms (bug 201473)
744
745* Thu Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.14.20060721git.fc5.aiglx
746- Add Requires: gnome-session 2.15.4-3
747
748* Wed Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
749- New version of dialog box. Macro the version number.
750
751* Wed Aug  2 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
752- Add 'desktop effects' dialog box.
753
754* Mon Jul 31 2006 Kristian H淡gsberg <krh@redhat.com> 0.0.13-0.12.20060721git.fc5.aiglx
755- Add libwnck requires.
756
757* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.11.20060721git.fc5.aiglx
758- Bump and build for fc5 AIGLX repo.
759
760* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.12.20060721git
761- Fix gconf hooks.
762
763* Tue Jul 25 2006 Kristian H淡gsberg <krh@redhat.com>
764- Require system-logos instead.
765
766* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.10.20060721git
767- Bump version to work around tagging weirdness.
768
769* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.9.20060721git
770- Add devel package and require redhat-logos instead of fedora-logos (#199757).
771
772* Fri Jul 21 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.8.20060720git
773- Add workaround for AIGLX throttling problem.
774
775* Thu Jul 20 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.7.20060720git
776- Drop scale plugin from snapshot.
777
778* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.6.20060717git
779- Don't build on s390
780
781* Mon Jul 17 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.5.20060717git
782- Do some changes forced upon us by package review
783
784* Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-5.1
785- Use sane numbering scheme.
786
787* Fri Jul  7 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-4
788- Drop the fullscreen hardcode patch and require X server that has
789  GLX_MESA_copy_sub_buffer.
790
791* Tue Jun 27 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-3
792- Unbreak --replace.
793
794* Thu Jun 15 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-2
795- Add Requires, fix start-compiz.sh.
796
797* Wed Jun 14 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-1
798- Spec file for compiz, borrowing bits and pieces from Alphonse Van
799  Assches spec file (#192432).
Note: See TracBrowser for help on using the repository browser.