source: projects/specs/trunk/y/yelp/yelp-vl.spec @ 9586

Revision 9586, 13.8 KB checked in by Takemikaduchi, 9 years ago (diff)

compiz: change BR & R: marco
task-compiz: add compiz-mate
yelp: add R

Line 
1%define glib2_version 2.44.0
2%define pango_version 1.36.3
3%define gtk3_version 3.16.0
4%define desktop_file_utils_version 0.17
5%define rarian_version 0.7.0
6%define gnome_common_version 3.14.0
7
8Summary: A system documentation reader from the Gnome project.
9Summary(ja): GNOME プロジェクトのシステムドキュメントリーダ
10Name: yelp
11Version: 3.16.1
12Release: 2%{?_dist_release}
13
14URL: http://live.gnome.org/Yelp
15Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.16/%{name}-%{version}.tar.xz
16Source10: man-convert-helper
17
18License: GPL
19Group: User Interface/Desktops
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21Requires: gtk3 >= %{gtk3_version}
22Requires: gnome-user-docs
23Requires: nkf
24Requires: yelp-xsl
25Requires: gnome-settings-daemon
26BuildRequires: glib2-devel >= %{glib2_version}
27BuildRequires: pango-devel >= %{pango_version}
28BuildRequires: gtk3-devel >= %{gtk3_version}
29BuildRequires: libxml2-devel >= 2.6.5
30BuildRequires: libxslt-devel >= 1.1.4
31BuildRequires: zlib-devel
32BuildRequires: xz-devel
33BuildRequires: bzip2-devel
34BuildRequires: startup-notification-devel >= 0.8
35BuildRequires: dbus-glib-devel
36BuildRequires: rarian-devel >= %{rarian_version}
37BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
38BuildRequires: gnome-common >= %{gnome_common_version}
39BuildRequires: yelp-xsl-devel
40BuildRequires: WebKit3-gtk-devel
41BuildRequires: sqlite3-devel
42BuildRequires: libSM-devel
43BuildRequires: yelp-tools
44BuildRequires: gtk-doc
45
46Vendor: Project Vine
47Distribution: Vine Linux
48Packager: Takemikaduchi
49
50%description
51Yelp is the Gnome 3 help/documentation browser. It is designed
52to help you browse all the documentation on your system in
53one central tool.
54
55%description -l ja
56Yelp は Gnome 3 のヘルプ/ドキュメントブラウザです。このツール
57によってシステム内の全てのドキュメントを参照できることを目標に
58作られています。
59
60%package libs
61Summary: Libraries for yelp
62Summary(ja): Yelp のライブラリ
63Group: System Environment/Libraries
64Requires: %{name} = %{version}-%{release}
65
66%description libs
67This package contains libraries used by the yelp help browser.
68
69%package devel
70Summary: Development files for yelp-libs
71Summary(ja): yelp-libs の開発用ファイル
72Group: Development/Libraries
73Requires: %{name}-libs = %{version}-%{release}
74
75%description devel
76This package contains header files and documentation for
77the libraries in the yelp-libs package.
78
79
80%package        docs
81Summary:        Documentation for %{name}
82Summary(ja):    %{name} のドキュメント
83Group:          Documentation
84Requires:       %{name} = %{version}-%{release}
85BuildArch:      noarch
86
87%description    docs
88This package contains documentation for %{name}.
89
90
91%prep
92%setup -q
93
94# autoreconf -f -i
95
96%build
97%configure \
98        --disable-static
99make
100
101%install
102rm -rf $RPM_BUILD_ROOT
103export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
104make install DESTDIR=$RPM_BUILD_ROOT
105unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
106
107mkdir -p -m 755 $RPM_BUILD_ROOT/%{_datadir}/gnome/help
108
109install -m755 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/yelp/
110
111rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
112
113%find_lang %{name}
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%post
119update-desktop-database %{_datadir}/applications >& /dev/null ||:
120update-mime-database %{_datadir}/mime >& /dev/null ||:
121
122touch %{_datadir}/icons/hicolor
123#if [ -x /usr/bin/gtk-update-icon-cache ]; then
124#  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
125#fi
126
127%postun
128update-desktop-database %{_datadir}/applications >& /dev/null ||:
129update-mime-database %{_datadir}/mime >& /dev/null ||:
130glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
131
132%posttrans
133glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
134
135%post libs -p /sbin/ldconfig
136
137%postun libs -p /sbin/ldconfig
138
139%files -f %{name}.lang
140%defattr(-,root,root)
141%{_bindir}/*
142%{_datadir}/applications/*
143%{_datadir}/glib-2.0/schemas/org.gnome.yelp.gschema.xml
144%{_datadir}/yelp-xsl/xslt/common/domains/yelp.xml
145%dir %{_datadir}/gnome/help
146%{_datadir}/%{name}
147#%{_datadir}/icons/hicolor/*
148
149%files libs
150%defattr(-,root,root,-)
151%{_libdir}/libyelp.so.*
152
153%files devel
154%defattr(-,root,root,-)
155%{_libdir}/libyelp.so
156%{_includedir}/libyelp
157
158%files docs
159%defattr(-,root,root,-)
160%{_datadir}/gtk-doc/html/libyelp
161
162
163%changelog
164* Sat Jun 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-2
165- add Requires: gnome-settings-daemon
166
167* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
168- new upstream release
169
170* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
171- new upstream release
172
173* Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.1-2
174- moved libs subpakage to System Environment/Libraries Group
175- added %%post and %%postun to libs subpackage
176
177* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
178- new upstream release
179
180* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
181- new upstream release
182
183* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
184- rebuild with VineSeed environment
185
186* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
187- new upstream release
188
189* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
190- new upstream release
191
192* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
193- new upstream release
194- create %%{name}-docs subpackage
195
196* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
197- new upstream release
198
199* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
200- new upstream release
201
202* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
203- new upstream release
204- change BuildRequires: yelp-tools instead of gnome-doc-utils
205
206* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
207- new upstream release
208
209* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
210- new upstream release
211- add BuildRequires: itstool
212- remove BuildRequires: GConf2-devel
213
214* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
215- new upstream release
216
217* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
218- new upstream release
219
220* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
221- new upstream release
222- add BuildRequires: libSM-devel
223
224* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-1
225- new upstream release
226
227* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.1-1
228- new upstream release
229- create -libs and -devel sub package
230- add BuildRequires: yelp-xsl-devel, WebKit3-gtk-devel, sqlite3-devel
231- remove BuildRequires: xulrunner-devel
232- change BuildRequires: gtk3-devel instead of gtk2-devel
233- change BuildRequires: xz-devel instead of lzma-devel
234- drop old Patches
235
236* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
237- update Patch2: yelp-2.30.2-add-mime-handling.patch
238
239* Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.2-2
240- rebuild with xulrunner-2.0
241- add Patch11 to build with xulrunner-2.0
242
243* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
244- new upstream release
245
246* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
247- new upstream release
248
249* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
250- new upstream release
251- change Requires: gecko-libs -> xulrunner
252- change BuildRequires: gecko-devel -> xulrunner-devel
253- drop Patch11
254
255* Mon Mar 01 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-1
256- new upstream release
257- build with xulrunner-1.9.2 (gecko-1.9.2)
258  - BR: gecko-devel instead of gecko-unstable-devel
259  - add patch11 to fix xulrunner-1.9.2 problem
260    - https://bugzilla.gnome.org/show_bug.cgi?id=603561
261    - http://git.gnome.org/browse/yelp/commit/?id=a5588114ed94d00ca64913aa5b248e09a5e13edc
262
263* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
264- new upstream release
265
266* Tue Aug 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
267- convert manpages from euc to utf8
268
269* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
270- rebuild with gecko-1.9.1
271
272* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
273- new upstream release
274- remove BR: libgnomeprintui-devel
275
276* Mon Jun 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1-2
277- use xulrunner-1.9 for gecko libs instead of firefox
278- add Patch7,8,9 to build with xulrunner-1.9
279
280* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
281- new upstream release
282
283* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
284- new upstream release
285- added Patches from Fedora Core
286  * Mon Mar 31 2008 Jon McCann <jmccann@redhat.com> - 2.22.0-4
287  - Disallow launchers when running under GDM.
288  * Thu Mar 13 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2
289  - Add patch for RH bug #437328 (searching with Beagle broken).
290  * Fri Nov 16 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-7
291  - Handle .HP tags in man pages
292  * Wed Sep  6 2006 Matthias Clasen  <mclasen@redhat.com> - 2.16.0-2.fc6
293  - Actually apply the Pango patch
294  * Thu Dec 15 2005 David Malcolm <dmalcolm@redhat.com> - 2.13.2-2
295  - Patched to include DocBook mimetype in desktop file, and added preun and
296    post hooks to update-desktop-database (#175880)
297  - Patched to ensure that Yelp recognizes that it can handle the mimetype of
298    the documentation as reported by gnomevfs (also #175880)
299
300* Sat Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
301- new upstream release
302- added BuildRequires: rarian-devel
303
304* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
305- rebuild with new environment/toolchain
306
307* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
308- new upstream release
309- drop Patch20
310
311* Thu Nov 16 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl3
312- added Patch20 (<BTS:0314>)
313- add BuildRequires: libgnomeprintui-devel
314
315* Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
316- rebuild with firefox-2.0
317
318* Sun Oct 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
319- updated to 2.14.3
320- changed Group to User Interface/Desktops
321
322* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl2
323- add Patch10 to fix corruption of help option message.
324- add Japanese summary and description
325
326* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
327- new upstream release
328
329* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
330- rebuild with firefox-1.5.0.2-0vl4
331
332* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
333- new upstream release
334- build with firefox-1.5.0.2
335
336* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
337- run gtk-update-icon-cache in %%post script.
338
339* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
340- new upstream release
341
342* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.6-0vl1
343- new upstream release
344
345* Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl2
346- rebuild with firefox-1.5.0.1
347
348* Fri Dec 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
349- new upstream release
350- build with firefox-1.5
351
352* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
353- new upstream release
354- build with mozilla-1.7.12
355
356* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
357- new upstream release
358
359* Sat Aug 20 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl4
360- rebuilt with mozilla-1.7.11 (doh! 0vl3 had stupid mistake in the changelog)
361
362* Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
363- rebuild with mozilla-1.7.8
364
365* Mon May 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
366- new upstream release
367
368* Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl4
369- rebuild with mozilla-1.7.7
370
371* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl3
372- add Requires/BuildRequires to gnome-doc-utils
373
374* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl2
375- include yelp.schemas
376- add versioned requires to mozilla
377
378* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl1
379- new upstream version
380- use mozilla's gecko engine, add Requires: mozilla
381
382* Mon Nov 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
383- new upstream release
384
385* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
386- new upstream release
387- rebuild with new toolchains
388
389* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
390- new upstream release
391
392* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
393- new upstream release
394
395* Thu May 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0-0vl1
396- new upstream release
397
398* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
399- new upstream release
400
401* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
402- new upstream release
403- build for Vine Linux
404
405* Mon Nov 18 2002 Tim Powers <timp@redhat.com>
406- rebuild for all arches
407
408* Mon Aug 12 2002 Alexander Larsson <alexl@redhat.com>
409- Remove the strange copyright on the start page. Fixes #69106
410
411* Thu Aug  8 2002 Havoc Pennington <hp@redhat.com>
412- 1.0.2
413- include libexecdir stuff
414
415* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
416- rebuild with new gail
417- 1.0.1
418
419* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
420- automated rebuild
421
422* Tue Jun 18 2002 Havoc Pennington <hp@redhat.com>
423- put all the binaries in the file list... why is this package so hard?
424
425* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
426- put images in file list, this thing will be non-ugly yet
427
428* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
429- 1.0
430- use desktop-file-install to install/munge .desktop files
431- put the sgml stuff in file list
432
433* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
434- rebuild in different environment
435
436* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
437- 0.10
438
439* Sun May 26 2002 Tim Powers <timp@redhat.com>
440- automated rebuild
441
442* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
443- rebuild in different environment
444
445* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
446- 0.8
447
448* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
449- 0.6.1
450
451* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
452- 0.6
453
454* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
455- Rebuild for new gnome2 libraries
456
457* Mon Jan 28 2002 Alex Larsson <alexl@redhat.com>
458- Initial build.
Note: See TracBrowser for help on using the repository browser.