source: projects/specs/trunk/y/yelp/yelp-vl.spec @ 9601

Revision 9601, 13.9 KB checked in by Takemikaduchi, 9 years ago (diff)

task-mate,yelp: fix R:
mate-menus: fix Source
mate-control-center: fix ja.po
others: new upstream release

Line 
1%define glib2_version 2.44.0
2%define pango_version 1.36.3
3%define gtk3_version 3.16.0
4%define desktop_file_utils_version 0.17
5%define rarian_version 0.7.0
6%define gnome_common_version 3.14.0
7
8Summary: A system documentation reader from the Gnome project.
9Summary(ja): GNOME プロジェクトのシステムドキュメントリーダ
10Name: yelp
11Version: 3.16.1
12Release: 3%{?_dist_release}
13
14URL: http://live.gnome.org/Yelp
15Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.16/%{name}-%{version}.tar.xz
16Source10: man-convert-helper
17
18License: GPL
19Group: User Interface/Desktops
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21Requires: gtk3 >= %{gtk3_version}
22Requires: nkf
23Requires: yelp-xsl
24Requires: gsettings-desktop-schemas
25BuildRequires: glib2-devel >= %{glib2_version}
26BuildRequires: pango-devel >= %{pango_version}
27BuildRequires: gtk3-devel >= %{gtk3_version}
28BuildRequires: libxml2-devel >= 2.6.5
29BuildRequires: libxslt-devel >= 1.1.4
30BuildRequires: zlib-devel
31BuildRequires: xz-devel
32BuildRequires: bzip2-devel
33BuildRequires: startup-notification-devel >= 0.8
34BuildRequires: dbus-glib-devel
35BuildRequires: rarian-devel >= %{rarian_version}
36BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
37BuildRequires: gnome-common >= %{gnome_common_version}
38BuildRequires: yelp-xsl-devel
39BuildRequires: WebKit3-gtk-devel
40BuildRequires: sqlite3-devel
41BuildRequires: libSM-devel
42BuildRequires: yelp-tools
43BuildRequires: gtk-doc
44
45Vendor: Project Vine
46Distribution: Vine Linux
47Packager: Takemikaduchi
48
49%description
50Yelp is the Gnome 3 help/documentation browser. It is designed
51to help you browse all the documentation on your system in
52one central tool.
53
54%description -l ja
55Yelp は Gnome 3 のヘルプ/ドキュメントブラウザです。このツール
56によってシステム内の全てのドキュメントを参照できることを目標に
57作られています。
58
59%package libs
60Summary: Libraries for yelp
61Summary(ja): Yelp のライブラリ
62Group: System Environment/Libraries
63Requires: %{name} = %{version}-%{release}
64
65%description libs
66This package contains libraries used by the yelp help browser.
67
68%package devel
69Summary: Development files for yelp-libs
70Summary(ja): yelp-libs の開発用ファイル
71Group: Development/Libraries
72Requires: %{name}-libs = %{version}-%{release}
73
74%description devel
75This package contains header files and documentation for
76the libraries in the yelp-libs package.
77
78
79%package        docs
80Summary:        Documentation for %{name}
81Summary(ja):    %{name} のドキュメント
82Group:          Documentation
83Requires:       %{name} = %{version}-%{release}
84BuildArch:      noarch
85
86%description    docs
87This package contains documentation for %{name}.
88
89
90%prep
91%setup -q
92
93# autoreconf -f -i
94
95%build
96%configure \
97        --disable-static
98make
99
100%install
101rm -rf $RPM_BUILD_ROOT
102export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
103make install DESTDIR=$RPM_BUILD_ROOT
104unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
105
106mkdir -p -m 755 $RPM_BUILD_ROOT/%{_datadir}/gnome/help
107
108install -m755 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/yelp/
109
110rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
111
112%find_lang %{name}
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post
118update-desktop-database %{_datadir}/applications >& /dev/null ||:
119update-mime-database %{_datadir}/mime >& /dev/null ||:
120
121touch %{_datadir}/icons/hicolor
122#if [ -x /usr/bin/gtk-update-icon-cache ]; then
123#  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
124#fi
125
126%postun
127update-desktop-database %{_datadir}/applications >& /dev/null ||:
128update-mime-database %{_datadir}/mime >& /dev/null ||:
129glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
130
131%posttrans
132glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
133
134%post libs -p /sbin/ldconfig
135
136%postun libs -p /sbin/ldconfig
137
138%files -f %{name}.lang
139%defattr(-,root,root)
140%{_bindir}/*
141%{_datadir}/applications/*
142%{_datadir}/glib-2.0/schemas/org.gnome.yelp.gschema.xml
143%{_datadir}/yelp-xsl/xslt/common/domains/yelp.xml
144%dir %{_datadir}/gnome/help
145%{_datadir}/%{name}
146#%{_datadir}/icons/hicolor/*
147
148%files libs
149%defattr(-,root,root,-)
150%{_libdir}/libyelp.so.*
151
152%files devel
153%defattr(-,root,root,-)
154%{_libdir}/libyelp.so
155%{_includedir}/libyelp
156
157%files docs
158%defattr(-,root,root,-)
159%{_datadir}/gtk-doc/html/libyelp
160
161
162%changelog
163* Sat Jun 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-3
164- change Requires: gsettings-desktop-schemas
165- remove Requires: gnome-user-docs
166
167* Sat Jun 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-2
168- add Requires: gnome-settings-daemon
169
170* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
171- new upstream release
172
173* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
174- new upstream release
175
176* Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.1-2
177- moved libs subpakage to System Environment/Libraries Group
178- added %%post and %%postun to libs subpackage
179
180* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
181- new upstream release
182
183* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
184- new upstream release
185
186* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
187- rebuild with VineSeed environment
188
189* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
190- new upstream release
191
192* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
193- new upstream release
194
195* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
196- new upstream release
197- create %%{name}-docs subpackage
198
199* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
200- new upstream release
201
202* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
203- new upstream release
204
205* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
206- new upstream release
207- change BuildRequires: yelp-tools instead of gnome-doc-utils
208
209* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
210- new upstream release
211
212* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
213- new upstream release
214- add BuildRequires: itstool
215- remove BuildRequires: GConf2-devel
216
217* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
218- new upstream release
219
220* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
221- new upstream release
222
223* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
224- new upstream release
225- add BuildRequires: libSM-devel
226
227* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-1
228- new upstream release
229
230* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.1-1
231- new upstream release
232- create -libs and -devel sub package
233- add BuildRequires: yelp-xsl-devel, WebKit3-gtk-devel, sqlite3-devel
234- remove BuildRequires: xulrunner-devel
235- change BuildRequires: gtk3-devel instead of gtk2-devel
236- change BuildRequires: xz-devel instead of lzma-devel
237- drop old Patches
238
239* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
240- update Patch2: yelp-2.30.2-add-mime-handling.patch
241
242* Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.2-2
243- rebuild with xulrunner-2.0
244- add Patch11 to build with xulrunner-2.0
245
246* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
247- new upstream release
248
249* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
250- new upstream release
251
252* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
253- new upstream release
254- change Requires: gecko-libs -> xulrunner
255- change BuildRequires: gecko-devel -> xulrunner-devel
256- drop Patch11
257
258* Mon Mar 01 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-1
259- new upstream release
260- build with xulrunner-1.9.2 (gecko-1.9.2)
261  - BR: gecko-devel instead of gecko-unstable-devel
262  - add patch11 to fix xulrunner-1.9.2 problem
263    - https://bugzilla.gnome.org/show_bug.cgi?id=603561
264    - http://git.gnome.org/browse/yelp/commit/?id=a5588114ed94d00ca64913aa5b248e09a5e13edc
265
266* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
267- new upstream release
268
269* Tue Aug 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
270- convert manpages from euc to utf8
271
272* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
273- rebuild with gecko-1.9.1
274
275* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
276- new upstream release
277- remove BR: libgnomeprintui-devel
278
279* Mon Jun 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1-2
280- use xulrunner-1.9 for gecko libs instead of firefox
281- add Patch7,8,9 to build with xulrunner-1.9
282
283* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
284- new upstream release
285
286* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
287- new upstream release
288- added Patches from Fedora Core
289  * Mon Mar 31 2008 Jon McCann <jmccann@redhat.com> - 2.22.0-4
290  - Disallow launchers when running under GDM.
291  * Thu Mar 13 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2
292  - Add patch for RH bug #437328 (searching with Beagle broken).
293  * Fri Nov 16 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-7
294  - Handle .HP tags in man pages
295  * Wed Sep  6 2006 Matthias Clasen  <mclasen@redhat.com> - 2.16.0-2.fc6
296  - Actually apply the Pango patch
297  * Thu Dec 15 2005 David Malcolm <dmalcolm@redhat.com> - 2.13.2-2
298  - Patched to include DocBook mimetype in desktop file, and added preun and
299    post hooks to update-desktop-database (#175880)
300  - Patched to ensure that Yelp recognizes that it can handle the mimetype of
301    the documentation as reported by gnomevfs (also #175880)
302
303* Sat Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
304- new upstream release
305- added BuildRequires: rarian-devel
306
307* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
308- rebuild with new environment/toolchain
309
310* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
311- new upstream release
312- drop Patch20
313
314* Thu Nov 16 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl3
315- added Patch20 (<BTS:0314>)
316- add BuildRequires: libgnomeprintui-devel
317
318* Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
319- rebuild with firefox-2.0
320
321* Sun Oct 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
322- updated to 2.14.3
323- changed Group to User Interface/Desktops
324
325* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl2
326- add Patch10 to fix corruption of help option message.
327- add Japanese summary and description
328
329* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
330- new upstream release
331
332* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
333- rebuild with firefox-1.5.0.2-0vl4
334
335* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
336- new upstream release
337- build with firefox-1.5.0.2
338
339* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
340- run gtk-update-icon-cache in %%post script.
341
342* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
343- new upstream release
344
345* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.6-0vl1
346- new upstream release
347
348* Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl2
349- rebuild with firefox-1.5.0.1
350
351* Fri Dec 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
352- new upstream release
353- build with firefox-1.5
354
355* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
356- new upstream release
357- build with mozilla-1.7.12
358
359* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
360- new upstream release
361
362* Sat Aug 20 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl4
363- rebuilt with mozilla-1.7.11 (doh! 0vl3 had stupid mistake in the changelog)
364
365* Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
366- rebuild with mozilla-1.7.8
367
368* Mon May 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
369- new upstream release
370
371* Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl4
372- rebuild with mozilla-1.7.7
373
374* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl3
375- add Requires/BuildRequires to gnome-doc-utils
376
377* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl2
378- include yelp.schemas
379- add versioned requires to mozilla
380
381* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl1
382- new upstream version
383- use mozilla's gecko engine, add Requires: mozilla
384
385* Mon Nov 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
386- new upstream release
387
388* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
389- new upstream release
390- rebuild with new toolchains
391
392* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
393- new upstream release
394
395* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
396- new upstream release
397
398* Thu May 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0-0vl1
399- new upstream release
400
401* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
402- new upstream release
403
404* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
405- new upstream release
406- build for Vine Linux
407
408* Mon Nov 18 2002 Tim Powers <timp@redhat.com>
409- rebuild for all arches
410
411* Mon Aug 12 2002 Alexander Larsson <alexl@redhat.com>
412- Remove the strange copyright on the start page. Fixes #69106
413
414* Thu Aug  8 2002 Havoc Pennington <hp@redhat.com>
415- 1.0.2
416- include libexecdir stuff
417
418* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
419- rebuild with new gail
420- 1.0.1
421
422* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
423- automated rebuild
424
425* Tue Jun 18 2002 Havoc Pennington <hp@redhat.com>
426- put all the binaries in the file list... why is this package so hard?
427
428* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
429- put images in file list, this thing will be non-ugly yet
430
431* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
432- 1.0
433- use desktop-file-install to install/munge .desktop files
434- put the sgml stuff in file list
435
436* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
437- rebuild in different environment
438
439* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
440- 0.10
441
442* Sun May 26 2002 Tim Powers <timp@redhat.com>
443- automated rebuild
444
445* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
446- rebuild in different environment
447
448* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
449- 0.8
450
451* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
452- 0.6.1
453
454* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
455- 0.6
456
457* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
458- Rebuild for new gnome2 libraries
459
460* Mon Jan 28 2002 Alex Larsson <alexl@redhat.com>
461- Initial build.
Note: See TracBrowser for help on using the repository browser.