source: projects/specs/trunk/y/yelp/yelp-vl.spec @ 9569

Revision 9569, 13.6 KB checked in by Takemikaduchi, 9 years ago (diff)

cogl: add patch
others: new upstream release

Line 
1%define glib2_version 2.44.0
2%define pango_version 1.36.3
3%define gtk3_version 3.16.0
4%define desktop_file_utils_version 0.17
5%define rarian_version 0.7.0
6%define gnome_common_version 3.14.0
7
8Summary: A system documentation reader from the Gnome project.
9Summary(ja): GNOME プロジェクトのシステムドキュメントリーダ
10Name: yelp
11Version: 3.16.1
12Release: 1%{?_dist_release}
13
14URL: http://live.gnome.org/Yelp
15Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.16/%{name}-%{version}.tar.xz
16Source10: man-convert-helper
17
18License: GPL
19Group: User Interface/Desktops
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21Requires: gtk3 >= %{gtk3_version}
22Requires: gnome-user-docs
23Requires: nkf
24Requires: yelp-xsl
25BuildRequires: glib2-devel >= %{glib2_version}
26BuildRequires: pango-devel >= %{pango_version}
27BuildRequires: gtk3-devel >= %{gtk3_version}
28BuildRequires: libxml2-devel >= 2.6.5
29BuildRequires: libxslt-devel >= 1.1.4
30BuildRequires: zlib-devel
31BuildRequires: xz-devel
32BuildRequires: bzip2-devel
33BuildRequires: startup-notification-devel >= 0.8
34BuildRequires: dbus-glib-devel
35BuildRequires: rarian-devel >= %{rarian_version}
36BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
37BuildRequires: gnome-common >= %{gnome_common_version}
38BuildRequires: yelp-xsl-devel
39BuildRequires: WebKit3-gtk-devel
40BuildRequires: sqlite3-devel
41BuildRequires: libSM-devel
42BuildRequires: yelp-tools
43BuildRequires: gtk-doc
44
45Vendor: Project Vine
46Distribution: Vine Linux
47Packager: Takemikaduchi
48
49%description
50Yelp is the Gnome 3 help/documentation browser. It is designed
51to help you browse all the documentation on your system in
52one central tool.
53
54%description -l ja
55Yelp は Gnome 3 のヘルプ/ドキュメントブラウザです。このツール
56によってシステム内の全てのドキュメントを参照できることを目標に
57作られています。
58
59%package libs
60Summary: Libraries for yelp
61Summary(ja): Yelp のライブラリ
62Group: System Environment/Libraries
63Requires: %{name} = %{version}-%{release}
64
65%description libs
66This package contains libraries used by the yelp help browser.
67
68%package devel
69Summary: Development files for yelp-libs
70Summary(ja): yelp-libs の開発用ファイル
71Group: Development/Libraries
72Requires: %{name}-libs = %{version}-%{release}
73
74%description devel
75This package contains header files and documentation for
76the libraries in the yelp-libs package.
77
78
79%package        docs
80Summary:        Documentation for %{name}
81Summary(ja):    %{name} のドキュメント
82Group:          Documentation
83Requires:       %{name} = %{version}-%{release}
84BuildArch:      noarch
85
86%description    docs
87This package contains documentation for %{name}.
88
89
90%prep
91%setup -q
92
93# autoreconf -f -i
94
95%build
96%configure \
97        --disable-static
98make
99
100%install
101rm -rf $RPM_BUILD_ROOT
102export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
103make install DESTDIR=$RPM_BUILD_ROOT
104unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
105
106mkdir -p -m 755 $RPM_BUILD_ROOT/%{_datadir}/gnome/help
107
108install -m755 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/yelp/
109
110rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
111
112%find_lang %{name}
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post
118update-desktop-database %{_datadir}/applications >& /dev/null ||:
119update-mime-database %{_datadir}/mime >& /dev/null ||:
120
121touch %{_datadir}/icons/hicolor
122#if [ -x /usr/bin/gtk-update-icon-cache ]; then
123#  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
124#fi
125
126%postun
127update-desktop-database %{_datadir}/applications >& /dev/null ||:
128update-mime-database %{_datadir}/mime >& /dev/null ||:
129glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
130
131%posttrans
132glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
133
134%post libs -p /sbin/ldconfig
135
136%postun libs -p /sbin/ldconfig
137
138%files -f %{name}.lang
139%defattr(-,root,root)
140%{_bindir}/*
141%{_datadir}/applications/*
142%{_datadir}/glib-2.0/schemas/org.gnome.yelp.gschema.xml
143%{_datadir}/yelp-xsl/xslt/common/domains/yelp.xml
144%dir %{_datadir}/gnome/help
145%{_datadir}/%{name}
146#%{_datadir}/icons/hicolor/*
147
148%files libs
149%defattr(-,root,root,-)
150%{_libdir}/libyelp.so.*
151
152%files devel
153%defattr(-,root,root,-)
154%{_libdir}/libyelp.so
155%{_includedir}/libyelp
156
157%files docs
158%defattr(-,root,root,-)
159%{_datadir}/gtk-doc/html/libyelp
160
161
162%changelog
163* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
164- new upstream release
165
166* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
167- new upstream release
168
169* Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.1-2
170- moved libs subpakage to System Environment/Libraries Group
171- added %%post and %%postun to libs subpackage
172
173* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
174- new upstream release
175
176* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
177- new upstream release
178
179* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
180- rebuild with VineSeed environment
181
182* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
183- new upstream release
184
185* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
186- new upstream release
187
188* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
189- new upstream release
190- create %%{name}-docs subpackage
191
192* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
193- new upstream release
194
195* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
196- new upstream release
197
198* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
199- new upstream release
200- change BuildRequires: yelp-tools instead of gnome-doc-utils
201
202* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
203- new upstream release
204
205* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
206- new upstream release
207- add BuildRequires: itstool
208- remove BuildRequires: GConf2-devel
209
210* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
211- new upstream release
212
213* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
214- new upstream release
215
216* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
217- new upstream release
218- add BuildRequires: libSM-devel
219
220* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-1
221- new upstream release
222
223* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.1-1
224- new upstream release
225- create -libs and -devel sub package
226- add BuildRequires: yelp-xsl-devel, WebKit3-gtk-devel, sqlite3-devel
227- remove BuildRequires: xulrunner-devel
228- change BuildRequires: gtk3-devel instead of gtk2-devel
229- change BuildRequires: xz-devel instead of lzma-devel
230- drop old Patches
231
232* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
233- update Patch2: yelp-2.30.2-add-mime-handling.patch
234
235* Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.2-2
236- rebuild with xulrunner-2.0
237- add Patch11 to build with xulrunner-2.0
238
239* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
240- new upstream release
241
242* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
243- new upstream release
244
245* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
246- new upstream release
247- change Requires: gecko-libs -> xulrunner
248- change BuildRequires: gecko-devel -> xulrunner-devel
249- drop Patch11
250
251* Mon Mar 01 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-1
252- new upstream release
253- build with xulrunner-1.9.2 (gecko-1.9.2)
254  - BR: gecko-devel instead of gecko-unstable-devel
255  - add patch11 to fix xulrunner-1.9.2 problem
256    - https://bugzilla.gnome.org/show_bug.cgi?id=603561
257    - http://git.gnome.org/browse/yelp/commit/?id=a5588114ed94d00ca64913aa5b248e09a5e13edc
258
259* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
260- new upstream release
261
262* Tue Aug 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
263- convert manpages from euc to utf8
264
265* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
266- rebuild with gecko-1.9.1
267
268* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
269- new upstream release
270- remove BR: libgnomeprintui-devel
271
272* Mon Jun 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1-2
273- use xulrunner-1.9 for gecko libs instead of firefox
274- add Patch7,8,9 to build with xulrunner-1.9
275
276* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
277- new upstream release
278
279* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
280- new upstream release
281- added Patches from Fedora Core
282  * Mon Mar 31 2008 Jon McCann <jmccann@redhat.com> - 2.22.0-4
283  - Disallow launchers when running under GDM.
284  * Thu Mar 13 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2
285  - Add patch for RH bug #437328 (searching with Beagle broken).
286  * Fri Nov 16 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-7
287  - Handle .HP tags in man pages
288  * Wed Sep  6 2006 Matthias Clasen  <mclasen@redhat.com> - 2.16.0-2.fc6
289  - Actually apply the Pango patch
290  * Thu Dec 15 2005 David Malcolm <dmalcolm@redhat.com> - 2.13.2-2
291  - Patched to include DocBook mimetype in desktop file, and added preun and
292    post hooks to update-desktop-database (#175880)
293  - Patched to ensure that Yelp recognizes that it can handle the mimetype of
294    the documentation as reported by gnomevfs (also #175880)
295
296* Sat Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
297- new upstream release
298- added BuildRequires: rarian-devel
299
300* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
301- rebuild with new environment/toolchain
302
303* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
304- new upstream release
305- drop Patch20
306
307* Thu Nov 16 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl3
308- added Patch20 (<BTS:0314>)
309- add BuildRequires: libgnomeprintui-devel
310
311* Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
312- rebuild with firefox-2.0
313
314* Sun Oct 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
315- updated to 2.14.3
316- changed Group to User Interface/Desktops
317
318* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl2
319- add Patch10 to fix corruption of help option message.
320- add Japanese summary and description
321
322* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
323- new upstream release
324
325* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
326- rebuild with firefox-1.5.0.2-0vl4
327
328* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
329- new upstream release
330- build with firefox-1.5.0.2
331
332* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
333- run gtk-update-icon-cache in %%post script.
334
335* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
336- new upstream release
337
338* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.6-0vl1
339- new upstream release
340
341* Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl2
342- rebuild with firefox-1.5.0.1
343
344* Fri Dec 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
345- new upstream release
346- build with firefox-1.5
347
348* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
349- new upstream release
350- build with mozilla-1.7.12
351
352* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
353- new upstream release
354
355* Sat Aug 20 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl4
356- rebuilt with mozilla-1.7.11 (doh! 0vl3 had stupid mistake in the changelog)
357
358* Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
359- rebuild with mozilla-1.7.8
360
361* Mon May 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
362- new upstream release
363
364* Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl4
365- rebuild with mozilla-1.7.7
366
367* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl3
368- add Requires/BuildRequires to gnome-doc-utils
369
370* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl2
371- include yelp.schemas
372- add versioned requires to mozilla
373
374* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl1
375- new upstream version
376- use mozilla's gecko engine, add Requires: mozilla
377
378* Mon Nov 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
379- new upstream release
380
381* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
382- new upstream release
383- rebuild with new toolchains
384
385* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
386- new upstream release
387
388* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
389- new upstream release
390
391* Thu May 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0-0vl1
392- new upstream release
393
394* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
395- new upstream release
396
397* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
398- new upstream release
399- build for Vine Linux
400
401* Mon Nov 18 2002 Tim Powers <timp@redhat.com>
402- rebuild for all arches
403
404* Mon Aug 12 2002 Alexander Larsson <alexl@redhat.com>
405- Remove the strange copyright on the start page. Fixes #69106
406
407* Thu Aug  8 2002 Havoc Pennington <hp@redhat.com>
408- 1.0.2
409- include libexecdir stuff
410
411* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
412- rebuild with new gail
413- 1.0.1
414
415* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
416- automated rebuild
417
418* Tue Jun 18 2002 Havoc Pennington <hp@redhat.com>
419- put all the binaries in the file list... why is this package so hard?
420
421* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
422- put images in file list, this thing will be non-ugly yet
423
424* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
425- 1.0
426- use desktop-file-install to install/munge .desktop files
427- put the sgml stuff in file list
428
429* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
430- rebuild in different environment
431
432* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
433- 0.10
434
435* Sun May 26 2002 Tim Powers <timp@redhat.com>
436- automated rebuild
437
438* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
439- rebuild in different environment
440
441* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
442- 0.8
443
444* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
445- 0.6.1
446
447* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
448- 0.6
449
450* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
451- Rebuild for new gnome2 libraries
452
453* Mon Jan 28 2002 Alex Larsson <alexl@redhat.com>
454- Initial build.
Note: See TracBrowser for help on using the repository browser.