source: projects/specs/trunk/y/yatex/yatex-vl.spec @ 5603

Revision 5603, 9.8 KB checked in by munepi, 12 years ago (diff)

updated yatex-vl.spec

RevLine 
[521]1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4Name:          yatex
[5603]5Version:       1.75
6Release:       1%{?_dist_release}
[521]7License:       Distributable
8Source0:       http://www.yatex.org/yatex%{version}.tar.gz
9#Source0:       http://www.yatex.org/yatex10203151806.tar.gz
10Source1:       %{name}-install.sh
11Source2:       %{name}-remove.sh
12Source3:       %{name}-init.el
13Source4:       vine-default-%{name}.el
[2599]14Source5:       vine-default-yahtml.el
[521]15
16## pre-formatted info files here
17Source10:      yatexe
18Source11:      yatexj
19Source12:      yahtmle
20Source13:      yahtmlj
21
22## Vine Patch(es)
23Patch0:        yatex-info.diff
24Patch1:        yatexhlp-emacs.diff
25Patch2:        yatex-make.diff
26# based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
27# and modified to suit 1.70 release
28Patch3:        yahtml-1.70-timestamp.patch
29
[5257]30Patch10:       yatex-1.74-vine-vl7.patch
31
[521]32URL:           http://www.yatex.org/
33Group:         Applications/Editors/Emacs
34BuildRoot:     %{_tmppath}/%{name}-%{version}-root
35Summary:       YaTeX - Yet Another TeX mode for Emacs
36Summary(ja):   野鳥(YaTeX) - Yet Another TeX mode for Emacs
37BuildArch:     noarch
38
39PreReq:        emacsen
40%prereq_ge     emacsen-common
[4582]41Requires(post): make
[521]42BuildRequires: emacsen-common
43Obsoletes:     yatex-xemacs
44
45Distribution:  Vine Linux
46Vendor:        Project Vine
[5257]47Packager:      munepi
[521]48
49%description
50YaTeX is an intelligent, acquisitive and integrated package which reduces
51your efforts of composing LaTeX source on GNU Emacs.
52
[2750]53
54If you are YaTeX user and you install both yatex and auctex on your system,
55you may add the following configure in your emacs init file
56%if %{?_dist_release} == "vl5"
57~/.emacs.el:
58%else
59~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
60%endif
61
62;; I am YaTeX user!!!
63(setq vine-default-auctex nil
64      vine-default-preview-latex nil)
65
66
[521]67%description -l ja
68YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
69してくれる、LaTeX 入力支援環境です。
70
71
[2750]72yatex と auctex パッケージの両方をインストールする場合、
73%if %{?_dist_release} == "vl5"
74~/.emacs.el:
75%else
76~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
77%endif
78に以下の設定を追加するとよいでしょう。
79
80;; YaTeX ユーザです!!!
81(setq vine-default-auctex nil
82      vine-default-preview-latex nil)
83
84
[521]85%prep
86%setup -n yatex%{version}
87%patch0 -p1
88%patch1 -p1
89%patch2 -p1
90%patch3 -p1
91
[5257]92%if %{?_dist_release} == "vl7"
93%patch10 -p1 -b .vine
94%endif
[521]95
96%build
97
[2599]98(cd docs
99    chmod 644 *
100    %__install -v -m 644 %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} .
[521]101)
102
103
104%install
105
[2599]106[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
[521]107
[2599]108%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
109%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
110%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
111%__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
[521]112
113
114#
115# install el files
116#
117
[2599]118%__cp -a *.el makefile help \
119      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
120%__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
121      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
[521]122
123#
124# install info files
125#
126
[2599]127%__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
[521]128   ${RPM_BUILD_ROOT}%{_infodir}
129
130
131#
132# install script (bytecompile el and install elc, remove)
133#
134
135%_installemacsenscript %{name} %{SOURCE1}
136
137%_removeemacsenscript  %{name} %{SOURCE2}
138
139
140%clean
[2599]141[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
[521]142
143
144%post
145#
146# bytecompile and install
147#
148
149if [ "$1" = 2 ] ; then
150
151%_emacsenPackageRemove %{name}
152
153fi
154
155%_addemacsenlist %{name}
156
157%_emacsenPackageInstall %{name}
158
159
160/sbin/install-info %{_infodir}/yatexe.gz %{_infodir}/dir \
161  --section="Emacs"
162/sbin/install-info %{_infodir}/yatexj.gz %{_infodir}/dir \
163  --section="Emacs"
164/sbin/install-info %{_infodir}/yahtmle.gz %{_infodir}/dir \
165  --section="Emacs"
166/sbin/install-info %{_infodir}/yahtmlj.gz %{_infodir}/dir \
167  --section="Emacs"
168
169
170%preun
171
172if [ "$1" = 0 ]; then
173
174%_emacsenPackageRemove %{name}
175
176%_removeemacsenlist %{name}
177
178/sbin/install-info --delete %{_infodir}/yatexe.gz %{_infodir}/dir \
179  --section="Emacs"
180/sbin/install-info --delete %{_infodir}/yatexj.gz %{_infodir}/dir \
181  --section="Emacs"
182/sbin/install-info --delete %{_infodir}/yahtmle.gz %{_infodir}/dir \
183  --section="Emacs"
184/sbin/install-info --delete %{_infodir}/yahtmlj.gz %{_infodir}/dir \
185  --section="Emacs"
186
187fi
188
189
190%files
191%defattr(-,root,root)
192%doc 00readme install manifest yatex.new
193%doc docs
194
195%{_datadir}/emacs/site-lisp/yatex/
196%{_infodir}/*
197%{emacsen_pkgdir}/install/%{name}
198%{emacsen_pkgdir}/remove/%{name}
199
200
[5257]201%changelog
[5603]202* Thu Feb  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-1
203- new upstream release
204- updated vine-default-yatex.el
205
[5257]206* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-9
207- support TeX Live 2011
208- applied yatex-1.74-vine-vl7.patch
209- updated vine-default-yatex.el
210
[4582]211* Thu Aug 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-8
212- added Requires(post): make
213
[3482]214* Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-7
215- updated vine-default-yatex.el
216  - check 'YaTeX-inhibit-prefix-letter
217  - used "pbibtex -kanji=utf8" as default bibtex-command
218  - used "mendex -U" as default makeindex-command
219
[3080]220* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-6
221- updated vine-default-{yatex,yahtml}.el
222  - revived auto-fill-mode on {yatex,yahtml}-mode
223
[2750]224* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-5
225- updated yatex-init.el
226  - dropped all pathes of auctex and preview-latex from load-path
227
[2599]228* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
229- updated vine-default-yatex.el
230  - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
231  - supported TeX Live
232    - used "eplatex", "pxdvi", "pdvips" as default commands
233- updated yatex-init.el
234  - output "Loading vine-default-yatex ..." to the buffer *Messages*
235  - defined vine-default-yahtml
236- added vine-default-yahtml.el
237
[2443]238* Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
239- updated vine-default-yatex.el
240  - added bbl extension in auto-mode-alist to run yatex-mode
241
242* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
243- updated vine-default-yatex.el
244  - supported new vine-default
245
[521]246* Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
247- new upstream release
248
249* Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
250- updated vine-default-yatex.el
251  - dropped (setq YaTeX-no-begend-shortcut t)
252- use %{emacsen_pkgdir}
253
254* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
255- updated vine-default-yatex.el
256  - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
257
258* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
259- updated yatex-install.sh
260  - *-init.el: changed from hard copy to symbolic link
261    on /etc/emacs-XX.YY/site-start.d
262
263* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
264- fixed yatex-init.el
265
266* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
267- added yatex-init.el, vine-default-yatex.el
268- updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
269
270* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
271- spec in utf8
272
273* Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
274- applied new versioning policy
275
276* Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
277- new upstream release
278
279* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
280- s/Copyright/License/
281- changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
282
283* Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
284- update yatex-1.72
285
286* Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
287- update yatex-1.71
288
289* Fri Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
290- added Patch3 to add hhmts timestamp feature
291
292* Tue May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
293- update yatex-1.70
294
295* Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
296- update yatex10203151806
297
298* Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
299- fixed: bytecompile yatex19
300
301* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
302- now emacsen-common aware
303- FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
304
305* Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
306- 1.68-0vl2
307- no kanji code conversion of documents
308
309* Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
310- 1.68-0vl1
311- update to 1.68
312
313* Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
314- 1.67-6vl5
315- YATEXHLP.{jp,eng} moved to appropriate dir
316
317* Thu Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
318- 1.67-6vl3
319- rebuilt for emacs-20.7
320
321* Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
322- 1.67-6vl2
323- oops ... fixed target dir for help files
324
325* Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
326- 1.67-6vl1
327- rebuilt for emacs-20.6
328
329* Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
330- 1.67-6
331- included forgotten info file for YaHTML
332
333* Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
334- 1.67-5
335- updated for emacs-20.5a release
336
337* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
338- 1.67-4
339- change Group to Applications/Editors/EmacsLisp
340
341* Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
342- 1.67-3
343- %post and %preun section modified
344
345* Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
346- 1.67-2
347- fixed minor problem in the %files section
348
349* Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
350- 1.67-1
351- updated to 1.67 release
352- rebuilt for emacs-20.4 on Vine Linux 1.9
353- updated URL for the new web site of YaTeX
354- some typo fix
355
356* Tue May  4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
357- Initial Release
Note: See TracBrowser for help on using the repository browser.