source: projects/specs/trunk/y/yatex/yatex-vl.spec @ 5257

Revision 5257, 9.7 KB checked in by munepi, 12 years ago (diff)

updated yatex: TeX Live 2011

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4Name:          yatex
5Version:       1.74
6Release:       9%{?_dist_release}
7License:       Distributable
8Source0:       http://www.yatex.org/yatex%{version}.tar.gz
9#Source0:       http://www.yatex.org/yatex10203151806.tar.gz
10Source1:       %{name}-install.sh
11Source2:       %{name}-remove.sh
12Source3:       %{name}-init.el
13Source4:       vine-default-%{name}.el
14Source5:       vine-default-yahtml.el
15
16## pre-formatted info files here
17Source10:      yatexe
18Source11:      yatexj
19Source12:      yahtmle
20Source13:      yahtmlj
21
22## Vine Patch(es)
23Patch0:        yatex-info.diff
24Patch1:        yatexhlp-emacs.diff
25Patch2:        yatex-make.diff
26# based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
27# and modified to suit 1.70 release
28Patch3:        yahtml-1.70-timestamp.patch
29
30Patch10:       yatex-1.74-vine-vl7.patch
31
32URL:           http://www.yatex.org/
33Group:         Applications/Editors/Emacs
34BuildRoot:     %{_tmppath}/%{name}-%{version}-root
35Summary:       YaTeX - Yet Another TeX mode for Emacs
36Summary(ja):   野鳥(YaTeX) - Yet Another TeX mode for Emacs
37BuildArch:     noarch
38
39PreReq:        emacsen
40%prereq_ge     emacsen-common
41Requires(post): make
42BuildRequires: emacsen-common
43Obsoletes:     yatex-xemacs
44
45Distribution:  Vine Linux
46Vendor:        Project Vine
47Packager:      munepi
48
49%description
50YaTeX is an intelligent, acquisitive and integrated package which reduces
51your efforts of composing LaTeX source on GNU Emacs.
52
53
54If you are YaTeX user and you install both yatex and auctex on your system,
55you may add the following configure in your emacs init file
56%if %{?_dist_release} == "vl5"
57~/.emacs.el:
58%else
59~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
60%endif
61
62;; I am YaTeX user!!!
63(setq vine-default-auctex nil
64      vine-default-preview-latex nil)
65
66
67%description -l ja
68YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
69してくれる、LaTeX 入力支援環境です。
70
71
72yatex と auctex パッケージの両方をインストールする場合、
73%if %{?_dist_release} == "vl5"
74~/.emacs.el:
75%else
76~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
77%endif
78に以下の設定を追加するとよいでしょう。
79
80;; YaTeX ユーザです!!!
81(setq vine-default-auctex nil
82      vine-default-preview-latex nil)
83
84
85%prep
86%setup -n yatex%{version}
87%patch0 -p1
88%patch1 -p1
89%patch2 -p1
90%patch3 -p1
91
92%if %{?_dist_release} == "vl7"
93%patch10 -p1 -b .vine
94%endif
95
96%build
97
98(cd docs
99    chmod 644 *
100    %__install -v -m 644 %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} .
101)
102
103
104%install
105
106[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
107
108%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
109%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
110%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
111%__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
112
113
114#
115# install el files
116#
117
118%__cp -a *.el makefile help \
119      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
120%__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
121      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
122
123#
124# install info files
125#
126
127%__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
128   ${RPM_BUILD_ROOT}%{_infodir}
129
130
131#
132# install script (bytecompile el and install elc, remove)
133#
134
135%_installemacsenscript %{name} %{SOURCE1}
136
137%_removeemacsenscript  %{name} %{SOURCE2}
138
139
140%clean
141[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
142
143
144%post
145#
146# bytecompile and install
147#
148
149if [ "$1" = 2 ] ; then
150
151%_emacsenPackageRemove %{name}
152
153fi
154
155%_addemacsenlist %{name}
156
157%_emacsenPackageInstall %{name}
158
159
160/sbin/install-info %{_infodir}/yatexe.gz %{_infodir}/dir \
161  --section="Emacs"
162/sbin/install-info %{_infodir}/yatexj.gz %{_infodir}/dir \
163  --section="Emacs"
164/sbin/install-info %{_infodir}/yahtmle.gz %{_infodir}/dir \
165  --section="Emacs"
166/sbin/install-info %{_infodir}/yahtmlj.gz %{_infodir}/dir \
167  --section="Emacs"
168
169
170%preun
171
172if [ "$1" = 0 ]; then
173
174%_emacsenPackageRemove %{name}
175
176%_removeemacsenlist %{name}
177
178/sbin/install-info --delete %{_infodir}/yatexe.gz %{_infodir}/dir \
179  --section="Emacs"
180/sbin/install-info --delete %{_infodir}/yatexj.gz %{_infodir}/dir \
181  --section="Emacs"
182/sbin/install-info --delete %{_infodir}/yahtmle.gz %{_infodir}/dir \
183  --section="Emacs"
184/sbin/install-info --delete %{_infodir}/yahtmlj.gz %{_infodir}/dir \
185  --section="Emacs"
186
187fi
188
189
190%files
191%defattr(-,root,root)
192%doc 00readme install manifest yatex.new
193%doc docs
194
195%{_datadir}/emacs/site-lisp/yatex/
196%{_infodir}/*
197%{emacsen_pkgdir}/install/%{name}
198%{emacsen_pkgdir}/remove/%{name}
199
200
201%changelog
202* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-9
203- support TeX Live 2011
204- applied yatex-1.74-vine-vl7.patch
205- updated vine-default-yatex.el
206
207* Thu Aug 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-8
208- added Requires(post): make
209
210* Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-7
211- updated vine-default-yatex.el
212  - check 'YaTeX-inhibit-prefix-letter
213  - used "pbibtex -kanji=utf8" as default bibtex-command
214  - used "mendex -U" as default makeindex-command
215
216* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-6
217- updated vine-default-{yatex,yahtml}.el
218  - revived auto-fill-mode on {yatex,yahtml}-mode
219
220* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-5
221- updated yatex-init.el
222  - dropped all pathes of auctex and preview-latex from load-path
223
224* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
225- updated vine-default-yatex.el
226  - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
227  - supported TeX Live
228    - used "eplatex", "pxdvi", "pdvips" as default commands
229- updated yatex-init.el
230  - output "Loading vine-default-yatex ..." to the buffer *Messages*
231  - defined vine-default-yahtml
232- added vine-default-yahtml.el
233
234* Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
235- updated vine-default-yatex.el
236  - added bbl extension in auto-mode-alist to run yatex-mode
237
238* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
239- updated vine-default-yatex.el
240  - supported new vine-default
241
242* Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
243- new upstream release
244
245* Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
246- updated vine-default-yatex.el
247  - dropped (setq YaTeX-no-begend-shortcut t)
248- use %{emacsen_pkgdir}
249
250* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
251- updated vine-default-yatex.el
252  - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
253
254* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
255- updated yatex-install.sh
256  - *-init.el: changed from hard copy to symbolic link
257    on /etc/emacs-XX.YY/site-start.d
258
259* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
260- fixed yatex-init.el
261
262* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
263- added yatex-init.el, vine-default-yatex.el
264- updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
265
266* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
267- spec in utf8
268
269* Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
270- applied new versioning policy
271
272* Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
273- new upstream release
274
275* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
276- s/Copyright/License/
277- changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
278
279* Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
280- update yatex-1.72
281
282* Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
283- update yatex-1.71
284
285* Fri Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
286- added Patch3 to add hhmts timestamp feature
287
288* Tue May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
289- update yatex-1.70
290
291* Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
292- update yatex10203151806
293
294* Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
295- fixed: bytecompile yatex19
296
297* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
298- now emacsen-common aware
299- FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
300
301* Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
302- 1.68-0vl2
303- no kanji code conversion of documents
304
305* Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
306- 1.68-0vl1
307- update to 1.68
308
309* Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
310- 1.67-6vl5
311- YATEXHLP.{jp,eng} moved to appropriate dir
312
313* Thu Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
314- 1.67-6vl3
315- rebuilt for emacs-20.7
316
317* Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
318- 1.67-6vl2
319- oops ... fixed target dir for help files
320
321* Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
322- 1.67-6vl1
323- rebuilt for emacs-20.6
324
325* Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
326- 1.67-6
327- included forgotten info file for YaHTML
328
329* Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
330- 1.67-5
331- updated for emacs-20.5a release
332
333* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
334- 1.67-4
335- change Group to Applications/Editors/EmacsLisp
336
337* Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
338- 1.67-3
339- %post and %preun section modified
340
341* Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
342- 1.67-2
343- fixed minor problem in the %files section
344
345* Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
346- 1.67-1
347- updated to 1.67 release
348- rebuilt for emacs-20.4 on Vine Linux 1.9
349- updated URL for the new web site of YaTeX
350- some typo fix
351
352* Tue May  4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
353- Initial Release
Note: See TracBrowser for help on using the repository browser.