source: projects/specs/trunk/y/yatex/yatex-vl.spec @ 6173

Revision 6173, 10.3 KB checked in by munepi, 12 years ago (diff)

updated yatex

Line 
1%define _noVersionedDependencies        1
2#% define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4%if %{?_dist_release} <= "vl5"
5exit 1
6%endif
7
8Name:          yatex
9Version:       1.76
10Release:       1.20120511%{?_dist_release}
11License:       Distributable
12#Source0:       http://www.yatex.org/yatex%{version}.tar.gz
13Source0:       http://www.gentei.org/~yuuji/tmp/yatex11205111805.tar.gz
14Source1:       %{name}-install.sh
15Source2:       %{name}-remove.sh
16Source3:       %{name}-init.el
17Source4:       vine-default-%{name}.el
18Source5:       vine-default-yahtml.el
19
20## Vine Patch(es)
21Patch1:        yatexhlp-emacs.diff
22Patch2:        yatex-make.diff
23# based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
24# and modified to suit 1.70 release
25Patch3:        yahtml-1.70-timestamp.patch
26
27Patch10:       yatex-1.76-vine-vl7.patch
28Patch11:       yatex-1.76-vine-vl6.patch
29
30URL:           http://www.yatex.org/
31Group:         Applications/Editors/Emacs
32BuildRoot:     %{_tmppath}/%{name}-%{version}-root
33Summary:       YaTeX - Yet Another TeX mode for Emacs
34Summary(ja):   野鳥(YaTeX) - Yet Another TeX mode for Emacs
35BuildArch:     noarch
36
37Requires(post): emacsen
38Requires(post): emacsen-common
39Requires(post): make
40BuildRequires: emacsen-common
41BuildRequires: nkf perl
42Obsoletes:     yatex-xemacs
43
44Distribution:  Vine Linux
45Vendor:        Project Vine
46Packager:      munepi
47
48%description
49YaTeX is an intelligent, acquisitive and integrated package which reduces
50your efforts of composing LaTeX source on GNU Emacs.
51
52
53If you are YaTeX user and you install both yatex and auctex on your system,
54you may add the following configure in your emacs init file
55~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
56
57;; I am a YaTeX user!!!
58(setq vine-default-auctex nil
59      vine-default-preview-latex nil)
60
61
62%description -l ja
63YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
64してくれる、LaTeX 入力支援環境です。
65
66
67yatex と auctex パッケージの両方をインストールする場合、
68~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
69に以下の設定を追加するとよいでしょう。
70
71;; YaTeX ユーザです!!!
72(setq vine-default-auctex nil
73      vine-default-preview-latex nil)
74
75
76%prep
77%setup -n yatex%{version}
78%patch1 -p1
79%patch2 -p1
80%patch3 -p1
81
82%if %{?_dist_release} == "vl7"
83%patch10 -p1 -b .vine
84%elseif %{?_dist_release} == "vl6"
85%patch11 -p1 -b .vine
86%endif
87
88(cd docs
89    # change permissions
90    chmod 644 *
91
92    # encode as utf-8 (LF)
93    # NOTE: This changes needs to entry info files to Info DIR
94    for i in yatexj yatexe yahtmlj yahtmle; do nkf --unix -w --overwrite $i; done
95)
96
97
98%build
99
100
101%install
102
103[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
104
105%__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
106%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
107%__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
108%__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
109
110
111#
112# install el files
113#
114
115%__cp -a *.el makefile help \
116      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
117%__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
118      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
119
120#
121# install info files
122#
123
124%__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
125   ${RPM_BUILD_ROOT}%{_infodir}
126
127
128#
129# install script (bytecompile el and install elc, remove)
130#
131
132%_installemacsenscript %{name} %{SOURCE1}
133
134%_removeemacsenscript  %{name} %{SOURCE2}
135
136
137%clean
138[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
139
140
141%post
142#
143# bytecompile and install
144#
145
146if [ "$1" = 2 ] ; then
147
148%_emacsenPackageRemove %{name}
149
150fi
151
152%_addemacsenlist %{name}
153
154%_emacsenPackageInstall %{name}
155
156for i in yatexe yatexj yahtmle yahtmlj; do
157    /sbin/install-info --dir-file %{_infodir}/dir --section="Emacs" \
158                       %{_infodir}/${i}.gz
159done
160
161
162%preun
163
164if [ "$1" = 0 ]; then
165
166%_emacsenPackageRemove %{name}
167
168%_removeemacsenlist %{name}
169
170for i in yatexe yatexj yahtmle yahtmlj; do
171    /sbin/install-info --delete --dir-file %{_infodir}/dir --section="Emacs" \
172                       %{_infodir}/${i}.gz
173done
174
175fi
176
177
178%files
179%defattr(-,root,root)
180%doc 00readme install manifest yatex.new
181%doc docs
182
183%{_datadir}/emacs/site-lisp/yatex/
184%{_infodir}/yahtmle*
185%{_infodir}/yahtmlj*
186%{_infodir}/yatexe*
187%{_infodir}/yatexj*
188%{emacsen_pkgdir}/install/%{name}
189%{emacsen_pkgdir}/remove/%{name}
190
191
192%changelog
193* Sat May 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.76-1.20120511
194- source snapshot 20120511: testing version 1.76 development
195- dropped obsoleted/upstreamed patches
196- applied yatex-1.76-vine-vl{6,7}.patch
197
198* Fri May 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-3
199- added BuildRequires: nkf perl
200- updated yatex-1.74-vine.patch as yatex-1.75-vine-vl{6,7}.patch
201- dropped pre-formatted info files
202- use original info files
203  - encode info files as utf-8
204  - add INFO-DIR-ENTRY
205
206* Thu May 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-2
207- fixed vine-default-yatex.el
208- applied yatex-1.74-vine.patch for vl6
209- updated yatex-1.74-vine.patch: support some extensions for \includegraphics
210
211* Thu Feb  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-1
212- new upstream release
213- updated vine-default-yatex.el
214
215* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-9
216- support TeX Live 2011
217- applied yatex-1.74-vine-vl7.patch
218- updated vine-default-yatex.el
219
220* Thu Aug 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-8
221- added Requires(post): make
222
223* Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-7
224- updated vine-default-yatex.el
225  - check 'YaTeX-inhibit-prefix-letter
226  - used "pbibtex -kanji=utf8" as default bibtex-command
227  - used "mendex -U" as default makeindex-command
228
229* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-6
230- updated vine-default-{yatex,yahtml}.el
231  - revived auto-fill-mode on {yatex,yahtml}-mode
232
233* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-5
234- updated yatex-init.el
235  - dropped all pathes of auctex and preview-latex from load-path
236
237* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
238- updated vine-default-yatex.el
239  - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
240  - supported TeX Live
241    - used "eplatex", "pxdvi", "pdvips" as default commands
242- updated yatex-init.el
243  - output "Loading vine-default-yatex ..." to the buffer *Messages*
244  - defined vine-default-yahtml
245- added vine-default-yahtml.el
246
247* Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
248- updated vine-default-yatex.el
249  - added bbl extension in auto-mode-alist to run yatex-mode
250
251* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
252- updated vine-default-yatex.el
253  - supported new vine-default
254
255* Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
256- new upstream release
257
258* Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
259- updated vine-default-yatex.el
260  - dropped (setq YaTeX-no-begend-shortcut t)
261- use %{emacsen_pkgdir}
262
263* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
264- updated vine-default-yatex.el
265  - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
266
267* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
268- updated yatex-install.sh
269  - *-init.el: changed from hard copy to symbolic link
270    on /etc/emacs-XX.YY/site-start.d
271
272* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
273- fixed yatex-init.el
274
275* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
276- added yatex-init.el, vine-default-yatex.el
277- updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
278
279* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
280- spec in utf8
281
282* Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
283- applied new versioning policy
284
285* Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
286- new upstream release
287
288* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
289- s/Copyright/License/
290- changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
291
292* Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
293- update yatex-1.72
294
295* Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
296- update yatex-1.71
297
298* Fri Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
299- added Patch3 to add hhmts timestamp feature
300
301* Tue May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
302- update yatex-1.70
303
304* Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
305- update yatex10203151806
306
307* Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
308- fixed: bytecompile yatex19
309
310* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
311- now emacsen-common aware
312- FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
313
314* Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
315- 1.68-0vl2
316- no kanji code conversion of documents
317
318* Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
319- 1.68-0vl1
320- update to 1.68
321
322* Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
323- 1.67-6vl5
324- YATEXHLP.{jp,eng} moved to appropriate dir
325
326* Thu Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
327- 1.67-6vl3
328- rebuilt for emacs-20.7
329
330* Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
331- 1.67-6vl2
332- oops ... fixed target dir for help files
333
334* Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
335- 1.67-6vl1
336- rebuilt for emacs-20.6
337
338* Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
339- 1.67-6
340- included forgotten info file for YaHTML
341
342* Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
343- 1.67-5
344- updated for emacs-20.5a release
345
346* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
347- 1.67-4
348- change Group to Applications/Editors/EmacsLisp
349
350* Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
351- 1.67-3
352- %post and %preun section modified
353
354* Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
355- 1.67-2
356- fixed minor problem in the %files section
357
358* Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
359- 1.67-1
360- updated to 1.67 release
361- rebuilt for emacs-20.4 on Vine Linux 1.9
362- updated URL for the new web site of YaTeX
363- some typo fix
364
365* Tue May  4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
366- Initial Release
Note: See TracBrowser for help on using the repository browser.