source: projects/specs/trunk/x/xulrunner/xulrunner-vl.spec @ 732

Revision 732, 24.7 KB checked in by daisuke, 14 years ago (diff)

update to 1.9.2.3

Line 
1%define nspr_version 4.8
2%define nss_version 3.12.3
3%define cairo_version 1.8.6
4%define libnotify_version 0.4
5%define tarballdir mozilla-1.9.2
6
7%define build_vine6 0
8%define build_vine5 0
9%if "%{?_dist_release}" == "vl6"
10%define build_vine6 1
11%define build_vine5 1
12%endif
13%if "%{?_dist_release}" == "vl5"
14%define build_vine5 1
15%endif
16
17%if %build_vine6
18%define sqlite_version 3.6.21
19%endif
20
21%define version_internal  1.9.2
22%define mozappdir         %{_libdir}/%{name}-%{version_internal}
23
24Summary:        XUL Runtime for Gecko Applications
25Summary(ja):    Gecko アプリケーションのための XUL ランタイム
26Name:           xulrunner
27Version:        1.9.2.3
28Release:        1%{?_dist_release}
29URL:            http://www.mozilla.org/projects/xulrunner/
30License:        MPLv1.1 or GPLv2+ or LGPLv2+
31Group:          Applications/Internet
32Source0:        %{name}-%{version}-source.tar.bz2
33Source10:       %{name}-mozconfig
34Source11:       %{name}-mozconfig-vine5
35Source12:       %{name}-vine-default-prefs.js
36Source21:       %{name}.sh.in
37Source23:       %{name}.1
38
39# locale sources
40%define MOZ_BUILD_LOCALES "ja"
41Source1000:     xulrunner-%{version}-ja.tar.bz2
42
43# build patches
44Patch0:         xulrunner-version.patch
45Patch1:         mozilla-build.patch
46Patch3:         mozilla-jemalloc.patch
47Patch5:         mozilla-jemalloc-526152.patch
48Patch7:         xulrunner-1.9.2.1-build.patch
49Patch8:         mozilla-plugin.patch
50Patch9:         mozilla-build-sbrk.patch
51
52# patches from Fedora
53Patch10:       mozilla-192-pkgconfig.patch
54
55# Upstream patches
56Patch26:        mozilla-ps-pdf-simplify-operators.patch
57
58
59# ---------------------------------------------------
60
61BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
62BuildRequires:  nspr-devel >= %{nspr_version}
63BuildRequires:  nss-devel >= %{nss_version}
64BuildRequires:  cairo-devel >= %{cairo_version}
65BuildRequires:  libpng-devel
66BuildRequires:  libjpeg-devel
67BuildRequires:  bzip2-devel
68BuildRequires:  zlib-devel
69BuildRequires:  lcms-devel
70BuildRequires:  libIDL-devel
71BuildRequires:  gtk2-devel
72BuildRequires:  gnome-vfs2-devel
73BuildRequires:  libgnome-devel
74BuildRequires:  libgnomeui-devel
75BuildRequires:  pango-devel
76BuildRequires:  freetype2-devel >= 2.1.9
77BuildRequires:  libXt-devel
78BuildRequires:  libXrender-devel
79%if %{build_vine6}
80BuildRequires:  sqlite3-devel >= %{sqlite_version}
81%endif
82BuildRequires:  libnotify-devel >= %{libnotify_version}
83BuildRequires:  startup-notification-devel
84BuildRequires:  alsa-lib-devel
85BuildRequires:  lcms-devel
86BuildRequires:  zip
87# For -sqlite.patch
88BuildRequires:  autoconf213
89
90Requires:       nspr >= %{nspr_version}
91Requires:       nss >= %{nss_version}
92
93Provides:       gecko-libs = %{version}
94
95%description
96XULRunner provides the XUL Runtime environment for Gecko applications.
97
98%package devel
99Summary: Development files for Gecko
100Group: Development/Libraries
101
102Obsoletes: mozilla-devel
103Obsoletes: firefox-devel < 2.1
104Obsoletes: xulrunner-devel-unstable
105
106Provides: gecko-devel = %{version}
107Provides: gecko-devel-unstable = %{version}
108
109Requires: xulrunner = %{version}-%{release}
110Requires: nspr-devel >= %{nspr_version}
111Requires: nss-devel >= %{nss_version}
112Requires: cairo-devel >= %{cairo_version}
113Requires: libjpeg-devel
114Requires: zip
115Requires: bzip2-devel
116Requires: zlib-devel
117Requires: lcms-devel
118Requires: libIDL-devel
119Requires: gtk2-devel
120Requires: gnome-vfs2-devel
121Requires: libgnome-devel
122Requires: libgnomeui-devel
123Requires: pango-devel
124Requires: freetype2-devel >= 2.1.9
125Requires: libXt-devel
126Requires: libXrender-devel
127%if %{build_vine6}
128Requires: sqlite3-devel >= %{sqlite_version}
129%endif
130Requires: startup-notification-devel
131Requires: alsa-lib-devel
132
133%description devel
134Gecko development files.
135
136#---------------------------------------------------------------------
137
138%prep
139%setup -q -c -b 1000
140cd %{tarballdir}
141
142sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' \
143    %{P:%%PATCH0} > version.patch
144%{__patch} -p1 -b --suffix .version < version.patch
145
146%patch1  -p1 -b .build
147%patch3  -p1 -b .jemalloc
148%patch5  -p1 -b .jemalloc-526152
149%patch7  -p2 -b .del
150%patch8  -p1 -b .plugin
151%patch9  -p2 -b .sbrk
152
153%patch10 -p1 -b .pkgconfig
154
155%patch26 -p1 -b .ps-pdf-simplify-operators
156
157%{__rm} -f .mozconfig
158%if %{build_vine6}
159%{__cp} %{SOURCE10} .mozconfig
160%else
161%{__cp} %{SOURCE11} .mozconfig
162%endif
163
164#---------------------------------------------------------------------
165
166%build
167cd %{tarballdir}
168
169INTERNAL_GECKO=%{version_internal}
170MOZ_APP_DIR=%{_libdir}/%{name}-${INTERNAL_GECKO}
171
172# Mozilla builds with -Wall with exception of a few warnings which show up
173# everywhere in the code; so, don't override that.
174MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//')
175export CFLAGS=$MOZ_OPT_FLAGS
176export CXXFLAGS=$MOZ_OPT_FLAGS
177
178export PREFIX='%{_prefix}'
179export LIBDIR='%{_libdir}'
180
181MOZ_SMP_FLAGS=-j1
182%ifnarch ppc ppc64 s390 s390x
183[ -z "$RPM_BUILD_NCPUS" ] && \
184     RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
185[ "$RPM_BUILD_NCPUS" -gt 1 ] && MOZ_SMP_FLAGS=-j2
186%endif
187
188export LDFLAGS="-Wl,-rpath,${MOZ_APP_DIR}"
189make -f client.mk configure STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
190make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
191
192# build locales
193LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
194            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
195for dir in $LOCALEDIRS
196do
197  for lang in %{MOZ_BUILD_LOCALES} ; do
198    make -C $dir/locales AB_CD=$lang
199  done
200done
201
202#---------------------------------------------------------------------
203
204%install
205cd %{tarballdir}
206%{__rm} -rf $RPM_BUILD_ROOT
207
208INTERNAL_GECKO=%{version_internal}
209
210INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
211MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
212
213INTERNAL_APP_SDK_NAME=%{name}-sdk-${INTERNAL_GECKO}
214MOZ_APP_SDK_DIR=%{_libdir}/${INTERNAL_APP_SDK_NAME}
215
216#DESTDIR=$RPM_BUILD_ROOT make -f client.mk install STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
217DESTDIR=$RPM_BUILD_ROOT make install
218
219%{__mkdir_p} $RPM_BUILD_ROOT/${MOZ_APP_DIR} \
220             $RPM_BUILD_ROOT%{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
221             $RPM_BUILD_ROOT%{_includedir}/${INTERNAL_APP_SDK_NAME}
222%{__install} -p dist/sdk/bin/regxpcom $RPM_BUILD_ROOT/$MOZ_APP_DIR
223
224%{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
225
226# set up our default preferences
227%{__cat} %{SOURCE12} | %{__sed} -e 's,RPM_VERREL,%{version}-%{release},g' > vl-default-prefs
228%{__install} -p -D -m 644 vl-default-prefs $RPM_BUILD_ROOT/${MOZ_APP_DIR}/defaults/pref/all-vine.js
229%{__rm} vl-default-prefs
230
231# Start script install
232%{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
233%{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{version_internal},g' > \
234  $RPM_BUILD_ROOT%{_bindir}/%{name}
235%{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
236
237%{__rm} -f $RPM_BUILD_ROOT${MOZ_APP_DIR}/%{name}-config
238
239cd $RPM_BUILD_ROOT${MOZ_APP_DIR}/chrome
240find . -name "*" -type d -maxdepth 1 -exec %{__rm} -rf {} \;
241cd -
242
243# install locales
244for lang in %{MOZ_BUILD_LOCALES} ; do
245  %{__install} -p -D -m 664 dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT/${MOZ_APP_DIR}/chrome/
246done
247
248# Prepare our devel package
249%{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
250%{__mkdir_p} $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_SDK_NAME}
251%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
252
253%{__cp} -rL dist/include/* \
254  $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
255
256# Copy pc files (for compatibility with 1.9.1)
257%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
258        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
259%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
260        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
261
262# Fix multilib devel conflicts...
263%ifarch x86_64 ia64 s390x ppc64
264%define mozbits 64
265%else
266%define mozbits 32
267%endif
268
269function install_file() {
270genheader=$*
271mv ${genheader}.h ${genheader}%{mozbits}.h
272cat > ${genheader}.h << EOF
273// This file exists to fix multilib conflicts
274#if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__)
275#include "${genheader}64.h"
276#else
277#include "${genheader}32.h"
278#endif
279EOF
280}
281
282pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
283install_file "mozilla-config"
284popd
285
286pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
287install_file "jsautocfg"
288popd
289
290%{__install} -p -c -m 755 dist/bin/xpcshell \
291  dist/bin/xpidl \
292  dist/bin/xpt_dump \
293  dist/bin/xpt_link \
294  $RPM_BUILD_ROOT/${MOZ_APP_DIR}
295
296%{__rm} -rf $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
297%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_NAME}
298
299%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
300ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
301       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
302
303%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
304ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
305       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
306
307%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
308ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
309       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
310
311%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
312ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
313       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
314
315find $RPM_BUILD_ROOT/%{_includedir} -type f -name "*.h" | xargs chmod 644
316find $RPM_BUILD_ROOT/%{_datadir}/idl -type f -name "*.idl" | xargs chmod 644
317
318%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/*.so
319pushd $RPM_BUILD_ROOT${MOZ_APP_DIR}
320for i in *.so; do
321    ln -s ${MOZ_APP_DIR}/$i $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/$i
322done
323popd
324
325# GRE stuff
326%ifarch x86_64 ia64 ppc64 s390x
327%define gre_conf_file gre64.conf
328%else
329%define gre_conf_file gre.conf
330%endif
331
332MOZILLA_GECKO_VERSION=`./config/milestone.pl --topsrcdir=.`
333%{__mv} $RPM_BUILD_ROOT/etc/gre.d/$MOZILLA_GECKO_VERSION".system.conf" \
334        $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
335chmod 644 $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
336
337# Library path
338%ifarch x86_64 ia64 ppc64 s390x
339%define ld_conf_file xulrunner-64.conf
340%else
341%define ld_conf_file xulrunner-32.conf
342%endif
343
344%{__mkdir_p} $RPM_BUILD_ROOT/etc/ld.so.conf.d
345%{__cat} > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{ld_conf_file} << EOF
346${MOZ_APP_DIR}
347EOF
348                       
349# Copy over the LICENSE
350%{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT${MOZ_APP_DIR}
351
352# Use the system hunspell dictionaries
353%{__rm} -rf ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
354ln -s %{_datadir}/myspell ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
355
356# ghost files
357%{__mkdir_p} $RPM_BUILD_ROOT${MOZ_APP_DIR}/components
358touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/compreg.dat
359touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/xpti.dat
360
361#---------------------------------------------------------------------
362
363%clean
364%{__rm} -rf $RPM_BUILD_ROOT
365
366#---------------------------------------------------------------------
367
368%post
369/sbin/ldconfig
370
371%postun
372/sbin/ldconfig
373
374%preun
375# is it a final removal?
376if [ $1 -eq 0 ]; then
377  %{__rm} -rf ${MOZ_APP_DIR}/components
378fi
379
380%files
381%defattr(-,root,root,-)
382%{_bindir}/xulrunner
383%dir /etc/gre.d
384/etc/gre.d/%{gre_conf_file}
385%dir %{mozappdir}
386%doc %attr(644, root, root) %{mozappdir}/LICENSE
387%doc %attr(644, root, root) %{mozappdir}/README.txt
388%{mozappdir}/chrome
389%{mozappdir}/dictionaries
390%dir %{mozappdir}/components
391%ghost %{mozappdir}/components/compreg.dat
392%ghost %{mozappdir}/components/xpti.dat
393%{mozappdir}/components/*.so
394%{mozappdir}/components/*.xpt
395%attr(644, root, root) %{mozappdir}/components/*.js
396%{mozappdir}/defaults
397%{mozappdir}/greprefs
398%dir %{mozappdir}/icons
399%attr(644, root, root) %{mozappdir}/icons/*
400%{mozappdir}/modules
401%{mozappdir}/plugins
402%{mozappdir}/res
403%{mozappdir}/*.so
404%{mozappdir}/mozilla-xremote-client
405%{mozappdir}/run-mozilla.sh
406%{mozappdir}/regxpcom
407%{mozappdir}/xulrunner
408%{mozappdir}/xulrunner-bin
409%{mozappdir}/xulrunner-stub
410%{mozappdir}/platform.ini
411%{mozappdir}/dependentlibs.list
412%{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
413
414# XXX See if these are needed still
415%{mozappdir}/updater*
416%exclude %{mozappdir}/update.locale
417%exclude %{mozappdir}/components/components.list
418
419%files devel
420%defattr(-,root,root,-)
421%dir %{_datadir}/idl/%{name}*%{version_internal}
422%{_datadir}/idl/%{name}*%{version_internal}/*
423%{_includedir}/%{name}*%{version_internal}
424%dir %{_libdir}/%{name}-sdk-*
425%dir %{_libdir}/%{name}-sdk-*/sdk
426%{_libdir}/%{name}-sdk-*/*
427%{_libdir}/%{name}-sdk-*/sdk/*
428%{_libdir}/pkgconfig/*.pc
429%{mozappdir}/xpcshell
430%{mozappdir}/xpidl
431%{mozappdir}/xpt_dump
432%{mozappdir}/xpt_link
433
434#---------------------------------------------------------------------
435
436%changelog
437* Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
438- update to 1.9.2.3 (sync with firefox-3.6.3)
439
440* Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
441- update to 1.9.2.2 (sync with firefox-3.6.2)
442- add patch7,9 for fix build failure
443
444* Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
445- enable libnotify support
446  - add ac_add_options --enable-libnotify
447- disable Necko wifi monitor
448  - add ac_add_options --disable-necko-wifi
449  - remove BR: wireless-tools-devel
450- fix %%files devel
451- add patch3,5 to fix jemalloc alignment assertion
452- add Patch8 to fix mozilla-plugin.pc
453
454* Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
455- add BR: libnotify-devel, wireless-tools-devel
456
457* Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
458- update to 1.9.2 (sync with firefox-3.6)
459- obsoletes xulrunner-devel-unstable
460
461* Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
462- use internal sqlite3 on vine5
463
464* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
465- update to 1.9.1.7
466
467* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
468- update to 1.9.1.6
469- build with sqlite3-3.6.21
470
471* Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
472- update to 1.9.1.5
473
474* Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
475- update to 1.9.1.3
476
477* Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
478- really update to 1.9.1.2 (<BTS:0748>)
479
480* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
481- update to 1.9.1.2 (sync with firefox-3.5.2)
482
483* Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
484- update to 1.9.1.1 (sync with firefox-3.5.1)
485- add missing Requires to -devel
486- add missing BR
487
488* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
489- enable-system-cairo
490
491* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
492- update to 1.9.1 (based on firefox 3.5)
493
494* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
495- update to 1.9.1rc3 (sync with firefox 3.5rc3)
496
497* Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
498- update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
499- remove old patches
500- require nspr >= 4.8
501
502* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
503- new upstream release
504
505* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
506- update mozconfig
507  - disable-system-cairo for stability
508
509* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
510- new upstream release
511
512* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
513- new upstream release
514- add ja locale
515
516* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
517- new upstream release
518
519* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
520- new upstream release
521
522* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
523- add Patch3
524
525* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
526- update to xulrunner 1.9.0.2 byild 6
527- build with gnome-2.24
528
529* Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
530- new upstream release
531
532* Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
533- initial build for Vine Linux
534
535* Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
536- Update to 1.9 final
537
538* Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
539- Simplify PS/PDF operators
540
541* Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
542- Upstream patch to fsync() less
543
544* Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
545- Ensure we enable startup notification; add BR and modify config
546  (bug #445543)
547
548* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
549- Some files moved to mozilla-filesystem; kill them and add the Req
550
551* Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
552- Clean up the %%files list and get rid of the executable bit on some files
553
554* Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
555- Fix font scaling
556
557* Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
558- Enabled phishing protection (#443403)
559
560* Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
561- Changed "__ppc64__" to "__powerpc64__",
562  "__ppc64__" doesn't work anymore
563- Added fix for #443725 - Critical hanging bug with fix
564  available upstream (mozbz#429903)
565
566* Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
567- Fixed multilib issues, added starting script instead of a symlink
568  to binary (#436393)
569
570* Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
571- Add upstream patches for dpi, toolbar buttons, and invalid keys
572- Re-enable system cairo
573
574* Mon Apr  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
575- Spec cleanups
576
577* Wed Apr  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
578- Beta 5
579
580* Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
581- Beta 5 RC2
582
583* Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
584- Update to latest trunk (2008-03-27)
585
586* Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
587- Update to latest trunk (2008-03-26)
588
589* Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
590- Update to latest trunk (2008-03-25)
591
592* Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
593- Update to latest trunk (2008-03-24)
594
595* Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
596- Update to latest trunk (2008-03-20)
597
598* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
599- Update to latest trunk (2008-03-17)
600
601* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
602- Revert to trunk from the 15th to fix crashes on HTTPS sites
603
604* Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
605- Update to latest trunk (2008-03-16)
606- Add patch to negate a11y slowdown on some pages (#431162)
607
608* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
609- Update to latest trunk (2008-03-15)
610
611* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
612- Avoid conflicts between gecko debuginfo packages
613
614* Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
615- Update to latest trunk (2008-03-12)
616
617* Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
618- Update to latest trunk (2008-03-11)
619
620* Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
621- Update to latest trunk (2008-03-10)
622
623* Sun Mar  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
624- Update to latest trunk (2008-03-09)
625
626* Fri Mar  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
627- Update to latest trunk (2008-03-07)
628
629* Thu Mar  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
630- Update to latest trunk (2008-03-06)
631
632* Tue Mar  4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
633- Update to latest trunk (2008-03-04)
634
635* Sun Mar  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
636- Update to latest trunk (2008-03-02)
637
638* Sat Mar  1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
639- Update to latest trunk (2008-03-01)
640
641* Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
642- Update to latest trunk (2008-02-29)
643
644* Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
645- Update to latest trunk (2008-02-28)
646
647* Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
648- Update to latest trunk (2008-02-27)
649
650* Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
651- Update to latest trunk (2008-02-26)
652
653* Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
654- Update to latest trunk (2008-02-23)
655
656* Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
657- Update to latest trunk (2008-02-22)
658
659* Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
660- Update to latest trunk (2008-02-21)
661
662* Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
663- Update to latest trunk (2008-02-20)
664
665* Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
666- Update to latest trunk (2008-02-17)
667
668* Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
669- Update to latest trunk (2008-02-15)
670
671* Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
672- Update to latest trunk (2008-02-14)
673- Use system hunspell
674
675* Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
676- Update to latest trunk (2008-02-11)
677
678* Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
679- STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
680  you know, debuginfo.
681
682* Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
683- Update to latest trunk (2008-02-10)
684
685* Sat Feb  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
686- Update to latest trunk (2008-02-09)
687
688* Wed Feb  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
689- Update to latest trunk (2008-02-06)
690
691* Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
692- Update to latest trunk (2008-01-30)
693
694* Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
695- rebuild agains new nss
696- enabled gnome vfs
697
698* Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
699- fixed stable pkg-config files (#429654)
700- removed sqlite patch
701
702* Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
703- Update to latest trunk (2008-01-21)
704
705* Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
706- Update to latest trunk (2008-01-15)
707- Now with system extensions directory support
708
709* Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
710- Update to latest trunk (2008-01-13)
711- Use CFLAGS instead of configure arguments
712- Random cleanups: BuildRequires, scriptlets, prefs, etc.
713
714* Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
715- Provide gecko-devel-unstable as well
716
717* Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
718- divided devel package to devel and devel-unstable
719
720* Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
721- removed fedora specific pkg-config files
722- updated to the latest trunk (2008-01-07)
723- removed unnecessary patches
724- fixed idl dir (#427965)
725
726* Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
727- Re-enable camellia256 support now that NSS supports it
728
729* Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
730- updated to the latest trunk (2008-01-03)
731
732* Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
733- Don't Provide webclient (xulrunner is not itself a webclient)
734- Don't Obsolete old firefox, only firefox-devel
735- Kill legacy obsoletes (phoenix, etc) that were never in rawhide
736
737* Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
738- added java and plugin subdirs to plugin includes
739
740* Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
741- dependency fixes, obsoletes firefox < 3 and firefox-devel now
742
743* Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
744- updated to Beta 2.
745- moved SDK to xulrunner-sdk
746
747* Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
748- fixed mozilla-plugin.pc (#412971)
749
750* Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
751- export /etc/gre.d/gre.conf (it's used by python gecko applications)
752
753* Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
754- added xulrunner/js include dir to xulrunner-js
755
756* Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
757- update to beta 1
758
759* Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
760- packed all gecko libraries (#389391)
761
762* Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
763- registered xulrunner libs system-wide
764- added xulrunner-gtkmozembed.pc
765
766* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
767- added proper nss/nspr dependencies
768
769* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
770- more build fixes, use system nss libraries
771
772* Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
773- build fixes
774
775* Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
776- updated to the latest trunk
777
778* Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
779- build fixes for ppc/ppc64
780
781* Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
782- removed conflicts with the current gecko-based apps
783- added updated ppc64 patch
784
785* Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
786- build fixes
787
788* Wed Sep  5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
789- Initial cut at XULRunner 1.9 Alpha 7
790- Temporarily revert camellia 256 support since our nss doesn't support it yet
Note: See TracBrowser for help on using the repository browser.