source: projects/specs/trunk/x/xulrunner/xulrunner-vl.spec @ 1238

Revision 1238, 24.9 KB checked in by daisuke, 14 years ago (diff)

xulrunne: update to 1.9.2.4

Line 
1%define nspr_version 4.8
2%define nss_version 3.12
3%define cairo_version 1.8.6
4%define libnotify_version 0.4
5%define tarballdir mozilla-1.9.2
6
7%define build_vine6 0
8%define build_vine5 0
9%if "%{?_dist_release}" == "vl6"
10%define build_vine6 1
11%define build_vine5 1
12%endif
13%if "%{?_dist_release}" == "vl5"
14%define build_vine5 1
15%endif
16
17%if %build_vine6
18%define sqlite_version 3.6.21
19%endif
20
21%define version_internal  1.9.2
22%define mozappdir         %{_libdir}/%{name}-%{version_internal}
23
24Summary:        XUL Runtime for Gecko Applications
25Summary(ja):    Gecko アプリケーションのための XUL ランタイム
26Name:           xulrunner
27Version:        1.9.2.4
28Release:        1%{?_dist_release}
29URL:            http://www.mozilla.org/projects/xulrunner/
30License:        MPLv1.1 or GPLv2+ or LGPLv2+
31Group:          Applications/Internet
32Source0:        %{name}-%{version}-source.tar.bz2
33Source10:       %{name}-mozconfig
34Source11:       %{name}-mozconfig-vine5
35Source12:       %{name}-vine-default-prefs.js
36Source21:       %{name}.sh.in
37Source23:       %{name}.1
38
39# locale sources
40%define MOZ_BUILD_LOCALES "ja"
41Source1000:     xulrunner-%{version}-ja.tar.bz2
42
43# build patches
44Patch0:         xulrunner-version.patch
45Patch1:         mozilla-build.patch
46Patch3:         mozilla-jemalloc.patch
47Patch5:         mozilla-jemalloc-526152.patch
48Patch7:         xulrunner-1.9.2.1-build.patch
49Patch8:         mozilla-plugin.patch
50Patch9:         mozilla-build-sbrk.patch
51Patch10:        firefox-3.6.4-ipc-chromium-nspr4.patch
52
53# patches from Fedora
54Patch100:       mozilla-192-pkgconfig.patch
55
56# Upstream patches
57Patch200:        mozilla-ps-pdf-simplify-operators.patch
58
59
60# ---------------------------------------------------
61
62BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
63BuildRequires:  nspr-devel >= %{nspr_version}
64BuildRequires:  nss-devel >= %{nss_version}
65BuildRequires:  cairo-devel >= %{cairo_version}
66BuildRequires:  libpng-devel
67BuildRequires:  libjpeg-devel
68BuildRequires:  bzip2-devel
69BuildRequires:  zlib-devel
70BuildRequires:  lcms-devel
71BuildRequires:  libIDL-devel
72BuildRequires:  gtk2-devel
73BuildRequires:  gnome-vfs2-devel
74BuildRequires:  libgnome-devel
75BuildRequires:  libgnomeui-devel
76BuildRequires:  pango-devel
77BuildRequires:  freetype2-devel >= 2.1.9
78BuildRequires:  libXt-devel
79BuildRequires:  libXrender-devel
80%if %{build_vine6}
81BuildRequires:  sqlite3-devel >= %{sqlite_version}
82%endif
83BuildRequires:  libnotify-devel >= %{libnotify_version}
84BuildRequires:  startup-notification-devel
85BuildRequires:  alsa-lib-devel
86BuildRequires:  lcms-devel
87BuildRequires:  zip
88# For -sqlite.patch
89BuildRequires:  autoconf213
90
91Requires:       nspr >= %{nspr_version}
92Requires:       nss >= %{nss_version}
93
94Provides:       gecko-libs = %{version}
95
96%description
97XULRunner provides the XUL Runtime environment for Gecko applications.
98
99%package devel
100Summary: Development files for Gecko
101Group: Development/Libraries
102
103Obsoletes: mozilla-devel
104Obsoletes: firefox-devel < 2.1
105Obsoletes: xulrunner-devel-unstable
106
107Provides: gecko-devel = %{version}
108Provides: gecko-devel-unstable = %{version}
109
110Requires: xulrunner = %{version}-%{release}
111Requires: nspr-devel >= %{nspr_version}
112Requires: nss-devel >= %{nss_version}
113Requires: cairo-devel >= %{cairo_version}
114Requires: libjpeg-devel
115Requires: zip
116Requires: bzip2-devel
117Requires: zlib-devel
118Requires: lcms-devel
119Requires: libIDL-devel
120Requires: gtk2-devel
121Requires: gnome-vfs2-devel
122Requires: libgnome-devel
123Requires: libgnomeui-devel
124Requires: pango-devel
125Requires: freetype2-devel >= 2.1.9
126Requires: libXt-devel
127Requires: libXrender-devel
128%if %{build_vine6}
129Requires: sqlite3-devel >= %{sqlite_version}
130%endif
131Requires: startup-notification-devel
132Requires: alsa-lib-devel
133
134%description devel
135Gecko development files.
136
137#---------------------------------------------------------------------
138
139%prep
140%setup -q -c -b 1000
141cd %{tarballdir}
142
143sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' \
144    %{P:%%PATCH0} > version.patch
145%{__patch} -p1 -b --suffix .version < version.patch
146
147%patch1  -p1 -b .build
148%patch3  -p1 -b .jemalloc
149%patch5  -p1 -b .jemalloc-526152
150%patch7  -p2 -b .del
151%patch8  -p1 -b .plugin
152%patch9  -p2 -b .sbrk
153%patch10 -p1 -b .nspr4
154
155%patch100 -p1 -b .pkgconfig
156
157%patch200 -p1 -b .ps-pdf-simplify-operators
158
159%{__rm} -f .mozconfig
160%if %{build_vine6}
161%{__cp} %{SOURCE10} .mozconfig
162%else
163%{__cp} %{SOURCE11} .mozconfig
164%endif
165
166#---------------------------------------------------------------------
167
168%build
169cd %{tarballdir}
170
171INTERNAL_GECKO=%{version_internal}
172MOZ_APP_DIR=%{_libdir}/%{name}-${INTERNAL_GECKO}
173
174# Mozilla builds with -Wall with exception of a few warnings which show up
175# everywhere in the code; so, don't override that.
176MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//')
177export CFLAGS=$MOZ_OPT_FLAGS
178export CXXFLAGS=$MOZ_OPT_FLAGS
179
180export PREFIX='%{_prefix}'
181export LIBDIR='%{_libdir}'
182
183MOZ_SMP_FLAGS=-j1
184%ifnarch ppc ppc64 s390 s390x
185[ -z "$RPM_BUILD_NCPUS" ] && \
186     RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
187[ "$RPM_BUILD_NCPUS" -gt 1 ] && MOZ_SMP_FLAGS=-j2
188%endif
189
190export LDFLAGS="-Wl,-rpath,${MOZ_APP_DIR}"
191make -f client.mk configure STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
192make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
193
194# build locales
195LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
196            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
197for dir in $LOCALEDIRS
198do
199  for lang in %{MOZ_BUILD_LOCALES} ; do
200    make -C $dir/locales AB_CD=$lang
201  done
202done
203
204#---------------------------------------------------------------------
205
206%install
207cd %{tarballdir}
208%{__rm} -rf $RPM_BUILD_ROOT
209
210INTERNAL_GECKO=%{version_internal}
211
212INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
213MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
214
215INTERNAL_APP_SDK_NAME=%{name}-sdk-${INTERNAL_GECKO}
216MOZ_APP_SDK_DIR=%{_libdir}/${INTERNAL_APP_SDK_NAME}
217
218#DESTDIR=$RPM_BUILD_ROOT make -f client.mk install STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
219DESTDIR=$RPM_BUILD_ROOT make install
220
221%{__mkdir_p} $RPM_BUILD_ROOT/${MOZ_APP_DIR} \
222             $RPM_BUILD_ROOT%{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
223             $RPM_BUILD_ROOT%{_includedir}/${INTERNAL_APP_SDK_NAME}
224%{__install} -p dist/sdk/bin/regxpcom $RPM_BUILD_ROOT/$MOZ_APP_DIR
225
226%{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
227
228# set up our default preferences
229%{__cat} %{SOURCE12} | %{__sed} -e 's,RPM_VERREL,%{version}-%{release},g' > vl-default-prefs
230%{__install} -p -D -m 644 vl-default-prefs $RPM_BUILD_ROOT/${MOZ_APP_DIR}/defaults/pref/all-vine.js
231%{__rm} vl-default-prefs
232
233# Start script install
234%{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
235%{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{version_internal},g' > \
236  $RPM_BUILD_ROOT%{_bindir}/%{name}
237%{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
238
239%{__rm} -f $RPM_BUILD_ROOT${MOZ_APP_DIR}/%{name}-config
240
241cd $RPM_BUILD_ROOT${MOZ_APP_DIR}/chrome
242find . -name "*" -type d -maxdepth 1 -exec %{__rm} -rf {} \;
243cd -
244
245# install locales
246for lang in %{MOZ_BUILD_LOCALES} ; do
247  %{__install} -p -D -m 664 dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT/${MOZ_APP_DIR}/chrome/
248done
249
250# Prepare our devel package
251%{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
252%{__mkdir_p} $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_SDK_NAME}
253%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
254
255%{__cp} -rL dist/include/* \
256  $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
257
258# Copy pc files (for compatibility with 1.9.1)
259%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
260        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
261%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
262        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
263
264# Fix multilib devel conflicts...
265%ifarch x86_64 ia64 s390x ppc64
266%define mozbits 64
267%else
268%define mozbits 32
269%endif
270
271function install_file() {
272genheader=$*
273mv ${genheader}.h ${genheader}%{mozbits}.h
274cat > ${genheader}.h << EOF
275// This file exists to fix multilib conflicts
276#if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__)
277#include "${genheader}64.h"
278#else
279#include "${genheader}32.h"
280#endif
281EOF
282}
283
284pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
285install_file "mozilla-config"
286popd
287
288pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
289install_file "jsautocfg"
290popd
291
292%{__install} -p -c -m 755 dist/bin/xpcshell \
293  dist/bin/xpidl \
294  dist/bin/xpt_dump \
295  dist/bin/xpt_link \
296  $RPM_BUILD_ROOT/${MOZ_APP_DIR}
297
298%{__rm} -rf $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
299%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_NAME}
300
301%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
302ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
303       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
304
305%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
306ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
307       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
308
309%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
310ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
311       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
312
313%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
314ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
315       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
316
317find $RPM_BUILD_ROOT/%{_includedir} -type f -name "*.h" | xargs chmod 644
318find $RPM_BUILD_ROOT/%{_datadir}/idl -type f -name "*.idl" | xargs chmod 644
319
320%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/*.so
321pushd $RPM_BUILD_ROOT${MOZ_APP_DIR}
322for i in *.so; do
323    ln -s ${MOZ_APP_DIR}/$i $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/$i
324done
325popd
326
327# GRE stuff
328%ifarch x86_64 ia64 ppc64 s390x
329%define gre_conf_file gre64.conf
330%else
331%define gre_conf_file gre.conf
332%endif
333
334MOZILLA_GECKO_VERSION=`./config/milestone.pl --topsrcdir=.`
335%{__mv} $RPM_BUILD_ROOT/etc/gre.d/$MOZILLA_GECKO_VERSION".system.conf" \
336        $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
337chmod 644 $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
338
339# Library path
340%ifarch x86_64 ia64 ppc64 s390x
341%define ld_conf_file xulrunner-64.conf
342%else
343%define ld_conf_file xulrunner-32.conf
344%endif
345
346%{__mkdir_p} $RPM_BUILD_ROOT/etc/ld.so.conf.d
347%{__cat} > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{ld_conf_file} << EOF
348${MOZ_APP_DIR}
349EOF
350                       
351# Copy over the LICENSE
352%{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT${MOZ_APP_DIR}
353
354# Use the system hunspell dictionaries
355%{__rm} -rf ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
356ln -s %{_datadir}/myspell ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
357
358# ghost files
359%{__mkdir_p} $RPM_BUILD_ROOT${MOZ_APP_DIR}/components
360touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/compreg.dat
361touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/xpti.dat
362
363#---------------------------------------------------------------------
364
365%clean
366%{__rm} -rf $RPM_BUILD_ROOT
367
368#---------------------------------------------------------------------
369
370%post
371/sbin/ldconfig
372
373%postun
374/sbin/ldconfig
375
376%preun
377# is it a final removal?
378if [ $1 -eq 0 ]; then
379  %{__rm} -rf ${MOZ_APP_DIR}/components
380fi
381
382%files
383%defattr(-,root,root,-)
384%{_bindir}/xulrunner
385%dir /etc/gre.d
386/etc/gre.d/%{gre_conf_file}
387%dir %{mozappdir}
388%doc %attr(644, root, root) %{mozappdir}/LICENSE
389%doc %attr(644, root, root) %{mozappdir}/README.txt
390%{mozappdir}/chrome
391%{mozappdir}/dictionaries
392%dir %{mozappdir}/components
393%ghost %{mozappdir}/components/compreg.dat
394%ghost %{mozappdir}/components/xpti.dat
395%{mozappdir}/components/*.so
396%{mozappdir}/components/*.xpt
397%attr(644, root, root) %{mozappdir}/components/*.js
398%{mozappdir}/defaults
399%{mozappdir}/greprefs
400%dir %{mozappdir}/icons
401%attr(644, root, root) %{mozappdir}/icons/*
402%{mozappdir}/modules
403%{mozappdir}/plugins
404%{mozappdir}/res
405%{mozappdir}/*.so
406%{mozappdir}/mozilla-xremote-client
407%{mozappdir}/run-mozilla.sh
408%{mozappdir}/regxpcom
409%{mozappdir}/xulrunner
410%{mozappdir}/xulrunner-bin
411%{mozappdir}/xulrunner-stub
412%{mozappdir}/plugin-container
413%{mozappdir}/platform.ini
414%{mozappdir}/dependentlibs.list
415%{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
416
417# XXX See if these are needed still
418%{mozappdir}/updater*
419%exclude %{mozappdir}/update.locale
420%exclude %{mozappdir}/components/components.list
421
422%files devel
423%defattr(-,root,root,-)
424%dir %{_datadir}/idl/%{name}*%{version_internal}
425%{_datadir}/idl/%{name}*%{version_internal}/*
426%{_includedir}/%{name}*%{version_internal}
427%dir %{_libdir}/%{name}-sdk-*
428%dir %{_libdir}/%{name}-sdk-*/sdk
429%{_libdir}/%{name}-sdk-*/*
430%{_libdir}/%{name}-sdk-*/sdk/*
431%{_libdir}/pkgconfig/*.pc
432%{mozappdir}/xpcshell
433%{mozappdir}/xpidl
434%{mozappdir}/xpt_dump
435%{mozappdir}/xpt_link
436
437#---------------------------------------------------------------------
438
439%changelog
440* Wed Jun 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.4-1
441- update to 1.9.2.4 (sync with firefox-3.6.4)
442- add patch10 to fix build failure
443
444* Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
445- update to 1.9.2.3 (sync with firefox-3.6.3)
446
447* Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
448- update to 1.9.2.2 (sync with firefox-3.6.2)
449- add patch7,9 for fix build failure
450
451* Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
452- enable libnotify support
453  - add ac_add_options --enable-libnotify
454- disable Necko wifi monitor
455  - add ac_add_options --disable-necko-wifi
456  - remove BR: wireless-tools-devel
457- fix %%files devel
458- add patch3,5 to fix jemalloc alignment assertion
459- add Patch8 to fix mozilla-plugin.pc
460
461* Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
462- add BR: libnotify-devel, wireless-tools-devel
463
464* Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
465- update to 1.9.2 (sync with firefox-3.6)
466- obsoletes xulrunner-devel-unstable
467
468* Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
469- use internal sqlite3 on vine5
470
471* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
472- update to 1.9.1.7
473
474* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
475- update to 1.9.1.6
476- build with sqlite3-3.6.21
477
478* Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
479- update to 1.9.1.5
480
481* Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
482- update to 1.9.1.3
483
484* Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
485- really update to 1.9.1.2 (<BTS:0748>)
486
487* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
488- update to 1.9.1.2 (sync with firefox-3.5.2)
489
490* Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
491- update to 1.9.1.1 (sync with firefox-3.5.1)
492- add missing Requires to -devel
493- add missing BR
494
495* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
496- enable-system-cairo
497
498* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
499- update to 1.9.1 (based on firefox 3.5)
500
501* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
502- update to 1.9.1rc3 (sync with firefox 3.5rc3)
503
504* Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
505- update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
506- remove old patches
507- require nspr >= 4.8
508
509* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
510- new upstream release
511
512* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
513- update mozconfig
514  - disable-system-cairo for stability
515
516* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
517- new upstream release
518
519* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
520- new upstream release
521- add ja locale
522
523* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
524- new upstream release
525
526* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
527- new upstream release
528
529* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
530- add Patch3
531
532* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
533- update to xulrunner 1.9.0.2 byild 6
534- build with gnome-2.24
535
536* Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
537- new upstream release
538
539* Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
540- initial build for Vine Linux
541
542* Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
543- Update to 1.9 final
544
545* Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
546- Simplify PS/PDF operators
547
548* Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
549- Upstream patch to fsync() less
550
551* Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
552- Ensure we enable startup notification; add BR and modify config
553  (bug #445543)
554
555* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
556- Some files moved to mozilla-filesystem; kill them and add the Req
557
558* Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
559- Clean up the %%files list and get rid of the executable bit on some files
560
561* Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
562- Fix font scaling
563
564* Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
565- Enabled phishing protection (#443403)
566
567* Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
568- Changed "__ppc64__" to "__powerpc64__",
569  "__ppc64__" doesn't work anymore
570- Added fix for #443725 - Critical hanging bug with fix
571  available upstream (mozbz#429903)
572
573* Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
574- Fixed multilib issues, added starting script instead of a symlink
575  to binary (#436393)
576
577* Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
578- Add upstream patches for dpi, toolbar buttons, and invalid keys
579- Re-enable system cairo
580
581* Mon Apr  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
582- Spec cleanups
583
584* Wed Apr  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
585- Beta 5
586
587* Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
588- Beta 5 RC2
589
590* Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
591- Update to latest trunk (2008-03-27)
592
593* Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
594- Update to latest trunk (2008-03-26)
595
596* Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
597- Update to latest trunk (2008-03-25)
598
599* Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
600- Update to latest trunk (2008-03-24)
601
602* Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
603- Update to latest trunk (2008-03-20)
604
605* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
606- Update to latest trunk (2008-03-17)
607
608* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
609- Revert to trunk from the 15th to fix crashes on HTTPS sites
610
611* Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
612- Update to latest trunk (2008-03-16)
613- Add patch to negate a11y slowdown on some pages (#431162)
614
615* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
616- Update to latest trunk (2008-03-15)
617
618* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
619- Avoid conflicts between gecko debuginfo packages
620
621* Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
622- Update to latest trunk (2008-03-12)
623
624* Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
625- Update to latest trunk (2008-03-11)
626
627* Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
628- Update to latest trunk (2008-03-10)
629
630* Sun Mar  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
631- Update to latest trunk (2008-03-09)
632
633* Fri Mar  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
634- Update to latest trunk (2008-03-07)
635
636* Thu Mar  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
637- Update to latest trunk (2008-03-06)
638
639* Tue Mar  4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
640- Update to latest trunk (2008-03-04)
641
642* Sun Mar  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
643- Update to latest trunk (2008-03-02)
644
645* Sat Mar  1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
646- Update to latest trunk (2008-03-01)
647
648* Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
649- Update to latest trunk (2008-02-29)
650
651* Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
652- Update to latest trunk (2008-02-28)
653
654* Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
655- Update to latest trunk (2008-02-27)
656
657* Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
658- Update to latest trunk (2008-02-26)
659
660* Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
661- Update to latest trunk (2008-02-23)
662
663* Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
664- Update to latest trunk (2008-02-22)
665
666* Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
667- Update to latest trunk (2008-02-21)
668
669* Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
670- Update to latest trunk (2008-02-20)
671
672* Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
673- Update to latest trunk (2008-02-17)
674
675* Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
676- Update to latest trunk (2008-02-15)
677
678* Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
679- Update to latest trunk (2008-02-14)
680- Use system hunspell
681
682* Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
683- Update to latest trunk (2008-02-11)
684
685* Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
686- STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
687  you know, debuginfo.
688
689* Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
690- Update to latest trunk (2008-02-10)
691
692* Sat Feb  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
693- Update to latest trunk (2008-02-09)
694
695* Wed Feb  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
696- Update to latest trunk (2008-02-06)
697
698* Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
699- Update to latest trunk (2008-01-30)
700
701* Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
702- rebuild agains new nss
703- enabled gnome vfs
704
705* Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
706- fixed stable pkg-config files (#429654)
707- removed sqlite patch
708
709* Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
710- Update to latest trunk (2008-01-21)
711
712* Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
713- Update to latest trunk (2008-01-15)
714- Now with system extensions directory support
715
716* Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
717- Update to latest trunk (2008-01-13)
718- Use CFLAGS instead of configure arguments
719- Random cleanups: BuildRequires, scriptlets, prefs, etc.
720
721* Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
722- Provide gecko-devel-unstable as well
723
724* Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
725- divided devel package to devel and devel-unstable
726
727* Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
728- removed fedora specific pkg-config files
729- updated to the latest trunk (2008-01-07)
730- removed unnecessary patches
731- fixed idl dir (#427965)
732
733* Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
734- Re-enable camellia256 support now that NSS supports it
735
736* Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
737- updated to the latest trunk (2008-01-03)
738
739* Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
740- Don't Provide webclient (xulrunner is not itself a webclient)
741- Don't Obsolete old firefox, only firefox-devel
742- Kill legacy obsoletes (phoenix, etc) that were never in rawhide
743
744* Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
745- added java and plugin subdirs to plugin includes
746
747* Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
748- dependency fixes, obsoletes firefox < 3 and firefox-devel now
749
750* Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
751- updated to Beta 2.
752- moved SDK to xulrunner-sdk
753
754* Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
755- fixed mozilla-plugin.pc (#412971)
756
757* Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
758- export /etc/gre.d/gre.conf (it's used by python gecko applications)
759
760* Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
761- added xulrunner/js include dir to xulrunner-js
762
763* Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
764- update to beta 1
765
766* Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
767- packed all gecko libraries (#389391)
768
769* Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
770- registered xulrunner libs system-wide
771- added xulrunner-gtkmozembed.pc
772
773* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
774- added proper nss/nspr dependencies
775
776* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
777- more build fixes, use system nss libraries
778
779* Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
780- build fixes
781
782* Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
783- updated to the latest trunk
784
785* Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
786- build fixes for ppc/ppc64
787
788* Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
789- removed conflicts with the current gecko-based apps
790- added updated ppc64 patch
791
792* Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
793- build fixes
794
795* Wed Sep  5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
796- Initial cut at XULRunner 1.9 Alpha 7
797- Temporarily revert camellia 256 support since our nss doesn't support it yet
Note: See TracBrowser for help on using the repository browser.